PC Проектант

Made in Bulgaria

Система за конструктивно проектиране в строителството

Графично въвеждане на конструкция или обекти от нея в 3D. Контрол между обекти. Геометрични и товарни характеристики на обекти.Автоматична генерация на триъгълна мрежа за обект с възможности за контрол и редактиране.Изчисление на въведен кофражен план с автоматично предаване на товарите между констр. елементи (полета, греди, колони).Изчислява фундаментни, етажни и смесени плочи по МКЕ (триъгълни 3x3 3x6).Изключва опъна на обект или група от обекти.Проверка на сечение или група от сечения на косо огъване, натиск или опън в общо положение.Изчисление на сгради на сеизмично въздействие (включително шайби с отвори т.е. рамки имащи безкрайно корави зони).Изчислява гредостени по МКЕ (триъгълни 3x2).Изчислява равнинни рамки по МКЕ, включващи безкрайно корави зони. Комбинации с обвивки за надлъжна и напречна армировки.Автоматично оразмеряване на еле- менти по нива (колони от кофражни планове, шайби и рамки от сеизмично изследване) в табличен вид.Модул за преглеждане на входна информация и резултати в 3D графичен вид.Модул за преглеждане на входна информация и резултати в текстов вид.Модул за печат на входна информация и резултати в текстов и графичен вид.Изчислява аритметичен израз или процедура от изрази (разклонение, цикъл, debug, запис), конвертиране.Таблица за преглед и контрол на армировка по бройки/диаметър.Таблица за преглед и контрол на армировка за стремена.Възможност за конвертиране, стръскване по матрици и форми на текстов файл (резултати).Средство за: Старт на PCPcad. Експорт на DXF-DWG файл. Връзка между AutoCAD и SCRIPT файл.Изчислява стойността на вложените материалиУправление на стартираните модули от 'PC Проектант'.Помощ и описание при работата с модулите - Home.Обучаващи филми за работа със системата - учител.AboutКонфигуриране на системата.Право на достъп за потребител.Изчисление на конзолни, еднопосочно армирани, тристранно (с балкон) и четиристранно подпрени полета. Статика, оразмеряване, провисване.Изчисление на непрекъснати греди (до 15 отвора + 2 конзоли) с край: конзола, става, запъване. До 15 товара на участък.Изчисление на единични бетонни и стоманобетонни (симетрични и не- симетрични) фундаменти, натоварени центрично и нецентрично. Слягане.Изчисление на стоманобетонни сечения на огъване, срязване, усукване, натиск, опън, кобилици и комбинации от тях.Изчисление на правоъгълни, плочо- гредови, обратно плочогредови, 2T стоманобетонни сечения на провисване.Изчертаване на кофражен и арми- ровачен план, с пълен контрол на въведените и изчислени данни.Изчертаване на греди (прости и непрекъснати), с пълен контрол на въведените и изчислени данни.Изчертаване на кофражен и арми- ровачен план за безгредова плоча, с пълен контрол на въведените и изчислени данни.Изчертаване на вложените мрежи при гредостена, с пълен контрол на въведените и изчислени данни.Създаване и подготовка на библиотека от параметрични детайли необходими при изчертаване.Определя състава на бетона по метода на последователните приближения (плътните обеми).Контрол и оценка якостта на бетона за доказване принадлежността му към определен клас (B).Библиотека от бетони с характеристики по I и II гранични състояния.Библиотека от стомани с характеристики по I и II гранични състояния.Изчисление на температурно поле за ограждащи конструкции по МКР.За контакт:Къде и как работи !Language Bulgarian - officialПомощ Файлове разширения.Помощ Схема на връзките между модулите.PCPcad Пълно функционална CAD среда.Каталог на профили с въведени характеристики по групи.Каталог на материали с въведени характеристики по групи.Текстов редактор. Пълно функционална среда за редактиране и печат.Информация.Files Find.Synchronize time.Standart BDS <-> EuroCODEЗа контакт:

Час:

Дата:


Къде и как работи !

.
 Return to Home

·Системата е 32-bit приложение, разработена за ОС Windows:

, [image] , [image] , [image] , [image] , [image] , [image] , [image], [image], [image].

·Инсталира се автоматично (при проблем с антивирус - виж).
·За нормална работа на кирилица и в менютата следва Windows да е инсталиран за България (пoдробно - виж).
·При работна (не демо) версия бърз клавиш за стартиране Ctrl+Alt+P.
·Системата е защитена с хардуерен ключ. При интервенция върху ключа (включително: Debug, Dump, Disassemble, промяна на кода на модулите, разглобяване на хардуерния ключ и други), при загубен или счупен ключ, при предоставяне модулите на друг, потребителят губи всякакви права върху продукта

Внимание: При интервенция върху ключа той се унищожава

Работа със системата: условия и цени !


Вход на обекти

Общо:

Модул за графичен вход на цяла конструкция в 3D, както и за въвеждане на отделни обекти за самостоятелна работа (генерация на мрежа, изчисление, оразмеряване и изчертаване) с тях. Възможност за изчисляване на геометричните и тежестни характеристики на всеки обект.

Ляв бутон на мишката потвърждава. Десен бутон на мишката или Esc - отказ. Всички текущи действия се отпечатват от ляво на горната хоризонтална лента под менюто.

Меню:

При извършване на действие от менюто отказа е възможен, като върху хоризонталната лента под менюто се натисне десния бутон на мишката или Esc.

Файл

Ново

Текущо чете

Текущ запис Ctrl-Z

Вмъква DXF-DWG

При изчетен DXF-DWG файл не заетите в елементи възли се различават по цвят. Текста се игнорира тук.

Затваря DXF-DWG

Прекъсва съответствието между линии и възли от DXF-DWG файла. Възможност за работа с нов.

Чете Ctrl-R

При четене auto convert от версия 12.XX и следващи, към текущата версия.

Запис Ctrl-W

Кадър

Екран

Генерира векторен кадър с настройките от екрана.

Zoom x 2

Увеличава вътрешния мащаб (x 2 - избран от долните) за по - добър печат. Достъпно при работа в равнина без перспектива, в противен случай се приема (x 1).

x 1

x 1.5

o x 2

x 2.5

x 3

x 3.5

x 4

x 5

x 6

x 8

x 10

x 20 !

x 50 !

Изход текущо трие

Изход

Редакт

Undo F11

Redo F12

Възли

Обекти

Въвежда

При маркиране на тип обект, въвежда нов след натискане Go. Могат да се зададат Път/Име и Обект.

Редакт

Избор на обект за работа.

Мести

Мести възлите на избрания обект.

Върти

Завърта възлите на избрания обект около посочения възел.

Копира +

Копира обект (с подобектите му, ако има) с указаните отмествания зададения брой пъти. Възможност за конвертиране на плоча по МКЕ към обект изключване на опън и обратно, конвертират/пренасят се контури, отвори, концентрирани товари и тези от печати.

Трие

Трие обект (с подобектите му, ако има) с указаните отмествания.

Видимост +

Видимост на цял обект или всички обекти чрез опция. Видимост на елементи от обект при Редакт на обекта.

Характеристики

Изчисление на геометричните и тежестни характеристики на избран обект.

Чете

Добавя външен обект (с подобектите му, ако има) към конструкцията. Възможни формати (k02, r02, n02, i02, s02, t02, x02). Добавена възможност за вмъкване – изчитане на колоните при четене на обект кофражен план (задава се ниво на долен ръб колона).

Запис +

Отделя обект (с подобектите му, ако има) от конструкцията. Възможни формати (k02, r02, n02, i02, s02, t02, x02, z01, z02). При пусната опция контрол / товари записа се осъществява с контролиране между обектите, като при възможност (необходимите при конкретния случай обекти преди това са били изчислени) се прехвърлят товари между нивата (насадени колони), елементи и др. Само с тази опция е възможен записа за сеизмично изследване и общо оразмеряване. При тази опция за фундаментна плоча, автоматично се изготвят товарни състояния за вертикални товари (колони) или за елементи (шайби, рамки) и хоризонтални товари - земетръс (по периоди и гранични). За обекти тип (s02), автоматично се изготвят товарни състояния за вертикални товари и хоризонтални товари - земетръс (по периоди и гранични). За обекти тип (x02), автоматично се изготвят товарни състояния за вертикални товари. След запис при опция проверка се проверяват въведените геометрични данни на съответният обект (r02 - независим, n02, i02, s02, t02). За по-удобна работа при Запис без контрол / товари и проверка с натиснат Ctrl за обекти тип (r02 - независим, n02, i02, s02, t02) автоматично се стартира Генерация на мрежа, а за обект тип (x02) - Рамки (изчисление).

Таблици

Преглед и редактиране на печати, концентрирани, линейни и площни товари за всеки обект. Особено полезно при автоматична промяна на стойности, знаци и др.

Редукции

Редуцира и прихваща близките възли, принадлежащи на избрания обект. Опции – Редуцира възли към:

– възли – Редуцира принадлежащите към избрания обект възли по зададено dL;

– отсечки – Прихваща принадлежащите към избрания обект възли (по зададено dL – разстояние от точка

до отсечка) към съответния елемент и ги вмъква в полигона му (контури, типове и др.). Елементи определени строго от два възела се размнжават с граничен възел прихванатия (линейни опори, разпределени товари и др.). Елементи определени строго от един възел се игнорират (концентрирани товари, единични опори и др.). Игнорират се елементите: елементи колона, контур колони, участъци при полета и греди с над 10 възела и рамкови елементи с 'безкрайно' корави зони.

Групи

Групи Ctrl-G

Възможност за избор маркиране и демаркиране на всички елементи (възли, равнини и линии, сили и моменти, линейни товари, площни товари, 2D опори, 3D опори). Надписване на група с текст, за възли и избор на координати за надписване към номера на възела.

Изгледи Alt-I

Алтернативно разрешава/забранява диалог за управление на изгледи.

Add - добавя текущото като изглед, може да се зададе текст. Ctrl-Add, автоматично генерира изгледи за всички обекти по отделно. Get - взема текущото към съответния изглед. Shift-Get - взема текущото положение, видимост и групи и го добавя към всички изгледи. Del - трие текущият изглед. Shift -Del - трие всички. Ctrl -Del - трие изгледи в които няма/изтрити видими елементи т.е. - празни.

Текст Alt-T

Алтернативно разрешава/забранява текст за целия чертеж.

Горните определят начина на изчертаване и видимостта на съответната група елементи за всички обекти в конструкцията.

Настройка

Видимост

Граници видимост дава онази област от пространството в която координатите на възлите ще са видими и ще могат да бъдат прихващани съответните възли. Възможност за автоматично определяне на зоните на видимост, чрез Zoom - Auto.

Координати

Тук се задават стъпките на мрежата. Кратно на, е числото на което са кратни координатите на маркера върху работното поле когато е натиснат десен бутон на мишката и не е пусната мрежата. Ниво е координата по подразбиране при работа в равнина.

Елементи

Равнини и коефициенти за надписване на съответните елементи върху конструкцията (Ctrl/Alt-S - увеличава/намалява коефициентите за надписване с процент равен на стъпката за увеличение, но не по-малко от 10%). Възможности за автоматична смяна на равнината на надписване (auto), изобразяване на екран на координатната система (xyz). Работа с колони: размери, ъгъл и отместване. Особено полезна опция при по разширена работа със системата. Тези данни са в наличност при въвеждане на колона-рамка, при изчисление на кофражен план - греди статика - опори - ръбови моменти, таблично оразмеряване колони, таблично оразмеряване шайби - глави колони, изчертаване на кофражи класически и плочи по MKE.

Мести Alt-M

Алтернативно скрива/показва диалога за управление от работното поле.

Параметри

Проценти на мащабиране, движение, ъгъл на въртене, перспектива. Параметри необходими на диалога за управление от работното поле. Извиква се и от диалога за управление, като два пъти се натисне левия бутон на мишката върху горната лента. Възможност за ефект – светлина при работа с греди и колони. Задава се позиция на светлината.

Възли Alt-V

Диалог за бърз достъп до функциите с възли.

Чертае

Цветно F4

Използува базовите 16 цвята.

Бяло F5

Черно F6

Фон

Бял F7

Черен F8

Help

Home

Application F1

Работно поле:

При натискане ляв бутон на мишката прихваща най-близкия възел. Ако сте в една от трите равнини с изключена опция за перспектива при натискане десния бутон на мишката при включена Мрежа маркера прихваща координатите на най-близкия възел от мрежата, а при изключена Мрежа координатите.на маркера стават кратни на числото от Координати. При Shift + десен бутон на мишката маркера прихваща координатите на най-близкия въведен възел. Това се отпечатва от дясно на горната хоризонтална лента под менюто.

При свободно работно поле (без да сте в режим на работа с възли или елементи), ако натиснете ляв бутон на мишката се задава начална точка (примерно при Shift + десен бутон на мишката маркера прихваща координатите на най-близкия възел и той става начална точка). При което, ако сте в равнина всяко натискане на десен бутон на мишката, води до запомняне (mem) на текущите параметри - L, a, dX, dY. Те могат автоматично да се използуват (при кликване върху потъмнени позии на текст), като данни при местене, копиране, завъртане, размножаване и др.

BackSpace - връща назад маркирани възли. При Del и прехванат (с левия бутон на мишката) вече маркиран възел, той се демаркира. При работа с елементи, натиснат Ins и прехванат (с левия бутон на мишката) нов не маркиран възел, възможност за вмъкването му след указания по избор от потребителя възел (системата предлага мястото между двата най-близки от маркираните), това действие е възможно при маркирани над 2 възела. Възможност в момента на захващане/редактиране + Ctrl за избор за захванатия елемент по номер.

При натискане на десният бутон на мишката върху горната лента на диалози (tools), извиква диалог за конфигуриране на позицията им (индивидуално или по групи).

Диалог за управление

За да работи Мрежа трябва да сте в една от трите равнини с изключена опция за перспектива. Ако сте в общо положение при Zoom, трябва да сте прихванали поне два възела с различни кооординати. С Shift + Zoom се прихващат всички възли в областта. При натискане двойно ляв бутон на мишката върху горната лента извиква Параметри.

При задържане на Shift и кликване върху управляващи бутони, следва непрекъснато изпълнение на командите (анимация) до отпускане на Shift. При кликване върху управляващ бутон преди да е изчертан чертежа върху екрана, прекъсва изпълнението и чертае отново с новите параметри. Управление с клавиши от управляващ блок. Scroll Lock – on/off, променя алтернативно посоките на движение. Мащабиране при скролиране със среден бутон на мишката. При местене на мишката и натиснат среден бутон, следва движение на изчертаното. При двойно натискане на средния бутон на мишката – централна позиция.

Колони - служебен

При въвеждане на колони текущата 3D опора дава подпирането което евентуално ще се осъществи с обект тип (r02).

Кофражен план - (k02)

При въвеждане на поле 5 тип автоматично се създава подобект (r02), като в главния обект се пази само контура. Отвори, товари и др. трябва да се зададат допълнително в подобекта. Запъва се страна на поле с пореден номер по нисък от този на полето на което ще предава известен момент. Реда на задаване на полетата (номерата - могат в последствие да се разместят) трябва да бъде съобразен с начина на предаване на известните моменти между тях. Запъната страна може да бъде само тази граничеща от край до край с друга такава и също предаваща товар. При различен от този случай може да се влага известен момент при решението, като съблюдавате коректността. Момента от конзолно поле се тълкува като известен, следователно при наличие на страна:

- граничеща от край до край с тази от конзолното поле и също предаваща товар -предава се момент.

- липсваща или граничеща. но не от край до край с тази от конзолното поле -не се предава момент, но има възможност да се зададе такъв (примерно вариант греда - конзолно поле, конструкторът трябва да съобрази съответния усукващ момент върху гредата).

За всеки тип поле се описват всички възли по четирите страни (до 10). При греда всеки участък се описва с всички точки от опора до опора (до 10). Всеки следващ участък започва с последния възел на предходния. Реда на задаване на гредите трябва да е съобразен (второстепенната да е по-напред от главната греда за да е известна реакцията). Проста греда може да се зададе като пояс, тя не товари съответните колони, следователно трябва да се зададе като разпределен товар на долната плоча за съответната греда. Една греда може да има минимум един участък с една опора (колона или друга греда) т.е. конзола. При въвеждане на греди текущата 3D опора дава подпирането, което евентуално ще се осъществи с обект тип (r02). Бързо задаване на площен товар върху поле става, като при въведени 0 възли се натисне десен бутон на мишката (край въвеждане) избира се поле (при по-вече от едно) и товар.

Плоча по МКЕ - (r02)

Ако има обекти (колони) преминаващи през обекта, но нямащи общи възли (примерно колона минаваща по средата на плочата) тогава за да се отчете подпирането трябва да ги прибавим чрез принадлежащи възли. Обект под който няма колони (възли с по ниско Z) при Запис с контрол се счита за фундаментна плоча. Задават се затворен контур (материал: E - модул; коефициент на Поасон (0.16 - 0.20), дебелина, Винклерова константа примерно 15000 kN/m2/m'/) на плочата и евентуално затворени контури на отвори, ако има такива (те не бива да се пресичат с контура на плочата). При въвеждане на линейни опорни връзки да се има в предвид следното :

Връзка по: Vz, Zx, Zy

Да Да Не - при свободна страна по X

Да Не Да - при свободна страна по Y

Да Да Да - при запъната страна по Y

Да Да Да - при запъната страна по X

Връзка по: Vz, Zx, Zy, Kxx,Kxy,Kyy

Да Да Не Да Не Не - при свободна страна по X

Да Не Да Не Не Да - при свободна страна по Y

Да Да Да Не Да Да - при запъната страна по Y

Да Да Да Да Да Не - при запъната страна по X

При въвеждане на линейни опорни връзки, те се трансформират при работа с елемент с 18 степени на свобода по X при ъгъл на опората < 45° и по Y при ъгъл на опората >= 45°. Възможни са корекции на трансформацията в Генерация на мрежа. При печати се задават усилия (F, Mx, My) и затворен контур. Усилията се прилагат в центъра на контура и дебелината на плочата в контура се приема с 20% по голяма от H базово закръглено до cm (може да се промени в Генерация на мрежа). Върху площите заети от печати не се разпростират разпределени товари след генерацията на мрежа. Бързо задаване на площен товар върху контур става, като при въведени 0 възли се натисне десен бутон на мишката (край въвеждане) избира се контур (при по-вече от един) и товар. При копиране на печати и концентрирани товари, чрез Alt възможност за конвертиране от единия към другия елемент и обратно.

Шайба - (s02)

За да отчетете съвместната работа между обектите трябва да въведете контур колони (посочвате две колони), тогава автоматично се генерират греди на местата на подпиране с кофражните планове. Генерираните греди при подпирането евентуално с обект тип (r02) са с текущата 3D опора за контур колони.

Рамка - (x02)

За да отчетете съвместната работа между обектите трябва да въведете елементи колона (посочвате една колона)-автоматично се генерират елементи. Тогава при въвеждане на нови елементи с краища от генерирани елементи автоматично се генерират греди на местата на подпиране с кофражните планове. Генерираните греди при подпирането евентуално с обект тип (r02) са с текущата 3D опора при въвеждането на елементите.

Бутона с икона на обекта е за изход след редактиране на обект, при Shift алтернативен вход с менюто за възли.

Ресурси:

Няма софтуерен лимит.

При описване на страна на поле или участък на греда до 10 възела.

Файлове:

Формат за модула (b02).

Приема от:

DXF-DWG files.

Формати (k02, r02, n02, i02, s02, t02, x02).

Предава на:

Генерация на мрежа - с формати (r02, n02, i02, s02, t02). Тези обекти са в графичен формат (полигони, линии и др.), те се разбиват на мрежа от крайни елементи с формати (r01, n01, i01, s01, t01) при пълен контрол на проектанта.

Кофражен план (изчисление) - с формат (k02).

Сеизмично изследване - с формати (z01 - общо за конструкцията, z02 - рамки).

Рамки (изчисление) - с формат (x02).

3DD Рамки (изчисление) - с формат (x02).

Общо оразмеряване.

Геометричните и тежестни характеристики.

Принтер - кадър.


Вход на обекти - Геометрични характеристики

Общо:

Възможност за изчисляване геометричните и тежестни характеристики на избран обект. Допълнителна възможност за филтриране на неговите подобекти на площни, линейни и точкови обекти. Корекция на резултатите чрез транслиране и ротиране на координатните оси. Промяна на равнината на работа. Възможност за създаване на колекция/библиотека от характеристики (G, Xcm, Ycm, Jmc) и контури на етажни плочи за последващо използуване към Сеизмично изследване при задаване на нива.

Приема от:

Вход на обекти.

Предава на:

Преглед графика - ревю.


Генерация на мрежа

Общо:

Модул за автоматично генериране на мрежа с последваща пълна редакция и контрол на възли, елементи, гранични условия, товари и др.

Ляв бутон на мишката потвърждава. Десен бутон на мишката или Esc - отказ. Всички текущи действия се отпечатват от ляво на горната хоризонтална лента под менюто.

Меню:

При извършване на действие от менюто отказа е възможен, като върху хоризонталната лента под менюто се натисне десния бутон на мишката или Esc.

Файл

Ново

Тук се избира вида на обекта с който евентуално ще се работи и дали Графичното съответствие (между възлите и съответните графични данни) да се запази.

Текущо чете

Текущ запис Ctrl-Z

Кадър

Цветен печат

Генерира векторен кадър - цветно върху бяла основа.

Моно печат

Генерира векторен кадър - черно върху бяла основа.

Екран

Генерира векторен кадър - цветно върху черна основа.

Моно негатив

Генерира векторен кадър - бяло върху черна основа.

Zoom x 2

Увеличава вътрешния мащаб (x 1.5 - избран от долните) за по - добър печат. Достъпно при работа в равнина без перспектива, в противен случай се приема (x 1).

x 1

o x 1.5

x 2

x 2.5

x 3

x 3.5

x 4

x 5

x 6

x 8

x 10

x 20 !

x 50 !

Чете Ctrl-R

Тук се избира вида на обекта с който ще се работи (по подразбиране това е обекта избран в Ново).

При избран обект с формат (r02, n02, i02, s02, t02), се появява диалога за автоматичното генериране на мрежи с извършване на проверка на коректността на въведената графична информация. Възможност за работа по два метода:

S_metod - Възможности за задаване на максималния размер на триъгълник по двете направления, както и минималния размер под който възлите се обединяват. Опция за тежестното разместване на възлите въз основа на положението им в мрежата;

P_metod - Възможности за задаване на максималния размер на триъгълник вътре и около контури, отвори, опори и др. Десен бутон на мишката + Esc - прекъсва итерациите. Опция Force chain обединява линейните опори и линейните товари в общи полигони по възможност.

Общи са опциите за сгъстяване на възлите около контури, отвори, опори и др. и за размазване печати (при плочи) за намаляване на получените концентрации. Go - генерация на мрежата на текущия полигон зададен в combo box над бутона, в работно поле информация за условията на генерация и резултата от нея. Quit - изход с приемане на данните за работа. Cancel - изход от извършеното.

Запис Ctrl-W

Изход текущо трие

Изход

Редакт

Undo F11

Redo F12

Таблици Ctrl-T

В зависимост от обекта с който се работи, се преглеждат, редактират, добавят или изтриват възли, елементи, гранични условия, товари и др. При плоча за гранични условия, при Shift + ляв бутон на мишката се прихваща текущия възел и се предлага за него готова генерация за опорна връзка по x или y (запъната или става, с 3 или 6 неизвестни). При плоча и гредостена е възможно да се задават Пружинни константи или Подаване/преместване на опорите в съответните мерни единици за всяка връзка, ако има необходимост и данни за това. Опция Стени, бордове + Гранични условия – възможност за задаване на допълнителни елементи: сутеренни стени, бордове, парапети, които внасят допълнителна коравина в равнината на плочата. Тези елементи се задават като линейни опори с нулеви връзки (без връзки) при задаване на обекта плоча по МКЕ. Материала и сечението на елемента за всяка така зададена (без връзки) линейна опора се задават в текущата таблица.

Текст Alt-T

Алтернативно разрешава/забранява текст за целия чертеж.

Възли

Контрол

Проверки

Контрол за коректността на въведените и редактирани данни. Извежда колко и кои елементи са некоректни при всяка от проверките, като ги изчертава с магента върху екрана.

Оптимизация

Извършва RCM (Reverse Cuthill-McKee метод) - оптимизация на номерацията на възлите с предварително определен възел. Възможности за промяна на началния възел за оптимизацията и задаване на връзки между възли с формат (I-j, k-l, …), това е наложително при наличие на няколко полигона в рамките на един обект без общи възли. При движение върху панела на матрицата се отпечатва члена върху който е маркера в формат A(I, j).

Настройка

Координати

Тук се задават стъпките на мрежата. Кратно на, е числото на което са кратни координатите на маркера върху работното поле когато е натиснат десен бутон на мишката и не е пусната мрежата. От това число зависят резултатите при Проверки и то трябва да се съобрази с мащаба на елемента и размера на разбиване.

Елементи

Равнини и коефициенти за надписване на съответните елементи върху конструкцията (Ctrl/Alt-S - увеличава/намалява коефициентите за надписване с процент равен на стъпката за увеличение, но не по-малко от 10%). Възможности за автоматична смяна на равнината на надписване (auto), изобразяване на екран на координатната система (xyz).

Мести Alt-M

Алтернативно скрива/показва диалога за управление от работното поле.

Параметри

Проценти на мащабиране, движение, ъгъл на въртене, перспектива. Параметри необходими на диалога за управление от работното поле. Извиква се и от диалога за управление, като два пъти се натисне левия бутон на мишката върху горната лента.

Възли Alt-V

Диалог за бърз достъп до функциите с възли.

Обект Alt-O

Алтернативно скрива/показва диалога за редактиране на текущия обект.

Решение

Стартира автоматично изчислението на текущия обект, като преди това той трябва да бъде записан Запис Ctrl-W.

Help

Home

Application F1

Работно поле:

При натискане ляв бутон на мишката прихваща най-близкия възел. Ако сте в една от трите равнини с изключена опция за перспектива при натискане десния бутон на мишката при включена Мрежа маркера прихваща координатите на най-близкия възел от мрежата, а при изключена Мрежа координатите.на маркера стават кратни на числото от Координати. При Shift + десен бутон на мишката маркера прихваща координатите на най-близкия въведен възел. Това се отпечатва от дясно на горната хоризонтална лента под менюто.

При свободно работно поле (без да сте в режим на работа с възли или елементи), ако натиснете ляв бутон на мишката се задава начална точка (примерно при Shift + десен бутон на мишката маркера прихваща координатите на най-близкия възел и той става начална точка). При което, ако сте в равнина всяко натискане на десен бутон на мишката, води до запомняне (mem) на текущите параметри - L, a, dX, dY. Те могат автоматично да се използуват (при кликване върху потъмнени позии на текст), като данни при местене, копиране, завъртане, размножаване и др.

BackSpace - връща назад маркирани възли. При Del и прехванат (с левия бутон на мишката) вече маркиран възел/триъгълник, той се демаркира.

При натискане на десният бутон на мишката върху горната лента на диалози (tools), извиква диалог за конфигуриране на позицията им (индивидуално или по групи).

Диалог за управление

За да работи Мрежа трябва да сте в една от трите равнини с изключена опция за перспектива. Ако сте в общо положение при Zoom, трябва да сте прихванали поне два възела с различни кооординати. С Shift + Zoom се прихващат всички възли или елементи в областта. При натискане двойно ляв бутон на мишката върху горната лента извиква Параметри.

При задържане на Shift и кликване върху управляващи бутони, следва непрекъснато изпълнение на командите (анимация) до отпускане на Shift. При кликване върху управляващ бутон преди да е изчертан чертежа върху екрана, прекъсва изпълнението и чертае отново с новите параметри. Управление с клавиши от управляващ блок. Scroll Lock – on/off, променя алтернативно посоките на движение. Мащабиране при скролиране със среден бутон на мишката. При местене на мишката и натиснат среден бутон, следва движение на изчертаното. При двойно натискане на средния бутон на мишката – централна позиция.

Диалог за обекта

Възможности за сгъстяване на маркирани триъгълници, генерация на триъгълници по три, четири или по-вече възела. Възможност да се обработват група възли или елементи от обекта. Око Ctrl-G - задаване на видимите елементи и начина им на изчертаване (възможност за маркиране и демаркиране на всички елементи). При въвеждане или редактиране на гранични условия текущата 3D опора дава подпирането което ще се осъществи.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за модула (r01, r02, n01, n02, i01, i02, s01, s02, t01, t02).

Приема от:

Вход на обекти - с формати (r02, n02, i02, s02, t02).

Предава на:

Плочи (изчисление) - с формат (r01).

Оразмеряване на сечения - с формат (n01).

Изключване на опън - с формат (i01).

Гредостени (изчисление) - с формат (s01).

Температури - с формат (t01).

Принтер - кадър.


Кофражен план (изчисление)

Общо:

Модул за управление и контрол при изчислението на определен кофражен план. Справки за взаимовръзките и товарите на всеки етап от изчислението.

Меню:

Файл

Ново

Текущо чете

Текущ запис Ctrl-Z

Пакет

Чете записан преди това с Запис Ctrl-W изцяло изчислен кофраж, ако това е възможно (т.е. всички данни са достъпни) с формат (k01) за евентуална корекция на определени елементи (полета, греди). При повторното изчисление на елемент дава указания с кои е във връзка (за коректни резултати би следвало те да се преизчислят). Запомня пътя към полета тип МКЕ с формат (r__) от кофражния план, ако те липсват там се прави опит те да се открият в работната директория автоматично.

Чете Ctrl-R

Чете обект с формат (k02) за начално изчисление. Контрол за коректността на данните при изчетения обект. При наличие на обекти с формат (r02) - плочи МКЕ, те трябва да се доведат до формат (r01) - мрежа.

Запис Ctrl-W

Запис на изцяло изчислен кофраж с формат (k01). Автоматичен преглед на получени файлове с резултати (p__ - полета, g__ - греди, k__ - колони).

Изход текущо трие

Изход

Help

Home

Application F1

Работно поле:

Възможност преглед на графика - ревю на изчетения обект. Преглед на зададените размери, товари и взаимовръзки между елементите (страна поле - участък греда, товар плоча МКЕ - участък греда, опора греда - участък греда и др.) на всеки етап от изчислението на кофражния план. При изчисление на поле (Усилия, оразмеряване, провисване) става автоматично задаване на размери и товари (ако има зададени). Критерий за завършена работа с текущото поле е неговият запис. В работното поле то се маркира като решено. Възможност за повторно решение на поле с последно записаните данни. При изчисление на плоча по МКЕ, възможност за задаване коравина на греди (някои или всички), за да се отчете подаването им (т.е. те не се разглеждат като неподаваеми опори). Възможност за задаване на вида на гредата в рамките на предопределеното от кофражния план, материал, сечение и опции къде по участъци и греди това да се приеме. При кликване върху име на греда алтернативно я изважда/добавя към групата деформируеми греди (Shift - маркира/демаркира всички), това може да се види и управлява за всички, чрез опция Zv. Опция Zx-y задава/отчита и коравината на огъване при деформацията на гредите (опция Zv моделира гредите само като вертикални пружини). Връзките на съответните линейни опори за деформируемите греди се модифицират, като се премахват зададените евентуално пружини и премествания и са добавя вертикална връзка, ако не е зададена такава. Възможност за автоматично изчисление на всички полета от текущото до края, при текущите настройки, чрез Shift. След решаване на всички полета от кофража се преминава към Прехвърля товари от полета върху греди, при което е възможен преглед на връзки между греди и колони и работа с греди.

Възможност за управление генерацията на броя и вида на равномерно разпределените товари от една линейна опора при плоча МКЕ, върху всеки участък от гредата. Задава се max стойност от 1 до 14 на товарите, като при стойности/възли над зададения те се редуцират до max стойност. При 1 - един равномерно разпределен товар с q1=q2, при 2 - един равномерно разпределен товар q1 - q2, така, че сумарно товара да е равен на сумата от единичните сили във възлите и приложната му точка да съвпада с тази на силите, от 3 до 14 - генерация на зададеният брой равномерно разпределени товари q1=q2, на разстояние средата до съседните възли. При получени окончателно над 15 товара за участък се прави опит - първо за редукция към по - малки стойности за брой на товарите (q1 - q2) - стъпка [1]. Ако не е намерено решение се преминава автоматично към стъпка [2] при изключена стъпка [3]. Ако отново не е намерено решение автоматично се включва и стъпка [3], което дава винаги решение без загуба на товари. За повишаване на точността в рамките на max възможните товари е предвидена опция за редукция на всички товари върху гредата (концентрирани при включва опция - стъпка [3] и линейни), без товара собствено тегло, до равномерно разположени концентрирани сили (от 3 до 14) по дължината на гредата - стъпка [2]. При получени окончателно над 15 товара за участък се прави опит - първо за редукция към по - малки стойности за брой на равномерно разположените концентрирани сили. Ако не е намерено решение автоматично се включва и стъпка [3], което дава винаги решение без загуба на товари.

При изчисление на греда (Усилия) става автоматично задаване на типа на гредата, размери и товари (собствено тегло (функция от зададеното напречно сечение), от полета, от опори на други греди, зададени), като всеки товар носи своя пояснителен коментар (натоварването за текущата греда може да се прегледа предварително). Ако е зададена проста греда в кофражния план, то тя може да се зададе като пояс (или да и се смени типа, ако е възможно). При изчисляване на пояс (греда), той не товари колоните си и не може да бъде оразмеряван или да се прави проверка на провисване в последствие. Критерий за завършена работа с текуща греда е нейният запис. В работното поле тя се маркира като решена. Възможност за повторно решение на греда с последно записаните данни. Допълнителна възможност за автоматично изчисление на всички греди от текущата до края, при текущите настройки, чрез Shift. Решената вече греда по желание може да се оразмери по участъци или да се направи проверка на провисване (всяко от тези действия се маркира съответно с + и = ). Обединява в една кобилица, сили при dL< B и генерира автоматично едностранни кобилици при разстояние от ръба < H. При извършване на оразмеряване в модула се появява диалог Данни от греда с възможностите за оразмеряване при всеки участък. Критерий за завършена работа с текущото оразмеряване е неговият запис. В работното поле то се маркира като решено. При завършена работа с данните за текущата греда се натиска бутон Запис към греда. Възможност за автоматично оразмеряване на всички сечения за разглежданата греда, чрез Ctrl. Допълнителна възможност за оразмеряване на всички сечения на всички греди от текущата до края, при текущите настройки, чрез Shift. Аналогична са действията при проверка на провисване. След решаване на всички греди от кофража се преминава към Прехвърля товари от полета и греди върху колони, при което е възможен преглед на товари върху колони. След Запис се формира пакета на съответния кофражен план.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за модула (k01 - решен кофражен план - пакет, k02 - обект), формати за запис - резултати (p__ - полета, g__ - греди, k__ - колони).

Приема от:

Вход на обекти - с формат (k02).

Генерация на мрежа - с формат (r01).

Приема информация и управлява в процеса на работа следите модули:

Поле;

Плочи (изчисление);

Греда;

Оразмеряване;

Провисване.

Предава на:

Общо оразмеряване - информация за товарите върху колоните за съответния кофраж.

Вход на обекти - информация за товари при запис с контрол на вертикални обекти.

Кофражен план (изчертаване).

Греди (изчертаване).

Преглед на графика - ревю.

Преглед текст.

Предава информация и управлява в процеса на работа следите модули:

Поле;

Плочи (изчисление);

Греда;

Оразмеряване;

Провисване.


Плочи (изчисление)

Общо:

Модул за изчисление на фундаментни, етажни и смесени плочи по МКЕ (триъгълни с 3x3 - Vz, Zx, Zy и 3x6 - Vz, Zx, Zy, Kxx, Kxy, Kyy неизвестни за елемент).Възможни товари са концентрирани сили и/или моменти във възли, линейни товари, печати или равномерно разпределени товари върху определена зона. Възможност за изчисление на по-вече от една за един път. Табличен и графичен преглед на данни и резултати.

Меню:

Файл

Ново

Чете Ctrl-R

Изход

Решение

Решение (F9, Go) на изчетения обект.

Преглед

Таблици

Възли

Преглед на координати на възли. При Shift + ляв бутон на мишката се прихваща текущия възел, като за него се появява пълна информация за входни данни и резултати.

Типове

Преглед на характеристиките на отделните слоеве за обекта.

Елементи

Преглед на зададените елементи (възли, типове и товар).

Концентрирани товари

Преглед на зададените концентрирани товари (сили и моменти) по възли.

Опори и реакции

Преглед на опори по възли и получените реакции в тях.

Vz, Zx, Zy

Преглед на премествания и завъртания по възли.

Mi - усилия

Преглед на разрезни и главни (ъгъл) усилия по възли.

Оразмерителни усилия

Преглед на оразмерителни усилия по възли получени при комбиниране на: Mx + Mxy, Mx - Mxy, My + Mxy, My - Mxy.

Почвена реакция

Преглед на получената почвена реакция по възли.

Единични опори

Преглед на получените реакции (във възел) за зададените единични опори.

Линейни опори

Преглед на получените товари (начален и краен възел, дължина, сума и разпределен товар) за зададените линейни опори.

Графичен

Преглед на графика - ревю, на зададените входни данни и получените резултати - повърхнини на:

Vz

Вертикално преместване.

Zx

Завъртане по x.

Zy

Завъртане по y.

Mx

Разрезно усилие Mx.

My

Разрезно усилие My.

Mxy

Разрезно усилие Mxy.

Mmax

Главни усилия, направления.

Mmin

Главни усилия, направления.

Mxд

Оразмерително усилие Mx долно.

Mxг

Оразмерително усилие Mx горно.

Myд

Оразмерително усилие My долно.

Myг

Оразмерително усилие My горно.

Rz

Опорни реакции (линейни и едиинични) и земна реакция по възли при зададена Винклерова константа.

Help

Home

Application F1

Работно поле:

Информация за изчетения и евентуално изчислен обект. Текущия обект (Път/Име и Обект) се отпечатва от дясно на горната хоризонтална лента под менюто. Възможност за избор на броя неизвестни във възел (3 или 6). Опция Rz за извършване на итерации при обратен знак на земната реакция. Възможност да се контролират броя на итерациите. Решението (ако то е изобщо възможно) и сходимостта при този подход, силно зависят от начина на натоварване на плочата. Сума товари, опори, земна реакция за осъществяване на контрол след изчислението.

Препоръка: Препоръчително е при изчисление на конкретна задача да се 'засичат' резултатите с приблизителни или примерно по методите с 9 и 18 степени на свобода. Това се налага, тъй като регулярно моделиране (разбиване) на конструкцията не винаги е възможно, което води до определени проблеми (особено при елемент с 9 степени на свобода), затова при възможност е желателна определена кратност на размерите и разбиването на КЕ. Според някои източници предпоставките при които се извършва изчислението по МКЕ са коректни при следните условия:

– H плоча < 0.2 х L

– |Vz max| < 0.01х L

– |Vz max| < 0.2 х H плоча

(където: H плоча-дебелина на плочата; L-минимален размер на плочата.)

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за четене (r01), формат за запис (r__).

Приема от:

Генерация на мрежа - с формат (r01).

Предава на:

Кофражен план (изчисление).

Кофражен план (изчертаване).

Преглед на графика - ревю - с формат (r__).


Изключване на опън

Общо:

Модул за изключване на опън при произволно сечение или сечения. Графичен преглед на данни и резултати.

Меню:

Файл

Ново

Чете Ctrl-R

Изход

Решение

Решение (F9, Go) на изчетения обект.

Help

Home

Application F1

Работно поле:

Информация за изчетения и евентуално изчислен обект. Текущия обект (Път/Име и Обект) се отпечатва от дясно на горната хоризонтална лента под менюто. Възможност за контрол на приведените ексцентрицитети (Ex, Ey). Преглед на графика - ревю, на зададените входни данни и получените резултати. Десен бутон на мишката + Esc - прекъсва итерациите.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за четене (i01), формат за запис (i__).

Приема от:

Генерация на мрежа - с формат (i01).

Предава на:

Преглед на графика - ревю - с формат (i__).


Оразмеряване на сечения

Общо:

Модул за оразмеряване на произволно сечение или сечения на кос нецентричен натиск, кос нецентричен опън или косо огъване по БДС или EC. Графичен преглед на данни и резултати.

Меню:

Файл

Ново

Чете Ctrl-R

Изход

Настройка

Материали

Задават се материалите - бетон и стомана. Съществува възможност за корекция на изчислителните им характеристики чрез промяна на съответния за материала коефициент.

Армировка

Задават се брой, позиция и площ на вложената армировка.

Решение

Решение (F9, Go) на изчетения обект.

Help

Home

Application F1

Работно поле:

Информация за изчетения и евентуално изчислен обект. Текущия обект (Път/Име и Обект) се отпечатва от дясно на горната хоризонтална лента под менюто. Възможност за контрол на приведените ексцентрицитети (Ex, Ey). Промяна на характера на оразмеряване огъване, натиск (-), опън (+). Видът на нормите за оразмеряване БДС или EC се определя автоматично в зависимост от текущото състояние при стартиране на модула. Преглед на графика - ревю, на зададените входни данни и получените резултати (нулеви линии, диаграми на напрежения в бетона и стоманата). Десен бутон на мишката + Esc - прекъсва итерациите.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за четене (n01), формат за запис (n__).

Приема от:

Генерация на мрежа - с формат (n01).

Предава на:

Преглед на графика - ревю - с формат (n__).


Сеизмично изследване

Общо:

Провежда сеизмично изследване на сгради за 2D и 3D по Норми – НПССЗР '87, '07, '10 и EuroCode 8 до етап разрезни усилия на всяко етажно ниво (за всяка форма и гранични) за всеки елемент (шайба и/или шайба с отвори т.е. рамка с 'безкрайно' корави зони), отчитайки транслация, ротация и PD-ефект (т.е. коригира получената етажна сила по правилник). При съответните изчисления се отчита влиянието на M и Q. При наличие на шайби с отвори т.е. рамки, те се изчисляват с припадащите им се сили от всеки етаж за всяка форма до гранични разрезни усилия на елементите на рамката.

ПРЕДПОСТАВКИ ЗА РАБОТА при 2D:

– Сградата се разглежда като запъната конзола с концентрирани маси по етажите.

– При намиране на периодите се отчита влиянието на M и Q.

– Могат да се отчитат до три форми на трептене в направление.

– Относителните премествания се намират като във върха се задава (1).

– Окончателната етажна сила в дадено направление се определя с отчитане на PD-ефекта по правилник.

– Шайбите може да са в две взаимно перпендикулярни направления или под ъгъл.

– Всяка шайба може да има различен E-модул.

– Всяка шайба може да прекъсва по височина на сградата, но в двете направления сумарно, минимум три са догоре, като тази минимум е образуван от шайби с различни координати в даденото направление.

– Ако шайбата е с променливо сечение и E-модул по височина да се разглежда като рамка (конзола).

– Конструкторът определя геометричната схема на нерегулярната шайба като рамка.

– Конструкторът определя вида и начина на подпиране при рамките.

– За всяка рамка се определят хоризонталните премествания от единични сили за всеки етаж.

– Възможност за задаване на произволен външен елемент, за който е построена матрицата на преместванията за всяко етажно ниво от единични сили.

– Автоматична възможност генерация на матрицата на преместванията за всяко етажно ниво от единични сили за гредостена.

– При транслация се изравняват преместванията за всяко етажно ниво (т.е. етажните плочи в равнината си се приемат за 'безкрайно' корави).

– Отчита се несъвпадението между центровете на масите и коравините - ротация за всяка форма, като се контролира минимума по Норми – НПССЗР или се добавя (EC8) ефекта му със знак (+).

– Отчита се меродавната комбинация от [Транслация + Ротация] и [Ротация] за които се търсят M-max, Q-max за всяка форма на всеки етаж.

– Товарите по рамките са от комбинация даваща Q-max за етаж '0', като конзола за всяка форма.

– Премествания за всяко етажно ниво с отчитане M и Q.

– Възможност при рамка да се зададе направо EF и EJ.

Меню:

Файл

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

Запис Ctrl-W

Изход текущо трие

Изход

Решение

Решение (F9) за текущия обект. Информация за етапа на изчисление. Преглед на графика - ревю на получените резултати.

Help

Home

Application F1

Работно поле:

Задават се евентуално обект от който се чете (при Ctrl, файл чете = файл запис) и задължително за запис. Възможност за въвеждане на свободен текст Обект и Задал, брой концентрирани маси по височина Mn, брой елементи поемащи хоризонтален товар по X - Nx, брой елементи поемащи хоризонтален товар по Y - Ny и брой елементи работещи под ъгъл - Na.

Норми – НПССЗР

Периоди -отчитане на желания брой форми. C -коефициент за значимост на сградите. R -коефициент на реагиране на конструкцията при сеизмично въздействие. Kc -сеизмичен коефициент, представляващ отношението на приетото за всяка сеизмична степен изчислително ускорение на почвата към земното ускорение. Възможност за определянето му по наименованието на населеното място. Почви групи -определяне на динамичния коефициент бета в зависимост от вида на почвата. Преместване -контрол върху коравината на сградата, чрез относителните етажни премествания. При неизпълнено условие (голямо относително етажно преместване или недопустим PD-ефект), след съобщение изчислението продължава. Bx -габарит на сградата в план по X. By -габарит на сградата в план по Y.

EuroCode 8

Периоди -отчитане на желания брой форми. yi, v -класове на значимост на сградите. DCM, DCH - qо, ао -базови стойности на коефициента на поведение. agr -референтно максимално ускорение на земна основа. Възможност за определянето му по наименованието на населеното място. Почви групи, спектър -определят/задават се S, Ta, Tb, Tc и Td. Преместване -контрол върху коравината на сградата, чрез относителните етажни премествания. При неизпълнено условие (голямо относително етажно преместване или недопустим PD-ефект), след съобщение изчислението продължава. Bx -габарит на сградата в план по X. By -габарит на сградата в план по Y. Контрол върху критериите за регулярност по височина и в план със съответните нормативни корекции.

Вход нива

Таблично се задават етажна височина, етажно тегло и център на масите (X, Y) за зададения брой нива (концентрирани маси) и тегловен инерционен момент и контури при 3D. Възможност за автоматично изчитане на характеристики (G, Xcm, Ycm, Jmc) и контури на етажни плочи, записани преди това в Вход на обекти - Геометрични характеристики. Промяна на броя на нивата е възможна и чрез: (Ins) - въвеждане, (Del) - триене, виж таблицата.

Вход елементи 2D

Таблично се задават: Вид елемент (шайба, рамка, елемент); Име (по подразбиране S_i), при шайба - редактиране, а при външен елемент или рамка - работа с диалог. При рамка се задават Елемент рамка (задължителна работа с диалог при не въведена рамка - ??? или променено съответствие - *). Тук се задава еднаква с предходната или чете рамка с възможни формати (z02, x02 - след изчитане автоматично се конвертира до формат z02). Задаване или редактиране на възли по нива (входа им е задължителен, ако не са зададени, при формат (x02) възлите по нива се определят автоматично в зависимост от етажните височини с разлика не са по-вече от 5 cm). Възможност за преглед на изчетената рамка. При външен елемент се задават Име, Премествания. В група Auto, възможност за изчитане на гредостена (s01) с автоматична генерация на матрицата на пртеместванията от единични сили и последващо (след решението) автоматично създаване на файлове (s02) с товари по форми и гранични. За шайба материал (E-модул, той може да се зададе като число или да се вземе от базата с бетони чрез Shift + ляв бутон на мишката), характеристики (B, H) и ниво, съответна координата (координати) и евентуално ъгъл за всеки елемент. Промяна на броя на елементите е възможна и чрез: (Ins) - въвеждане, (Del) - триене, виж таблицата.

Вход елементи 3D

Задават се 4 типа елементи: шайба, сечение, рамка и данни. За шайба се задават име, материал (E-модул и коефициент на Поасон, те могат да се зададат или да се вземат от базата с бетони "Е ="), характеристики (B, H) и ниво, съответни координати и евентуално ъгъл на завъртане. Възможен е импорт на елементи/шайби от 2D чрез Ctrl + "Add+" бутон. При сечения се вмъкват файлове с формат (n02, i02). При рамки се вмъкват се файлове с формат (d__). Съществува и възможност за задаване на елемент чрез характеристики - пряко. Възможност за редактиране или задаване характеристики на елементи групово (маркирани). По височина характеристики на съответните елементи могат да се променят също или да нямат връзка с определено ниво.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формати за четене (z01 - общо за конструкцията, z02 - рамки), формат за запис (z__), формат за запис при 3D (d__).

Приема от:

Вход на обекти - с формати (z01, z02).

Генерация на мрежа - с формат (s01).

3D земетръс - с формат (n02, i02, d__).

Предава на:

Вход на обекти.

Общо оразмеряване. - с формат (z__, d__).

Преглед на графика - ревю - с формат (z__, d__).

Генерация на мрежа - с формат (s02).


Гредостени (изчисление)

Общо:

Модул за изчисление на гредостени по МКЕ (триъгълни с 3x2 за елемент). Възможност за изчисление на по-вече от една за един път. Табличен и графичен преглед на данни и резултати.

Меню:

Файл

Ново

Чете Ctrl-R

Изход

Решение

Решение (F9, Go) на изчетения обект.

Преглед

Таблици

Възли

Преглед на координати на възли. При Shift + ляв бутон на мишката се прихваща текущия възел, като за него се появява пълна информация за входни данни и резултати.

Типове

Преглед на характеристиките на отделните слоеве за обекта.

Елементи

Преглед на зададените елементи (възли и типове).

Концентрирани товари

Преглед на зададените концентрирани товари по възли.

Опори и реакции

Преглед на опори по възли и получените реакции в тях.

Vx, Vy

Преглед на преместванията по възли.

Напрежения

Преглед на разрезни и главни (ъгъл) напрежения по възли.

Оразмерителни напрежения

Преглед на оразмерителни напрежения по възли.

Единични опори

Преглед на получените реакции (във възел) за зададените единични опори.

Линейни опори

Преглед на получените товари (начален и краен възел, дължина, сума и разпределен товар) за зададените линейни опори.

Графичен

Преглед на графика - ревю, на зададените входни данни и получените резултати - повърхнини на:

Vx

Преместване по x.

Vy

Преместване по y.

Сигма x

Напрежение сигма по x.

Сигма y

Напрежение сигма по y.

Тау xy

Напрежение тау.

Сигма max

Главни напрежения, направления.

Сигма min

Главни напрежения, направления.

Сигма x+

Оразмерителни напрежения x опън.

Сигма x-

Оразмерителни напрежения x натиск.

Сигма y+

Оразмерителни напрежения y опън.

Сигма y-

Оразмерителни напрежения y натиск.

Ax/y

Опорни реакции (линейни и едиинични).

Help

Home

Application F1

Работно поле:

Информация за изчетения и евентуално изчислен обект. Текущия обект (Път/Име и Обект) се отпечатва от дясно на горната хоризонтална лента под менюто. Сума товари (X, Y) и опори (X, Y) за осъществяване на контрол след изчислението.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за четене (s01), формат за запис (s__).

Приема от:

Генерация на мрежа - с формат (s01).

Предава на:

Вход на обекти.

Гредостени (изчертаване).

Преглед на графика - ревю - с формат (s__).


Рамки (изчисление)

Общо:

Модул за изчисление и комбиниране на рамки. Табличен и графичен преглед на данни и резултати.

Меню:

Файл

Ново

Чете Ctrl-R

Изход

Опори

Таблица в която е възможно да се задават Пружинни константи или Подаване/преместване на опорите в съответните мерни единици за всяка връзка, ако има необходимост и данни за това.

Решение

Решение (F9, Go) на изчетения обект.

Преглед

Таблици

Възли

Преглед на координати на възли. При Shift + ляв бутон на мишката се прихваща текущия възел, като за него се появява пълна информация за входни данни и резултати.

Елементи

Преглед на зададените елементи (възли, тип на връзката, EJ, EF, безкрайно корави зони - проекции).

Товари

Преглед на зададените по елементи и възли.

Опори и реакции

Преглед на опори по възли и получените реакции в тях.

Vx, Vy, Zz

Преглед на премествания и завъртане по възли.

Разрезни усилия

Преглед на разрезни усилия (M, Q, N) по възли.

Графичен

Преглед на графика - ревю, на зададените входни данни и получените резултати (M, Q, N - диаграми).

Комбинации

Файл

Ново

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

Запис Ctrl-W

Изход текущо трие

Изход

Настройка

Възможност за Настройка условията за оразмеряване.

Комбиниране - [Екрани]

Комбинират се файлове с формати: (x__) – 2D рамки, (z__) – земетръс (шайби и рамки), (d__) – 3D рамки (избор на товарно състояние). При обекти с формат: (d__) – се правят следните приемания: четат се координати x, z (y - се игнорира), използува се Zy, работи се с разрезни усилия Myy, Qz, Nx, опорните връзки дават: Fx, Fy – връзка по x, Fz – връзка по y, Mx, My, Mz – връзка за Zz, сеченията се привеждат към правоъгълни, ако не са.

Възможност за генерациа на гранична армировка (надлъжна и напречна) с контрол за min (конструктивна) и max допустима по БДС или EC. Чрез опцията MQN се задава след Go - Комбиниране кои гранични диаграми (за коя комбинация) да се изчертаят, при изключена опция се генерира обвивката на армировката (надлъжна и напречна - конструктивна и максимална) за цялата рамка. Преди комбинирането възможност за прецизиране (размери, коефициенти и покрития) на условията за оразмеряване за всеки елемент на рамката. Тези промени се помнят при запазване на комбинациите - брой елементи. След вход в Настройка питане дали индивидуалните данни за елементите да се запазят. Alt при Ок - отказ от комбиниране.

Работно поле комбиниране:

Възможност за задаване броя на комбинациите Nmax, сеизмични коефциенти за всяка от тях и тежестен коефициент за всяко събираемо в комбинацията. Ляв бутон на мишката - избор на файл при съответния коефициент, десен бутон на мишката - трие реда от текущата комбинация (Ctrl + десен бутон на мишката - нулира цялата текуща комбинация). С бутони -> и <- движение по комбинации (Ctrl + бутони -> и <- предава редове (коефициент, файл) от текуща комбинация към новата по места, ако съответния ред на новата комбинация е без зададен файл). Възможност за избор на файл или файлове (стандартна работа с Control и/или Shift). Съществуват три възможности за генерация при изчислена армировка:

– Надлъжна - An cm2, за стремена - As cm2 / m' ;

– Брой железа N за надлъжна и разстояние между стремената S при зададени диаметри Dn, Ds;

– Получени диаметри Dn, Ds при зададени брой железа N за надлъжна и разстояние S между стремената.

Смяната на режима на генерация става, като се натисне ляв бутон върху армировка и се държи натиснат Control.

3DD

Help

Home

Application F1

Работно поле:

Информация за изчетения и евентуално изчислен обект. Текущия обект (Път/Име и Обект) се отпечатва от дясно на горната хоризонтална лента под менюто. Сума товари (X, Y) и опори (X, Y) за осъществяване на контрол след изчислението.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за четене (x02), формат за запис (x__).

Формат на модула за комбиниране (kor).

Приема от:

Вход на обекти.

Комбиниране - с формат (x__, z__, d__).

Предава на:

Вход на обекти.

Преглед на графика - ревю - с формат (x__, Комбинации).


3DD Рамки (изчисление)

Общо:

Модул за изчисление (статика и динамика) на пространствени 3D рамки.

Меню:

Файл

Ново

Текущо чете

Текущ запис Ctrl-Z

Вмъква

Стави конверт

При вмъкнатата геометрия за файл с формат (x02) - диалог за автоматично задаване на характеристиките (Lo, Jxx, Iyy, Izz) на генерираните допълнително елементи при симулация на ставен ефект.

Файл X02

Вмъква файл с формат (x02). Създава необходимия брой типове правоъгълни сечения обвързани с обекта. Тълкува опори – би следвало да се прецизират допълнително в съответния диалог.

Чете Ctrl-R

Допълнително бутон за обект от който се чете (при Ctrl, файл чете = файл запис).

Запис Ctrl-W

Допълнително бутон за запис.

Изход текущо трие

Изход

Решение

Решение (F9, Go) на въведения обект. Esc – прекъсва или изход от диалог при приключило решение.

Help

Home

Application F1

Работно поле:

Възможност за въвеждане на свободен текст за обект. Опции за Срязване ефект и Геометрия ефект.

Типове сечения

Диалог за създаване на набор от различни по вид и размери сечения, които могат да се привързват към елементите. При изход от диалога характеристиките на привързаните елементи се актуализират.

Елементи

Диалог за задаване на Ax, Asy (при Срязване ефект), Asz (при Срязване ефект), Jxx, Iyy, Izz, E - модул; коефициент на Поасон, ъгъл на завъртане на сечението, плътност (при собствено тегло и динамика), тип сечение. При елементите симулиращи ставен ефект се отцветяват Jxx, Iyy, Izz.

Възли

Диалог за задаване на координати на възли и радиус на безкрайно' коравата зона за този възел.

Опори

Диалог за контрол на опорни връзки при възли. Ляв бутон на мишката върху пореден номер алтернативно активира/деактивира 'всички' опорни връзки за него.

Статика

Задават се брой товарни състояния (1–95).

За всяко товарно състояние могат да се въведат текст и следните видове товари: Глобални – по възли, по елементи, трапецовидни товари, вътрешни концентрирани товари, опори – премествания и пружини. Локални – температури. При зададен елемент за товари по елементи, трапецовидни товари и вътрешни концентрирани товари, съществува възможност за конвертиране на конкретен товар от глобален в локален или обратно в зависимост от това как е бил зададен предварително.

Възможност за копиране, триене и местене по товарни състояния.

Динамика

Задават се търсения брой периоди (0–теоретичен max).

Опция за отчитане/добавяне собствената маса на обекта към общата. Задават се допълнителни маси по възли и елементи. Допълнителна възможност за задаване на инерционни маси по възли. Опции за Метод, Матрица на масите и Толеранс.

Video/Image

Диалог за контрол на получените резултати – два режима на работа стандартен и OpenGL.

Преглед на текст, ревю - текуща форма или товарно състояние. Преглед и запис на анимация/video или image (bmp, jpg, gif, png, tif) за текущо състояние. Опции за вида на анимацията (gif, avi – избор на codec), fps, размери, дебелини, цветове (при фон възможност за задаване на image - мащаб, позиция, stretch), текстове (служебни променливи – [C] - текст, [N] – име на файл, [T] – период или товарно състояние), завъртане (брой цикли, стъпка в градуси), позиция, параметри перспектива, коефициент при деформирана схема (изисква частично преизчисление).

Ресурси:

Няма софтуерен лимит.

Файлове:

Формати за четене (x02 - вмъква, d__ - 3D рамки), формат за запис (d__).

Приема от:

Вход на обекти - с формат (x02).

Предава на:

Преглед на графика - ревю - с формат (d__).

Video - с формати (gif, avi).


Общо оразмеряване

Общо:

Модул за таблично оразмеряване по БДС или EC на колони по нива, шайби и рамки от сеизмично изследване.

Работно поле:

Може да се зададе име на файл за запис с формат (o__). Задава се файл за четене, задължителен при работа с шайби и рамки (z01, z02, z__).

Таблица на нивата

Вход или редактиране на броя на нивата (въвеждане (Ins) и триене (Del), виж таблицата), етажните височини и описание на файлове с формат (k__) за всяко етажно ниво.

Настройка

Настройка оразмеряване -активни са Нецентричен натиск, Нецентричен опън и Срязване в зависимост от усилията. Това са базови (начални) данни, които по-късно за всеки елемент могат да се променят. Те са конфигурирани в оразмеряване.

Колони, Шайби, Рамка

Елементи:

– изчетени елементи N (брой колони х етажност, брой шайби х ниво до което достига всяка, брой елементи рамка х брой товарни състояния);

– допълнителни елементи (задават се от проектанта).

Корекции (групови корекции на усилията):

– Собствено тегло G - Автоматична генерация на товари от собствено тегло за елементите: колони, шайби, рамки (само за вертикалните елементи - колоните) и за допълнително зададените елементи;

– % от стойността на M усилието (недостъпно при Колони);

– абсолютна стойност M kNcm;

– % от стойността на N силата;

– стойност ±N kN (- натиск, + опън);

– % от стойността на Q силата (недостъпно при Колони);

– абсолютна стойност Q kN.

Размери:

– височина L;

– ширина B;

– дължина H.

При работа с шайби и рамки се въвеждат допълнително номерата на колоните които стъпват върху съответния елемент. Товарите от тези колони се сумират по нива от Таблица на нивата, така се получават ±N усилията в елементите. Всички данни включително и усилията е възможно да бъдат редактирани индивидуално. При работа с шайби, опция за автоматична им генерация като рамки за вертикални товари – файлове с формат (x__). Това дава възможност за комбинирането им със земетръс впоследствие.

Решена таблица

След избор на файл с формат (o__) се изчита маркираната таблица. В таблицата съществува пълна възможност за редактиране на всяко поле (след загуба на фокус автоматично преизчисляване на текущата колона). При зелен цвят на изчислената армировката - тя е конструктивна, а при червен - над допустимата. Възможност за избор на вложената армировка. При кликване върху името на елемента той потъмнява, т.е. забранява се записа на тази елемент при Запис+ (добавяне към файл) на таблицата. Възможност за скриване или показване на целият елемент (колона/шайба) по височина (етажи), при кликване върху името му и задържан Shift. При кликване на същото място и задържан Control се появява прозорец за групова работа по етажи и по елемнти, като елемнтите се изброяват със запетаи, а от до се указва чрез тире (11,3,17-28,1,35 ...). Възможност за автоматична смяна на B/H (работи се в същият прозорец по аналогичен начин). Преглед текст, възможност за преглеждане на файл с формат (o__).

БДС:

Елементи: K.1e1, S.1e1, S.1e2, E.1 л, Е.1 д

M - усилие

N - усилие (- натиск, + опън)

L - височина

B - ширина

H - дължина

a' - покритие

jz - сеизмичен коефициент надлъжна армировка

jb3 - коефициент вертикално бетониране

jb5 - площен коефициент за сечението

Kiz - коефициент на изкълчване

Ea - случаен ексцентрицитет

jso - коефициент при опън

A=A' - изчислена армировка в cm2

nФD - приета армировка бройки/диаметър

Q - усилие

jz ср - сеизмичен коефициент за стремена

A - изчислена армировка за Q

n/D/l - приета армировка срезност/диаметър/през разстояниею

EC:

Елементи: K.1e1, S.1e1, S.1e2, E.1 л, Е.1 д

M - усилие

N - усилие (- натиск, + опън)

L - височина

B - ширина

H - дължина

a' - покритие

A=A' - изчислена армировка в cm2

nФD - приета армировка бройки/диаметър

Q - усилие

a' - покритие

A - изчислена армировка за Q

n/D/l - приета армировка срезност/диаметър/през разстояниею

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за запис (o__).

Приема от:

Кофражен план (изчисление) - с формат (k__).

Сеизмично изследване - с формати (z01, z02, z__).

Вход на обекти.

Предава на:

Детайли - с формат (o__).

Рамки (изчисление) - Комбинации - с формат (x__).

Преглед текст.


Поле

Общо:

Изчислява четиристранно и тристранно (с конзола) подпрени полета по метода на преразпределение на усилията (Нисимов), едностранно армирани и конзолни. За всички видове полета се дават моменти, линии на разрушение, равномерно разпределени товари (приведени за момент), оразмеряване, избор на армировка и проверка на провисване.

Меню:

Файл

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

Чете обекти след избор и от файл с формат (p__).

Запис Ctrl-W

Изход текущо трие

Изход

Решение

Решение (F9) за текущото поле.

Help

Home

Application F1

Работно поле:

Възможности за промяна на типа на полето (четиристранно подпряно - тип 4, тристранно подпряно (конзола) - тип 3, еднопосочно армирано - тип 2, конзола - тип 1), материали (бетон и стомана).

Задават се дебелина и полезни височини в последствие те остават по подразбиране. Възможност за генерация на предлаганият товар, равен на собственото тегло на m2. Възможно е въвеждане на линеен товар, който в последствие се 'размазва' до равномерно разпределен, като за различните типове полета той действува по:

– средата на Х и/или Y за тип 4;

– не подпряната страна за тип 3;

– надлъжната ос (успоредно на носещите страни) за тип 2;

– надлъжен свободен ръб (успоредно на носещата страна) за тип 1.

В зависимост от типът поле, могат да се зададат Mа или cа, Mб или cб, Mв или cв и Mг или cг. Допустимо е ci да е в интервала [0.00 - 2.50]. За изчетено поле напълно възможно е да променяте Li, ако сте го задали неточно или M известно, ако имате съображения за това. Извеждат се схемата на подпиране, както и други подсказващи съобщения. При предлаганите варианти за армировка е направена проверка в хоризонтално и вертикално направление. Извършва се проверка на провисването на полето. За четиристранно и тристранно подпрени полета по Нисимов, за останалите с Mп/M = 1.0 и ks = 0.104 за едностранни, ks = 0.250 за конзола. При провисване (Wрез - от постоянни товари, Wрез к - от кратковременни товари) по-голямо от допустимото (Wдоп), възможност за корекции на Qнормативно (допълнителна възможност за задаване/генерация на нормативен площен товар по зададен коефициент - Ctrl), дебелина и вложена армировка. При неизпълнено условие за провисване по усмотрение на проектанта тази проверка може да се пренебрегне. Възможност за преглед на графика - ревю.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за запис ( ).

Приема от:

Кофражен план (изчисление).

Предава на:

Кофражен план (изчисление).

Преглед на графика - ревю - с формат ( ).


Греда

Общо:

Изчислява греди с конзолен, свободен и запънат край.

Натоварване концентрирана сила и разпределен товар (вариантите на p1 и p2 по знак и стойност дават различни видове товари).

Дават се стойности за M и Q над опорите и в девет точки в полето (т.е. съответния участък се дели на десет равни части), ръбови стойности (M, Q) и търси Mmax положително. Съществува възможност за промяна на опорните моменти с последващо преразпределение на разрезните усилия.

Меню:

Файл

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

Чете обекти след избор и от файл с формат (g__).

Запис Ctrl-W

Изход текущо трие

Изход

Решение

Решение (F9) за текущата греда. Извеждане на вертикална сума рекации. Преглед на M и Q през десет равни части за текущия участък, ръбови стойности за M,Q и намиране на Mmax положително (+M). Изчисление на M и Q за произволна точка от текущия участък L.Възможности за задаване на нови опорни моменти (различни от изчислените) с последващо преразпределение на разрезните усилия. Моментите над опорите могат да се задават пряко чрез стойности, или чрез коефициент k за намаление/повишение или промяна на знак при диалог [%] за маркираните опори. Чрез Enter – умножава маркираните опорни моменти по коефициента k, Esc – отказ. Извършване на оразмеряване и проверка на провисване в необходимите сечения. При извършване на оразмеряване в модула се появява диалог Данни от греда с възможностите за оразмеряване при всеки участък. Обединява в една кобилица, сили при dL< B и генерира автоматично едностранни кобилици при разстояние от ръба < H. Критерий за завършена работа с текущото оразмеряване е неговият запис. В работното поле то се маркира като решено. След оразмеряване или при наличен от преди това подчинен модул за оразмеряване, фона на някои текстови полета се променя, което е критерий, че има възможност за работа и контрол със max моменти за единична и двойна армировка. Промяната на условията в подчиненият модул за оразмеряване се отразява на max моменти след натискане на ляв бутон на мишката върху Mp_i= (Get Mmax) или върху всяка контрола с данни за полета. Max моменти се дават като ToolTip в формат: - Mmax – max отрицателен момент за текущото сечение за единична армировка, - Mmax2 – max отрицателен момент за текущото сечение за двойна армировка, + Mmax – max положителен момент за текущото сечение за единична армировка, + Mmax2 – max положителен момент за текущото сечение за двойна армировка. След натискане на ляв бутон на мишката върху контрола с данни за опори, автоматично се приема за опорен момент, в зависимост от знака на ръбовите моменти min от двете съседни полета от max моменти за единична армировка. Като ToolTip се дават ръбовите моменти, чрез които се осъществява контрола към съседните полета за опора. При цвят магента, опората (представена, чрез ръбови си моменти) или полето има момент над този за единична армировка, но по-малък от този при двойна. Ако цвета е червен, момента при опората (представена, чрез ръбови си моменти) или полето е по-голям от този при двойна. При завършена работа с данните за цялата греда се натиска бутон Запис към греда. Възможност за автоматично оразмеряване на всички сечения за разглежданата греда, чрез Ctrl. Аналогична са действията при проверка на провисване. Възможност за преглед на графика - ревю на текущото състояние.

Help

Home

Application F1

Работно поле:

Промяна на типа на гредата и брой участъци (ляв бутон върху текущия участък). Възможност за преместване на участъците при греди с лява конзола - при промяна на типа на гредата от или към лява конзола. За избор на нов участък ляв бутон на мишката или клавиши лява и дясна стрелка върху малката схема горе в дясно (текущият участък се маркира - магента). Редактиране на полето: дължина и напречно сечение (ляв бутон върху сечението). Десен бутон върху сечението - възможност за пренос на сечението върху другите участъци (ляв бутон върху малката схема), още веднъж десен бутон - отказ. Shift + десен бутон върху сечението - същото плюс пренос и на дължината.

За промяна на дадена опора се кликва върху нея. Десен бутон върху опора - възможност за пренос на опората върху другите опори (ляв бутон върху малката схема), още веднъж десен бутон - отказ. Въвежда товар след ляв бутон върху полето за товари на съответния ред, ако там има товар - редактиране. Възможност за генерация на предлаганият товар, равен на собственото тегло на m'. При десен бутон върху товар - възможност за преноса му върху другите участъци (ляв бутон върху малката схема), още веднъж десен бутон - отказ. Shift + десен бутон върху полето за товари - възможност за преноса на всички товари върху другите участъци (ляв бутон върху малката схема), ако участъците са с различни дължини товарите се редуцират пропорционално на дължината. Захванат товар или товари се изтриват с Del. Възможност за въвеждане на товари едновременно върху всички полета на дясно от текущото, ако размера на товара е по-голям от дължината на гредата той се реже пропорционално. Местото на товара в съседните полета се определя от позицията му (ако е свободна), в противен случай се взема най-близката, ако товарите са максимален брой (15), товара се разполага в неговата си позиция. При функция пренос маркера се сменя по подходящ (указващ) начин. При концентрирана сила с коментар започващ с ">", не се извършва пренос към оразмеряване за намиране на кобилици и за тази сила не се очаква кобилица при изчертаване.

Ресурси:

За греда 15 участъка + 2 конзоли. На всеки участък до 15 товара.

Файлове:

Формат за запис ( ).

Приема от:

Кофражен план (изчисление).

Предава на:

Оразмеряване.

Провисване.

Кофражен план (изчисление).

Греди (изчертаване).

Преглед на графика - ревю - с формат ( ).


Фундамент

Общо:

Изчислява бетонни и стоманобетонни единични фундаменти (симетрично и несиметрично развити), натоварени центрично или нецентрично (на единично и двойно огъване). Изключва опъна при необходимост и проектира фундамент с оптимални размери, като всички проверки могат де се прегледат при необходимост. По желание може да се зададе фундамент с конкретни размери за който, да се извършат необходимите проверки (включително проверка на слягане).

Меню:

Файл

Текущо чете

Чете данни (първо срещнатите, ако са няколко) за фундамент с формат ( ).

Текущ запис Ctrl-Z

Чете Ctrl-R

Запис Ctrl-W

Настройка запис

Записва в служебен файл редактираните данни от Настройка.

Изход текущо трие

Изход

Решение

Решение (F9) за текущият фундамент.

Слягане

Диалог за проверка на слягане на фундамент след автоматично пренасяне данните за текущия. Промяната на броя на слоевете на земната основа става чрез: (Ins) - въвеждане, (Del) - триене, виж таблица. Възможност за отчет на напрежение и слягане за произволна дълбочина.

Файл

Чете Ctrl-R

Чете данни (първо срещнатите, ако са добавени няколко) за слягане от файл с формат ( ).

Запис+ Ctrl-W

Записва (добавя) данни и резултати за слягане във файл с формат ( ).

Кадър

Екран

Генерира векторен кадър с настройките от екрана.

Zoom x 1

Фиксиран вътрешен мащаб (x 1).

Изход слягане

Изход от диалога за проверка на слягане.

Решение

Проверка на слягането (F9) за текущите данни.

Възможност за задаване изчисление на фундаментна плоча.

Брой, имена и характеристики (j, Eo, h) на пластовете в земната основа се задават в таблица Пластове.

Резултати са дълбочината на активната зона Ha, слягането на фундамента S и Винклерови константи (фундамент: Wf, Wfz - сеизмична, фундаментна плоча: Wp, Wpz - сеизмична).

Настройка

Виж Настройка долу. Показва параметрите необходими при слягане.

Настройка

Конфигуриране (настройка) на модула за работа, тук се задават параметрите свързани с нормативните изисквания при проектиране на единични фундаменти. След Настройка запис се запазват текущите промени при необходимост.

Help

Home

Application F1

Работно поле:

След ляв бутон върху схемата на текущият фундамент, възможност за избор на нов тип фундамент и натоварване.

Входни данни

Избира се вида почва с нейното условно изчислително натоварване Ro (възможност за редактирането му), материалите (бетон и стомана). Задават се геометричните характеристики на колоната (ac, bc), дълбочината до първата стъпка на фундамента (l) и натоварването (N, Ma, Qa, Mb, Qb) му. Възможност за генерация на предлаганият товар, равен на собственото тегло.

Резултати

Приведеното в зависимост от дълбочината на фундамента почвено натоварване R. Геометрични размери на фундамента (габарити, брой стъпки и размерите им). При стоманобетонов, необходимата армировка. Пълен контрол за всички необходими проверки (напрежения в ръбовете, максимално и средно напрежение, изключен опън - площ и положение, продънване, ъгъл на предаване на товара за бетонов, срязване и огъване за всяка конзола при стоманобетонов).

При първо решение модула прави опит за предложение на оптимален (да излизат проверките) вариант, след корекция на данните (задаване на конкретен случай), възможност за ново изчисление Go. Възможност за преглед на графика - ревю на текущото състояние.

При големи моменти (т.е. преобръщане на фундамента) итерациите спират до получаване на до 9 стъпки (една стъпка е с размери от 30 до 60 cm в зависимост от случая).

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за запис ( ).

Приема от:

x.

Предава на:

Преглед на графика - ревю

- с формат ( ).


Оразмеряване

Общо:

Изчислява стоманобетонно сечение на огъване, срязване, усукване, натиск, опън, кобилици и комбинации от тях по БДС или EC.

Меню:

Файл

Ново

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

Чете данни (до 100) за оразмеряване от файл с формат ( , g__).

Запис+ Ctrl-W

Записва (добавя) данни и резултати за оразмеряване във файл с формат ( ).

Преглед текст

Преглед на файл с резултати.

Настройка запис

Записва в служебен файл текущото състояние на редактираните данни.

Изход текущо трие

Изход

Оразмеряване

Огъване

Работи - самостоятелно, в комбинация със срязване и/или усукване.

Нецентричен натиск

Работи - самостоятелно, в комбинация със срязване и/или усукване.

Нецентричен опън

Работи - самостоятелно, в комбинация със срязване и/или усукване.

Срязване

Работи - самостоятелно, в комбинация със усукване и/или с едно от огъване, натиск, опън.

Усукване

Работи - самостоятелно, в комбинация със срязване и/или с едно от огъване, натиск, опън.

Кобилици

Работи - самостоятелно.

Решение

Решение (F9) за текущите данни.

Help

Home

Application F1

Работно поле:

След десен бутон извиква Оразмеряване.

Общи

Избор на материали (бетон и стомани) и коефициенти. В Combo box са последните 100 оразмерявания - преглед (системен цвят), Enter - приема текущото.

Диалози за оразмеряване

Настройва се средата (условията) за текущите действия.

Вход и резултати

Задават се име, геометрични характеристики, натоварване за конкретното изчисление. В някои случаи се предлагат подсказващи, стойности, примерно при съдействаща ширина на плочогредово сечение.

При активен jz, следва корекция на КсиR*0.85 по "Норми за проектиране на сгради и съоръжения в земетръсни райони", раздел III, чл. 56 в сила от март 1987 г. При влизане в модула за оразмеряване от непрекъснати греди се предават необходимите геометрични характеристики и разрезни усилия за всеки участък последователно (примерно -Mляво ръбово, -Mдясно ръбово, +Mполе, Qmax, кобилици при концентрирани сили за всеки участък). При изчисление (F9) извежда: Mmax, x, m%, като при невъзможност за поемане на усилието от единична армировка се прави опит за поемането му с двойна армировка. Отчита влиянието на N по знак (опън, натиск) и плочата при плочогредово сечение, при комбинирано оразмеряване на сечение. При срезност 2 и комбинация с усукване армировката за стремена се сумира с тази от усукването. Ако пред изчислените cm2 е изписано b (примерно bA = 5.12), това значи, че бетона поема усилието, ако е изписано k (примерно kA = 5.12), това значи, че армировката е конструктивна. При срязване е възможно да е изписано m, това значи че е приет минимума по изменение N#2 за изчисление на напречната армировка в сила от 01.10.1993 г. За EC при определяне на ki e добавена работа с рамки формат (x__).

Тълкуване на армировка

За B<>100 cm това са от 2 до n броя железа от един или два съседни диаметъра разположени в един ред, а за B=100 cm от 5 до 14 броя железа също разположени в един ред. За предлаганите варианти е направена проверка в хоризонтално направление: покритие, диаметри, разстояние между тях. Аналогична проверка се извършва и във вертикално направление: покритие, диаметър. При a'>10 cm се дава армировка за цялото сечение, не се контролира ширината на сечението. При H>100 cm за конструктивна армировка се дава армировка, като за глава на шайба 4N12.

Ресурси:

Помни последните 100 изчисления.

Файлове:

Формат за запис ( ).

Приема от:

Греда.

Предава на:

Греда.

Преглед текст.


Провисване

Общо:

Изчислява стоманобетонно сечение (правоъгълно, плочогредово, обратно плочогредово, 2Т-сечение) на провисване по БДС или EC, като отчита евентуалната поява на пукнатини.

Меню:

Файл

Ново

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

Чете данни (до 100) за провисване от файл с формат ( , g__).

Запис+ Ctrl-W

Записва (добавя) данни и резултати за провисване във файл с формат ( ).

Преглед текст

Преглед на файл с резултати.

Настройка запис

Записва в служебен файл текущото състояние на редактираните данни.

Изход текущо трие

Изход

Решение

Решение (F9) за текущите данни.

Help

Home

Application F1

Работно поле:

Общи

Избор на материали (бетон и стомани) и коефициенти.

Вход и резултати

Задават се име, геометрични характеристики, натоварване за конкретното изчисление. В някои случаи се предлагат подсказващи, стойности, примерно при съдействаща ширина на плочогредово сечение. При влизане в модула за провисване от непрекъснати греди се предават необходимите геометрични характеристики, ks, допълнителното провисване Wкор от завъртане при козоли, разрезни усилия за всеки участък последователно (примерно +Mполе) и вложена армировка. При изчисление (F9) се извеждат подсказващи съобщения. В Combo box са последните 100 оразмерявания - преглед (системен цвят), Enter - приема текущото.

Ресурси:

Помни последните 100 изчисления.

Файлове:

Формат за запис ( ).

Приема от:

Греда.

Предава на:

Греда.

Преглед текст.


Надлъжна армировка

Общо:

Диалог за преглед и контрол на въведена армировка (площ cm2), като функция на бройките и диаметъра (фmm). Възможности за сортиране на получените комбинации по ред на използувани/желани диаметри – A, по предпочитана бройка пръти (при стремена разстояние между тях в cm) – B, по оптимална комбинация армировка т.е. min разход на стомана – C. Чрез Edit възможност за задаване на горните условия за различните типове армиране и задаване на критерий за сортиране по подразбиране (влияе върху първоначално предлаганата армировка).


Напречна армировка - стремена

Общо:

Диалог за преглед и контрол на въведена армировка (площ cm2), като функция на бройките и диаметъра (фmm). Възможности за сортиране на получените комбинации по ред на използувани/желани диаметри – A, по предпочитана бройка пръти (при стремена разстояние между тях в cm) – B, по оптимална комбинация армировка т.е. min разход на стомана – C. Чрез Edit възможност за задаване на горните условия за различните типове армиране и задаване на критерий за сортиране по подразбиране (влияе върху първоначално предлаганата армировка).


Кофражен план (изчертаване)

Общо:

Модул в който се изчертава решен (зададен) преди това кофражен план (без това да е задължително). Той се обработва чрез нанасяне и/или разместване на съответните елементи до получаване на пълен работен чертеж в стил кофражен или армировъчен (автоматично определяне закотвяне и дължина на армировката) план. Пълна спецификация (автоматично изчисление на МА и столчета, таблица на фигурите на железата) на армировката.

Ляв бутон на мишката потвърждава. Десен бутон на мишката или Esc - отказ. Всички текущи действия се отпечатват от ляво на горната хоризонтална лента под менюто.

Меню:

При извършване на действие от менюто отказа е възможен, като върху хоризонталната лента под менюто се натисне десния бутон на мишката или Esc.

Файл

Ново

С Control не изтрива детайлите върху чертежа, ако има такива.

Трие детайли

Изтрива всички детайли върху чертежа, ако има такива.

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

При четене auto convert от версия 12.XX и следващи, към текущата версия.

Запис Ctrl-W

Кадър

Цветен печат

Генерира векторен кадър - цветно върху бяла основа.

Моно печат

Генерира векторен кадър - черно върху бяла основа.

Екран

Генерира векторен кадър - цветно върху черна основа.

Моно негатив

Генерира векторен кадър - бяло върху черна основа.

Zoom x 2

Увеличава вътрешния мащаб (x 2 - избран от долните) за по - добър печат.

x 1

x 1.5

o x 2

x 2.5

x 3

x 3.5

x 4

x 5

x 6

x 8

x 10

x 20 !

x 50 !

Обект чете

Чете обект с формат (k02) - Задължителни и се опитва да прочете обекти с формати (p__, g__, o__) - Препоръчителни. За обект с формат (o__) - възможност да се зададе нов файл и ниво (етаж) за уточняване размерите на колоните (направленията им впоследствие се уточняват). Go - ново изчитане. Quit - изход с приемане на данните за работа. Преместване на обекта върху чертежа.

Елементи чете

променя

Греди

Изчита позиция (възможност за задаване на отместване) и характеристики на греди. Изчетените греди препокриват тези от работната среда.

Колони

Изчита позиция (възможност за задаване на отместване) и характеристики на колони. Изчетените колони препокриват тези от работната среда.

добавя

Детайли

Изчита позиция (възможност за задаване на отместване) на детайли. Добавя изчетените детайли към тези от работната среда.

Колони - променя

Изчита позиция (възможност за задаване на отместване) и характеристики на колони. Изчетените колони препокриват тези от работната среда.

Запис чертеж

CAD

Изготвя сборен чертеж на всички елементи които са видими върху екрана и по начина по който са видими плюс тези изчертани в PCPcad по време на работа. Чертежа е с формат dpf. Следва автоматичен старт на PCPcad. Препоръчва се.

DXF-DWG

Записва чертеж с формати (dxf-dwg, spc - при пусната армировка). В чертежа се генерират всички елементи които са видими върху екрана и по начина по който са видими. Настройка и преглед на генерирания DXF-DWG файл. Автоматичен преглед на количества файл с формат (spc), ако е генериран такъв.

SCRIPT

Записва чертеж с формати (scr, spc - при пусната армировка). В чертежа се генерират всички елементи които са видими върху екрана и по начина по който са видими. Автоматичен преглед на количества файл с формат (spc), ако е генериран такъв.

Изход текущо трие

Изход

Редакт

Undo F11

Redo F12

Коментари Ctrlt-T

Преглед и пълно редактиране (възел, текст, позиция спрямо входния възел, ъгъл, размер и видимост) на въведени стрингове (коментари). Въвеждане (Ins) и триене (Del) на въведени коментари в таблицата за редактиране. С Ctrl-T захваща позицията на маркера и предлага най-близкия възел в таблицата (първият коментар задължително се въвежда по този начин). С Del-Коментари изтрива всички въведени до момента. Възможност за разполагане на един коментар на няколко реда, чрез въвеждане на служебните символи - \R (\r) в текста. Работа с константи: %t – име на системата (PC Proektant), %v – версия (13.03c), %l – лиценз (текст), %n – регистрационен номер (000000000), %u – потребител (текст), %y – година (2003), %m – месец (05), %d – ден (28), %s – мащаб (1:50), %f – формат (A3 или празно, ако е нестандартен), %p – размери (594x420), възможност да се използуват потребителските константи (%c0–%c9) зададени при Печат.

Текст Alt-T

Алтернативно разрешава/забранява текст за целия чертеж.

Възли

Настройка

Материали F9

Избор на бетон, стомани: носеща (ако не изчетена друга), РА - разпределителна армировка (бройки/диаметър на m'), МА - монтажна армировка (бройки/диаметър на m'), столчета (бройки/диаметър на m2).

Настройка

Базова принципи

Задават се отношенията спрямо размера на съответното поле за запъване на армировка в съседни полета, като се разграничават конзолните (запъват се обикновено на Lконзола) от другите (запъват се обикновено на L/4). Задават се отношенията за огъване на армировка в поле към свободна страна (обикновено L/10) и към запъната страна (обикновено L/5). Задават се и разстояние на закотвяне в гредите за армировката. Може да се зададе и равно на нула. Тази стойност може да се тълкува като ширина на гредите без покритието (Bгреда-5 = 20 cm). Примери за правия участък на армировката при 0.20 m закотвяне в гредите:

- усилител = L ляво поле/4 + L дясно поле/4 + 0.20;

- права = L поле + 0.20;

- огъната - крайна = L поле/10 + 0.20;

- огъната - средна = L поле/5 + L съседно поле/4 + 0.20.

(L - осови размери на полето)

Горна армировка

Динамично задаване на размера на огъвката за огъната армировка и усилители. Възможни са три начина на задаване: auto - като функция на ho, auto и параметър със знак +/- и фиксирана стойност.

Столчета

Динамично задаване на размера - дълбочината на столчето. Възможни са три начина на задаване: auto - като функция на ho, auto и параметър със знак +/- и фиксирана стойност. Задават се като стойности ширината и крачетата на столчето.

Редакт армировка Ctrl-A

Бързо редактиране на конкретна армировка става, чрез посочването й с мишката и натискане на Ctrl-A (прихваща фигурата по центъра й). При номера и името на прихваната фигура се добавя "*".

Таблица армировка

Генерация в чертеж

Вмъква при генерацията на чертежа сортирана таблица с фигурите на армировката.

Количества

Изчислява количества на кофраж, бетон и стомана (включително на m2 и m3) за пуснатите/видимите на екрана елементи. Десен бутон на мишката стандартно меню за маркиране (копиране).

Лист/Мащаб

Избор размери на лист, богат набор от стандартни листа или избор на такъв с уникални размери. Мащаб по избор в стил 1:Y, X:1 или X:Y. Коефициент за размер на всички надписи по чертежа (Ctrl/Alt-S - увеличава/намалява коефициентите за надписване с процент равен на стъпката за увеличение, но не по-малко от 10%). Auto - автоматично променя коефициента за текст и размерите на листа в зависимост от промяната на мащаба, като запазва текущото съотношение.

Надписване

Оси

Диалог за задаване позиция и символи за надписване на оси (вертикални, хоризонтални), примерно: 1, 2, 3, 3', 3'', A, B, B1, C, d, Ea, Eb, F - разделител запетая. Тези имена се приемат, ако не е зададено друго при вход или редакт име на ос (тук е възможно да се зададе и наклон на оста). При запис, те стават общи за останалите модули за чертане. При недостиг на зададени символи (брой символи < брой оси вертикални или хоризонтални) системата автоматично добавя за вертикални - поредния номер, а за хоризонтални - поредната главна буква от латиница (A, B, C, … Z) при изчерпването добавя индекси (A1, B1 … Z1, A2, …).

Полета

Диалог за указване на надписване при знака на полетата тяхната дебелина - стил кофражен план (при спряна армировка). Изчертаване на диагоналите и изписване на дебелината на полето. При запис, те стават общи за останалите модули за чертане, където има такива елементи.

Греди

Диалог за задаване на типов текст - име за надписване, вид на щриховката за различните греди и типа на сечението на гредата при разрези - нормално или отворено (бетонов елемент - шайба). При запис, те стават общи за останалите модули за чертане, където има такива елементи.

Колони

Диалог за задаване на типов текст - име за надписване и вид на щриховката за нормална и насадена колони. Възможност за указване начина на надписване на размерите на колоните (Аuto – при спряна армировка, Аlways – винаги, No – без надписване). При запис, те стават общи за останалите модули за чертане, където има такива елементи.

Армировка

Диалог за избор на начин на надписване за армировка (бройки /m', разстояние между прътите във всяко направление - армировъчен план - при знака на полетата (горе/долу в зависимост от покритието в съответното направление), подробно, позиция, бройки, диаметър, дължина, разстояние между прътите). При запис, те стават общи за останалите модули за чертане, където има такива елементи.

Рамка

Диалог за попълване на параметрите за изчертаване на единична или двойна рамка към чертежа.

Печат

Диалог за попълване на печата към чертежа. Възможност за работа със стрингови константи на системата и/или зададени потребителски (Калкулатаор – Custom – User strings). Възможно е да се работи и с уникален печат – детайл, в който освен форматиран текст, могат да се добавят/рисуват фирмени знаци, лого и други.

Преместване

Преместване на целият чертеж върху (спрямо) листа, без това да води до промяна на координатите на въведените обекти. Преместването се изчислява спрямо две точки (кликвания с левия бутон на мишката), т.е. дадената 1-точка, да се премести в 2-точка.

Координати

Тук се задават стъпките на мрежата. Кратно на, е числото на което са кратни координатите на маркера върху работното поле когато е натиснат десен бутон на мишката и не е пусната мрежата.

Мести Alt-M

Алтернативно скрива/показва диалога за управление от работното поле.

Параметри

Проценти на мащабиране и движение. Параметри необходими на диалога за управление от работното поле. Извиква се и от диалога за управление, като два пъти се натисне левия бутон на мишката върху горната лента.

Възли Alt-V

Диалог за бърз достъп до функциите с възли.

Обект Alt-O

Алтернативно скрива/показва диалога за редактиране на чертежа.

CAD

Help

Home

Application F1

Работно поле:

При натискане ляв бутон на мишката прихваща най-близкия възел. При натискане десния бутон на мишката при включена Мрежа маркера прихваща координатите на най-близкия възел от мрежата, а при изключена Мрежа координатите.на маркера стават кратни на числото от Координати. При Shift + десен бутон на мишката маркера прихваща координатите на най-близкия въведен възел. Това се отпечатва от дясно на горната хоризонтална лента под менюто.

При свободно работно поле (без да сте в режим на работа с възли или елементи), ако натиснете ляв бутон на мишката се задава начална точка (примерно при Shift + десен бутон на мишката маркера прихваща координатите на най-близкия възел и той става начална точка). При което, всяко натискане на десен бутон на мишката, води до запомняне (mem) на текущите параметри - L, a, dX, dY. Те могат автоматично да се използуват (при кликване върху потъмнени позии на текст), като данни при местене, копиране, завъртане, размножаване и др.

BackSpace - връща назад маркирани възли. При Del и прехванат (с левия бутон на мишката) вече маркиран възел, той се демаркира. При местене (втори възел) и натиснат клавиш A (Align), ъгъла между двата възела става автоматично кратен на 5°.

При натискане на десният бутон на мишката върху горната лента на диалози (tools), извиква диалог за конфигуриране на позицията им (индивидуално или по групи).

При некоректна армировка (недостиг на площ спрямо изчетеното/изчисленото или бройки на m' извън интервала 5-14) за полета и усилители - основният надпис за съответното желязо се изписва в червено или магента, ако е вече редактирано/променено ръчно. Същото става и при участъка за огъната армировка над съседно поле, ако е зададено такова.

Диалог за управление

С Shift + Zoom се прихващат всички възли в областта, а с Alt + Zoom се задава правоъгълна област за изчертаване на оси (Alt + Zoom без възли изтрива зона оси). Ако тя е със сложно очертание, би следвало да се опише при вход полигон, след което да се задържи Alt, като указание за зона оси. При натискане двойно ляв бутон на мишката върху горната лента извиква Параметри.

При задържане на Shift и кликване върху управляващи бутони, следва непрекъснато изпълнение на командите (анимация) до отпускане на Shift. При кликване върху управляващ бутон преди да е изчертан чертежа върху екрана, прекъсва изпълнението и чертае отново с новите параметри. Управление с клавиши от управляващ блок. Scroll Lock – on/off, променя алтернативно посоките на движение. Мащабиране при скролиране със среден бутон на мишката. При местене на мишката и натиснат среден бутон, следва движение на изчертаното. При двойно натискане на средния бутон на мишката – екран всичко.

Диалог за редактиране

Бутона с двойна стрелка задава направление x или y (при коти, оси и др.), а бутона xy задава начин на местене на възлите или елементите по чертежа (ръчно или чрез зададено отместване) при натиснат Ctrl действието му алтернативно се променя. При Вход детайл се маркират възли за пренос (ако има такива) и се натиска десен бутон на мишката, възлите се пренасят в работното поле на детайли, там се изчитат (вмъкват), редактират и записват в буфера (към 'Кофраж') необходимите един или няколко детайли (тези действия могат да се повторят неколкократно). При Редакт детайл, маркираният детайл се пренася в работното поле на детайли, там се редактира и след запис в буфера (към 'Кофраж') се пренася върху чертежа в редактиран вид. При Трие детайл, маркираният детайл алтернативно се скрива (червен възел) или показва на екрана, без да е изтрит от буфера, ако е натиснат Ctrl в момента на захващане на детайла, той се изтрива от буфера. Чрез Alt при Трие детайл се работи по групи детайли. При видимост групи: маркирани – видими, немаркирани – невидими (Enter – приема, Esc – отказ). При трие групи – Ctrl, маркираните се изтриват (Enter – приема, Esc – отказ). При Редакт поле за конзолни и еднопосочно армирани полета да се задават ненулеви стойности за hx или hy (по не носещата посока) за да се изчертават правилно усилители, ако има такива по не носещата посока на полето. В името на полето трябва да се съдържа задължително номер [1-255] и след него евентуално [0-3] символа, примерно 99а'. При Редакт греда се задават име/номер (при "--" в началото, текста е уникален и не се сумира с базовия за определения тип греда), тип греда, тип сечение, размери отстъпи: -отляво, +отдясно.

При Редакт колона се задават име/номер (при "--" в началото, текста е уникален и не се сумира с базовия за определения тип колона). При Редакт армировка, маркира снопа армировка по направление на съответното поле и светва диалога за контрол (опция за работа с прави или огънати за всеки сноп). За всеки сноп армировка се задават ъгъл на снопа, съседни полета, дължини на полето и съседите - определят размера на снопа, вида стомана, вложена армировка в полетo и съседните, контрол на армировка над опори (от къде-цвят магента стрелки и колко бройки n/n~ - всичко броя/външни за опората), вложена армировка (Aput cm2), изчислена армировка (Acal cm2). При смяната на вида на стоманата се редуцира изчислената армировка Acal пропорционално на Rs, вложената армировка Aput също се сумира пропорционално на Rs за всички стомани участващи в формирането й (* – подсказва, че има стомани при сумирането с различни Rs). Запъване за усилители L/4. Огъване в поле при запъване L/5, при свободен край L/10 (L са съответни осови размери на полето). Автоматично определяне на МА, РА и столчета при необходимост. При наличие на непрекъсната греда с различни напречни сечения в различните участъци е целесъобразно да се зададат няколко греди с едно и също име, но с различни напречни сечения. Око Ctrl-G - задаване на видимите елементи и начина им на изчертаване (възможност за маркиране и демаркиране на всички елементи). Ако пред елемент има две Check box, то лявата е за текст, дясната е указаното в диалога. При изключени Възли, съществува възможност за изчертаване на онези възли (с или без текст), чиито елементи са видими - групови. При Полигони се задава дали някои елементи да се изчертават върху екрана с дебелина. При Вход ос/кота/разрез и натиснат Alt, възможност за въвеждане на наклонено направление. При Вход кота и натиснат Alt, при прихващане на първи елемент – греда, колона, ос (първи възел от котата), следва автоматична промяна на направлението на котата спрямо ъгъла на прихванатия елемент (при колони направлението се приема от зададеното горе). BackSpace – при вход кота връща стъпка назад. При Редакт кота, възможност за промяна на ъгъла и последващо автоматично редуциране на размера и текста за всяко поле на котата (особено полезно при необходимост от наклонени коти). Размера и текста за всяко поле на котата могат да се редактират и индивидуално при необходимост. При въвеждане на разрез за греда и натиснат Alt, възможност за завъртане на разреза по наклона на направлението, а не по направление на гредата, което е по подразбиране.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за модула (k03).

Приема от:

Кофражен план (изчисление) - с формати (k02, p__, g__,).

Общо оразмеряване - с формати (o__,) - размери на колони за съответно ниво.

Предава на:

Старт на PCPcad - с формат (dpf, dxf, dwg).

Старт на AutoCAD - с формат (dxf, dwg, scr).

Преглед текст - количества с формат (spc).

Принтер - кадър.


Греди (изчертаване)

Общо:

Модул в който се изчертават решени и евентуално оразмерени преди това греди (без това да е задължително). Те се обработват чрез нанасяне и/или разместване на съответните елементи до получаване на пълен работен чертеж. Пълна спецификация (таблица на фигурите на железата) на армировката.

УСЛОВИЯ НА РАБОТА:

– Изчертават се греди с конзолен, свободен и запънат край;

– Изчертават се греди до 15 отвора + 2 конзоли;

– Всеки отвор може да има различна дължина, височина и ширина;

– При наклонена греда се задават хоризонталните проекции (наклон [-45° - +45°]);

– Възможни напречни сечения: правоъгълно, плочогредово (двустранно, едностранно - ляво, дясно и всички обърнати и с отстъпи: -отляво, +отдясно);

– Напречните сечения се изчертават за средата на участъка;

– Напречните сечения се номерират в рамките на една греда;

– Броя на железата на горната надлъжна армировка в напречните сечения се показват в един ред ако се събират, ако не, те разполагат на колкото реда е необходимо със стремеж за зпълване от към външните позиции (ляво и дясно) на двата края към средата при стремената, ако и тези позиции се изчерпят при същият стремеж се запълват средите на местата между стремената;

– Броя на железата на средната надлъжна армировка (ако има такава) в напречните сечения е четен, те се показват в необходимия брой редове през равни разстояния по-височина, като се изчертават 2 пръта в двата края. Тази армировка се захваща с S-ове през стреме с диаметър равен с този на горна монтажна армировка;

– Броя на железата на долната надлъжна армировка в напречните сечения се показват в един ред ако се събират, ако не, те разполагат на колкото реда е необходимо със стремеж за зпълване от към външните позиции (ляво и дясно) на двата края към средата при стремената, ако и тези позиции се изчерпят при същият стремеж се запълват средите на местата между стремената;

– Стремена видове: отворено, затворено, двойно затворено от различни класове стомана. При нечетна срезност (в частност срезност единица) се генерират допълнително S-ове;

– Размерите на стремената се изчисляват H-3 cm, B-3 cm;

– Разреждане на стремената, като дължината на средната зона и гъстотата на стремената в нея се задават по желание (предлага се по норми на L/4 и Smax е min от 3/4хH и 50 cm);

– Възможност за чертане на всички стремена по гредата (без и с разреждане) или чертане на три стремена в средата и при двата случая без и с разреждане;

– Ширината на фигурата на стремето при различната срезност се определя от (B-3)/(срезност-1) cm. При нечетна срезност (в частност срезност единица) се генерира допълнително S;

– Усилителите над опорите са с една дължина и от един диаметър;

– Горната монтажна армировка се чертае, ако усилителите от двете опори не се препокриват, в противен случай се изчислява дължината (независимо от това, че усилителя може да примерно е един);

– Възможност за различни видове кобилици от различни класове стомана;

– Кобилиците са захванати от ляв ръб на текущия участък до средата на долния хоризонтален участък на кобилицата (до базовата точка) (примерно, ако това разстояние е 250 cm, то (250)2N12x200);

– Огънатата долна армировка е от един диаметър и се чертае при H-2x3.5 cm с произволен ъгъл на огъване;

– Възможност за вътрешна огъната долна армировка (с нова фигура) с различен от правата армировка диаметър;

– Правата долна армировка е от един диаметър. Ако участъка на гредата която изчитаме е оразмерен с два диаметъра 2N12+3Н14, втория 3Н14 се приема за огъната армировка (бройките се разделят при зададена вътрешна огъната армировка – две фигури).

– Всички основни принципи и условия за чертане, закотвяне и огъване на армировката се настройват програмно по желание на проектанта;

– Дали да се чертаят куки по правилник се определя от зададеното при характеристиките за съответният клас стомана;

– Дължината на една фигура се закръгля на 5 cm.

– Допълнителни/втори крайни вертикални линии при запънат край на греда се чертаят, ако усилителите към този край са огънати (дължината на запънатия участък на усилителя е по-голяма от зададената ширина на опората) или липсват.

Ляв бутон на мишката потвърждава. Десен бутон на мишката или Esc - отказ. Всички текущи действия се отпечатват от ляво на горната хоризонтална лента под менюто.

Меню:

При извършване на действие от менюто отказа е възможен, като върху хоризонталната лента под менюто се натисне десния бутон на мишката или Esc.

Файл

Ново

С Control не изтрива детайлите върху чертежа, ако има такива.

Трие детайли

Изтрива всички детайли върху чертежа, ако има такива.

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

При четене auto convert от версия 12.XX и следващи, към текущата версия.

Запис Ctrl-W

Кадър

Цветен печат

Генерира векторен кадър - цветно върху бяла основа.

Моно печат

Генерира векторен кадър - черно върху бяла основа.

Екран

Генерира векторен кадър - цветно върху черна основа.

Моно негатив

Генерира векторен кадър - бяло върху черна основа.

Zoom x 2

Увеличава вътрешния мащаб (x 2 - избран от долните) за по - добър печат.

x 1

x 1.5

o x 2

x 2.5

x 3

x 3.5

x 4

x 5

x 6

x 8

x 10

x 20 !

x 50 !

Греди чете

Добавя към текущия чертеж нови греди изчетени от файл с формат (g__) или произволен, възможност за избор на файл или файлове (стандартна работа с Control и/или Shift). Възможност за добавяне на греди между изчетените, за тях приема данните от Базови. При изчитане данните за греди се вземат и данните от оразмеряване (ako има такива за съответния участък и усилие, ако са няколко се взема последното оразмеряване, ако няма от Базови). При четене на данни за усилители при опорни моменти и различие в армировките от двете страни на опората се работи със зададената (по площ) по-голяма армировка и се изчита по-голяма площ на изчислената армировка. Ако вложената армировка за едно оразмеряване е с различен диаметър n1/D1+n2/D2, тогава се приемат за бройки n1+n2 и за диаметър max(D1, D2). При долна армировка и различен диаметър n1/D1+n2/D2, втория диаметър се приема за огъната, ако това е зададено в Базови (при зададена вътрешна огъната фигура броя n2 се разделя на две между двете огънати фигури). Обединява в една кобилица, сили при dL< B и за едностранни кобилици автоматично разпознаване на вида им. Прави опит за наредба на гредите върху чертежа с възможност за Преместване на последно изчетените. Ляв бутон на мишката - избор на файл, десен бутон на мишката - трие реда (Ctrl + десен бутон на мишката - нулира всички редове).

Елементи чете

добавя

Детайли

Изчита позиция (възможност за задаване на отместване) на детайли. Добавя изчетените детайли към тези от работната среда.

Запис чертеж

CAD

Изготвя сборен чертеж на всички елементи които са видими върху екрана и по начина по който са видими плюс тези изчертани в PCPcad по време на работа. Чертежа е с формат dpf. Следва автоматичен старт на PCPcad. Препоръчва се.

DXF-DWG

Записва чертеж с формати (dxf-dwg, spc - при пусната армировка). В чертежа се генерират всички елементи които са видими върху екрана и по начина по който са видими. Настройка и преглед на генерирания DXF-DWG файл. Автоматичен преглед на количества файл с формат (spc), ако е генериран такъв.

SCRIPT

Записва чертеж с формати (scr, spc - при пусната армировка). В чертежа се генерират всички елементи които са видими върху екрана и по начина по който са видими. Автоматичен преглед на количества файл с формат (spc), ако е генериран такъв.

Изход текущо трие

Изход

Редакт

Undo F11

Redo F12

Коментари Ctrlt-T

Преглед и пълно редактиране (възел, текст, позиция спрямо входния възел, ъгъл, размер и видимост) на въведени стрингове (коментари). Въвеждане (Ins) и триене (Del) на въведени коментари в таблицата за редактиране. С Ctrl-T захваща позицията на маркера и предлага най-близкия възел в таблицата (първият коментар задължително се въвежда по този начин). С Del-Коментари изтрива всички въведени до момента. Възможност за разполагане на един коментар на няколко реда, чрез въвеждане на служебните символи - \R (\r) в текста. Работа с константи: %t – име на системата (PC Proektant), %v – версия (13.03c), %l – лиценз (текст), %n – регистрационен номер (000000000), %u – потребител (текст), %y – година (2003), %m – месец (05), %d – ден (28), %s – мащаб (1:50), %f – формат (A3 или празно, ако е нестандартен), %p – размери (594x420), възможност да се използуват потребителските константи (%c0–%c9) зададени при Печат.

Текст Alt-T

Алтернативно разрешава/забранява текст за целия чертеж.

Възли

Настройка

Бетон B20 F9

Избор на бетон за работа.

Настройка

Общи

Съществува опция форма при изчитане на греда да се въведат глобални символи Свободен текст ## (примерно при Греда ##, за всяка греда ще се получи Греда i', където i - пореден номер на гредата.

Разстояния

Усилители

Горна (монтажна) армировка

Права средна армировка

Права долна армировка

Огъната долна армировка

Кобилици

Условия при които работи изчертаването на греди (закотвяне, дължини, размери и др.).

Базови

Вид

Участък

Сечение

Стремена

Горна (монтажна) армировка

Права долна армировка

Усилител

Права средна армировка

Кобилица

Огъната долна армировка

Приемане да данни за чертане на греди при Вход греда, добавяне на нова греда между изчетени, изчетена не оразмерена греда, изчетена не пълно оразмерена греда (липсват данни за участък, отчасти или изцяло).

Редакт армировка Ctrl-A

Бързо редактиране на конкретна армировка става, чрез посочването й с мишката и натискане на Ctrl-A (прихваща фигурата по центъра й). При номера и името на прихваната фигура се добавя "*".

Таблица армировка

Генерация в чертеж

Вмъква при генерацията на чертежа сортирана таблица с фигурите на армировката.

Количества

Изчислява количества на кофраж, бетон и стомана (включително на m2 и m3) за пуснатите/видимите на екрана елементи. Десен бутон на мишката стандартно меню за маркиране (копиране).

Лист/Мащаб

Избор размери на лист, богат набор от стандартни листа или избор на такъв с уникални размери. Мащаб по избор в стил 1:Y, X:1 или X:Y. Коефициент за размер на всички надписи по чертежа (Ctrl/Alt-S - увеличава/намалява коефициентите за надписване с процент равен на стъпката за увеличение, но не по-малко от 10%). Auto - автоматично променя коефициента за текст и размерите на листа в зависимост от промяната на мащаба, като запазва текущото съотношение.

Надписване

Оси

Диалог за задаване позиция и символи за надписване на оси (вертикални, хоризонтални), примерно: 1, 2, 3, 3', 3'', A, B, B1, C, d, Ea, Eb, F - разделител запетая. Тези имена се приемат, ако не е зададено друго при вход или редакт име на ос (тук е възможно да се зададе и наклон на оста). При запис, те стават общи за останалите модули за чертане. При недостиг на зададени символи (брой символи < брой оси вертикални или хоризонтални) системата автоматично добавя за вертикални - поредния номер, а за хоризонтални - поредната главна буква от латиница (A, B, C, … Z) при изчерпването добавя индекси (A1, B1 … Z1, A2, …).

Армировка

Диалог за избор на начин на надписване за армировка (подробно, позиция, бройки, диаметър, дължина). При запис, те

стават общи за останалите модули за чертане, където има такива елементи.

Рамка

Диалог за попълване на параметрите за изчертаване на единична или двойна рамка към чертежа.

Печат

Диалог за попълване на печата към чертежа. Възможност за работа със стрингови константи на системата и/или зададени потребителски (Калкулатаор – Custom – User strings). Възможно е да се работи и с уникален печат – детайл, в който освен форматиран текст, могат да се добавят/рисуват фирмени знаци, лого и други.

Преместване

Преместване на целият чертеж върху (спрямо) листа, без това да води до промяна на координатите на въведените обекти. Преместването се изчислява спрямо две точки (кликвания с левия бутон на мишката), т.е. дадената 1-точка, да се премести в 2-точка.

Пренареждане

Пренарежда всички греди върху текущия размер на листа.

Координати

Тук се задават стъпките на мрежата. Кратно на, е числото на което са кратни координатите на маркера върху работното поле когато е натиснат десен бутон на мишката и не е пусната мрежата.

Мести Alt-M

Алтернативно скрива/показва диалога за управление от работното поле.

Параметри

Проценти на мащабиране и движение. Параметри необходими на диалога за управление от работното поле. Извиква се и от диалога за управление, като два пъти се натисне левия бутон на мишката върху горната лента.

Възли Alt-V

Диалог за бърз достъп до функциите с възли.

Обект Alt-O

Алтернативно скрива/показва диалога за редактиране на чертежа.

CAD

Help

Home

Application F1

Работно поле:

При натискане ляв бутон на мишката прихваща най-близкия възел. При натискане десния бутон на мишката при включена Мрежа маркера прихваща координатите на най-близкия възел от мрежата, а при изключена Мрежа координатите.на маркера стават кратни на числото от Координати. При Shift + десен бутон на мишката маркера прихваща координатите на най-близкия въведен възел. Това се отпечатва от дясно на горната хоризонтална лента под менюто.

При свободно работно поле (без да сте в режим на работа с възли или елементи), ако натиснете ляв бутон на мишката се задава начална точка (примерно при Shift + десен бутон на мишката маркера прихваща координатите на най-близкия възел и той става начална точка). При което, всяко натискане на десен бутон на мишката, води до запомняне (mem) на текущите параметри - L, a, dX, dY. Те могат автоматично да се използуват (при кликване върху потъмнени позии на текст), като данни при местене, копиране, завъртане, размножаване и др.

BackSpace - връща назад маркирани възли. При Del и прехванат (с левия бутон на мишката) вече маркиран възел, той се демаркира. При местене (втори възел) и натиснат клавиш A (Align), ъгъла между двата възела става автоматично кратен на 5°.

При натискане на десният бутон на мишката върху горната лента на диалози (tools), извиква диалог за конфигуриране на позицията им (индивидуално или по групи).

При некоректна армировка (недостиг на площ спрямо изчетеното/изчисленото или размери при усилители) - основният надпис за съответното желязо се изписва в червено или магента, ако е вече редактирано/променено ръчно.

Диалог за управление

С Shift + Zoom се прихващат всички възли в областта, а с Alt + Zoom се задава правоъгълна област за изчертаване на оси (Alt + Zoom без възли изтрива зона оси). Ако тя е със сложно очертание, би следвало да се опише при вход полигон, след което да се задържи Alt, като указание за зона оси. При натискане двойно ляв бутон на мишката върху горната лента извиква Параметри.

При задържане на Shift и кликване върху управляващи бутони, следва непрекъснато изпълнение на командите (анимация) до отпускане на Shift. При кликване върху управляващ бутон преди да е изчертан чертежа върху екрана, прекъсва изпълнението и чертае отново с новите параметри. Управление с клавиши от управляващ блок. Scroll Lock – on/off, променя алтернативно посоките на движение. Мащабиране при скролиране със среден бутон на мишката. При местене на мишката и натиснат среден бутон, следва движение на изчертаното. При двойно натискане на средния бутон на мишката – екран всичко.

Диалог за редактиране

Бутона с двойна стрелка задава направление x или y (при коти, оси и др.), а бутона xy задава начин на местене на възлите или елементите по чертежа (ръчно или чрез зададено отместване) при натиснат Ctrl действието му алтернативно се променя. При Вход детайл се маркират възли за пренос (ако има такива) и се натиска десен бутон на мишката, възлите се пренасят в работното поле на детайли, там се изчитат (вмъкват), редактират и записват в буфера (към 'Греди') необходимите един или няколко детайли (тези действия могат да се повторят неколкократно). При Редакт детайл, маркираният детайл се пренася в работното поле на детайли, там се редактира и след запис в буфера (към 'Греди') се пренася върху чертежа в редактиран вид. При Трие детайл, маркираният детайл алтернативно се скрива (червен възел) или показва на екрана, без да е изтрит от буфера, ако е натиснат Ctrl в момента на захващане на детайла, той се изтрива от буфера. Чрез Alt при Трие детайл се работи по групи детайли. При видимост групи: маркирани – видими, немаркирани – невидими (Enter – приема, Esc – отказ). При трие групи – Ctrl, маркираните се изтриват (Enter – приема, Esc – отказ). При Редакт греда, захваща по възела посочения елемент и предлага съответния диалог (виж Базови) за редакт и контрол върху елемента. Shift + Редакт греда извежда меню за участъка на съответната греда, чрез което могат също да се редактират или добавят нови елементи (усилители, кобилици и др.) към гредата или да се пренаредят участък (Shift-всички), опора (Shift-всички) или цялата греда (Shift-всички). Око Ctrl-G - задаване на видимите елементи и начина им на изчертаване (възможност за маркиране и демаркиране на всички елементи). Ако пред елемент има две Check box, то лявата е за текст, дясната е указаното в диалога. При изключени Възли, съществува възможност за изчертаване на онези възли (с или без текст), чиито елементи са видими - групови. При Полигони се задава дали някои елементи да се изчертават върху екрана с дебелина. При Вход ос/кота и натиснат Alt, възможност за въвеждане на наклонено направление. При Вход кота и натиснат Alt, при прихващане на първи елемент – ос (първи възел от котата), следва автоматична промяна на направлението на котата спрямо ъгъла на прихванатия елемент. BackSpace – при вход кота връща стъпка назад. При Редакт кота, възможност за промяна на ъгъла и последващо автоматично редуциране на размера и текста за всяко поле на котата (особено полезно при необходимост от наклонени коти). Размера и текста за всяко поле на котата могат да се редактират и индивидуално при необходимост.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за модула (g03).

Приема от:

Греда.

Кофражен план (изчисление) - с формат (g__).

Предава на:

Старт на PCPcad - с формат (dpf, dxf, dwg).

Старт на AutoCAD - с формат (dxf, dwg, scr).

Преглед текст - количества с формат (spc).

Принтер - кадър.


Плочи (изчертаване)

Общо:

Модул в който се комбинират, оразмеряват (огъване и кобилици) и изчертават решени преди това безгредови плочи. Те се обработват чрез нанасяне и/или разместване на съответните елементи до получаване на пълен работен чертеж в стил кофражен или армировъчен план. Пълна спецификация (автоматично изчисление на МА и столчета, таблица на фигурите на железата) на армировката.

Ляв бутон на мишката потвърждава. Десен бутон на мишката или Esc - отказ. Всички текущи действия се отпечатват от ляво на горната хоризонтална лента под менюто.

Меню:

При извършване на действие от менюто отказа е възможен, като върху хоризонталната лента под менюто се натисне десния бутон на мишката или Esc.

Файл

Ново

С Control не изтрива детайлите върху чертежа, ако има такива.

Трие детайли

Изтрива всички детайли върху чертежа, ако има такива.

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

При четене auto convert от версия 12.XX и следващи, към текущата версия.

Запис Ctrl-W

Кадър

Цветен печат

Генерира векторен кадър - цветно върху бяла основа.

Моно печат

Генерира векторен кадър - черно върху бяла основа.

Екран

Генерира векторен кадър - цветно върху черна основа.

Моно негатив

Генерира векторен кадър - бяло върху черна основа.

Zoom x 2

Увеличава вътрешния мащаб (x 2 - избран от долните) за по - добър печат.

x 1

x 1.5

o x 2

x 2.5

x 3

x 3.5

x 4

x 5

x 6

x 8

x 10

x 20 !

x 50 !

Сеизмична комбинация

Формиране (запис) на сеизмична комбинация (квадратен корен от сумата на квадратите на състоянията-формите), която впоследствие да участвува в комбинирането. Комбинират се оразмерителните моменти и почвената реакция (ако има такава). Възможност за избор на файл или файлове (стандартна работа с Control и/или Shift). Ляв бутон на мишката - избор на файл, десен бутон на мишката - трие реда (Ctrl + десен бутон на мишката - нулира всички редове).

Комбинации чете

Обработва неограничен брой комбинации с до 9 състояния (всяко със своя тежестен коефициент) всяка. За първи обект от първа комбинация да са налични файлове с формати (r01, r02, r__), за следващите файлове с формат (r__). Възможност за избор на файл или файлове (стандартна работа с Control и/или Shift). Ляв бутон на мишката - избор на файл, десен бутон на мишката - трие реда (Ctrl + десен бутон на мишката - нулира всички редове). Go - извършва комбиниране за текущата комбинация. Quit - изход с приемане на данните за работа. Комбинират се освен оразмерителните моменти, така също и почвената реакция (ако има такава) и зададените концентрирани сили и получените опорни реакции. Възможност/опция за комбиниране само на огъващите моменти Mx и My. Преместване на обекта върху чертежа.

Елементи чете

променя

Греди

Изчита позиция (възможност за задаване на отместване) и характеристики на греди. Изчетените греди препокриват тези от работната среда.

Колони

Изчита позиция (възможност за задаване на отместване) и характеристики на колони. Изчетените колони препокриват тези от работната среда.

добавя

Детайли

Изчита позиция (възможност за задаване на отместване) на детайли. Добавя изчетените детайли към тези от работната среда.

Зони

Изчита позиция (възможност за задаване на отместване) и характеристики на зони (армировка и наклонени). Добавя изчетените зони към тези от работната среда.

Запис чертеж

CAD

Изготвя сборен чертеж на всички елементи които са видими върху екрана и по начина по който са видими плюс тези изчертани в PCPcad по време на работа. Чертежа е с формат dpf. Следва автоматичен старт на PCPcad. Препоръчва се.

DXF-DWG

Записва чертеж с формати (dxf-dwg, spc - при пусната армировка). В чертежа се генерират всички елементи които са видими върху екрана и по начина по който са видими. Настройка и преглед на генерирания DXF-DWG файл. Автоматичен преглед на количества файл с формат (spc), ако е генериран такъв.

SCRIPT

Записва чертеж с формати (scr, spc - при пусната армировка). В чертежа се генерират всички елементи които са видими върху екрана и по начина по който са видими. Автоматичен преглед на количества файл с формат (spc), ако е генериран такъв.

Изход текущо трие

Изход

Редакт

Undo F11

Redo F12

Коментари Ctrlt-T

Преглед и пълно редактиране (възел, текст, позиция спрямо входния възел, ъгъл, размер и видимост) на въведени стрингове (коментари). Въвеждане (Ins) и триене (Del) на въведени коментари в таблицата за редактиране. С Ctrl-T захваща позицията на маркера и предлага най-близкия възел в таблицата (първият коментар задължително се въвежда по този начин). С Del-Коментари изтрива всички въведени до момента. Възможност за разполагане на един коментар на няколко реда, чрез въвеждане на служебните символи - \R (\r) в текста. Работа с константи: %t – име на системата (PC Proektant), %v – версия (13.03c), %l – лиценз (текст), %n – регистрационен номер (000000000), %u – потребител (текст), %y – година (2003), %m – месец (05), %d – ден (28), %s – мащаб (1:50), %f – формат (A3 или празно, ако е нестандартен), %p – размери (594x420), възможност да се използуват потребителските константи (%c0–%c9) зададени при Печат.

Текст Alt-T

Алтернативно разрешава/забранява текст за целия чертеж.

Възли

Настройка

Материали/Оразмеряване F9

Избор на бетон, избор на стомана долна и горна - x, долна и горна - y (с Ctrl + Ok общ избор на носещи стомани) и за останалите елементи (с Ctrl + Ok общ избор на всички стомани), покрития, МА - монтажна армировка (бройки/диаметър на m'), столчета (бройки/диаметър на m2). Възможност за оразмеряване при сеизмична комбинация - сеизмичен коефициент, чийто стойност се изчита от настройката зададена и записана преди това при оразмеряване. Допълнителна възможност да се задава минимална (конструктивна) армировка min %, по два критерия: минимален процент на армиране и армировка получена от условието за поемане на M пукнатина. Дали да се чертаят куки по правилник се определя от зададеното при характеристиките за съответният клас стомана. Промяна на дебелините (cm) на типовете. Радиус r на обработка при опори и концентрирани товари (в кръг с радиус r около възела оформя плато с ниво средната стойност на обработваната характеристиката на разстояние r). Възлите, които се обработват се маркират с циан и се изчертават окръжностите след пускане на опция Възли от диалог Групи. Go - извършва оразмеряване с текущото състояние на параметрите (с получените резултати се работи в последствие). При невъзможност за поемане на усилие с единична армировка се прави опит това да стане с двойна. При невъзможност това да стане и с двойна (в рамките на допустимото) след съобщение за това, оразмеряването продължава, т.е. дава се възможност определени зони с концентрация на напрежения да не се покриват с армировка, ако конструктора има съображения за това.

Настройка

Изолинии

Брой изолинии за изчертаване в цветове (при >14 надписва през изолиниите при пуснат текст в два цвята). Възможност за задаване на конкретни стойности на изолиниите за текущата, групата или за всички характеристики. При задаване на изразите за изолиниите са допустими всички действия и функции от калкулатор, а така също и два параметъра: максимална стойност %max и минимална стойност %min на текущата характеристика. Възможност за автоматична генерация на изрази или стойности при задаване на изолиниите.

Базова армировка

Максимална дължина на желязо L (за фигурите при спецификацията) и процент на завишение на изчислената армировка за закотвяне.

Горна армировка

Възможност за изчертаване на горните зони по x/y с вертикално огъване на долу на армировката - П. Динамично задаване на размера на огъвката. Възможни са три начина на задаване: auto - като функция на ho, auto и параметър със знак +/- и фиксирана стойност.

Кобилици

Динамично задаване на размера - дълбочината на кобилицата. Възможни са три начина на задаване: auto - като функция на ho, auto и параметър със знак +/- и фиксирана стойност.

Столчета

Динамично задаване на размера - дълбочината на столчето. Възможни са три начина на задаване: auto - като функция на ho, auto и параметър със знак +/- и фиксирана стойност. Задават се като стойности ширината и крачетата на столчето.

Продънване

Контрол Ctrlt-K

Настройка на параметрите за контрол при продънване. При контрол колони/детайли за всяка колона/детайл се показват: Бетон (размери на колоната, в какво положение я разпознава, периметри - възможност за задаване/редакт на средния периметър Um, след Alt, връща изчисления Um, полезна височина и резултата - Qb; Стомана, ако има зона от тип кобилица над съответната колона (минималната и максимална допустима сила от армировката и резултата - Qs, (от коя зона и с колко среза е изчислена, контрол дали е в допустимите граници); Общо сравнява пасивната и активна (сила-f, реакция-r) сили и контролира дали е изпълнено неравенството. Move, възможност за автоматично движение на чертежа с позициониране върху текущата колона. to File - генерация на резултати във файл. При пуснати линии - периметри на продънване, системата указва чрез цветовете на линиите дали са необходими кобилици по изчисление или бетона поема силата - зелено, активната сила би могла да се поеме, като се добавят кобилици по изчисление - магента, активната сила е поета с кобилици по изчисление - циан, голяма активна сила - червено (необходимо е да се увеличат размерите на колоната/детайла или дебелината на плочата). Елементи (контури, окръжности) от даден детайл се разпознават като колони, ако са червени (цвят 1*) и са с пусната опция площ (дали да изтрива при чертеж, линиите под детайла). Възможност за редактиране на колони/детайли и зони. При опит за редактиране на зона и липса на такава при колона/детайл, автоматично добавя нова зона с подходящи размери +5 cm във всички посоки при колона и 100/100 cm при детайл, като изчислява необходимите бройки на база диаметър от последна подобна зона.

Проверката на продънване се извършва като се намират дебелините на плочата под четирите точки за всяка колона, от където се определя тежестно H продънване, чрез него се определя срещуположния (долния) периметър на продънване, за който се проверява местоположението на четирите му точки. Намират се двата периметъра (горен и долен), като за всяка от четирите прави за всеки периметър се търси пресечница с контура или отвори. Активната сила се определя от единични опори и концентрирани сили така, че да попадат в рамките на срещуположния периметър за текущата колона. Възможност за завишаване на активната сила (примерно при отчитане на огъващи моменти от плочата) чрез задени от проектанта индивидуално (след Alt, връща типов процент) или типови проценти: крайни (примерно 40%, ъглови - 50%), средни (примерно 15%). Възможност за задаване на стомана за кобилици, дължина на закотвяне и ъгъл на огъване. За EC отчита влиянието на надлъжните армировки (само на пуснатите в момента) при проверката на продънване.

Сили N

Таблица за контрол, редактиране, добавяне и триене на концентрирани сили, включително моменти - Mx, My, оказващи влияние върху продънването.

Опори N

Таблица за контрол, редактиране, добавяне и триене на концентрирани сили - опори, оказващи влияние върху продънването.

Провисване

Контрол на провисването с отчитане на пластичната работа на бетона с наличие или без пукнатини (в зависимост от получените разрезни усилия и класа на бетона) и текущо вложената армировка по количество, положение, вид и клас.

Редакт армировка Ctrl-A

Бързо редактиране на конкретна армировка става, чрез посочването й с мишката и натискане на Ctrl-A (прихваща фигурата по центъра й, а за детайли с базова армировка - по направление). При номера и името на прихваната фигура се добавя "*".

Таблица армировка

Генерация в чертеж

Вмъква при генерацията на чертежа сортирана таблица с фигурите на армировката.

Количества

Изчислява количества на кофраж, бетон и стомана (включително на m2 и m3) за пуснатите/видимите на екрана елементи. Десен бутон на мишката стандартно меню за маркиране (копиране).

Лист/Мащаб

Избор размери на лист, богат набор от стандартни листа или избор на такъв с уникални размери. Мащаб по избор в стил 1:Y, X:1 или X:Y. Коефициент за размер на всички надписи по чертежа (Ctrl/Alt-S - увеличава/намалява коефициентите за надписване с процент равен на стъпката за увеличение, но не по-малко от 10%). Auto - автоматично променя коефициента за текст и размерите на листа в зависимост от промяната на мащаба, като запазва текущото съотношение.

Надписване

Оси

Диалог за задаване позиция и символи за надписване на оси (вертикални, хоризонтални), примерно: 1, 2, 3, 3', 3'', A, B, B1, C, d, Ea, Eb, F - разделител запетая. Тези имена се приемат, ако не е зададено друго при вход или редакт име на ос (тук е възможно да се зададе и наклон на оста). При запис, те стават общи за останалите модули за чертане. При недостиг на зададени символи (брой символи < брой оси вертикални или хоризонтални) системата автоматично добавя за вертикални - поредния номер, а за хоризонтални - поредната главна буква от латиница (A, B, C, … Z) при изчерпването добавя индекси (A1, B1 … Z1, A2, …).

Греди

Диалог за задаване на типов текст - име за надписване, вид на щриховката за различните греди и типа на сечението на гредата при разрези - нормално или отворено (бетонов елемент - шайба). При запис, те стават общи за останалите модули за чертане, където има такива елементи.

Колони

Диалог за задаване на типов текст - име за надписване и вид на щриховката за нормална и насадена колони. При запис, те стават общи за останалите модули за чертане, където има такива елементи. Възможност за указване начина на надписване на размерите на колоните (Аuto – при спряна армировка, Аlways – винаги, No – без надписване).

Зони

Диалог за указване на надписване на зоните (отстояние от базовата точка, размери, ъгъл – ако е различен от '0'). Изчертаване на диагоналите на зоните и стрелка при армировката ( <---o---> ). Възможност за показване интензитета на армировката с плътни линии или с точки. При запис, те стават общи за останалите модули за чертане, където има такива елементи.

Армировка

Диалог за избор на начин на надписване за армировка - бройки /m', разстояние между прътите (при спряно 'подробно'), подробно (кобилици, огънати зони, зони с куки), позиция, бройки, диаметър, дължина, разстояние между прътите, знаци за положението на зоната първи/втори ред ). При запис, те стават общи за останалите модули за чертане, където има такива елементи.

Рамка

Диалог за попълване на параметрите за изчертаване на единична или двойна рамка към чертежа.

Печат

Диалог за попълване на печата към чертежа. Възможност за работа със стрингови константи на системата и/или зададени потребителски (Калкулатаор – Custom – User strings). Възможно е да се работи и с уникален печат – детайл, в който освен форматиран текст, могат да се добавят/рисуват фирмени знаци, лого и други.

Преместване

Преместване на целият чертеж върху (спрямо) листа, без това да води до промяна на координатите на въведените обекти. Преместването се изчислява спрямо две точки (кликвания с левия бутон на мишката), т.е. дадената 1-точка, да се премести в 2-точка.

Координати

Тук се задават стъпките на мрежата. Кратно на, е числото на което са кратни координатите на маркера върху работното поле когато е натиснат десен бутон на мишката и не е пусната мрежата.

Мести Alt-M

Алтернативно скрива/показва диалога за управление от работното поле.

Параметри

Проценти на мащабиране и движение. Параметри необходими на диалога за управление от работното поле. Извиква се и от диалога за управление, като два пъти се натисне левия бутон на мишката върху горната лента.

Възли Alt-V

Диалог за бърз достъп до функциите с възли.

Обект Alt-O

Алтернативно скрива/показва диалога за редактиране на чертежа.

CAD

Help

Home

Application F1

Работно поле:

При натискане ляв бутон на мишката прихваща най-близкия възел. При натискане десния бутон на мишката при включена Мрежа маркера прихваща координатите на най-близкия възел от мрежата, а при изключена Мрежа координатите.на маркера стават кратни на числото от Координати. При Shift + десен бутон на мишката маркера прихваща координатите на най-близкия въведен възел. Това се отпечатва от дясно на горната хоризонтална лента под менюто.

При свободно работно поле (без да сте в режим на работа с възли или елементи), ако натиснете ляв бутон на мишката се задава начална точка (примерно при Shift + десен бутон на мишката маркера прихваща координатите на най-близкия възел и той става начална точка). При което, всяко натискане на десен бутон на мишката, води до запомняне (mem) на текущите параметри - L, a, dX, dY. Те могат автоматично да се използуват (при кликване върху потъмнени позии на текст), като данни при местене, копиране, завъртане, размножаване и др.

BackSpace - връща назад маркирани възли. При Del и прехванат (с левия бутон на мишката) вече маркиран възел, той се демаркира. При местене (втори възел) и натиснат клавиш A (Align), ъгъла между двата възела става автоматично кратен на 5°.

При натискане на десният бутон на мишката върху горната лента на диалози (tools), извиква диалог за конфигуриране на позицията им (индивидуално или по групи).

Диалог за управление

С Shift + Zoom се прихващат всички възли в областта, а с Alt + Zoom се задава правоъгълна област за изчертаване на оси (Alt + Zoom без възли изтрива зона оси). Ако тя е със сложно очертание, би следвало да се опише при вход полигон, след което да се задържи Alt, като указание за зона оси. При натискане двойно ляв бутон на мишката върху горната лента извиква Параметри.

При задържане на Shift и кликване върху управляващи бутони, следва непрекъснато изпълнение на командите (анимация) до отпускане на Shift. При кликване върху управляващ бутон преди да е изчертан чертежа върху екрана, прекъсва изпълнението и чертае отново с новите параметри. Управление с клавиши от управляващ блок. Scroll Lock – on/off, променя алтернативно посоките на движение. Мащабиране при скролиране със среден бутон на мишката. При местене на мишката и натиснат среден бутон, следва движение на изчертаното. При двойно натискане на средния бутон на мишката – екран всичко.

Диалог за редактиране

Бутона с двойна стрелка задава направление x или y (при коти, оси и др.), а бутона xy задава начин на местене на възлите или елементите по чертежа (ръчно или чрез зададено отместване) при натиснат Ctrl действието му алтернативно се променя. При Вход детайл се маркират възли за пренос (ако има такива) и се натиска десен бутон на мишката, възлите се пренасят в работното поле на детайли, там се изчитат (вмъкват), редактират и записват в буфера (към 'Плоча') необходимите един или няколко детайли (тези действия могат да се повторят неколкократно). При Редакт детайл, маркираният детайл се пренася в работното поле на детайли, там се редактира и след запис в буфера (към 'Плоча') се пренася върху чертежа в редактиран вид. При Трие детайл, маркираният детайл алтернативно се скрива (червен възел) или показва на екрана, без да е изтрит от буфера, ако е натиснат Ctrl в момента на захващане на детайла, той се изтрива от буфера. Чрез Alt при Трие детайл се работи по групи детайли. При видимост групи: маркирани – видими, немаркирани – невидими (Enter – приема, Esc – отказ). При трие групи – Ctrl, маркираните се изтриват (Enter – приема, Esc – отказ). При Редакт греда се задават име/номер (при "--" в началото, текста е уникален и не се сумира с базовия за определения тип греда), тип греда, тип сечение, размери отстъпи: -отляво, +отдясно.

При Редакт колона се задават име/номер (при "--" в началото, текста е уникален и не се сумира с базовия за определения тип колона). При Вход зона (без зони кобилици), възможност да се въведе трапецовидна или триъгълна зона при натиснат Alt преди кликване за втори възел. Изменение на размерите, вида и позицията на зоната може да се постигне и след задаване на съответните стойности Редакт (-L намалява страна към втори възел по съответното направление x или y, +L увеличава страна към втори възел по съответното направление x или y). При Вход зона кобилици или Редакт зона кобилици, в таблицата им след кликване върху тях в Combo Box, възможност за промяна на типа кобилици в двете направления поотделно (едностранни, двустранни или обърнати). Направлението им се определя автоматично от наклона на колоната попадаща в зоната, ако има такава, ако не - от ъгъла на наклонената зона (ако попада в такава). При Вход зона или Редакт зона, след кликване върху размерите на всяка зона възможност за промяна на размерите, вида и позицията на зоната спрямо указаните точки (долен-ляв, горен-ляв, долен-десен, горен-десен, център). При наличие на зони от горна армировка в началото на пръта от долу се изчертава един триъгълник за направлението с по-голяма полезна височина (първи ред) и два триъгълника за това с по-малка (втори ред). За зони от долна армировка триъгълника или триъгълниците се изчертават от горе на пръта, а броя им се определя по аналогичен начин. Автоматично определяне на МА и столчета при необходимост. При наличие на непрекъсната греда с различни напречни сечения в различните участъци е целесъобразно да се зададат няколко греди с едно и също име, но с различни напречни сечения. Око Ctrl-G - задаване на видимите елементи и начина им на изчертаване (възможност за маркиране и демаркиране на всички елементи). Ако пред елемент има две Check box, то лявата е за текст, дясната е указаното в диалога. При изключени Възли, съществува възможност за изчертаване на онези възли (с или без текст), чиито елементи са видими - групови. При Полигони се задава дали някои елементи да се изчертават върху екрана с дебелина. При Вход ос/кота/разрез и натиснат Alt, възможност за въвеждане на наклонено направление. При Вход кота и натиснат Alt, при прихващане на първи елемент – греда, колона, ос (първи възел от котата), следва автоматична промяна на направлението на котата спрямо ъгъла на прихванатия елемент (при колони направлението се приема от зададеното горе). BackSpace – при вход кота връща стъпка назад. При Редакт кота, възможност за промяна на ъгъла и последващо автоматично редуциране на размера и текста за всяко поле на котата (особено полезно при необходимост от наклонени коти). Размера и текста за всяко поле на котата могат да се редактират и индивидуално при необходимост. При въвеждане на разрез за греда и натиснат Alt, възможност за завъртане на разреза по наклона на направлението, а не по направление на гредата, което е по подразбиране. Включването на една от изолиниите за армировка (Axд, Axг, Ayд, Ayг) не води до автоматично изключване на опциите (зони и базова) на останалите, ако армировката не е изчислена следва автоматично стартиране на диалог Служебни/Оразмеряване. Съществуват три възможности при работа с изолиниите за армировка:

– Изолинии за cm2 / m' [Ax/y/г/д - Axд];

– Изолинии за бройки / m' при зададен диаметър [Nx/y/г/д/Диаметър - Nxд12];

– Изолинии за необходими диаметри при зададени бройки / m' [Dx/y/г/д/Бройки - Dxд5].

Смяната на режима при работа с армировки става, като се натисне ляв бутон върху една от изолинии армировка и се държи натиснат Control. Axд, Axг, Ayд, Ayг и Rz се изчертават за граничните стойности, а всички останали за първият елемент при първа комбинация. Базова армировка е тази, която се разполага непрекъснато по цялата плоча (дори и въведена тя може да бъде забранена със съответната опция). Включването на опция Стойности дава стойностите на съответната характеристика, ако това е армировка + включена опция Bij, дава разликата между стойността във възела и вложената базова армировка. Армировката в зона се сумира с базовата или с други зони, ако има такива под нея (да се внимава за максималния брой железа на m'). Възможност за изчертаване на горните зони по x/y с вертикално огъване на долу на армировката - П. Възможност за задаване на наклонени за армиране зони. В тези зони всички действия се извършват под зададения ъгъл. Системата контролира действията с тях (застъпване на зона с друга зона - грешка, преизчисляване на армировката автоматично при въвеждане на нова зона, изтриване, местене, редакт или копиране на зони). Системата не контролира, ако при действия с възли сте довели до промяна на състоянието на наклонените зони.

Диалог за изолинии

Изолинии за всички резултати и армировки (Axд, Axг, Ayд, Ayг). При работа с изолинии за армировки (достъпни само след оразмеряване), те се покриват със зони или базова армировка с графичен контрол на процеса до резултат задоволяващ проектанта. При застъпване на зони(мрежи) от еднакъв вид, но с различен ъгъл (различна наклонена зона) се прави оценка на принадлежността на всеки възел и се взема само зоната(мрежата) към която принадлежи възела. При армировки знака # дава изолинията с вложената базова армировка, а правоъгълник дава максималното сечение за двойна армировка (ако тя е достигната), в този случай изолиниите не са през равен интервал в зависимост от броя им. Те се строят по следния начин, при условие, че са по-вече от 5.

брой изолинии 7

max получена армировка 24 cm2/m'

max допустима армировка 15 cm2/m'

изолиния 0 0.0 cm2/m' min

изолиния 1 3.0 cm2/m'

изолиния 2 6.0 cm2/m'

изолиния 3 9.0 cm2/m'

изолиния 4 12.0 cm2/m'

изолиния 5 15.0 cm2/m' max допустима

изолиния 6 19.5 cm2/m' среда между 5 и 7 изолиния

изолиния 7 24.0 cm2/m' max получена

При армировки с червено на предпоследен ред максималната непокрита армировка и с кръгче мястото и (при натискане ляв бутон на мишката - центриране на позицията в зависимост от мащаба, при натискане десен бутон на мишката - включва/изключва зони с армировка). При натискане ляв бутон на мишката на последен ред върху бройки или диаметри, следва увеличение на бройки или диаметри с една стъпка (при натискане десен бутон на мишката върху тях - обратно). При натискане ляв бутон на мишката на последен ред върху N,Ф, следва редактиране на армировка, а при натискане десен бутон на мишката - включва/изключва базова армировка). При натискане двойно ляв бутон на мишката върху горната лента - увеличава, Shift - намалява броя на изолиниите.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за модула (r03).

Приема от:

Вход на обекти - с формат (r02).

Генерация на мрежа - с формат (r01).

Плочи (изчисление) - с формат (r__).

Предава на:

Старт на PCPcad - с формат (dpf, dxf, dwg).

Старт на AutoCAD - с формат (dxf, dwg, scr).

Преглед текст - количества с формат (spc).

Принтер - кадър.


Гредостени (изчертаване)

Общо:

Модул в който се комбинират, оразмеряват и изчертават решени преди това гредостени. Те се обработват чрез нанасяне и/или разместване на съответните елементи до получаване на пълен работен чертеж в стил кофражен или армировъчен план. Пълна спецификация (автоматично изчисление на МА и S-ове, таблица на фигурите на железата) на армировката.

Ляв бутон на мишката потвърждава. Десен бутон на мишката или Esc - отказ. Всички текущи действия се отпечатват от ляво на горната хоризонтална лента под менюто.

Меню:

При извършване на действие от менюто отказа е възможен, като върху хоризонталната лента под менюто се натисне десния бутон на мишката или Esc.

Файл

Ново

С Control не изтрива детайлите върху чертежа, ако има такива.

Трие детайли

Изтрива всички детайли върху чертежа, ако има такива.

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

При четене auto convert от версия 12.XX и следващи, към текущата версия.

Запис Ctrl-W

Кадър

Цветен печат

Генерира векторен кадър - цветно върху бяла основа.

Моно печат

Генерира векторен кадър - черно върху бяла основа.

Екран

Генерира векторен кадър - цветно върху черна основа.

Моно негатив

Генерира векторен кадър - бяло върху черна основа.

Zoom x 2

Увеличава вътрешния мащаб (x 2 - избран от долните) за по - добър печат.

x 1

x 1.5

o x 2

x 2.5

x 3

x 3.5

x 4

x 5

x 6

x 8

x 10

x 20 !

x 50 !

Сеизмична комбинация

Формиране (запис) на сеизмична комбинация (квадратен корен от сумата на квадратите на състоянията-формите), която впоследствие да участвува в комбинирането. Комбинират се оразмерителните напрежения. Възможност за избор на файл или файлове (стандартна работа с Control и/или Shift). Ляв бутон на мишката - избор на файл, десен бутон на мишката - трие реда (Ctrl + десен бутон на мишката - нулира всички редове).

Комбинации чете

Обработва неограничен брой комбинации с до 9 състояния (всяко със своя тежестен коефициент) всяка. За първи обект от първа комбинация да са налични файлове с формати (s01, s02, s__), за следващите файлове с формати (s__). Възможност за избор на файл или файлове (стандартна работа с Control и/или Shift). Ляв бутон на мишката - избор на файл, десен бутон на мишката - трие реда (Ctrl + десен бутон на мишката - нулира всички редове). Go - извършва комбиниране за текущата комбинация. Quit - изход с приемане на данните за работа. Комбинират се оразмерителните напрежения. Преместване на обекта върху чертежа.

Елементи чете

добавя

Детайли

Изчита позиция (възможност за задаване на отместване) на детайли. Добавя изчетените детайли към тези от работната среда.

Зони

Изчита позиция (възможност за задаване на отместване) и характеристики на зони (армировка и наклонени). Добавя изчетените зони към тези от работната среда.

Запис чертеж

CAD

Изготвя сборен чертеж на всички елементи които са видими върху екрана и по начина по който са видими плюс тези изчертани в PCPcad по време на работа. Чертежа е с формат dpf. Следва автоматичен старт на PCPcad. Препоръчва се.

DXF-DWG

Записва чертеж с формати (dxf-dwg, spc - при пусната армировка). В чертежа се генерират всички елементи които са видими върху екрана и по начина по който са видими. Настройка и преглед на генерирания DXF-DWG файл. Автоматичен преглед на количества файл с формат (spc), ако е генериран такъв.

SCRIPT

Записва чертеж с формати (scr, spc - при пусната армировка). В чертежа се генерират всички елементи които са видими върху екрана и по начина по който са видими. Автоматичен преглед на количества файл с формат (spc), ако е генериран такъв.

Изход текущо трие

Изход

Редакт

Undo F11

Redo F12

Коментари Ctrlt-T

Преглед и пълно редактиране (възел, текст, позиция спрямо входния възел, ъгъл, размер и видимост) на въведени стрингове (коментари). Въвеждане (Ins) и триене (Del) на въведени коментари в таблицата за редактиране. С Ctrl-T захваща позицията на маркера и предлага най-близкия възел в таблицата (първият коментар задължително се въвежда по този начин). С Del-Коментари изтрива всички въведени до момента. Възможност за разполагане на един коментар на няколко реда, чрез въвеждане на служебните символи - \R (\r) в текста. Работа с константи: %t – име на системата (PC Proektant), %v – версия (13.03c), %l – лиценз (текст), %n – регистрационен номер (000000000), %u – потребител (текст), %y – година (2003), %m – месец (05), %d – ден (28), %s – мащаб (1:50), %f – формат (A3 или празно, ако е нестандартен), %p – размери (594x420), възможност да се използуват потребителските константи (%c0–%c9) зададени при Печат.

Текст Alt-T

Алтернативно разрешава/забранява текст за целия чертеж.

Възли

Настройка

Материали/Оразмеряване F9

Избор на бетон, избор на стомана по - x, по - y (с Ctrl + Ok общ избор на носещи стомани) и за останалите елементи (с Ctrl + Ok общ избор на всички стомани), покрития, МА - монтажна армировка (бройки/диаметър на m'), S-ове (бройки/диаметър на m2). Възможност за оразмеряване при сеизмична комбинация - сеизмичен коефициент, чийто стойност се изчита от настройката зададена и записана преди това при оразмеряване. Допълнителна възможност да се задава минимална (конструктивна) армировка min % по двете направления: хоризонтално – x и вертикално – y. Дали да се чертаят куки по правилник се определя от зададеното при характеристиките за съответният клас стомана. Промяна на дебелините (cm) на типовете. Go - извършва оразмеряване с текущото състояние на параметрите (с получените резултати се работи в последствие)!

Настройка

Изолинии

Брой изолинии за изчертаване в цветове (при >14 надписва през изолиниите при пуснат текст в два цвята). Възможност за задаване на конкретни стойности на изолиниите за текущата, групата или за всички характеристики. При задаване на изразите за изолиниите са допустими всички действия и функции от калкулатор, а така също и два параметъра: максимална стойност %max и минимална стойност %min на текущата характеристика. Възможност за автоматична генерация на изрази или стойности при задаване на изолиниите.

Базова армировка

Максимална дължина на желязо L (за фигурите при спецификацията) и процент на завишение на изчислената армировка за закотвяне.

S-ове

Динамично задаване на размера - ширината на фигурата. Възможни са три начина на задаване: auto - като функция на дебелината, auto и параметър със знак +/- и фиксирана стойност. Задават се като стойност и огъвките на фигурата.

Редакт армировка Ctrl-A

Бързо редактиране на конкретна армировка става, чрез посочването й с мишката и натискане на Ctrl-A (прихваща фигурата по центъра й, а за детайли с базова армировка - по направление). При номера и името на прихваната фигура се добавя "*".

Таблица армировка

Генерация в чертеж

Вмъква при генерацията на чертежа сортирана таблица с фигурите на армировката.

Количества

Изчислява количества на кофраж, бетон и стомана (включително на m2 и m3) за пуснатите/видимите на екрана елементи. Десен бутон на мишката стандартно меню за маркиране (копиране).

Лист/Мащаб

Избор размери на лист, богат набор от стандартни листа или избор на такъв с уникални размери. Мащаб по избор в стил 1:Y, X:1 или X:Y. Коефициент за размер на всички надписи по чертежа (Ctrl/Alt-S - увеличава/намалява коефициентите за надписване с процент равен на стъпката за увеличение, но не по-малко от 10%). Auto - автоматично променя коефициента за текст и размерите на листа в зависимост от промяната на мащаба, като запазва текущото съотношение.

Надписване

Оси

Диалог за задаване позиция и символи за надписване на оси (вертикални, хоризонтални), примерно: 1, 2, 3, 3', 3'', A, B, B1, C, d, Ea, Eb, F - разделител запетая. Тези имена се приемат, ако не е зададено друго при вход или редакт име на ос (тук е възможно да се зададе и наклон на оста). При запис, те стават общи за останалите модули за чертане. При недостиг на зададени символи (брой символи < брой оси вертикални или хоризонтални) системата автоматично добавя за вертикални - поредния номер, а за хоризонтални - поредната главна буква от латиница (A, B, C, … Z) при изчерпването добавя индекси (A1, B1 … Z1, A2, …).

Зони

Диалог за указване на надписване на зоните (отстояние от базовата точка, размери). Изчертаване на диагоналите на зоните и стрелка при армировката ( <---o---> ). Възможност за показване интензитета на армировката с плътни линии или с точки. При запис, те стават общи за останалите модули за чертане, където има такива елементи.

Армировка

Диалог за избор на начин на надписване за армировка - бройки /m', разстояние между прътите (при спряно 'подробно'), подробно (зони с куки), позиция, бройки, диаметър, дължина, разстояние между прътите, знаци за положението на зоната първи/втори ред ). При запис, те стават общи за останалите модули за чертане, където има такива елементи.

Рамка

Диалог за попълване на параметрите за изчертаване на единична или двойна рамка към чертежа.

Печат

Диалог за попълване на печата към чертежа. Възможност за работа със стрингови константи на системата и/или зададени потребителски (Калкулатаор – Custom – User strings). Възможно е да се работи и с уникален печат – детайл, в който освен форматиран текст, могат да се добавят/рисуват фирмени знаци, лого и други.

Преместване

Преместване на целият чертеж върху (спрямо) листа, без това да води до промяна на координатите на въведените обекти. Преместването се изчислява спрямо две точки (кликвания с левия бутон на мишката), т.е. дадената 1-точка, да се премести в 2-точка.

Координати

Тук се задават стъпките на мрежата. Кратно на, е числото на което са кратни координатите на маркера върху работното поле когато е натиснат десен бутон на мишката и не е пусната мрежата.

Мести Alt-M

Алтернативно скрива/показва диалога за управление от работното поле.

Параметри

Проценти на мащабиране и движение. Параметри необходими на диалога за управление от работното поле. Извиква се и от диалога за управление, като два пъти се натисне левия бутон на мишката върху горната лента.

Възли Alt-V

Диалог за бърз достъп до функциите с възли.

Обект Alt-O

Алтернативно скрива/показва диалога за редактиране на чертежа.

CAD

Help

Home

Application F1

Работно поле:

При натискане ляв бутон на мишката прихваща най-близкия възел. При натискане десния бутон на мишката при включена Мрежа маркера прихваща координатите на най-близкия възел от мрежата, а при изключена Мрежа координатите.на маркера стават кратни на числото от Координати. При Shift + десен бутон на мишката маркера прихваща координатите на най-близкия въведен възел. Това се отпечатва от дясно на горната хоризонтална лента под менюто.

При свободно работно поле (без да сте в режим на работа с възли или елементи), ако натиснете ляв бутон на мишката се задава начална точка (примерно при Shift + десен бутон на мишката маркера прихваща координатите на най-близкия възел и той става начална точка). При което, всяко натискане на десен бутон на мишката, води до запомняне (mem) на текущите параметри - L, a, dX, dY. Те могат автоматично да се използуват (при кликване върху потъмнени позии на текст), като данни при местене, копиране, завъртане, размножаване и др.

BackSpace - връща назад маркирани възли. При Del и прехванат (с левия бутон на мишката) вече маркиран възел, той се демаркира. При местене (втори възел) и натиснат клавиш A (Align), ъгъла между двата възела става автоматично кратен на 5°.

При натискане на десният бутон на мишката върху горната лента на диалози (tools), извиква диалог за конфигуриране на позицията им (индивидуално или по групи).

Диалог за управление

С Shift + Zoom се прихващат всички възли в областта, а с Alt + Zoom се задава правоъгълна област за изчертаване на оси (Alt + Zoom без възли изтрива зона оси). Ако тя е със сложно очертание, би следвало да се опише при вход полигон, след което да се задържи Alt, като указание за зона оси. При натискане двойно ляв бутон на мишката върху горната лента извиква Параметри.

При задържане на Shift и кликване върху управляващи бутони, следва непрекъснато изпълнение на командите (анимация) до отпускане на Shift. При кликване върху управляващ бутон преди да е изчертан чертежа върху екрана, прекъсва изпълнението и чертае отново с новите параметри. Управление с клавиши от управляващ блок. Scroll Lock – on/off, променя алтернативно посоките на движение. Мащабиране при скролиране със среден бутон на мишката. При местене на мишката и натиснат среден бутон, следва движение на изчертаното. При двойно натискане на средния бутон на мишката – екран всичко.

Диалог за редактиране

Бутона с двойна стрелка задава направление x или y (при коти, оси и др.), а бутона xy задава начин на местене на възлите или елементите по чертежа (ръчно или чрез зададено отместване) при натиснат Ctrl действието му алтернативно се променя. При Вход детайл се маркират възли за пренос (ако има такива) и се натиска десен бутон на мишката, възлите се пренасят в работното поле на детайли, там се изчитат (вмъкват), редактират и записват в буфера (към 'Шайба') необходимите един или няколко детайли (тези действия могат да се повторят неколкократно). При Редакт детайл, маркираният детайл се пренася в работното поле на детайли, там се редактира и след запис в буфера (към 'Шайба') се пренася върху чертежа в редактиран вид. При Трие детайл, маркираният детайл алтернативно се скрива (червен възел) или показва на екрана, без да е изтрит от буфера, ако е натиснат Ctrl в момента на захващане на детайла, той се изтрива от буфера. Чрез Alt при Трие детайл се работи по групи детайли. При видимост групи: маркирани – видими, немаркирани – невидими (Enter – приема, Esc – отказ). При трие групи – Ctrl, маркираните се изтриват (Enter – приема, Esc – отказ). При Вход зона, възможност да се въведе трапецовидна или триъгълна зона при натиснат Alt преди кликване за втори възел. Изменение на размерите, вида и позицията на зоната може да се постигне и след задаване на съответните стойности Редакт (-L намалява страна към втори възел по съответното направление x или y, +L увеличава страна към втори възел по съответното направление x или y). При Вход зона или Редакт зона, след кликване върху размерите на зоната възможност за промяна на размерите, вида и позицията на зоната спрямо указаните точки (долен-ляв, горен-ляв, долен-десен, горен-десен, център). При наличие на зони в началото на пръта се изчертава един триъгълник за направлението с по-голяма полезна височина (първи ред) и два триъгълника за това с по-малка (втори ред). Автоматично определяне на МА и S-ове при необходимост. Око Ctrl-G - задаване на видимите елементи и начина им на изчертаване (възможност за маркиране и демаркиране на всички елементи). Ако пред елемент има две Check box, то лявата е за текст, дясната е указаното в диалога. При изключени Възли, съществува възможност за изчертаване на онези възли (с или без текст), чиито елементи са видими - групови. При Полигони се задава дали някои елементи да се изчертават върху екрана с дебелина. При Вход ос/кота и натиснат Alt, възможност за въвеждане на наклонено направление. При Вход кота и натиснат Alt, при прихващане на първи елемент – ос (първи възел от котата), следва автоматична промяна на направлението на котата спрямо ъгъла на прихванатия елемент. BackSpace – при вход кота връща стъпка назад. При Редакт кота, възможност за промяна на ъгъла и последващо автоматично редуциране на размера и текста за всяко поле на котата (особено полезно при необходимост от наклонени коти). Размера и текста за всяко поле на котата могат да се редактират и индивидуално при необходимост. Включването на една от изолиниите за армировка (Ax, Ay) не води до автоматично изключване на опциите (зона и базова) на другата, ако армировката не е изчислена следва автоматично стартиране на диалог Служебни/Оразмеряване. Съществуват три възможности при работа с изолиниите за армировка:

– Изолинии за cm2 / m' [Ax/y/г/д - Axд];

– Изолинии за бройки / m' при зададен диаметър [Nx/y/г/д/Диаметър - Nxд12];

– Изолинии за необходими диаметри при зададени бройки / m' [Dx/y/г/д/Бройки - Dxд5].

Смяната на режима при работа с армировки става, като се натисне ляв бутон върху една от изолинии армировка и се държи натиснат Control. Ax и Ay се изчертават за граничните стойности, а всички останали за първият елемент при първа комбинация. Базова армировка е тази, която се разполага непрекъснато по цялата плоча (дори и въведена тя може да бъде забранена със съответната опция). Включването на опция Стойности дава стойностите на съответната характеристика, ако това е армировка + включена опция Bi, дава разликата между стойността във възела и вложената базова армировка. Армировката в зона се сумира с базовата или с други зони, ако има такива под нея (да се внимава за максималния брой железа на m'). Възможност за задаване на наклонени за армиране зони. В тези зони всички действия се извършват под зададения ъгъл. Системата контролира действията с тях (застъпване на зона с друга зона - грешка, преизчисляване на армировката автоматично при въвеждане на нова зона, изтриване, местене, редакт или копиране на зони). Системата не контролира, ако при действия с възли сте довели до промяна на състоянието на наклонените зони.

Диалог за изолинии

Изолинии за всички резултати и армировки (Ax, Ay). При работа с изолинии за армировки (достъпни само след оразмеряване), те се покриват със зони или базова армировка с графичен контрол на процеса до резултат задоволяващ проектанта. При армировки знака # дава изолинията с вложената базова армировка. При армировки с червено на предпоследен ред максималната непокрита армировка и с кръгче мястото и (при натискане ляв бутон на мишката - центриране на позицията в зависимост от мащаба, при натискане десен бутон на мишката - включва/изключва зони с армировка). При натискане ляв бутон на мишката на последен ред върху бройки или диаметри, следва увеличение на бройки или диаметри с една стъпка (при натискане десен бутон на мишката върху тях - обратно). При натискане ляв бутон на мишката на последен ред върху N,Ф, следва редактиране на армировка, а при натискане десен бутон на мишката - включва/изключва базова армировка). При натискане двойно ляв бутон на мишката върху горната лента - увеличава, Shift - намалява броя на изолиниите.

Ресурси

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за модула (s03).

Приема от:

Вход на обекти - с формат (s02).

Генерация на мрежа - с формат (s01).

Плочи (изчисление) - с формат (s__).

Предава на:

Старт на PCPcad - с формат (dpf, dxf, dwg).

Старт на AutoCAD - с формат (dxf, dwg, scr).

Преглед текст - количества с формат (spc).

Принтер - кадър.


Детайли

Общо:

Модул за изготвяне на библиотека от детайли (параметрично обвързани) и последващото им поставяне (евентуално редактиране преди това) върху чертеж с автоматична актуализация на бетон, кофраж и армировка.

Ляв бутон на мишката потвърждава. Десен бутон на мишката или Esc - отказ. Всички текущи действия се отпечатват от ляво на горната хоризонтална лента под менюто.

Меню:

При извършване на действие от менюто отказа е възможен, като върху хоризонталната лента под менюто се натисне десния бутон на мишката или Esc.

Файл

Ново

Текущо чете

Текущ запис Ctrl-Z

Чете Shift Ctrl-R

При Shift + Чете Shift Ctrl-R предлага избор, чрез преглед на всички детайли от текущата директория и принадлежащите и поддиректории, които се разглеждат като отделни групи, ако започват с 3 space. Възможност за избор по групи динамично - предлагат се за преглед само маркираните групи. Чрез Enter – изчита избрания детайл, Esc – отказ. Принадлежащи поддиректории, които започват с 3 space и са празни се изтриват.

При четене auto convert от версия 12.XX и следващи, към текущата версия.

Запис Ctrl-W

Могат да се зададат: принадлежност към група (името и е поддиректория към основната с добавени 3 space отпред – да се използуват само разрешените за директория символи), коментар/име към детайла. Групите се използуват за подредба на детайлите по предназначение, което води до по доброто им управление (видимост, триене) при чертане. Принадлежащи поддиректории, които започват с 3 space и са празни се изтриват

Кадър

Цветен печат

Генерира векторен кадър - цветно върху бяла основа.

Моно печат

Генерира векторен кадър - черно върху бяла основа.

Екран

Генерира векторен кадър - цветно върху черна основа.

Моно негатив

Генерира векторен кадър - бяло върху черна основа.

Zoom x 2

Увеличава вътрешния мащаб (x 2 - избран от долните) за по - добър печат.

x 1

x 1.5

o x 2

x 2.5

x 3

x 3.5

x 4

x 5

x 6

x 8

x 10

x 20 !

x 50 !

Вмъква DXF-DWG

При изчетен DXF-DWG файл, автоматично се добавят всички възли и се генерират елементи в стил детайли (линии, полигони, контури или окръжности - при по-вече от 4 възела и текстове).

Вмъква детайл Shift

Възможност за окрупняване (вмъкване) на детайли един в друг след задаване на позицията на базовия (магента) възел. При Shift + Вмъква детайл Shift предлага избор, чрез преглед на всички детайли от текущата директория и принадлежащите и поддиректории, които се разглеждат като отделни групи, ако започват с 3 space. Възможност за избор и преглед по групи динамично - предлагат се за преглед само маркираните групи. Чрез Enter – изчита избрания детайл, Esc – отказ. Пинадлежащи поддиректории, които започват с 3 space и са празни се изтриват. Всички изрази на вмъкнатия детайл, автоматично се пренастройват за новите номера на елементите. Изразите за спецификациите се добавят към основните на нови редове.

Към ...

Буфер за детайли. Забранено, ако модула е извикан самостоятелно и разрешено, ако модула е извикан от друг (виж Кофражен план (изчертаване), Греди (изчертаване), Плочи (изчертаване), Гредостени (изчертаване)).

Изход текущо трие

Изход

Редакт

Undo F11

Redo F12

Текст Alt-T

Алтернативно разрешава/забранява текст за целия чертеж.

Възли

Настройка

Спецификация F9

Възможност за добавяне и триене на изрази за бетон, кофраж и армировка. Опция за действие (Go) на всички или текущия редове за включената опция. Go - Текст, диалог за пълен контрол на въведения израз (суров вид, окончателен вид), Color - повдига и оцветява служебните думи алтернативно. Go или F9 решение, пренос към калкулатор (чрез Изход пренася редактирания текст (последния ред), а чрез Alt-F4 не), потвърждение или отказ, ако е възможно.

Възможност за въвеждане на изрази, чиито резултат се сумира за бетон, кофраж и армировка по знак. При изчитане на детайла от друг модул, бетона се сумира към избрания клас бетон в модула, а армировката се сумира към съответния клас по диаметри. Задължителни указатели за разпознаване на резултата:

– кофраж

… К[#####.## m2 = ....] .. К - на кирилица, m2 - на латиница.

– бетон

... Б[#####.## m3 = ....] .. Б - на кирилица, m3 - на латиница.

– армировка

... 6.5Ф[###.## m' = ..] 20.0N[###.## m' = ..] .. ##.#Ф - на кирилица - главно, ##.#N - на латиница, m'- на латиница.

При армировка за указване или смяна класа на стоманата трябва да се запише {Име Rs=xxx}, примерно {Ст.A3 Rs=37.500}, при нов ред автоматично се генерира този израз за текущата стомана. В рамките на един израз могат многократно да се срещат еднотипни указатели (налага се при вмъкване на детайли или за добра прегледност на израза), примерно:

– кофраж;

... К[###.# m2 = ....] .. К[### m2 = ....] ..

– бетон;

... Б[###.# m3 = ....] .. Б[### m3 = ....] ..

– армировка.

... 8.0Ф[##.# m' = ...] 8.0Ф[##.# m' = ...] ..

Резултата би бил сумата от стойностите в средните скоби за кофраж, бетон и при еднакви диаметри и стомани за армировката.

Лист/Мащаб

Избор размери на лист, богат набор от стандартни листа или избор на такъв с уникални размери. Мащаб по избор в стил 1:Y, X:1 или X:Y. Коефициент за размер на всички надписи по чертежа (Ctrl/Alt-S - увеличава/намалява коефициентите за надписване с процент равен на стъпката за увеличение, но не по-малко от 10%). Auto - автоматично променя коефициента за текст и размерите на листа в зависимост от промяната на мащаба, като запазва текущото съотношение.

Преместване

Преместване на целият чертеж върху (спрямо) листа, без това да води до промяна на координатите на въведените обекти. Преместването се изчислява спрямо две точки (кликвания с левия бутон на мишката), т.е. дадената 1-точка, да се премести в 2-точка.

Координати

Тук се задават стъпките на мрежата. Кратно на, е числото на което са кратни координатите на маркера върху работното поле когато е натиснат десен бутон на мишката и не е пусната мрежата.

Мести Alt-M

Алтернативно скрива/показва диалога за управление от работното поле.

Параметри

Проценти на мащабиране и движение. Параметри необходими на диалога за управление от работното поле. Извиква се и от диалога за управление, като два пъти се натисне левия бутон на мишката върху горната лента.

Възли Alt-V

Диалог за бърз достъп до функциите с възли.

Обект Alt-O

Алтернативно скрива/показва диалога за редактиране на чертежа.

Обект Alt-H

Алтернативно скрива/показва диалога за статуса на текущия елемент.

Таблици

Колони

Достъпно след Ново. Елементите от Общо оразмеряване с формат (o__), които могат да се обработват са колони, глави на шайби и рамки. Параметрите, които могат да се задават са следните:

кота I етаж долу

Изчисляват се котите на надлъжната армировка в зависимост от етажните височини. При корекция е достатъчно да се коригира само долна кота ниво фусове, за да се преизчислят всички нагоре автоматично.

КОЛОНИ:

надлъжна армировка

Приема зададения диаметър и бройки, ако липсват;

стремена

Приема зададения диаметър и разстояние, ако липсва.

СНАЖДАНЕ:

зона на снаждане

Автоматично поддържа тази дължина в зависимост от диаметъра на армировката и автоматично преизчислява коти и спецификации;

стремена през

Разстояние между стремената в зоната на снаждане;

a =

Покритие на армировата/стремената.

ФУСОВЕ:

надолу

Основно разстояние от петата на фуса до кота I етаж долу;

размер на петата на фуса;

стремена през

Разстояние между стремената в зоната на фусовете, но не по-малко от минималната бройка стремена за участък;

минимална бройка стремена за участък.

ШАЙБИ:

глави шайба

Размера на колоните, които се оформят в краищата на колоната;

вертикална мрежа

Ако не е зададено;

хоризонтална мрежа

Ако не е зададено. Тази мрежа определя стремената в главите на колоните, ако не е зададена друга мрежа по изчисление;

застъпване на мрежите в главите

обедини еднакви

Възможност за автоматично обединяване на еднаквите колони по групи при необходимост.

Задават се максимумите на колони и етажи за съответната задача. Поддържа се пълно преизчисляване на коригираните параметри, препоръчва се корекциите да се правят при следните елементи:

– долна кота ниво фусове - за да се преизчислят всички коти нагоре автоматично;

– височина на колона за етаж - за да се преизчислят армировка за етаж, стремена, спецификация и всички коти нагоре автоматично;

– размери на напречното сечение - за да се преизчислят стремена и спецификация. Те трябва да с във следния формат '25/45' (да се обърне внимание на разделителя '/');

– брой надлъжна армировка - за да се преизчислят армировка за етаж и спецификация;

– диаметър надлъжна армировка - за да се преизчислят армировка за етаж, зона на снаждане (стремена в тази зона) и спецификация;

– диаметър на стремената - за да се преизчислят дължините им за този етаж и спецификация.

Поддържа се пълна спецификация (бетон, кофраж и армировка), която се коригира автоматично в зависимост от корекциите направени от проектанта върху по горните елементи. Генерират се необходимите забележки за материалите, съответствието елемент-колона, мрежи при шайби и други. Горна кота армировка, както и броя на стремената при снаждане се определят от първия диаметър на армировката, ако има два. При работа с рамки се изчита номера само на първата колона от съответната вертикална линията и ако тя е различна от 0 се обработва. При работа със шайби се изчита номера само на първите две колони (втората може да е нула) и ако поне първата колона е различна от 0 се обработва. Допълнителни елементи се обработват само при колони (не при шайби и рамки), като се приема номера им и че те достигат до 1 етаж.

Help

Home

Application F1

Работно поле:

При натискане ляв бутон на мишката прихваща най-близкия възел. При натискане десния бутон на мишката при включена Мрежа маркера прихваща координатите на най-близкия възел от мрежата, а при изключена Мрежа координатите.на маркера стават кратни на числото от Координати. При Shift + десен бутон на мишката маркера прихваща координатите на най-близкия въведен възел. Това се отпечатва от дясно на горната хоризонтална лента под менюто.

При свободно работно поле (без да сте в режим на работа с възли или елементи), ако натиснете ляв бутон на мишката се задава начална точка (примерно при Shift + десен бутон на мишката маркера прихваща координатите на най-близкия възел и той става начална точка). При което, всяко натискане на десен бутон на мишката, води до запомняне (mem) на текущите параметри - L, a, dX, dY. Те могат автоматично да се използуват (при кликване върху потъмнени позии на текст), като данни при местене, копиране, завъртане, размножаване и др.

BackSpace - връща назад маркирани възли. При Del и прехванат (с левия бутон на мишката) вече маркиран възел, той се демаркира. При местене (втори възел) и натиснат клавиш A (Align), ъгъла между двата възела става автоматично кратен на 5°.

При натискане на десният бутон на мишката върху горната лента на диалози (tools), извиква диалог за конфигуриране на позицията им (индивидуално или по групи).

Диалог за управление

С Shift + Zoom се прихващат всички възли в областта. При натискане двойно ляв бутон на мишката върху горната лента извиква Параметри.

При задържане на Shift и кликване върху управляващи бутони, следва непрекъснато изпълнение на командите (анимация) до отпускане на Shift. При кликване върху управляващ бутон преди да е изчертан чертежа върху екрана, прекъсва изпълнението и чертае отново с новите параметри. Управление с клавиши от управляващ блок. Scroll Lock – on/off, променя алтернативно посоките на движение. Мащабиране при скролиране със среден бутон на мишката. При местене на мишката и натиснат среден бутон, следва движение на изчертаното. При двойно натискане на средния бутон на мишката – екран всичко.

Диалог за редактиране

Бутона xy задава начин на местене на възлите или елементите по чертежа (ръчно или чрез зададено отместване) при натиснат Ctrl действието му алтернативно се променя.

ЕЛЕМЕНТИ:

линия;

Отсечка по зададени цвят, тип линия и дебелина.

полигон;

Полигон по зададени цвят, тип линия и дебелина.

контур;

Затворен контур по зададени цвят, тип линия, дебелина, площ (дали да изтрива при чертеж, линиите под детайла) и щриховка (кръстосана, разстояние и ъгъл).

кръг;

Кръг по зададени радиус (Alt-диаметър), цвят, тип линия, дебелина, площ (дали да изтрива при чертеж, линиите под детайла) и щриховка (кръстосана, разстояние и ъгъл).

текст1

Текст (по зададен един възел) по позиция спрямо възела, цвят, размер, коефициент на отместване и ъгъл. Работа със стрингови константи на системата и/или зададени потребителски (Калкулатаор – Custom – User strings).

текст2

Текст (по зададени два възела) по позиция спрямо възлите, цвят, размер, коефициент на отместване и ъгъл спрямо направлението образувано от двата възела (след завъртане на възлите му автоматично се променя ориентацията на текста за по-добра четимост). Работа със стрингови константи на системата и/или зададени потребителски (Калкулатаор – Custom – User strings).

Дава възможност за захващане на един елемент към друг елемент след Трие + Съвпадащи на съответните възли. При вход на текст е възможно да се задават изрази описващи числото или числата, които трябва да се изчислят и изчертаят, като резултат. В даден израз са допустими всички действия (описани към калкулатор) и параметри на елементи. Параметрите еi:jk, дават възможност за обвързване на елементите. При описване на параметъра за определен елемент да не се оставят свободни интервали в него. Примерно за даден елемент е с пореден номер i за отсечка j да се вземе k, където:

е или E - означение за елемент;

i - номер на елемент;

j - номер на отсечка за елемент или позиция при Текст1,2 с k=T);

k=X положителната стойност на (X2-X1) за отсечка j на елемент i;

k=Y положителната стойност на (Y2-Y1) за отсечка j на елемент i;

k=L дължина на отсечка j за елемент i.

При Текст1,2 наред с горните опции важи и опцията T:

k=T взема непрекъсната поредица от зададени символи от ляво на дясно образуващи число от позиция зададена чрез j;

k=T взема непрекъсната поредица от зададени символи от ляво на дясно образуващи число от позицията на първо срещнатия символ зададен чрез j. В j се задава само един символ различен от число и от служебни те символи [], като се различават малки от големи букви.

Възможен е параметър еi:k, където:

е или E означение за елемент в група;

i - номер на елемента в група;

k=N връща брой елементи в тази отсечка между двете точки определящи груповия елемент;

k=B връща брой елементи на m' на съответния групов елемент.

За даден израз работят главни и малки букви (eExXyYlLtTnNbB) и шпации между символите .

Пример за параметър на елемент: За да се получи дължината на 5-та отсечка на елемент 2, който е полигон, би следвало са се зададе следния параметър E2:5L. В средни скоби се загражда израз и начина по който бихте желали той да се представи. Извън средни скоби свободен текст.

Пример за текст с два израза: Кота.[|.####.##.cm.=.E2:5L*.100]..[|##=( (1e1 +2)/2) +1] Дължината на 5-та отсечка на елемент 2, който е полигон ще приемем с дължина 2 m, при което резултата е Кота.200.00.cm…7. Да се обърне внимание на точките (шпации) в резултата. Ако не искаме да се променя положението на резултата, то би следвало да запишем същия пример по следния начин: Кота.[######.##.cm.=.E2:5L*.100]..[###=( (1e1 +2)/2) +1] резултата е Кота….200.00.cm…..7.

Възможност в момента на захващане + Ctrl за избор за захванатия елемент. При Редакт елемент след захващането му се задава дали искаме елемента да е в група (задава се втори възел с ляв бутон и бройки на m' за образувалата се отсечка) или не (десен бутон). Око Ctrl-G - задаване на видимите елементи и начина им на изчертаване (възможност за маркиране и демаркиране на всички елементи). Ако пред елемент има две Check box, то лявата е за текст, дясната е указаното в диалога. При изключени Възли, съществува възможност за изчертаване на онези възли (с или без текст), чиито елементи са видими - групови. Текст изписва номера на елемента със зелено (на мястото на първа отсечка) и с циан номерата на следващите отсечки. При връзки изписва номера на елемента с жълто, ако взема с червено, ако дава и с магента, ако взема и дава информация на друг елемент.

Възможност за промяна реда на изчертване на елементите, чрез Последно маркирания елемент се изчертава последен.

Диалог за статус

Показва (при прихванат елемент.) и редактира текущите характеристики при вход на нов или редактиран елемент. Възможности за задаване на 9 позиции на текст, 255 цвята в стил ACI на AutoCAD (текст и графика) - 248 празен цвят, не се генерира върху чертежа (особено полезен при свободна генерация на 3Dface), тип линия в стил на AutoCAD (графика), дебелина (графика) и размер (текст), площ (контур и окръжност), щрих (контур и окръжност), кръстосан (щрих), разстояние (щрих) или коефициент на отместване (текст), ъгъл (щрих и текст) и група (текст и графика). Група се задава при редактиране на елемента.

Елементи (контури, окръжности) от даден детайл се разпознават като колони в Плочи (изчертаване), ако са червени (цвят 1*) и са с пусната опция площ (дали да изтрива при чертеж, линиите под детайла).

Детайл се тълкува като армировка (в сила са опциите за надписване на армировка, спецификация-фигури) ако:

– се състои точно от един графичен елемент (линия или полигон), без да се броят текстовете;

– има задължителен текст във формат брой Ф/N диаметър x дължина (5N20x400) и евентуално / разстояние (7N10x300/15);

– няма елемент група.

За този детайл-армировка се тълкуват:

– като основен надпис на армировката текстове във формат брой Ф/N диаметър x дължина (5N20x400) и евентуално / разстояние (7N10x300/15), ако има такова при греди то се игнорира;

– всички останали се приемат за подробни към съответната фигура;

– в спецификацията за надписване на армировката се пренасят само текст2, които са прехванати към два съседни възли на основния елемент (линия или полигон).

Две армировки са една фигура, ако съвпадат: броя на отсечките, броя на текстовете за подробна армировка и наклоните mod 180ё за всяка отсечка подред, като преди това армировката е завъртяна хоризонтално за най-дългият си участък. Това дава възможност на завъртени, несиметрични обърнати армировки в стил ляво/дясно или горе/долу да се тълкуват като една фигура).

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за модула (det).

Приема от:

Кофражен план (изчертаване) - с формат (det).

Греди (изчертаване) - с формат (det).

Плочи (изчертаване) - с формат (det).

Гредостени (изчертаване) - с формат (det).

Общо оразмеряване - с формат (o__).

Калкулатор.

Предава на:

Кофражен план (изчертаване) - с формат (det).

Греди (изчертаване) - с формат (det).

Плочи (изчертаване) - с формат (det).

Гредостени (изчертаване) - с формат (det).

Калкулатор.

Принтер - кадър.


Старт DPF-DXF-DWG

Общо:

PCPcad

Диалог за стартиране на PCPcad с възможност за автоматичен избор на файл с възможен формат – DPF, DXF, DWG.

DXF-DWG

След Go (преди това може да се зададе Script файл – незадължително), се появява диалог за автоматично генерация на DXF-DWG файл – Експорт DXF-DWG.

SCRIPT

Диалог за автоматично стартиране на Script файл. Пътя към AutoCAD (ако има инсталиран) може да се настрои автоматично чрез Associate . Script файла е създаден за Windows версии (кирилица, цветове) на AutoCAD. При този случай видимостта между обектите (примерно греди под колони) трябва се реши от проектанта (3DFACE са в слой - 00-dfc, а обектите всеки на зададеното си ниво/височина в слой - 00-xxx. Също така трябва да се вмъкнат използуваните типовете линии мащабирано в зависимост от мащаба на чертежа.

Приема от:

Кофражен план (изчертаване) - с формат (scr).

Греди (изчертаване) - с формат (scr).

Плочи (изчертаване) - с формат (scr).

Грдостени (изчертаване) - с формат (scr).

Предава на:

PCPcad, DXF-DWG, AutoCAD SCRIPT files.


PCPcad

Общо:

Пълно функционална CAD среда.

Работно поле:

При изпълнение на команда и в свободен режим, десен клавиш на мишката извежда меню с възможните/логични действия за продължение на работата. При изпълнение на команда и Shift + среден клавиш на мишката извежда меню за индивидуално прихващане/селектиране.

При въвеждане на координати могат да се използват следните помощни средства:

– чрез оказване стойностите на Х и У координати;

– чрез указване на отместване по Х или У координати. За указване на отместването се използва символа @;

– чрез указването им в полярни стойности;

– чрез указване отместването в полярни стойности.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за модула (dpf, dwg, dxf).

Приема от:

Кофражен план (изчертаване) - с формат (dpf).

Греди (изчертаване) - с формат (dpf).

Плочи (изчертаване) - с формат (dpf).

Гредостени (изчертаване) - с формат (dpf).

Предава на:

Кофражен план (изчертаване) - с формат (dpf).

Греди (изчертаване) - с формат (dpf).

Плочи (изчертаване) - с формат (dpf).

Гредостени (изчертаване) - с формат (dpf).

AutoCAD - с формати (dwg, dxf).


Файл

PCPcad - Файл

Файл

Ново Ctrl-N

Създава нов чертеж.

Чете Ctrl-O

Прочита вече създаден чертеж с формат (pdf, dwg, dxf).

Използвани...

Отваря диалогов прозорец с последните записани чертежи. Има възможност, както за отваряне на вече създадени чертежи, така и за създаване на нов чертеж. Възможност за изключване на тази опция.

Автозапис (60) Ctrl-A

Автоматичен запис на 60 min (стандартно). Чрез Ctrl-A възможност за запис принудително във файл AutoSave.dpf и нулиране на брояча за време. Възможност във файл ..\pcp.cad\cad.dat да се настрои/промени времето за автоматичен запис (0 - без Автозапис).

Запис Ctrl-S

Записва текущият чертеж с текущи име и формат (pdf, dwg, dxf).

Запис като

Записва текущият чертеж след задаване на ново име и формат (pdf, dwg, dxf).

Запис всички

Записва всички чертежи с текущи име и формат (pdf, dwg, dxf).

Затваря

Затваря текущият чертеж.

Затваря всички

Затваря всички чертежи от работната област.

Език

Сменя езика на работа.

Bulgrarian / български

English / английски

Конфигурация

Зарежда/записва създадения стил на работа, като го разделя на групи: Слоеве, Тип линия, Стил текст, Стил дименсия, Стил точка, Стил успоредни линии, Страници, Настройки, Команди.

Зарежда

Зарежда конфигурационен файл.

Автоматично зарежда...

Възможност за автоматично зареждане на конфигурационен файл.

Запис...

Записва конфигурационен файл.

Слоеве Записва всички слоеве заедно с техните параметри: Име, Включено/Заключено, Цвят, Тип на линията, Дебелина.
Тип линия Записва всички типове линии заедно с техните параметри: Име, Описание, Мащаб, Формат.
Стил текст Записва всички текстови стилове заедно с техните параметри: Шрифт, Ефекти.
Стил дименсия Записва всички стилове дименсии заедно с техните параметри: Геометрия, Текст, Единици.
Стил точка Записва всички стилове точки заедно с техните параметри: Име, Състояние, Блок, Мащаб, Шрифт, Височина, Ширина, Прихваща, Премества.
Стил успоредни линии Записва всички стилове успоредни линии заедно с техните параметри: Име, Покажи връзки, Главни, Елементи.
Страници Записва всички страници заедно с техните параметри: Име, Размер, Ориентация.
Настройки Записва всички настройки от менюто Помощни/Настройки...
Команди Записва всички ново зададени команди: Клавиш, Име, Кратко име.

Очиства...

Бързо очистване от ненужната информация (блокове, слоеве, страници, стилове). Възможност за автоматично изтриване по групи, по елементи или на всичко ненужно.

Принтер настройки...

Настройки на принтера: Избор на принтер, Тип на страницата, Ориентация.

Принтер преглед

Преглед на указаното за печат. Десен бутон на мишката - меню.

Принт...

Отваря диалогов прозорец за печат на текущият чертеж. Задават се: Област, Мащаб, Отместване, Вид принтер, Брой копия, Щампа и др.

Изход

Изход от програмата. В случай, че има промени извежда прозорец за запис.


Редактиране

PCPcad - Редактиране

Редктиране

Стъпка назад Ctrl-Z

Връща последно изпълнената команда или действие.

Стъпка напред Ctrl-Y

Връща последната върната назад командна или действие. Тази команда работи само ако е била върната команда назад преди това.

Cut Ctrl-X

Копира и изтрива маркираните обекти в клипборда.

Copy Ctrl-C

Копира маркираните обекти в клипборда.

Paste Ctrl-V

Връща/поставя върху чертежа преди това копирани обекти от клипборда.

Свойства...

Отваря помощен прозорец, чрез който могат да се форматират/редактират/задават параметрите (всеки различен тип обект има различни такива) на селектираните обекти.

Атрибути...

Отваря помощен прозорец за редактиране на блокови атрибути.

Изтрива Del

Изтрива обект.

Копира

Копира обект с неговите параметри и характеристики.

Огледало

Премества/завърта огледално обект.

Отмества

Отмества обект на зададеното разстояние.

Размножава...

Първа възможност за размножаване на селектирани обекти по площ/правоъгълник.

Втора възможност за размножаване на селектирани обекти полярно по окръжност.

Премества

Транслира обект.

Върти

Върти обект около зададена точка.

Мащаб

Мащабира размерите на обект.

Разтяга

Разтяга селектирани обекти. Обектите могат да са дъги, линии, полилинии и успоредни линии. Разтягат се възлите попаднали в правоъгълната зона при маркирането.

Свързва

Обединява/свързва обекти.

Подрязва

Подрязва обект спрямо друг обект или обекти.

Удължава

Удължава обект до друг обект или обекти.

Прекъсва

Прекъсва/разрязва по една или две точки селектирани обекти. Обектите могат да са дъги, окръжности, елипси, линии, полилинии и успоредни линии.

Закръгля

Удължава/подрязва, обединява и закръгля обекти.

Разбива

Селектиран обект |  | Разбива до обект/обекти
Линейна полилиния | ›› | Линии
Полилиния с изпъкналости | ›› | Линии и дъги
Гладка полилиния | ›› | Линейна полилиния
Дъги, окръжности, елипси | ›› | Полилинии
Вмъкнат блок | ›› | Обекти
Текст | ›› | Полилинии
Щрих | ›› | Линии
Точки | ›› | Вмъкнат блок и текст


Изглед

PCPcad - Изглед

Изглед

Изглед в реално време

Дава възможност потребителя в реално време да определя текущият изглед/мащаб на чертежа, чрез местене на мишката.

Предишен изглед

Връща предишното положение на изглед за чертежа.

Изглед прозорец Ctrl-W

Възможност потребителят да определи, чрез селектиране областта, която трябва да бъде видима.

Изглед граници Ctrl-Е

Видимост на всички обекти, чрез max граници.

Изглед навътре +

Увеличава текущият изглед на чертежа със стъпка.

Изглед навън -

Намалява текущият изглед на чертежа със стъпка.

Изглед селектирано

Текущият изглед на чертежа се променя в зависимост от селектираните обекти, така че те да заемат max екрана.

Движение в реално време

Дава възможност потребителя в реално време да определя текущият изглед/транслиране на чертежа, чрез местене на мишката.

Движение от точка

Премества текущият изглед спрямо точка.

3D изгледи

Отгоре

Отдолу

Отляво

Отдясно

Отпред

Отзад

ЮЗ изометрия

ЮИ изометрия

СИ изометрия

СЗ изометрия

Актуална точка на изглед...

Възможност да се избира позиция на изгледа, така и да се зададе хоризонтален и вертикален ъгъл.

Само текущ слой

Max изглед на обектите само от текущият слой.

Помощни ленти

Скрива/показва помощни ленти.

Стандартна

Свойства обект

Прихваща обект

Чертане

Дименсии

Редактиране

Команден ред Alt-C

Лупа

Спира/пуска помощен изглед върху чертежа, в който се изчертава/увеличава областта около позицията на маркера върху чертежа.

Навигатор (Въздушен изглед)

Спира/пуска помощен прозорец, даващ поглед върху целият чертеж.

Избира страница...

Сменя работната/текуща страница.


Форматиране

PCPcad - Форматиране

Форматиране

Слоеве...

Цветове...

Тип линия...

Типове линии могат да бъдат заредени от файл с формат (lin).

Всeки тип линия се описва с име, описание, мащаб и формат. Форматът на създаваният тип линия се описва с тирета, празно място, точка или символи. Всеки елемент в символичното описание на типовете линии се разделя със запетая. Празното място се задава с отрицателен знак, точка се задава с нула. Например: '1.5, -0.5, 0, -0.5' означава:

Комплексният тип линия съдържа и/или текстови низове заедно с празни места, точки и тирета. Символното описание се затваря в средни скоби []. Синтаксиса на този тип има следният вид: [име шрифт, параметър=стойност, параметър=стойност, ...]. Възможните параметри и стойности са описани по долу:

Параметри | Стойности
T | Текстов низ/стринг.
U | Символен шестнадесетичен UniCode. Можеш да видиш всеки символ и неговият код в Помощни/Инсталирани CAD шрифтове.
F | Bit флаг. Ако флага на бит 1 е вдигнат (1), тогава символа ще бъде запълнен, ако не (0) – само контура ще бъде показан. По подразбиране (0).
X | Хоризонтално отместване от точката на вмъкване. По подразбиране (0.0).
Y | Вертикално отместване от точката на вмъкване. По подразбиране (0.0).
S | Мащаб на символа (относително спрямо дефинираното във файла). По подразбиране (1.0).
R | Завъртане в градуси по часовниковата стрелка (относително спрямо ъгъла на линията). По подразбиране (0.0).

Описанието винаги трябва да съдържа T или U параметър.

Дебелина линия...

Стил текст...

Стил дименсии...

Стил точка...

Стил успоредни линии...

Блокове... Ctrl-B

Атрибути менажер...

Xref менажер...

Изображение менажер...

Страници...

Ред слоеве...

От реда на слоевете зависи и последователността в която те се изчертават.

Обекти отгоре

Сменя реда на чертане, като маркираните обекти се чертаят най-отгоре спрямо останалите обекти от слоя на който принадлежат. За реда на чертане на слоеве виж [image] Ред слоеве....

Обекти отдолу

Сменя реда на чертане, като маркираните обекти се чертаят най-отдолу спрямо останалите обекти от слоя на който принадлежат. За реда на чертане на слоеве виж [image] Ред слоеве....


Чертане

PCPcad - Чертане

Чертане

Линия

0 - начална, 1 - крайна, 2 - средна точки

Лъч

Конструктивна линия

Успоредна линия

Полигон

0...4 - възли, 5, 6 - среди дъги

Връзка при изпъкналост - дъга:

При въвеждане на полилинии могат да бъдат използвани следните видове свързвания между възлите:

– прави линии;

– прави линии и дъги;

– квадратичен сплайн;

– кубичен сплайн;

– крива на Безие;

– кубичен сплайн с тангента;

– полилиния със закръглени върхове;

– комбинация от права линия и кубичен сплайн.

Контур...

Правоъгълник

Дъга

0 - начална, 1 - крайна, 2 - средна точки, 3 - начален ъгъл, 4 - радиус, 5 - краен ъгъл

0 - център, 1, 2 - хоризонтален радиус, 3, 4 - вертикален радиус, 5 - ъгъл на завъртане, 6 - начален ъгъл, 7 - краен ъгъл

3 точки

Начало, център, край

Начало, център, ъгъл

Начало, център, дължина

Начало, край, ъгъл

Начало, край, направление

Начало, край, радиус

Център, начало, край

Център, начало, ъгъл

Център, начало, дължина

Продължение

Окръжност

0 - център, 1, 2, 3, 4 - радиуси през 0є, 180є, 90є, 270є

Център, радиус

Център, диаметър

2 точки

3 точки

Сплайн

Елипса

0 - център, 1, 2 - хоризонтален радиус, 3, 4 - вертикален радиус, 5 - ъгъл на завъртане, 6 - начален ъгъл, 7 - краен ъгъл

Точка

Някои стандартни видове точки:

Текст

За да бъдат начертани особени символи се използват контролни кодове:

Код |  | Резултат | Название
%%d | ›› | ° | Градус
%%p | ›› | ± | Плюс минус
%%c | ›› | ф | Диаметър

Могат да бъдат използвани символи чрез UniCode:

UniCode |  | Резултат | Название
\U+00B0 | ›› | ° | Градус
\U+00B1 | ›› | ± | Плюс минус
\U+2205 | ›› | ф | Диаметър
\U+20AC | ›› | € | Евро
\U+00A9 | ›› | © | Copyright

Много редов текст

Този тип текст може да бъде разположен на няколко реда. Възможно е използването на форматиращи текста кодове.

Код | Описание | Пример | Резултат
\O | Включва и изключва чертане линия над текста | Autodesk \OAutoCAD\o 2000 |
\L | Включва и изключва подчертаване на текста | Autodesk \LAutoCAD\l 2000 |
\~ | Вмъква разстояние | Autodesk AutoCAD\~2000 |
\\ | Наклонена черта на дясно | Autodesk \\AutoCAD |
\{ ... \} | Вмъква скоби | Autodesk \{AutoCAD\} 2000 |
\Cvalue; | Променя цвета | Autodesk \C2;AutoCAD 2000 |
\File name; | Променя файла на шрифта | Autodesk \Ftimes; AutoCAD 2000 |
\Hvalue; | Променя височината на текста | Autodesk \H2;AutoCAD |
\Hvaluex; | Променя текста като умножава текущата му стойност | Autodesk AutoCAD \H3x;2000 |
\S...^...; | Представя като дроб | 1\S1/2; |
\Tvalue; | Променя разстоянието между символите | \T2;Autodesk |
\Qangle; | Променя наклонът на текста | \Q20;Autodesk |
\Wvalue; | Променя широчината на текста | \W2;Autodesk |
\P; | Край на параграф | Autodesk\PAutoCAD 2000 |

Текст на един ред

0 - базова точка, 1 - мащаб, 2 - височина, 3 - фактор ширина, 4 - ъгъл на завъртане

Windows текст

Използване пряко на Windows TrueType шрифтове с формат (ttf).

Щриховка...

Поставяне на щриховка на даден затворен полигон.

Всеки затворен полигон може да бъде щрихован. Прихващането на полигона се извърша чрез маркиране на контура или чрез указване вътрешна точка за полигона. Типовете щриховка могат да бъдат заредени от файл с формат (pat). Всяка щриховка има два параметъра: Ъгъл, Мащаб.

Създава блок...

Създаването на блок се извърша чрез селектиране на обекти, които ще образуват блока. Параметри на блока са: Име, Базова точка, Мащаби и др.

Вмъква блок...

Вмъкването на блок в чертежа се осъществява, като се избере вече създаден блок и се укажат входните му параметри: Точка на вмъкване, Мащаб, Ъгъл на завъртане, Размножаване.

0 - базова точка, 1 - пропорционален мащаб, 2 - вертикален мащаб, 3 - хоризонтален мащаб, 4 - ъгъл на завъртане

Дефиниция атрибути...


Дименсии

PCPcad - Дименсии

Дименсии

Орто

0, 1 - отместване, 2 - позиция на линията (само Y се отчита), 3 - позиция на текста

0, 1 - отместване, 2 - позиция на линията (само X се отчита), 3 - позиция на текста

Наклонена

0, 1 - отместване, 2 - позиция на линията (ъгъла й се определя от направлението определено от 0, 1), 3 - позиция на текста

Продължение

Продължава изчертаването от последната дименсия (орто, наклонена). Възможност за задаване на нова (Start) дименсия за ново продължение. При наклонена дименсия режим на работа Mode: on - продължение със същият наклон, off - продължение с последно полученият наклон. При орто дименсия режим на работа Mode: on - продължение с напречни помощни линии еднакви по дължина с втората от основната дименсия, off - продължение с получените напречни помощни линии.

Ордината

0 - произволна/указана точка, 1 - позиция на текста

Радиус

0 - радиална точка, 1 - център на радиуса, 2 - позиция на текста

Диаметър

0, 1 - диаметрални точки, 2 - позиция на текста

Ъглова

При окръжност или дъга:

0, 1 - крайни точки, 2 - център, 3 - позиция, 4 - позиция на текста

При линии:

0, 1 - първа линия, 2, 3 - втора линия, 4 - позиция, 5 - позиция на текста

Външните линии не се чертаят, ако края на дъгата е между точките на линиите.

Водач

Чрез полигон/отсечка изнася/указва произволен текст.

Марка център

Маркира центъра на указана окръжност, елипса или дъга.

Стилове...

Виж Форматиране/Стил дименсии...


Вмъква

PCPcad - Вмъква

Вмъква

Блок...

Виж Чертае/Вмъква блок...

Външен чертеж

Вмъква външен чертеж (като блок) в текущия. Възможни формати (pdf, dwg, dxf). Контрол за блокове с еднакви имена в чертежите - преименува имената в текущият чертеж, като добавя "_[n", където n -поредно свободно число за съответното име на блок.

Външен чертеж Xref

Фиктивно вмъква (запомня пътя до чертежа) външния в текущия чертеж като блок. При Explode на този блок се губи/къса/унищожава връзката към външния чертеж. Контрол за име на блок - преименува името в текущият чертеж, като добавя "_[n", където n -поредно свободно число за съответното име на блока.

Растерно изображение...

Стандартно възможни формати (bmp, tif, jpg, gif).

Виж Plugins/Control/CAD...

ArcView Shapefile...

Xref manager...

Изображение менажер...

Виж Форматиране/Изображение менажер...


Селектиране

PCPcad - Селектиране

Селектиране

По идентификатор...

Селектира обект по идентификатора (Identifier) на обекта.

По данни потребител...

Селектира обекти по полето за потребителя - Данни потребител (User data) на обекта.

По текст...

Селектира обекти при намиране на търсеният текст.

По точка

Селектира обект при кликване върху него.

По правоъгълник

Селектират се обекти в рамките на посочен правоъгълник. При описание на правоъгълника от лява на дясно и от горе на долу, за да се селектират обектите, те трябва да попадат изцяло в областта на правоъгълника. При обратен случай се селектират всички обекти, които пресичат областта на правоъгълника.

По контур

Селектират се обекти които са изцяло в рамките на указания контур.

По полилиния

Селектират се обекти които се пресичат от указаната полилиния.

По разстояние

Селектират се обекти които са изцяло в рамките на образувалата се окръжност при указания център.

Текущ слой

Селектират се всички обекти от текущият слой.

Текуща страница

Селектират се всички обекти от текущата страница.

Всички обекти

Селектират се всички обекти от чертежа.

Група обекти...

От всички селектирани обекти се демаркират отказаните (uncheck) групи обекти. Възможност за филтриране на маркираните блокове по маска (WildCard):

* без или в по-вече символи;

? всеки символ;

# всеки числов символ.

example: ##?arm_* - осртавя маркирани всички армировки.

При само * или празно, работи с всички селектирани блокове.


Помощни

PCPcad - Помощни

Помощни

Измерва

Разстояние

Измерва разстояние (сумира) между две точки.

Разстояние по полилиния

Измерва разстояние (сумира) по полилинии при селектиране на две точки върху тях.

Площ

Измерва площ (сумира) при въведен контур.

Площ по вътрешна точка

Измерва площ (Shift-сумира) по указана вътрешна точка.

Калибрира...

Задава се мащаб/коефициент при измерване на дължини и площи.

Режим

Мрежа...

Ортогонален режим Alt-O

Спира/пуска ортогонален режим.

Проследява...

Прихваща

Средства при чертане...

Де / Маркира всички

по крайна точка

по средна точка

по център

по точка

по пресечница

по перпендикуляр

по тангента

по най-близък

Възможност за прихващане точки от най-близкият обект.

по маркер

Прихваща по маркери (grips), характерни за всеки обект.

Шрифтове

Конвертира TTF към VCF...

Конвертира SHX към VCF...

Инсталирани CAD шрифтове...

Информация чертеж...

Експорт в растер...

Convert coordinates...

Convert AutoCAD...

Подържани версии за DWG и DXF файлови формати:

– AutoCAD 2007/2008/2009;

– AutoCAD 2004/2005/2006;

– AutoCAD 2000/2000i/2002;

– AutoCAD 14;

– AutoCAD 13;

– AutoCAD 11/12;

– AutoCAD 10;

– AutoCAD 9;

– AutoCAD 2.6;

– AutoCAD 2.5.

Настройки...

Команди...

Възможност за задаване на уникални горещи клавиши - User Key и текстови команди - User Cmd. В таблицата са дадени стандартните такива.

Key | Command | Alias | Description
 |  |  | Преглед чертеж
Ctrl+E | ZOOME | ZE | Изглед граници
Add |  |  | Изглед навътре - уголемява
Subtract |  |  | Изглед навън - намалява
 | ZOOMP | ZP | Предишен изглед
Ctrl+W | ZOOMW | ZW | Изглед прозорец / правоъгълник
 | ZOOMRT | ZR | Изглед в реално време при натиснат ляв бутон на мишката
 | ZOOMSEL | ZS | Изглед на всички маркирани обекти
 | PANRT | PAR | Преместване в реално време при натиснат ляв бутон на мишката
 | PAN | P | Преместване на чертежа от една точка в друга
Left |  |  | Преместване на чертежа на дясно
Right |  |  | Преместване на чертежа наляво
Up |  |  | Преместване на чертежа на долу
Down |  |  | Преместване на чертежа на горе
PgDn |  |  | Преглед следваща страница
PgUp |  |  | Преглед предишна страница
Home |  |  | Преглед първа страница
End |  |  | Преглед последна страница
 |  |  | Избира страница от списък
 |  |  | 3D изглед отгоре (план)
 |  |  | Противоположен 3D изглед отдолу
 |  |  | 3D изглед отляво
 |  |  | 3D изглед отдясно
 |  |  | 3D изглед отпред
 |  |  | 3D изглед отзад
 |  |  | 3D изометрия Юг-Запад
 |  |  | 3D изометрия Юг-Изток
 |  |  | 3D изометрия Север-Изток
 |  |  | 3D изометрия Север-Запад
 |  |  | 3D изометрия чрез диалог
 |  |  | Налага режим на видимост само за текущия слой
 |  |  | Управление на не графични обекти
 | LAYER | LA | Извиква диалог 'Слоеве'
 |  |  | Извиква диалог 'Layers order'
 | COLOR | COL | Извиква диалог 'Цветове'
 | LINETYPE | LT | Извиква диалог 'Тип линия'
 | LWEIGHT | LW | Извиква диалог 'Дебелина линия'
 | TEXTSTYLE | TS | Извиква диалог 'Стил текст'
 | POINTSTYLE | PS | Извиква диалог 'Стил точка'
 | MLINESTYLE | MLS | Извиква диалог 'Стил успоредни линии'
 |  |  | Извиква диалог 'Стил дименсии'
 | IMAGE | IM | Извиква диалог 'Изображение менажер'
Ctrl+P | PAGE | PG | Извиква диалог 'Страници'
Ctrl+B |  |  | Извиква диалог 'Блокове'
Ctrl+T |  |  | Налага режим дебелина на линия
Ctrl+R |  |  | Налага режими - Изображения / Вектори / И двата
 |  |  | Добавяне на графични обекти към чертеж
 | POINT | PO | Чертае точка
 | LINE | L | Чертае линия
 | RAY |  | Чертае лъч
 | XLINE | XL | Чертае конструктивна линия
 | MLINE | ML | Чертае успоредна линия
 | PLINE | PL | Чертае полилиния
 | POLYGON | POL | Чертае полигон
 | RECTANG | REC | Чертае правоъгълник
 | CIRCLE | C | Чертае окръжност
 |  |  | Чертае окръжност по център, радиус
 |  |  | Чертае окръжност по център, диаметър
 |  |  | Чертае окръжност по 2 диаметрални точки
 |  |  | Чертае окръжност по 3 точки
 | ARC | A | Чертае дъга
 |  |  | Чертае дъга по 3 точки (начало, втора, край)
 |  |  | Чертае дъга по начало, център, край
 |  |  | Чертае дъга по начало, център, ъгъл
 |  |  | Чертае дъга по начало, център, дължина
 |  |  | Чертае дъга по начало, край, ъгъл
 |  |  | Чертае дъга по начало, център, направление
 |  |  | Чертае дъга по начало, център, радиус
 |  |  | Чертае дъга по център, начало, край
 |  |  | Чертае дъга по център, начало, ъгъл
 |  |  | Чертае дъга по център, начало, дължина
 |  |  | Чертае дъга / продължение по тангента от линия, дъга или полилиния
 | ELLIPSE | EL | Чертае елипса
 |  |  | Чертае сплайн
 | HATCH | HA | Чертае щриховка
 | DIMLIN |  | Чертае орто дименсия
 | DIMALI |  | Чертае наклонена дименсия
 | DIMCON | DC | Продължава дименсията (орто, наклонена)
 | DIMORD |  | Чертае ордината дименсия
 | DIMRAD |  | Чертае радиус дименсия
 | DIMDIA |  | Чертае диаметър дименсия
 | DIMANG |  | Чертае ъглова дименсия
 | CENMARK |  | Чертае марка център дименсия
 | LEADER |  | Чертае водач дименсия
 | TEXT | T | Вмъква текст на един ред
 | MTEXT | MT | Вмъква много редов текст
 | WTEXT | WT | Вмъква Windows текст (TrueType)
 | ATTDEF |  | Дефинира атрибути
 | ATTEDIT |  | Редактира атрибути на блок
 | INSERT | I | Вмъква блок
 | IMAGEATTACH | IAT | Вмъква изображение
 | BLOCK | B | Създава блок от маркирани обекти
 |  |  | Редактиращи операции
Ctrl+Z | UNDO | U | Стъпка назад (Undo)
Ctrl+Y | REDO |  | Стъпка напред (Redo)
Ctrl+X |  |  | Копира обекти в Clipboard и ги трие след това
Ctrl+C |  |  | Копира обекти в Clipboard
Ctrl+V |  |  | Вади обекти от Clipboard
 |  |  | Извиква диалог 'Properties'
Delete | ERASE | E | Трие обект
 | COPY | CO | Копира обект
 | MOVE | M | Мести обект
 | ROTATE | RO | Върти обект
 | SCALE | SC | Мащабира обект
 | MIRROR | MI | Огледало обект
 | EXPLODE | X | Разбива обект
 | JOIN | J | Обединява два обекта в един
 |  |  | Подрязва обекти
 |  |  | Удължава обекти
 | OFFSET | O | Отмества обекти
 | FILLET | F | Закръгля обекти
 | DEP |  | Max отклонение
 |  |  | Извиква диалог 'Настройки'
 |  |  | Маркира графични обекти
 |  |  | Маркира обекти по точка
 |  |  | Маркира обекти по правоъгълник
 |  |  | Маркира обекти по полигон
 |  |  | Маркира обекти пресичащи полилиния
 |  |  | Маркира обекти по радиус / окръжност
 |  |  | Маркира обекти по идентификатор
 |  |  | Маркира обекти по данни потребител
 |  |  | Маркира всички обекти от текущия слой
 |  |  | Маркира обекти съдържащи указания текст
 |  |  | Други
 | PRINT |  | Извиква диалог 'Принт'
Escape |  |  | Прекъсва текущата команда, демаркира всички обекти, пречертава чертежа
 | REGEN | RE | Регенерира чертежа
 |  |  | Повтаря последната команда
 |  |  | Насочва фокуса на клавиатурата към PCPcad прозореца
F7 |  |  | Налага режим чертане на мрежа
F9 |  |  | Налага режим прихващане към мрежа
F3 |  |  | Налага режим прихващане по признак
F8 |  |  | Налага режим проследяване
F1 |  |  | Показва Help
 |  |  | Извиква диалог 'Експорт в растерно изображение'
 | DIST | DI | Изчислява разстояние
 |  |  | Изчислява разстояние по полилиния
 | AREA | AA | Изчислява площ
 |  |  | Изчислява площ на полигон по указана негова вътрешна точка
 | CONVERT |  | Конвертира координати на обекти
 |  |  | Калибрира единици за изчисление
 |  |  | Показва информация за чертежа
 |  |  | Извиква диалог 'Средства при чертане'
 | PURGE | PU | Изтрива цялата неизползвана информация
Alt+A |  |  | Налага режим интерпретация на блокове [.arm_.] като армировка
Alt+O |  |  | Налага ортогонален режим
Alt+C |  |  | Команден ред
 | SPECIF | SP | Извършва / генерира спецификация на армировката

PCP стилове

Създава или променя (ако съществуват) типизирани стилове: дименсии – DIMPCP, DIMPCP_, стил текст – TXTPCP (използува се и към дименсии), както и стилове за успоредни линии MLSPCP (изчертаване на греди) и MLSPCP_. Стиловете се конфигурират със стандартно зададени параметри (осите на 'гредите' в стил MLSPCP се изчертават с линия стил DashDot, ако преди това е бил зададен). Стилове DIMPCP, TXTPCP и MLSPCP стават текущи.

Блокове [.arm_.] Alt-A

Спира/пуска режим интерпретация на блокове с армировка.

Един блок се разпознава като армировка/зона ако:

1. В името на блока съществува текста "arm_";

2. Броя полилинии е равен на броя текстове с "xX" в тях, виж Спецификация. Като от броя полилинии се игнорират/вадят:

– тези с 2 възела (vertex) и цвят magenta (6) - зони;

– тези с 3 възела (vertex) и цвят magenta (6) - детайли зони;

– тези с 2 възела (vertex) и в името на стила за тип линия има текста "DASH";

– тези със зададена дебелина = 0 (виж Кофражен/Армировъчен план – Дебелини...).

Към всяка полилиния/армировка/желязо в блока се групират наличните текстове и за тях се извършват следните промени:

1. Ако числото от текста е различно от 0 (280), търси най-близката отсечка от полилинията и текста се замества дължина й - форматирано;

2. Ако числото от текста е равно на 0 (v77), той не се променя, като текст - само се мащабира;

3. Ако в текста има "xX", за дължина се взема цялата дължнина на принадлежащата му полилиния/армировка.

За да се разпознае един блок армировка, като зона би следвало сумата от всички линии (в името на стила за тип линия има текста "DASH") или/и полилинии (с 2 възела (vertex) и в името на стила за тип линия има текста "DASH") да е равен на 4. За такава зона се разпознават:

1. Координати (x.x, y.y) за зоната. Техните стойности се изчисляват за центъра на окръжност принадлежаща на блок [ [image] ], който в името си има текста "arm_nul". Те трябва да са във формат (#.# - задължително точка), да са разположени извън зоната - хоризонтално (ъгъл 0) и вертикално (ъгъл 90) с позиции 'Долу дясно';

2. Размери на зоната (Lx, Ly), (Lx1-Lx2, Ly), (Lx, Ly1-Ly2). Те трябва да са във формат (#.# - задължително точка), да са разположени вътре в зоната и да са с ъгли по направление на зоната;

3. Lx или/и Ly с празно/шпация зад тях е критерий за добавяне на ъгъл, ако е различен от нула;

4. Бройките в зона се изчисляват при наличие на текст бройки / m' - точно, при липса на такъв се дели размера на зоната на бройките железа и се получават отново бройки / m';

5. За правилно изчисление дължината на прътите при трапецовидни зони, дължината на желязото да е среден размер от този на зоната.

Shift - Редактира автоматично всички блокове с "arm_".

Control - Вкарва в горната логика блока принудително. Особено полезно при колони (автоматична промяна на размери), детайл - конструктивен отвор (преизчислява армировка) и др.

Спецификация

След десен клавиш (край на селектирането) генерира сортирана таблица с армировка от селектираните преди това обекти. Те трябва да съдържат текст в следния формат:

Формат: | Number S Diameter x Length
Number | – n, n¹±n² → 5, 2+5=7 МА, 2*5=2x5=2X5=2-5=10 гредостени;
Symbol | – N, n, Ф, ф, %%C, %%c ≡ Ø – CAD диаметър;
Diameter | – D [mm] → 6.5, 8, 16, 20;
x | – x, X;
Length | – L, L¹-L² [cm] → 330, 500-0=250, 300-500=400 трапецовидни зони;
примери: | (180)<7>2-5N12x330-500/40 ≡ (180)<7>10N12x415/40;
 | 2+5Ф6.5X0-500 ≡ 7Ф6.5x250;
 | < 25 > 5 Ø 6.5 x 500 - 800 ≡ <25>5Ø6.5x650 – Spaces между елементите.

За подробна таблица с армирока – виж Armature).


PCP

PCPcad - PCP / CAD

В CAD среда - меню PCP, а в PCP среда - меню CAD за алтернативен преход към съответната среда. Менюто PCP е налично в CAD средата, само при съвместна работа с PCP.

1 Link - Total Lock Ctrl-1

Първа възможност за връзка с PCPcad. Синхронизиран преглед на обектите и в двата режима на работа. Бързо прехвърляне от среда в среда. В среда на PCPcad липса на възможност за работа (прехващане - snap, копиране) с преди това генерирани обекти.

2 Link - Drawing Lock Ctrl-2

Втора възможност за връзка с PCPcad. Синхронизиран преглед на обектите и в двата режима на работа. По бавно прехвърляне от PCP към CAD среда. В среда на PCPcad възможност за прехващане - snap на възли от преди това генерирани обекти. В среда на PCPcad липса на възможност за копиране на преди това генерирани обекти.

3 Link - Blocks Lock Ctrl-3

Трета възможност за връзка с PCPcad. Синхронизиран преглед на обектите и в двата режима на работа. По бавно прехвърляне от PCP към CAD среда. В среда на PCPcad възможност за прехващане - snap на възли от преди това генерирани обекти. В среда на PCPcad възможност за прехвърляне/копиране (автоматично след маркиране - единично или групово) на преди това генерирани обекти, с възможност за последваща обработка.

View entities Alt-~

При синхронизиран преглед видимост на обектите от алтернативният режим.


Plugins

PCPcad - Plugins

Plugins

Control

PCP...

Контрол на Plugins за PCPcad.

CAD...

Контрол на Plugins вътрешни за CAD.

На долу в това меню - зона за добавяне на менюта генерирани в Plugins.

Table TB

Table се старира от меню или с текстови команди TABLE, TB.


Plugins - CAD Таблица

PCPcad - Plugins - CAD Таблица

Общо:

Автоматична генерация на таблици в CAD среда. Команда – TABLE (пълна), TB (кратка).

Меню:

File

New

Нулира клетките без да променя базовите параметри на таблицата.

Current read

Current write Ctrl-Z

Read Ctrl-R

Чете таблица от файл с формат ( ). Този файл може да се изготви в произволен текстов редактор или да се генерира автоматично от програма при спазване на следните управляващи кодове:

TabSU | – текст на един ред горе в средата - заглавие (1.5 x TabH);
TabSD | – текст на един ред долу дясно;
TabSL | – текст на един ред вертикален, ляво долу;
TabSR | – текст на един ред вертикален, дясно долу;
TabC | – брой колони;
TabR | – брой редове;
TabH | – размер на текст в CAD units;
TabO | – параметър за отместване на текст (TabО x TabH);
TabF | – опция при генерация на таблица за чертане на цели линии или на части и квадрати;
C(i, j[, p]) | – текст в клетка на ред i, колона j и позиция p - може да липсва при описанието: Позиции за параметър p: (-p - клетка правоъгълник)
R(i) | – параметър за указан размер на ред (R(i) x TabH). При нула - Auto;
K(i) | – параметър за указан размер на колона (К(i) x TabH). При нула - Auto.

Write Ctrl-W

Записва таблица във файл с формат ( ).

Пример за формата на генерираният текстов файл.

TabSU=Specification armature

TabSD=$u

TabSL=

TabSR=$t $v

TabC=6

TabR=5

TabH=8.676

TabO=0.6

TabF=0

// C(Row, Column[, Pos])=Text

// Pos (-Pos)-Rectangle cell

// 33 23 13

// +----+-----+

// 32+ +22 +12

// +----+-----+

// 31 21 11

C(1,1,-32)=Steel

C(1,2,-32)=Diam

...

...

C(3,1,32)=%%f(2,1)-I

R(5)=2.5

K(2)=2.0

Exit current delete

Exit

Cells

Извиква таблица за работа по клетки с текущите параметри и данни. При кликване върху номера на колони или редове сменя режими на преглед (Final mode или Source mode). При кликване върху Columns/Rows - възможност за задаване на фиксиран размер на колона/ред, чрез зададения параметър умножен по размера на текста (0-Auto). При кликване върху останалите клетки възможност за задаване на текст или формула, тип на клетката и позиция на текста. Поддържа се и многоредов текст в клетка. При въвеждане на текст могат да се използват всички текстови и числови константи/функции, като в Калкулатор. Ако в текста има числови изрази те се форматират/ограждат със средни скоби като в Калкулатор. Допълнителни възможности за работа в таблица дават и следните параметри:

%%F(i, j) | – взема стойността от ред i, колона j при формиране на израза текстов/числов;
%%R(i) | – взема стойността от ред i и колоната където е формулата при формиране на израза текстов/числов;
%%C(j) | – взема стойността от реда където е формулата и колона j при формиране на израза текстов/числов.
(работи с главни и малки букви)

Могат да се ползват всички възможности на Таблица, (чрез Ctrl-F). Възможности за размножаване (текст, позиция, тип) на дясно и на долу от текущата позиция по колони, редове и блок. Виж Example.

Tools

Specification

Shutter !

Генерация (при наличие на plugin pcp-kof.dll) на таблица с количествата необходим кофраж. Автоматичен вход в Cells. Входа в това меню е възможен само чрез plugin pcp-kof.dll – *.

Concrete !

Генерация (при наличие на plugin pcp-kof.dll) на таблица с количествата необходим бетон. Автоматичен вход в Cells. Входа в това меню е възможен само чрез plugin pcp-kof.dll – *.

Armature

Автоматична генерация (при маркирани/селектирани елементи – виж Спецификация) на таблица с армировка. Възможност за управление на основните текстове и на броя на генерираните колони и крайните суми по диаметри, стомани и общо. Автоматичен вход в Cells.

Cost !

Генерация (при наличие на plugin pcp-kof.dll) на таблица с цени. Автоматичен вход в Cells. Входа в това меню е възможен само чрез plugin pcp-kof.dll – *.

Generation

Текущ запис и генерация (F9) на таблица за текущите данни.

Help

Home

Application F1

Example

Пример - демонстриращ някои от възможностите при работа с изрази (текстови и числови). Автоматичен вход в Cells.

Armature

Диалог - демонстриращ някои от възможностите при анализ на текстове армировка.

Работен диалог:

Задават се брой редове (Rows) и колони (Columns). Задава се и размера на текстовете (High) в чертожни единици (units). Настройва се параметъра за отместване (Offset parameter) на текст, като отместването спрямо зададената позиция на текста е равно на Offset parameter x High. Възможност при генерация на таблица за чертане на цели линии или на части и квадрати, в зависимост от типа на клетката. Задават се външни текстове към таблицата разположени към четирите й страни.

Ресурси:

Помни последно генерираната таблица.

Файлове:

Формат за запис ( ).

Приема от:

File.

Предава на:

File.

Преглед текст.


Plugins - Кофражен/Армировъчен план

PCPcad - Plugins - Кофражен/Армировъчен план

Общо:

Автоматично (обектно ориентирано) изчертаване на кофражни и армировъчни планове. Възможност за създаване на потребителски библиотеки от елементи за последващо използуване.

Меню:

Селектиране...

Филтър за избор на определени типове от глобално селектираните обекти. Възможност за селектиране на всички от диалога.

Рамка...

Команда – LIST (пълна), LIS (кратка).

Диалог за попълване на параметрите за изчертаване на единична или двойна рамка/и към чертежа. Възможност за маркиране размерите на листа.

Лист/Мащаб...

Избор размери на лист, богат набор от стандартни листа или избор на такъв с уникални размери. Мащаб по избор в стил 1:Y, X:1 или X:Y.

Обекти

С обектите се работи посредством команда (пълна, кратка), бутони от toolbar или меню. Редактирането на обект или група обекти става, чрез маркирането им и промяна на съответната характеристика, чрез диалог Свойства. Редактирането на конкретно маркиран обект може да се извърши и чрез преместването на характерните за него маркери (стъпките за размер и ъгъл могат да се настроят, чрез диалог Стъпки). За всички обекти се поддържат редактиращите функции Изтрива, Копира, Размножава (increment), Премества и Върти.

Ос...

Команда – AXE (пълна), AX (кратка).

Задават се следните параметри: име, автоматичен увеличение на името при следващо въвеждане, ориентация на текста по оста, видимост на позициите на текстовете и отмествания по X" и Y" на входните точки (тези отмествания зависят от ъгъла на въвежданата ос).

При въвеждане на ос има възможност за указване на ъгъла и/или дължината й.

О – орто режим (при on, изключва 'A');

А – фиксиран ъгъл (изключва 'O');
D – фиксирана дължина;

U – режим (изключва 'O', 'A' и 'D').

Поле...

Команда – FIELD (пълна), FIE (кратка).

Задават се следните параметри: име, автоматичен увеличение на името при следващо въвеждане, тип на полето (отвор), ъгъл, единична цена за кофраж и бетон.

Греда...

Команда – BEAM (пълна), BM (кратка).

Задават се следните параметри за избрания тип греда: име, автоматичен увеличение на името при следващо въвеждане, B, H, единична цена кофраж и бетон и отмествания по X" и Y" на входните точки (тези отмествания зависят от ъгъла на въвежданата греда). Базов тип сечение за гредата (вид, отворено или затворено) и параметри описващи неговите размери. Възможности за скриване на всички текстове или всички текстове без първия (име). Промяна режима на работа орто или свободен. Допълнителна възможност ‘Edit’ за контрол и въвеждане на текст (изрази) - оцветен синтаксис, експорт към Калкулатор, примери 'Help' към текущото.

При въвеждане на греда има възможност за указване на ъгъла и/или дължината й.

О – орто режим (при on, изключва 'A');

А – фиксиран ъгъл (изключва 'O');
D – фиксирана дължина;

U – режим (изключва 'O', 'A' и 'D').

Колона...

Команда – COLUMN (пълна), CLM (кратка).

Задават се следните параметри за избрания тип колона: име, автоматичен увеличение на името при следващо въвеждане, B, H, или R1, R2, единична цена кофраж и бетон и отмествания по X' и Y' на входните точки. Възможности за скриване на всички текстове или всички текстове без първия (име). Допълнителна възможност ‘Edit’ за контрол и въвеждане на текст (изрази) - оцветен синтаксис, експорт към Калкулатор, примери 'Help' към текущото.

Кота

Команда – ADIMENSION (пълна), ADI (кратка).

Автоматично оразмеряване/котиране на обекти. Селектират се обектите които трябва да се оразмерят/котират, те могат да бъдат: колони, греди, полета и оси.

Секущата линия при оразмеряването може да бъде указана с няколко параметъра.

О – орто режим (при on, изключва 'A'). При този режим и генерираните коти с в стил орто – за последващо по-удобно редактиране;

А – фиксиран ъгъл (изключва 'O');

U – режим (изключва 'O' и 'A');

T – тип/вид на генерираните оразмерителните линии (габарит, ос, подробна и комбинации от тях).

Ниво

Команда – LEVEL (пълна), LEV (кратка).

Котите за ниво са два вида.

При изчертаване на кота могат да се окажат няколко параметъра.

V – сменя вида на нивото;

А – работен ъгъл за изчертаване;

L – стойност.

Сечение

Команда – SECTION (пълна), SEC (кратка).

Изчертаване на единично сечение. Указва се обекта (може да бъде греда или поле) към който ще се изпълни сечението/разреза.

Сечение греда

Задават се размерите на сечението, вида му (отворено или затворено) и котирано или не да бъде то.

При изчертаването му могат да се укажат няколко параметъра.

B – размер за изчертаване на съответното сечение (може да е различен от този на гредата);

H – размер за изчертаване на съответното сечение (може да е различен от този на гредата);

А – фиксиран ъгъл (откача сечението);

U – режим (изключва 'A').

Ако ъгъла на сечението е зададен, то е откачено от съответната греда, в противен случай то се прихваща към нея.

Сечение поле

При изчертаването му могат да се укажат няколко параметъра.

H – дебелина за изчертаване на съответното сечение (може да е различна от тази на полето);

D – задава котиране на сечението;

А – фиксиран ъгъл (откача сечението);

U – режим (изключва 'A').

Ако ъгъла на сечението е зададен, то е откачено от съответното поле, в противен случай то се прихваща към него.

Автоматичен разрез

Команда – ASECTION (пълна), ASE (кратка).

Възможност за автоматично изчертаване на сечения. Необходимо е селектиране на група обекти с които ще се работи. Посочва се секуща която указва направлението на сеченията. При посочване на секущата е възможно указването на няколко параметъра.

О – орто режим (при on, изключва 'A');

А – фиксиран ъгъл (изключва 'O') за секущата;

U – режим (изключва 'O' и 'A');

М – начин на поставяне на сечението. Възможни са два начина за изчертаване на сечението: сечението се прихваща към обект и има ъгъл равен на ъгъла на обекта и сечението не е прихванато към обект и има ъгъл равен на ъгъла на секущата.

Рамо стълбище...

Команда – STAIR (пълна), STA (кратка).

Задават се следните параметри: ъгъл, дължина, ширина и височина на стълбищното рамо, брой стъпала, дебелина на плочата горе и долу, дебелина на рамото, единична цена кофраж и бетон. Възможност за отмествания по X' и Y' на входната точка. Рамото може да бъде качващо и слизащо. Чрез опция ''цяло сечение" може да се зададе изчертаване на пълен разрез на стълбищното рамо (особено подходящо при малък брой стъпала).

Армировка...

Команда – ARMATURE (пълна), ARM (кратка).

За избрания тип/вид на армировката се задават: интензивност, указват се параметри описващи характеристиката на армировката. Възможности за скриване на зоната, оразмерителната линия и размерите на зоната. Възможност за отмествания по X' и Y' на входната точка. Допълнителни възможности ‘d1’ и 'd2' за контрол и въвеждане на текст (изрази) - оцветен синтаксис, експорт към Калкулатор, примери 'Help' към текущото.

Библиотека

Създава се набор от определен тип обекти (греди, колони, армировки) – библиотеки, за последващо използване при работа.

Греда...

Указва се тип щриховка, B, H на гредата и се задават необходимите текстовете. Възможности за скриване на всички текстове или всички текстове без първия (име). Показване позиция на текст. Копиране и триене на текст или цяла греда.

Текста има следните параметри: ъгъл, височина, отместване от линията – указва се чрез параметър, линия на която принадлежи и позиция спрямо тази линия. В рамките на текста е възможно да се използуват динамично следните форматиращи символи (малки букви) характеризиращи гредата:

<b> – B греда;

<h> – H греда;

<l> – дължина греда;

<a> – ъгъл греда;

<x> – отместване ±ΔХ;

<y> – отместване ±ΔУ;

<p> – периметър;

<s> – площ;

<k> – кофраж;

<c> – бетон;

<ti> – взема текст (от тези зададени за гредата) с указания номер i = 1–n.

Допълнителна възможност ‘Edit’ за контрол и въвеждане на текст (изрази) - оцветен синтаксис, експорт към Калкулатор, примери 'Help' към текущото.

Колона...

Задаването на нов тип колона става чрез избиране на вече изчертан правоъгълник, окръжност, елипса, контур/многоъгълник или полигон или чрез изчертаването им в момента на създаване на колоната. Указва се насадена, тип щриховка (или без), B, H или R1, R2 на колоната и се задават необходимите текстовете.

Текста има следните параметри: ъгъл, височина, отместване от линията – указва се чрез параметър, линия на която принадлежи и позиция спрямо тази линия. В рамките на текста е възможно да се използуват динамично следните форматиращи символи (малки букви) характеризиращи гредата:

<b> – B колона (при тип правоъгълник);

<h> – H колона (при тип правоъгълник);

<r1> – R1 колона (при тип елипса);

<r2> – R2 колона (при тип елипса);

<li> – дължината на страна с указания номер i = 1–n (при тип полигон);

<аi> – ъгъл на страна с указания номер i = 1–n;

<xi> – отместване ±ΔХ за указания номер отсечка i = 1–n;

<yi> – отместване ±ΔУ за указания номер отсечка i = 1–n;

<p> – периметър;

<s> – площ;

<k> – кофраж;

<c> – бетон;

<ti> – взема текст (от тези зададени за колоната) с указания номер i = 1–n.

Допълнителна възможност ‘Edit’ за контрол и въвеждане на текст (изрази) - оцветен синтаксис, експорт към Калкулатор, примери 'Help' към текущото.

Армировка...

Създаването на нов тип армировка е свързано с указване на вида на желязото, респективно вида на полилинията. Това може да стане чрез посочване на вече изчертана полилиния или чрез изчертаването на нова. Избира се интензивност и се задават параметри характеризиращи дадената армировка. Възможно е указването на възел за начало на армировката. Броя на възможните възли се определя от броя на възлите на полилинията описваща конкретното желязо/армировка. Възможни са до две различни железа/армировки в една зона.

Текста има следните параметри: ъгъл, височина, отместване от линията – указва се чрез параметър, линия на която принадлежи и позиция спрямо тази линия. В рамките на текста е възможно да се използуват динамично следните форматиращи символи (малки букви) характеризиращи гредата:

<v> – височина зона;

<h> – дължина зона;

<ho> – ho (полезна височина зона);

<h1> – дължина на ляво от зоната;

<ho1> – ho1 (полезна височина на ляво от зоната);

<h2> – дължина на дясно от зоната;

<ho2> – ho2 (полезна височина на дясно от зоната);

<d> – разстояние/разлика ±d при трапецовидна зона;

<li> – дължината на страна с указания номер i = 1–n за полилиния/армировка;

<ls> – обща дължина на полилинията/армировката;

<n> – бройки армировка на m';

<f> – диаметър армировка в mm;

<ti> – взема текст (от тези зададени за полилинията/армировката) с указания номер i = 1–n.

Допълнителни възможности 'Edit', ‘d1’ и 'd2' за контрол и въвеждане на текст (изрази) - оцветен синтаксис, експорт към Калкулатор, примери 'Help' към текущото.

Добавя...

Обединява текущата библиотека с външна такава (формат – lib). Контрол на еднаквите (съвпадащи) елементи.

Конвертор...

Команда – PCONVERT (пълна), PCO (кратка).

Извършва конвертиране на обекти в блокове (при експорт към друг CAD) и обратно – блокове* в обекти.

* За блоковете при конвертирането им, поддържа/отчита промяната им с редактиращите функции Премества и Върти. От блокове в обекти могат да се конвертират само тези блокове, който преди това са били създадени чрез конвертиране в обратна посока (обект към блок). При запис в стандартен CAD формат (dwg, dxf), информацията за обектите в записания файл липсва, тъй като в тези формати се поддържат само блокове.

При конвертиране и в двете посоки е възможно запазване или изтриване на началния/маркирания обект. А при конвертиране на обекти в блокове има възможност за управление на цвета на новия/резултата обект/блок.

Параметри етаж...

Задават се следните параметри:

След Go за маркираните елементи задава:

h етаж – етажна височина необходима за кофраж и бетон при колони и шайби (греди с отворени сечения);

h плоча – дебелина на плочата необходима при полета, греди и сечения – полета, греди;

Кота на плоча – необходимо за начална кота при стълбища и нива;

3DFace – генерира 3DFace при работа с полета, греди, колони, сечения, стълбища и т.н.

Възможност за селектиране на всички от диалога. След потвърждение, приема h плоча за работна стойност при работа с полета и hляво, hдясно за сеченията на греди.

MA и РА...

Команда – MARM (пълна), MA (кратка).

Генерира монтажна и/или разпределителни армировки по зададени интензивности, дължини (и чрез указване), ъгли (и чрез указване).

Интензивност поле...

Команда – IFIELD (пълна), IFI (кратка).

Надписва интензивност в стил поле при зададен ъгъл (и чрез указване).

Интензивност армировка

Команда – CARM (пълна), CA (кратка).

Изчертава армировка (разрез) при зададена интензивност и указано разстояние. Възможност за отместване от входните/базовите точки.

N – интензивност на армировката за m';

D – отместване на 'входната точка'.

Цени...

От селектираните обекти се маркират/чекват обектите на които трябва да се укажат/променят цените. На избраните обекти се задават единични цени за кофраж, бетон и армировка. Указва се вида на валутата при която са валидни зададените стойности. Възможност за селектиране на всички от диалога. Чрез опция "Променя всички текущи" се задават текущи стойности за цени и се променят цените на всички елементи от библиотеката.

Спецификации...

Генерация на таблица с количествата необходим кофраж, бетон (при армировка – m, kg) и цени за маркираните елементи.

Виж Specification (Shutter !, Concrete !, Cost !).

Свойства...

Задава се видимост по групи на свойствата с които ще се работи в диалог 'Properties'.

Маркери...

Задава се комбинация за видимост/достъпност по характерни групи за онези маркери (grips) с които потребителят би искал да работи в конкретния момент. Възможност за селектиране на всички от диалога. За конкретен обект са достъпни само избраните/пуснатите от диалога групи маркери, ако той има такива. При армировка възможност за промяна действието на маркерите за местене и мащаб X, Y, XY (4 на брой) - при включена опция те разтягат зоната.

При работа с маркерите за местене и въртене откачените текстове и нива (ако има такива) се транслират или ротират без да се променя тяхния статус, докато при работа с маркерите за мащаб откачените текстове и нива (ако има такива) се прихващат автоматично към обекта. За разлика от промените направени за аналогичните характеристики чрез диалог Свойства.

Стъпки...

Задават се стъпки за разстоянията и ъгъл (ако обекта предполага). Контрол за това се извършва при въвеждане на обект, редактиране (чрез диалог 'Properties') или местене на контролните точки/глимки на съответния обект. Допълнителни възможности за ускоряване на работата, чрез опции 'Get default', 'Set min' и опция за изключяане на режима.

Дебелини...

Възможност за задаване/настройка на дебелените при изчертаване и работа на отделните eлементи.

Global width – възможна само за полилинии, като дебелината е функция от текущия работен мащаб.

Lineweight – зададена строго фиксирана дебелина в mm.

Допълнителна възможност за промяна на Lineweight на всички външни CAD обекти (текстове – TEXT, MTEXT, WTEXT и коти – DIM...) със стилове съответно TXTPCP, DIMPCP и DIMPCP_. За работа с опция ARM_ при новополучени (Custom -> Block) блокове е задължително преди действието конвертиране да е пусната опция GW – Global width от този диалог със стойности > 0.00 за съответните полилинии.

Regen...

Възможности за автоматична регенерация/изчистване на работната (ненужна) информация при работа (подхода зависи от компютърната система и обем на текущият чертеж) – ускорява работата и намалява обема на текущия чертеж.

Метод A – следва периодично ръчно да се изпълнява команда REGEN от потребителя.

Метод B – изпълнява се команда REGEN след всяко въвеждане на обект.

Метод C – изпълнява се команда REGEN през зададените sec (0 - изключва тази опция) и/или през зададения брой обекти (0 - изключва тази опция).

Подготовка и печат

Избира се преди това записана палитра с цветове за печат. Възможности за добавяне на нови палитри (при необходимост възможности за редактиране от диалога), триене на записани такива (без първите две). Формата на файла при палитрите е стандартния за PCPcad, което позволява тяхното управление през меню Помощни/Настройки - бутон 'Цветна палитра'.

След съответния избор на палитра за продължение към печат е необходимо да се натисне бутон 'Print'.

Цветен

Моно

Екран

Help

Работен диалог:

Работен диалог дублиращ основните функции от менюто за ускорена и удобна работа при чертане.

Ресурси:

Оси

Брой символи (име): 5

Полета

Брой символи (име): 5

Брой страни: 4

Брой възли за една страна: 10

Греди

Брой символи за име в библиотеката: 19

Брой текстове: 6

Брой символи за един текст(формула): 99

Брой възли: 4

Колони

Брой символи за име в библиотеката: 19

Брой текстове: 20

Брой символи за един текст(формула): 99

Брой възли: правоъгълник - 4, елиспа - 16, полигон - 20

Армировка

Брой символи за име в библиотеката: 19

Брой текстове: 20

Брой символи за един текст(формула): 99

Брой железа: 2

Брой възли за едно желязо: 20

Demo

Брой обекти в този режим при запис/печат: 10

Файлове:

Формат за модула (dpf).

Приема от:

x.

Предава на:

AutoCAD - с формат (dwg, dxf).


Windows

PCPcad - Windows

Windows


Help

PCPcad - Help

Help

Home

Application F1

Licence

Registration


Състав на бетона

Общо:

Определя състава на бетона по метода на последователните приближения (плътните обеми).


Контрол на бетона

Общо:

Контрол и оценка якостта на бетон за доказване принадлежността му към определен клас (B).


Бетони - характеристики

Общо:

БДС:

Преглед и редактиране на 50 вида бетони. За всеки вид (клас) се задава име и характеристиките Rb, Rbt, Rbs, Ebts, Eb, m, Pb. Бутон за автоматично получаване на характеристиките от класа.

ЕС:

Преглед и редактиране на 50 вида бетони. За всеки вид (клас) се генерира име от характеристиките Fck или Fckc. След като се зададат ζc, cm, αcc – се изчисляват Fcm, Fcd, Fcdc, Fctm, Fctk5 Fctk95, Ecm, Ec1, ζc1, ζcu1, ζc2, ζcu2, ζc3, ζcu3. Задават се и m, Pb. Бутон за графична визуализация на характеристиките.

Опция за общ преглед. PC Проектант автоматично взема необходимата за изчислението характеристика по името на избрания (текущ) вид бетон. При работа/четене на обекти с непознат(липсващ) бетон се търси този с най-голям процент съвпадения в името, като преди това римските цифри от I до IX се конвертират в арабски. При търсене на бетон с липсващи/изтрити/променени характеристики се взема този, чиято характеристика е най-близка до търсената.


Стомани - характеристики

Общо:

БДС:

Преглед и редактиране на 50 вида стомани. За всеки вид (клас) се задава име и характеристиките Rs, Rsw, Rsn, Es, m, Ps. Бутон за автоматично получаване на характеристиките от Rsn.

ЕС:

Преглед и редактиране на 50 вида стомани. За всеки вид (клас) се задава име и характеристиките Ftk, Fyk, ζs, k, ζuk, ζud, m, Ps. Изчислява се Fyd. Задава се Es=200 GPa. Бутон за графична визуализация на характеристиките за текущата стомана.

Възможност за задаване на гладка стомана, която се чертае с куки по правилник. Опция за общ преглед. PC Проектант автоматично взема необходимата за изчислението характеристика по името на избрания (текущ) вид стомана. При работа/четене на обекти с непозната(липсваща) стомана се търси тази с най-голям процент съвпадения в името, като преди това римските цифри от I до IX се конвертират в арабски. При търсене на стомана с липсващи/изтрити/променени характеристики се взема тази, чиято характеристика е най-близка до търсената.

Възможност за редактиране на 18 вида диаметри в mm при работа със стомана. При потвърждение те се сортират, допълват (при еднакви единия се трие, като се добавя нов с размер +2 mm от последния) и записват автоматично.


Профили

Общо:

Преглед на въведени над 15000 стандарти/категории профили по видове/групи. Възможност за сортиране по произволна характеристика, преглед на всички по видиве/групи в категория All. В категория User след кликване на десен бутон на мишката, възможност за дабавяне – Add, редактиране – Edit, триене – Delete и вмъкване от текстов файл – File import профили форматирани по редове с разделители в реда – "," и/или tab. След кликване на ляв бутон на мишката върху схемата тя се мащабира.

След вход при въвеждане на рамка или кофражен план при двойно кликване на мишката върху избран профил, автоматично пренася A, Iy и Asy, Asz, Iz, It в съответните мерни единици към основния модул.

Меню:

Изход

Help

Home

Application F1


Характеристики

Общо:

Преглед на въведени характеристики (име, обемна плътност, коефициент на топлопроводност, специфична топлоемкост, коефициент на топлоусвояване, коефициент на паропроницаемост, число на дифузно съпротивление на водната пара) на материали. Възможност за сортиране по произволна характеристика. При кликване на десен бутон на мишката, възможност за дабавяне – Add, редактиране – Edit, триене – Delete и вмъкване от текстов файл – File import профили форматирани по редове с разделители в реда – ";" и/или tab. Edit и Delete са достъпни след User. Един обект (при добавяне, редакт или ред от файл при import) се тълкува като група, ако има име (само при файл) и коефициента му на топлопроводност е равен на нула.

Меню:

Изход

Help

Home

Application F1


Температури

Общо:

Модул за изчисление на температурни полета по МКР. Възможност за изчисление на по-вече от едно за един път. Табличен и графичен преглед на данни и резултати. Изчисляване на Q и k обобщено, температури на оросяване.

Меню:

Файл

Ново

Чете Ctrl-R

Изход

Решение

Решение (F9, Go) на изчетения обект.

Преглед

Таблици

Възли

Преглед на координати на възли. При Shift + ляв бутон на мишката се прихваща текущия възел, като за него се появява пълна информация за входни данни и резултати.

Типове

Преглед на отделните типове материал - име, ламбда (коефициент на топлопроводност) W/m°C за обекта.

Елементи

Преглед на зададените елементи (възли и типове).

Гранични условия

Преглед на изчислените температури - t' при всеки възел с гранично условие (температура °C, коефициент на топлопредаване W/m2°C, влажност %), температура на оросяване - ts.

Температури

Преглед на изчислените температури при всеки възел.

Гранични температури

Преглед на температури (средна, max, min), начален и краен възел и дължина за всяко гранично условие (линия).

Графичен

Преглед на графика - ревю, на зададените входни данни и получените резултати (температурни повърхнини, изолинии, зони на конденз и др.). При преглед на изолинии с брой 1 разделя стойностите на t на червени - положителни и сини - отрицателни. При преглед на изолинии създава групи ts - гранични температури на конденз и t' - действителни температури по повърхността.

Help

Home

Application F1

Работно поле:

Информация за изчетения и евентуално изчислен обект. Текущия обект (Път/Име и Обект) се отпечатва от дясно на горната хоризонтална лента под менюто.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за четене (t01), формат за запис (t__).

Приема от:

Генерация на мрежа - с формат (t01).

Предава на:

Преглед на графика - ревю - с формат (t__).


Преглед графика - ревю

Общо:

Модул за графичен преглед на данни и резултати за всички формати на файлове за системата PC Проектант. При инсталиране те се асоцират автоматично към системата (при кликване от Explorer върху файл, следва старт на ревю или при натиснат Shift старт на текущия модул DOS/Windows от Преглед текст - опцията Convert се игнорира). При Shift от системата стартира Принтер за работа с кадри.

Меню:

Файл

Ново

Нулира информацията.

Преглед текст

Преглед на основният файл от който е генериран обекта.

Чете Ctrl-R

След предварителна настройка на параметри чете обект с формат описан в раздел Приема от:. С F9 възможност за пряко изчитане евентуално с нови параметри на текущия обект.

Кадър

Екран

Генерира векторен кадър с настройките от екрана.

Zoom x 2

Увеличава вътрешния мащаб (x 2 - избран от долните) за по - добър печат. Достъпно при работа в равнина без перспектива, в противен случай се приема (x 1).

x 1

x 1.5

o x 2

x 2.5

x 3

x 3.5

x 4

x 5

x 6

x 8

x 10

x 20 !

x 50 !

Изход буфер трие

Изход

Системата при изход записва автоматично текущата позиция на модула.

Групи

Групите (слоевете) се генерират автоматично от съответния филтър. Съществува възможност за маркиране и демаркиране на всички достъпни елементи от съответната група, както и на отделни елементи от нея, като автоматично се опреснява екрана. Горещи клавиши 1,2,3,...0 за групи/слоеве от 1-10, а за тези от 11-20 – Alt-1,2,3,...0. Маркиране, като радио бутон на групите/слоевете при използувани/пуснати техни елементи. Възможност за автоматично алтернативно маркиране/демаркиране на цяла група, при натискане на ляв бутон на мишката върху менюто на групата при задържан Ctrl. При диалог "Групи" ред/опция "Мести - Keys " за движение чрез горещи клавиши от диалог "Мести". При 3D рамки възможност за работа по елементи.

• Aaa Ctrl-G Shift-1

• Bbb Shift-2

Ccc Shift-3

…..

Коментари Ctrl-T

Преглед и пълно редактиране (позиция на чертежа - xyz, равнина на надписване, цвят, текст, позиция спрямо входната точка -xyz, ъгъл, размер, дебелина и видимост) на въведени стрингове (коментари). Въвеждане (Ins) и триене (Del) на въведени коментари в таблицата за редактиране. С Ctrl-T захваща позицията на маркера и я предлага в таблицата (първият коментар задължително се въвежда по този начин). С Del-Коментари изтрива всички въведени до момента. Възможност за разполагане на един коментар на няколко реда, чрез въвеждане на служебните символи - \R (\r) в текста. Работа със стрингови константи на системата и/или зададени потребителски (Калкулатаор – Custom – User strings).

Текст Alt-T

Алтернативно разрешава/забранява текст за целия чертеж.

Разрези

Генерират се по зададено направление, разрези - диаграми от текущата (изчетена) характеристика. Това действие е възможно само при определени филтри:

– изолинии за следните обекти: плочи по МКЕ, гредостени и температурни полета;

– M, Q, N - диаграми;

– M, Q, N - комбинации;

– покритие на надлъжна и напречна армировка.

Нов Ctrl

Задаване на нов разрез определен по две точки (отсечка). Това действие е възможно само, ако обекта е от горе изброените при Разрези. Примерно за филтри изолинии, се работи строго в равнината x0y без перспектива. Ако обекта е от този филтър и не е в равнината x0y или е с перспектива (маркирано меню), автоматично се изключва перспективата и се склопява в равнина x0y. Аналогично са действията и за обекти (M, Q, N - диаграми) в останалите две равнини. След въвеждане на втора точка следва автоматично движение на разреза след мишката при запазени направление и дължина до натискане левия бутон на мишката за потвърждение, или Esc за отказ. При натиснат Ctrl преди въвеждане на втора точка следва генерация на разреза без движение. При въвеждане на втора точка и натиснат клавиш A (Align), ъгъла между двата възела става автоматично кратен на 5°.

Всички

Функции отнасящи се до всички разрези.

Маркира

Видими всички разрези.

Демаркира

Невидими всички разрези.

+ нагоре

Check – положителни стойности на текущата (изчетена) характеристика нагоре, UnCheck – положителни стойности на текущата (изчетена) характеристика надолу.

x0y

Check – разрез в равнината x0y, UnCheck – разрез в равнините x0z или y0z в зависимост от наклона.

Текст

Check – текст към всички разрези, UnCheck – спира текст към разрези.

Пълни

Check – запълва всички разрези, UnCheck – не запълва разрезите, чертае само контура.

Коти

Check – чертае линиите на стойностите перпендикулярни на базовата, UnCheck – не чертае тези линии. При M, Q, N - диаграми и надлъжна и напречна армировка, това е параметър за надписване на разстоянието от началото в cm.

Трие

Трие всички генерирани разрези. име група

v N - име група

N-1 - име група

…..

3 - име група

v 2 - име група

v 1 - име група

Генерирани разрези. Check - видим, UnCheck - невидим.

Настройка

Елементи

Равнини и коефициенти за надписване на съответните елементи върху конструкцията (Ctrl/Alt-S - увеличава/намалява коефициентите за надписване с процент равен на стъпката за увеличение, но не по-малко от 10%). Възможности за автоматична смяна на равнината на надписване (auto), изобразяване на екран на координатната система (xyz).

Памет

При четене запазва въведените коментари. Връща записаното състояние за тип обект, ако има преди това запомнено такова чрез Помни текущо !.

Помни текущо !

За изчетения тип обект запазва текущото състояние: равнини и коефициенти за надписване на съответните елементи, перспектива, видимост по групи, положение на обекта, текст, фон и цветове. Положението на обекта се игнорира и той се изчертава на началната си позиция при натиснат бутон начална позиция и Помни текущо !.

Мести Alt-M

Алтернативно скрива/показва диалога за управление от работното поле.

Параметри

Проценти на мащабиране, движение, ъгъл на въртене, перспектива. Параметри необходими на диалога за управление от работното поле. Извиква се и от диалога за управление, като два пъти се натисне левия бутон на мишката върху горната лента.

Чертае

Цветно F4

Използува базовите 16 цвята.

Бяло F5

Черно F6

Избор

Предлага базовите и основните цветове в 16 степени в зависимост от зададения интервал в проценти, които чрез Конкретни цветове могат да се прегледат и редактират допълнително. Допълнителна възможност H за конвертиране (RGB към HSL) на всеки текущ цвят в 16 степени в зависимост от зададения интервал в проценти, или при натиснат Shift и избор на втори цвят, се генерира палитра между цвета при H и последно избрания цвят с Shift. Възможности за избор на цветовете на системата D и текущите цветове C, а чрез R възможност за задаване на цветове по аналогия на тези от цветната дъга (Start - начален цвят и End - краен цвят с изменение/генерация на междинните цветове по направление на часовниковата стрелка). Редактиране чрез инверсиране I и отместване < на текущите цветове групово.

Фон

Бял F7

Черен F8

Избор

Help

Home

Application F1

Работно поле:

При натискане ляв бутон на мишката в средните две четвъртини на прозореца увеличава чертежа. При натискане десен бутон на мишката в средните две четвъртини на прозореца намалява чертежа. При натискане ляв бутон на мишката в крайните две четвъртини на прозореца премества чертежа пропорционално на кликването спрямо центъра на екрана. При натискане десен бутон на мишката в крайните две четвъртини на прозореца връща в изходно положение.

При натискане на десният бутон на мишката върху горната лента на диалози (tools), извиква диалог за конфигуриране на позицията им (индивидуално или по групи).

Диалог за управление

Ако сте в общо положение при Zoom, трябва да сте прихванали поне два възела с различни кооординати. При натискане двойно ляв бутон на мишката върху горната лента извиква Параметри. При задържане на Shift и кликване върху управляващи бутони, следва непрекъснато изпълнение на командите (анимация) до отпускане на Shift. При кликване върху управляващ бутон преди да е изчертан чертежа върху екрана, прекъсва изпълнението и чертае отново с новите параметри. Управление с клавиши от управляващ блок. Scroll Lock – on/off, променя алтернативно посоките на движение. Мащабиране при скролиране със среден бутон на мишката. При местене на мишката и натиснат среден бутон, следва движение на изчертаното. При двойно натискане на средния бутон на мишката – централна позиция.

Ресурси:

Няма софтуерен лимит.

Файлове:

x.

Приема от:

Вход на обекти - с формати (k02, r02, n02, i02, s02, t02, x02, Геометрични характеристики).

Генерация на мрежа - с формати (r01, n01, i01, s01, t01).

Кофражен план (изчисление) - с формат (p__, g__).

Плочи (изчисление) - с формат (r__).

Изключване на опън - с формат (i__).

Оразмеряване на сечения - с формат (n__).

Сеизмично изследване - с формати (z01 - общо за конструкцията, z02 - рамки, z__ - резултати).

Гредостени (изчисление) - с формат (s__).

Рамки (изчисление) - с формат (x__, комбинацииi).

3DD Рамки (изчисление) - с формат (d__).

Поле.

Греда.

Фундамент.

Температури - с формат (t__).

Предава на:

Принтер - кадър.

Преглед текст - текстов файл.


Преглед текст

Общо:

Диалог за автоматично преглеждане или редактиране на текстов файл. При инсталацията пътищата се настройват автоматично към Default (вътрешните модули) Преглед текст под 'DOS и Преглед текст под Windows под DOS или Windows съответно. Под DOS при дълги имена на файловете те се конвертират автоматично до къси - DOS имена. При преглед на текстов файл под Windows е възможно конвертиране на файла, създава се временен файл, като към името на избрания файл се добавя .Convert. Препоръчва се окончателната обработка на файловете да става чрез Сорт. Системата работи със следните шрифтове:

– PC Proektant (от вида bmp);

– PC Proektant Solid (от вида bmp с постоянна ширина за запазване наредбата по колони при преглед - подобен на Fixedsys);

– PC Proektant Solid DOS (от вида bmp с постоянна ширина и наредба на знаците за DOS);

– PC Proektant Uni (от вида True Type - Unicode с постоянна ширина);

– PC Proektant Uni 80% (като горния, но кондензиран 80%);

– PC Proektant Print DOS (от вида True Type с постоянна ширина за печат и наредба на знаците за DOS - вътрешен).

Шрифтовете се деинсталират автоматично след приключване на работа със системата. При желание те могат да се инсталират от директория \pcp.dat\*.fon, \pcp.dat\*.ttf.

Приема от:

File.

Предава на:

File.


Преглед текст под Windows

Общо:

Модул за преглед, редактиране, записване и печат на данни (текстови файлове) под Windows.

Меню:

Файл

Ново

Текущо чете

Текущ запис Ctrl-K

Чете

Text Ctrl-O

Възможност за избор на файл или файлове (стандартна работа с Control и/или Shift) за обработка. Тези файлове се анализират автоматично като текстови. Генерират се указатели/маркери.

RTF Alt-O

Чете пълно функционален (с цветове, ефекти вмъкнати обекти) rtf файл. Чете указатели/маркери - при преди това записан от същия модул файл с налични такива.

Внъква

Text Ctrl-Q

Вмъква от текущата позиция или замества маркираното с изчетения файл (произволен файл, който се изчита като текстов). Анализира/конвертира изчетения файл и след това го вмъква по посочения начин, добавя указателите/маркерите към наличните. Вмъква + Shift не анализира/конвертира изчетения файл - вмъква го по посочения начин.

RTF Alt-Q

Вмъква от текущата позиция или замества маркираното с изчетения rtf файл. Вмъква указатели/маркери - при преди това записан от същия модул файл с налични такива.

Запис

DOS Ctrl-W

Тези файлове се анализират/записват като DOS текст.

ANSI

Тези файлове се анализират/записват като ANSI текст.

Unicode

Тези файлове се анализират/записват като Unicode текст.

RTF Alt-W

Записва пълно функционален (с цветове, ефекти вмъкнати обекти) rtf файл. Записва/маркира редовете с генерирани или зададени указатели/маркери.

HTML

Конвертира и записва текущото в html формат.

Печат преглед

RTF Alt-P

Стартира мощна компонента за преглед и печат.

Set - Избор на принтер, лист, ориентация. Възможност за 'бърза' настройка на евентуално избрания при инсталацията 'PDF Printer', ако той не е намерен (инсталиран) търси друг принтер съдържащ в името си 'PDF'. По подразбиране се приема 'PDF Internal *' вътрешна генерация (без инсталиран PDF принтер) на PDF файлове.

Page - Формират се броя и размерите на блоковете върху една страница по редове и колони, задават се отстояния/margins.

Headers - Header/Footer - надписване по избор на име на файл, дата, време, текуща страница, всичко страници, свободен текст, сива лента.

S - Маркиране/селектиране на текущата страница необходимо при печат. Ctrl-LButton върху изчертания лист прави същото. Shift-Ctrl-LButton върху изчертания лист прави същото от текущия до предпоследния маркиран лист.

D - Режим на изчертаване на страниците - една в центъра или автоматично в зависимост от размера на прозореца и избрания мащаб.

Print - За избраният принтер се задават страници за печат, брой копия, collate, към файл.

Възможности за избор на мащаб или задаване на такъв по избор. При LButton върху страница сменя мащаба между текущия и 100%.

HTML

Стартира печат преглед (след конвертиране до html формат) с последваща възможност за настройка и печат.

PEM Ctrl-P

Стартира Принтер, като автоматично задава файла/файловете. След редактиране/промяна на файл към принтера се подава само текущия, ако изчетените файлове са по-вече. На редактираният (не записан) файл се добавя служебна надставка с номер (.txt0007) и той се записва в temp. След приключване на работа с тези файлове те се изтриват от системата автоматично. Тези файлове се анализират като текстови.

Изход текущо трие

Изход

Системата при изход записва автоматично позиция на диалога, текущи цветове, тип и размер на шрифта (bmp/True Type).

Tools

Read only

Преглед без възможност за редактиране на файла при Check и с възможност за редактиране при UnCheck .

Find & Replace

Find Ctrl-F

Търси текст от маркера надолу до края на файла (при маркирана зона търси в нея). Match Whole Words - търси по думи, Match case - прави разлика между малки и главни букви.

Find Next F3

Търси следващо от маркера надолу.

Find & Replace

Търси и заменя намереното или всички.

Goto Line Ctrl-G

Възможност за скролиране до линия (зададена или запомнена). При натискане ляв бутон на мишката върху List Box приема реда, а при двойно натискане - отива на реда.

Възможност за добавяне на ред Add line към List Box за следваща работа.

Delete Filter Ctrl-D

Възможност за работа с указателите/маркерите получени: при изчитане, при вмъкване без натиснат Shift или зададени от потребителя в диалог Goto Line. При кликване върху реда маркира съответните редове, които биха били изтрити. При кликване върху CheckBox или двойно кликване върху реда - следва маркиране/демаркиране на реда. След Go изтрива маркираните блокове и актуализира диалога.

Insert Bitmap from file

Вмъкване на bmp изображение от файл. Такова може да се вмъкне и през Clipboard, чрез стандартните Ctrl-C, Ctrl-V функции на Windows. Вмъкнатото изображение може да се редактира допълнително, чрез двойно кликване на мишката върху него.

Insert Object

Вмъкване на Windows objects от файл или от инсталирано приложение. Такова може да се вмъкне и през Clipboard, чрез стандартните Ctrl-C, Ctrl-V функции на Windows. Вмъкнатото изображение може да се редактира допълнително, чрез двойно кликване на мишката върху него.

Upper Case

Конвертиране на маркираното, ако няма такова се конвертира всичко с главни букви.

Lower Case

Конвертиране на маркираното, ако няма такова се конвертира всичко с малки букви.

Auto fonts Base

Системата е разпознала текста (DOS/Windows/Unicode) при изчитане на файловете и ги конвертира до Unicode преди да го постави в редактора. Тези възможности са базови при работа с модула.

PC Proektant Uni int

Вътрешен Unicode шрифт с фиксирана ширина - препоръчва се.

PC Proektant Uni 80% int

Вътрешен Unicode шрифт с фиксирана ширина - като горния, но кондензиран на 80%.

Courier New ext

Системен външен Unicode шрифт с фиксирана ширина.

Lucida Console ext

Системен външен Unicode шрифт с фиксирана ширина.

User

Задават се от потребителят шрифтове по избор (препоръчват се шрифтовете на системата с фиксирана ширина).

Fixed fonts only

Предлаганите шрифтове в меню User са с фиксирана ширина на символите.

Bold

Потребителят задава ефект bold за обща работа с файлове.

Italic

Потребителят задава ефект italic за обща работа с файлове.

Auto colors Base

Задават се базови цветове при работа и автоматично оцветяване на файлове/резултати на системата.

Цветен печат

Комбинация от цветове на бяла основа.

Моно печат

Черен на бяла основа (работата се ускорява, тъй като не се контролира цвета по редове).

Екран

Комбинация от цветове на черна основа - DOS стил.

User

Цветовете се задават се от потребителят по избор (след кликване върху съответния обект на схемата, десен клавиш промяна на основата).

Auto paste Scene

При генерация на кадър от някой модул - автоматично поставя или замества при маркирано (Paste) кадъра (формат-emf) на позицията на маркера. Ако хоризонталният му размер е по-голям от 500 pixels, той се редуцира пропорционално до този размер.

View

Прихваща и стартира файла за преглед като асоциран към системата, най-често това става чрез Ревю. Това е възможно при не радактиран файл, при редактиран файл, би следвало той първо да се запише.

Help

Home

Application F1

Работно поле:

На указващ ред долу се маркират:

– позиция - ред, колона;

– глобални - позиция, размер на текста;

– разпознат файл - DOS (dos), Windows (win);

– редактиран/променен файл (*).

При разпознат файл чрез бутони (долу, дясно) или клавиши Alt-F2 предходно и F2 следващо, възможност за движение по обекти/таблици. Контрол при промяна на файла от друга програма. Възможности за промяна на шрифт (вид и размер), стил на текст, цвят. Промяна позиция на текст (ляво, център, дясно), задаване различно разстояние между редовете (чрез Control възможност за задаване на произволни стойности от потребителя на клaвиши – Ctrl-6,7,8,9,0). Форматиране – Bullets & Numbering (чрез Control възможност за задаване на произволни стойности за стартов номер, отместване и стил: 1) – по подразбиране, (1), 1., 1) При форматиране се подържат следните клавиши: Alt-0,1,2,3,4,5,6 – съответно: без, Bullets (*, *, *, ...), Arabic numbers (1, 2, 3, ...), Lowercase letters (a, b, c, ...), Uppercase letters (A, B, C, ...), Lowercase Roman numerals (i, ii, iii, ...), Uppercase Roman numerals (I, II, III, ...). Вмъкване на windows objects и други.

Управление:

Стандартно Windows управление. Ctrl/Alt-S - увеличава/намалява размера на текста (маркираното, ако няма такова всичко) с 2 pixels в интервала [2-1000] pixels - текста е с един размер за работната зона. Shift-Ctrl/Alt-S - увеличава/намалява размера на текста пропорционално (маркираното, ако няма такова всичко) с 10% от текущият размер. Ctrl/Alt-T - блоково преместване (Tab) на маркирани редове или на текущият ред съответно на дясно и ляво. Движение по редове/страници - Ctrl при скролиране със среден бутон на мишката. Обръщане алтернативно на скролирането по редове/страници, чрез Scroll Lock – on/off.

Редактиране:

След десен бутон извиква menu:

Undo Ctrl-Z

До 100 стъпки (default):

Redo Ctrl-Y

До 100 стъпки (default):

Cut Ctrl-X

Copy Ctrl-C

Paste Ctrl-V

Delete Del

Select all Ctrl-A

Upper Case

Lower Case

Font Size all

Up +2 equally Ctrl-S

Down -2 equally Alt-S

Up 10% proportional Shift-Ctrl-S

Down 10% proportional Shift-Alt-S

Виж Управление.

Go to

Up Alt-F2

Down F2

Виж Работно поле.

Ресурси:

Няма софтуерен лимит.

Файлове:

x.

Приема от:

Текстови файлове - Windows cyrillic.

Текстови файлове - DOS cyrillic.

Текстови файлове - Unicode.

Редактори - с формат (txt, rtf).

Clipboard - с формат (bmp, objects).

Предава на:

Редактори - с формат (txt, rtf, html).

Принтер - текстови файл/файлове.

Принтер преглед - с формат (rtf).

Принтер преглед - с формат (html).


Преглед текст под DOS

Общо:

Модул за преглед, редактиране, записване и разпечатване на данни (текстови файлове) под DOS.

Управление:

Home начало файл;

End край файл;

^ ред на горе;

< колона на ляво;

> колона на дясно;

v ред на долу;

PgUp страница на горе;

PgDn страница на долу.

Редактиране:

R вход;

F7 начало блок;

F8 край блок;

Ctrl-V мести блок;

Ctrl-C копира блок;

Ctrl-D трие блок;

Ent изход.

Цветове:

F3, F4 за управление;

F5, F6 за файл.

Печат:

P от екран;

Ctrl-P маркиран блок.

Други:

F2 запис във файл;

F търси текст;

Ctrl-F следващо;

Esc изход.

Ресурси:

Няма софтуерен лимит.

При наличие на свободна EMS памет, приоритетно файла се разполага там, ако такава липсва се прави опит той да се разположи в конвенционалната памет.


Принтер

Общо:

Модул за графичен преглед и разпечатване на кадри и резултати (текстови файлове) от всички модули на системата PC Проектант. Възможности за коментари, вмъкване на външни файлове (wmf) и редактиране.

Меню:

Файл

Ново

Текущо чете

Текущ запис Ctrl-Z

Чете Ctrl-R

Чете файл с формат (pec). Контрол за коректността на текущият принтер.

Запис Ctrl-W

Запис на файл с формат (pec).

Чете текст

Add - Въвежда се текст (left, center, right) или се четат файл/файлове (ляв бутон на мишката върху тъмна лента - добавя файл или файлове, десен бутон на мишката - трие текущият файл). Възможност за пренареждане на изчетените в група файлове - drag and drop. След обработка на файла възможност за преглед и отказ от генерираните страници. Автоматична генерация на header и footer за страница

Wrap - Размер на табулация с указания брой шпации, wrap - до дума или символ, знак за пренасяне на ред. Възможност за започване на всеки файл на нова страница - прекъсване.

Page - Формират се броя и размерите на блоковете върху една страница по редове и колони, задават се отстояния/margins.

Headers - Header/Footer - надписване по избор на име на файл, дата, време, текуща страница, всичко страници, свободен текст, сива лента. Възможност за конвертиране.

Font - Избор на шрифт (с фиксирана ширина или не), препоръчват се шрифтовете на системата (виж Преглед текст).

Чете (wmf)

Чете файл с формат (wmf). Възможно е файла да е външен (записан от друга програма) при спазване на изискванията (виж Metafiles).

Като резултат от горните се извършва контрол на текущото състояние (брой блокове в една страница, размери на един блок - mm, символи на един ред и брой редове в един блок).

Изход текущо трие

Изход

Help

Home

Application F1

Работно поле:

Страници:

Око - определя дали съответната сраницата ще се печата. Shift - всички като текущото.

Вход/Редакт - въвежда нова страница при Current или при текуща запомня направените промени.

Copy - копира на посочената позиция текущата страница.

Del - възможност за триене на текущата страница или с Shift - всички.

Кадри:

Око - определя дали съответният кадър за съответната страница е видим. Shift - всички като текущото.

Copy - слага със зададените размери в пиксели, текущия кадър в Clipboard с формати Bitmap - bmp или Enhanced metafile - emf. Особено полезно при работа с Преглед текст под Windows за оформяне на документация.

Запис - записва текущият кадър във файл с формат (wmf).

Del - възможност за триене на текущият кадър (изтрива се участието му във всички страници в които участвува) или с Shift - всички.

При натискане на левия бутон на мишката върху кадър, той става активен (в горния десен ъгъл на диалога се изписват името му, текущия процент на мащабиране, позиция и размери в mm). Той може да се мести и мащабира, чрез бутони, клавиши (Alt +: Up, Down, Left, Right, +, -) или ръчно, чрез движение на мишката (при движение върху кадъра системата чрез курсора указва възможното действие). При същата ситуация и натиснат Shift, активният кадър отива отгоре (чертае се последен) върху останалите кадри, това се отразява при наредбата на кадрите в Combo box. При натиснат Control за активния кадър в зависимост от маркера могат да се променят позицията/размера на прозореца (горната дясна колона) в пиксели.

При натискане на левия бутон на мишката върху работното поле и не захванат кадър, изчертава алтернативно помощна мрежа върху листа. Чрез бутони възможност за подравняване на кадри по мрежа или при изключена мрежа, по работна (полезна) площ на листа.

Екрана за работа може да се мести и мащабира, чрез клавиши (Ctrl +: Up, Down, Left, Right, +, -), клавиш Clear - (5), позиционира централно. Процента на движение е равен на този зададен за движение на кадрите при фокус/маркер върху него, в противен случай е равен на 20%. Scroll Lock – on/off, променя алтернативно посоките на движение. Мащабиране при скролиране със среден бутон на мишката. При местене на мишката и натиснат среден бутон, следва движение на листа. При двойно натискане на средния бутон на мишката – централна позиция.

Четка - възможност да се почиства или не, онази част от всеки кадър, която е извън екрана (правоъгълника взет от размера на прозореца при генериране на кадъра). Налични са два подхода на работа, чрез metafiles (wmf) - бърза работа, чисти около всички обекти едновременно (могат да възникнат проблеми при съседни кадри) или чрез генерация на пикселни кадри bitmaps (bmp) - точна поддръжка на кадрите по-бавно и евентуално по-ниско качество при печат. При bitmaps възможност за контрол на dpi (dots per inch).

Преглед на това как би изглеждал листа след печат, движение по страници, ако има такива и възможност за мащабиране (виж горе Ctrl ...) на екрана при преглед (излиза се от режима алтернативно или след натискане на десния бутон на мишката върху работното поле) .

Промяна на условията на разпечатване (принтер, лист, ориентация, брой копия, collate, към файл).

Препоръка: Добре е да се работи с по едри кадри, които в последствие да се намалят евентуално върху листа за да не губи точност Windows при генериране на Metafiles.

Ресурси:

Няма софтуерен лимит.

Файлове:

Формат за модула (pec).

Приема от:

Вход на обекти - кадър.

Генерация на мрежа - кадър.

Кофражен план (изчертаване) - кадър.

Греди (изчертаване) - кадър.

Плочи (изчертаване) - кадър.

Грдостени (изчертаване) - кадър.

Детайли - кадър.

Ревю - кадър.

Metafiles (text as curves, without header) - с формат (wmf).

Текстови файлове - Windows cyrillic.

Текстови файлове - DOS cyrillic.

Предава на:

Printer.

Metafiles - с формат (wmf).

Clipboard - с формат (bmp).


Калкулатор

Общо:

Модул за изчисляване на изрази и програмиране (програмируем калкулатор). Възможност за конверсиране на мерни единици по категории.

Меню:

Файл

Ново

Чете Ctrl-R

Запис Ctrl-W

Изход

Ако се идва от Детайли, чрез Изход пренася редактирания текст (последния ред), а чрез Alt-F4 не.

Tools

Find & Replace

Find Ctrl-F

Търси текст от маркера надолу до края на файла (при маркирана зона търси в нея). Match Whole Words - търси по думи, Match case - прави разлика между малки и главни букви.

Find Next F3

Търси следващо от маркера надолу.

Find & Replace

Търси и заменя намереното или всички.

Goto Line Ctrl-G

Възможност за скролиране до линия (зададена или запомнена). При натискане ляв бутон на мишката върху List Box приема реда, а при двойно натискане - отива на реда.

Възможност за добавяне на ред Add line към List Box за следваща работа.

Clipboard Ctrl-L

Custom

Expressions

Потребителят има възможност да зададе до 100 (%c0–%c99) свои константи или изрази %c7 – FAC( 2 * ( 3 + 7 ) ) - 10. Всяка текуща константа/израз може да съдържа по предните по номер константи/изрази %c7 – 7 * 9 + %c0.

Functions

Потребителят има възможност да зададе до 100 (F00–F99) свои функции F00() – FAC( 2 * ( 3 + 7 ) ) - 10, F01(&h=5; &h=7) – 2 * ( &h + &v ). Всяка текуща функция може да съдържа по предните по номер функции F02(&n) – &n * F01(&h=1; &v=2).

System strings

Възможност за работа с константи на системата: $t – име на системата (PC Proektant), $v – версия (13.03c), $l – лиценз (текст), $n – регистрационен номер (000000000), $u – потребител (текст), $y – година (2003), $m – месец (05), $d – ден (28), $s – мащаб (1:50), $f – формат (A3 или празно, ако е нестандартен), $p – размери (594x420).

User strings

Потребителят има възможност да зададе до 100 ($c0–$c99) свои константи с имена, обекти или всичко онова което се повтаря като текст при работа. Всяка текуща константа може да съдържа по предните по номер потребителски и/или стандартни константи $c7 – "Version $v".

Решение

Изчислява (F9) израза или изпълнява програмата.

Help

Home

Application F1

Работно поле:

Възможност за изчисляване в два режима. Първият е работа с израз – в този режим се изчислява, разглежда само първия ред, следващите служат за коментар. Този режим е активен, ако в редовете преди знака за коментар ' не се среща знака [, в противен сличай автоматично се активира втория програмируем режим. to File - записва резултата във файл, ако той вече е зададен добавя към него по подразбиране, променя се чрез задържане на Control). Debug - контрол реда на изчисление и междинни резултати за всеки израз. Buttons - помощен прозорец с действията, функциите, някои полезни символи и конверсиране. Color - повдига и оцветява служебните думи и коментари алтернативно. Convert - възможност за добавяне, редактиране и изтриване на категории и мерните единици групирани в тях (за мерните единици въвеждане (Ins) и триене (Del), виж таблицата). Конвертиране на зададена стойност по избрана категория и мерна единица - сортиране по име и стойност. При кликване върху име, то става избрано, същото при задържане на Control, пренася стойността на това име в левия панел. При описване на връзките за конверсия са достъпни всички действия и функции вкл. външни FUN( ). След задаване на мерна единица/Unit с име = "x" в една категория, възможност за задаване на стойности само на тази мерна единица виж категория "Constants". При двойно кликване в десен панел, ако на съответния ред има символ =, връща израза от дясно на символа на мястото на маркера в левия панел. Възможност за преместване средната вертикална линия между левия и десния панел.

При зададени маркери чрез бутони (долу, дясно) или клавиши Alt-F2 предходно и F2 следващо, възможност за движение по тях.

Управление:

Стандартно Windows управление. Ctrl/Alt-S - увеличава/намалява размера на текста с 2 pixels в интервала [2-1000] pixels. Ctrl/Alt-T - блоково преместване (Tab) на маркирани редове или на текущият ред съответно на дясно и ляво.

Редактиране:

След десен бутон върху ляв панел извиква menu:

Undo Ctrl-Z

Cut Ctrl-X

Copy Ctrl-C

Paste Ctrl-V

Delete Del

Select all Ctrl-A

Font Size

Up Ctrl-S

Down Alt-S

Go to

Up Alt-F2

Down F2

FUN(Имв) / Имв - Отваря функцията или главният файл, като преди това записва текущото. Този ред се появява, ако сте позиционирали с ляв бутон върху името на функцията или вече сте в нея.

Виж Работно поле.

След десен бутон върху десен панел извиква menu:

Select between last marks

Маркира всичко между последните две маркирани линии/блока, ако има такива.

UnSelect all

Clipboard Ctrl-L

( ) скоби (неограничен брой) налагат приоритет на действията.

e експонента (1е3 = 1000)

Действия:

^ степенуване (приоритет 1)

* умножение (приоритет 2)

/ деление (приоритет 2)

< по- малко (приоритет 2)

> по-голямо (приоритет 2)

@ закръгля (приоритет 2)

\ целочислено деление (приоритет 3)

M mod (приоритет 3)

+ събиране (приоритет 4)

- изваждане (приоритет 4)

And bitwise AND (приоритет 5)

Or bitwise OR (приоритет 5)

xoR bitwise XOR (приоритет 5)

eQv bitwise EQV (приоритет 5)

Imp bitwise IMP (приоритет 5)

Първо се извършват действията с по - преден номер (приоритет).

Функции:

FIX( ) реже цяло число

FRC( ) реже дробна част

CNT( ) закръгля до цяло число

CIL( ) нагоре до цяло число

INT( ) надолу до цяло число

ABS( ) абсолютна стойност

SGN( ) връща знака (-1, 0, +1)

INV( ) реципрочна стойност

SQR( ) квадратен корен

FAC( ) факториел

RND( ) случайно число от 0 до зададено

ICR( ) зададено + 1

DCR( ) зададено - 1

SIN( ) синус

ASI( ) аркус синус

SIH( ) синус хиперболичен

ASH( ) аркус синус хиперболичен

COS( ) косинус

ACO( ) аркус косинус

COH( ) косинус хиперболичен

ACH( ) аркус косинус хиперболичен

TAN( ) тангенс

ATN( ) аркус тангенс

TAH( ) тангенс хиперболичен

ATH( ) аркус тангенс хиперболичен

COT( ) котангенс

AOT( ) аркус котангенс

TOH( ) котангенс хиперболичен

AOH( ) аркус котангенс хиперболичен

SEC( ) секанс

ASE( ) аркус секанс

SEH( ) секанс хиперболичен

AEH( ) аркус секанс хиперболичен

CSC( ) косеканс

ACS( ) аркус косеканс

CSH( ) косеканс хиперболичен

ARH( ) аркус косеканс хиперболичен

LOG( ) логаритъм при основа е (_e)

LG2( ) логаритъм при основа 2 (_2)

LG0( ) логаритъм при основа 10 (_10)

EXP( ) експонента при основа е (_e)

EX2( ) експонента при основа 2 (_2)

EX0( ) експонента при основа 10 (_10)

DEG( ) ъгъл в градуси (задават се радиани)

RAD( ) ъгъл в радиани (задават се градуси)

GRA( ) ъгъл в гради (задават се радиани)

CEL( ) градуси по Целзий

FAR( ) градуси по Фаренхайт

KLG( ) тегло в килограми (задават се паундове)

PND( ) тегло в паундове (задават се килограми)

CNM( ) размер в сантиметри (задават се инчове)

INC( ) размер в инчове (задават се сантиметри)

KLM( ) разстояние в километри (задават се мили)

MIL( ) разстояние в мили (задават се километри)

LTR( ) обем в литри (задават се галони)

GAL( ) обем в галони (задават се литри)

FIS( ) площ в cm2 (задава се фmm)

FIT( ) тегло в kg (задава се фmm)

C_P( ) константа Pi (задава се k => k*Pi)

C_E( ) константа e (задава се k => k*e)

BIN( ) константа в 2 вид (01)

OCT( ) константа в 8 вид (01234567)

HEX( ) константа в 16 вид (0123456789ABCDEF)

NOT( ) bitwise NOT

FUN( ) ВЪНШНИ ФУНКЦИИ с формат FUN( Fname; Pin=a, ..; Pout) където:

Fname - име на файла-функция в директория \pcp.clc или поддиректории (групи) на тази, изписани пред името на файла-функция, като част от път - Folder\SubFolder\...\Fname;

Pin - име на входен параметър във файла-функция Fname;

a - име на стойност/параметър от текущия модул;

Pout - име на изходен параметър във файла-функция Fname.

Примери:

FUN( F-area; x=a, y=b; S)

FUN( Tabl; ; ) - няма обмен на параметри, евнтуално се използува печата(print) в тази процедура.

Не се подържа от Детайли.

Оператори и приемания:

Горна единична кавичка - коментар (Rem) след нея текста не се разглежда при изчисление.

Debug След този оператор се изпълнява контрол на реда за изчисление и междинни резултати (игнорира се при външни функции).

For i = n To k Step s

…

Next Оператори за цикъл.

If i = 6 then

…

Elseif i < 12 then

…

Elseif i <= 24 then

…

Elseif i <> 28 then

…

Else

…

End if Оператор за разклонение.

| След този символ реда се печата (при наличието му в формата премахва шпациите от резултата).

[n=6] Дефиниране на променлива n.

Примери:

За изчисление на израз 8.72337676933629 = exp ( inv ( cos ( ( 3 * 4 / ( 5 + 6 ) ) ) ) ).

За печат при програмиране:

Израз | Резултат
….. |…R=[###.#= 3 + 6] | …R=..9.0
….. |…R=[|###= 3 + 6] | …R=9
|.[+##.##^^^^= 7000e5] | .+70.00E+05
….. |…R=[h####= 20 + 7] | …R=h001B
….. |…R=[|h####= 20 + 7] | …R=h1B

(Аналогично за Bin и Oct)

Файлове:

Формат за модула (clc).

Приема от:

Детайли.

Предава на:

Детайли.

File.


Сорт

Общо:

Модул за автоматично стръскване размера или замяна (редактиране) на стрингове във файл за постигане на по-икономичен размер на файла. Възможности за конвертиране на файл на различни езици (могат да се задават от потребителя), ANSI кирилица DOS/Windows, Unicode, промяна на псевдографичните символи.

Меню:

Файл

Ново

Чете Ctrl-R

Запис Ctrl-W

Изход

Сорт

Стартира (F9) сортирането след избор на файл или файлове (стандартна работа с Control и/или Shift) за обработка. С Control прекъсва обработката.

Help

Home

Application F1

Работно поле:

Възможности:

Задаване разширението на обработения файл (възможност за работа с глобални символи, примерно при файл име.g__ и зададени ??#, резултата е име.g_#). Опция за автоматична замяна на оригинала-source с получения файл-target, тази опция се игнорира при прекъсване на обработката с десен бутон на мишката + Esc. Опция за ускоряване на обработката при особено големи файлове без преглед на source и target, за всички зададени форми на обработка се включва auto независимо от конкретната стойност на всяка една от тях (автоматичен изход, ако не е прекъсната обработката с десен бутон на мишката + Esc). Опция end view за преглед на всички файлове (входни и обработени) чрез текущото от Преглед текст. Възможност за добавяне на зададен брой шпации от ляво за всеки ред от файла (подобрена прегледност при печат). Конвертиране на файл (обикновено с резултати) на различни езици. Конвертиране на файл с ANSI кирилица - DOS/Windows или в Unicode. Промяна на линиите (псевдографичните символи) при таблиците от Terminal. Get запомня, приема текущите форми от екрана след редактиране. Auto не задава въпрос дали да извърши действието.

Replace - създава форми за подмяна на един стринг с друг. Pos задава позиция, на която би трябвало да се срещне търсения стринг (при 0 търси по целия ред).

Erase line - трие съответен ред/ове:

– празен;

– ред на който се среща формата;

– редове между начална форма и крайна форма с/без указващите форми.

Pos задава позиция на която би трябвало да се срещне дадената форма (при 0 търси по целия ред). Auto не задава въпрос дали да извърши действието. Възможност при задаване на формите след първата да се задават на първа и втора позиция във формата логически (и, and) връзки между тях (+& -съвпадаща форма и -& -различна форма), които са в сила за един ред, примерно:

форми пореден N

. . . . . .

Усилия к

M=-&0.00 к+1

Q=+&0.00 к+2

ред . . . Усилия M=1.23 Q=0.00 . . ., ще бъде изтрит.

Файлове:

Формат за модула (srt).

Приема от:

File.

Предава на:

File.

Преглед текст.


Стойност

Общо:

Сумиране по количества и стойност на отделни обекти (spc). Възможност за сортиране по произволна характеристика. При кликване на десен бутон на мишката, възможност за дабавяне (multi select) – Add, редактиране – Edit (Repeat, Title и цени по всички пера) и триене (select) – Delete. Files Find – стартира Files Find. При намерени обекти (spc) и включена опция Get – import на всички обекти.

Меню:

Изход

Настройка

Възможности за задаване брой повторения за този обект – Current file repeat. Да се добавя ли пълният текст от файла – Add file full text in result. Начин за автоматична генерация на Title. Текущ кофраж, възможност за редактиране Edit на библиотека от кофражи. Задава се и име на валута в която ще се работи.

Генерация

Генерира (F9) файл при зададените условия.

Help

Home

Application F1


Импорт DXF-DWG

Общо:

Модул за импорт на елементи (точка, линия, окръжност, дъга, елипса, полилиния, 3Dface, Solid и Текст) от DXF-DWG файлове. При кликване върху тъмен цвят извиква диалог за избор на DXF или DWG файл при пусната опция за такъв (десния бутон на мишката нулира текущото състояние - файл). Анализира изчетеният DXF-DWG файл (включително работа с блокове - scale, rotate в равнината x0y), като дава възможност за избор на елементи по слоеве (зададени при изчертаването и всички заедно) и цветове (зададени при изчертаването, съответствие: ACI -> RGB). Възможност за избор преди изчитане на брой точки [3:1000] и максимална дължина на сегментите в чертожните единици на чережа за елементите: окръжност, дъга, елипса, полилиния-vertex. Pабота с vertex при полилинии. Опция за заместване на текстове (при необходимост от автоматична замяна на специални символи или друг текст). Допълнителни текстове за замяна могат да се редактират, добавят или трият, чрез основните възможности на таблица. Маркиране и демаркиране на всички елементи за текущия слой. Потребителят трябва коректно да зададе съответствието 1 unit = X mm, при което е изчертан чертежа (файла). Разбиването на окръжности, дъги, елипси и vertex (при полилинии) става в равнината x0y. Възможности за транслиране на чертежа, чрез бутон автоматично изчислява за избраните елементи преместванията (които впоследствие могат да се променят), така че долния ляв възел да стане с координати (0, 0, 0). Опции за задаване на абсолютни координати (x,y,z) за всички възли. Това е особено полезно, когато е необходимо да се зададе на всички координати една стойност (примерно z), a чертежa e генериран/изчертан на различни нива (т.е с различни стойности на z).

Приема от:

DXF-DWG files.

Предава на:

Вход на обекти.

Детайли.


Експорт DXF-DWG

Общо:

Диалог в който могат да се задават следните опции за управление на генерацията:

dwg – задава DWG файл за генерация, алтернативно - DXF;

Script файл – задава се Script файл;

General;

– Trim – прекъсва (отсича) линиите под 3DFACE. Не пренася 3DFACE в DXF-DWG файла независимо дали е пусната или не опцията Trim (т.е. слой - 00-dfc e винаги празен);

– End view with ... – след Go, стартира автоматично преглед на генерирания DXF-DWG файл (това е възможно, ако има асоциран преглед на DXF-DWG файл към системата или зададена (предпочитана) програма за преглед/редакт/печат) и тоэи с количества (spc). Допълнителна възможност за преглед чрез PCPcad;

Plylines;

– Fillet – закръгля полилиниите – фигурите на армировката;

– Weight – задава нова дебелина за всички полилинии, обикновено се эадава 0;

Colors;

– Mono colors – генерира DXF-DWG в един цвят в зависимост от текущия в ACI;

Text;

– Language (...->...) – конвертиране на текста на различни езици, ако ги има инсталирани;

– Cyrillic (DOS<->Windows) – конвертиране DOS/Windows кирилица;

– Replace – опция за заместване на текстове (при необходимост от автоматична замяна на специални символи или друг текст). Допълнителни текстове за замяна могат да се редактират, добавят или трият, чрез основните възможности на таблица;

– Use font Description file (des) – използува различен от стандартния шрифт;

– Width factor – ширина на шрифта, обикновено е 1.

Dimension;

– Generation – конвертиране на коти към AutoCAD dimesion;

– Text override – при конвертиране на коти, text override за разлика между размер на кота и текст => 1 mm.

Specification - text file (spc) – генерира текстов файл (spc) с количествата на кофража, бетона и армировката по елементи и общо.

Автоматично мащабирани се вмъкнат типовете линии използувани в чертежа.

Препоръчва се този начин на работа.

Приема от:

Кофражен план (изчертаване) - с формат (scr).

Греди (изчертаване) - с формат (scr).

Плочи (изчертаване) - с формат (scr).

Грдостени (изчертаване) - с формат (scr).

Предава на:

PCPcad, DXF-DWG.


Task

Общо:

Диалог за контрол на стартираните в паметта модули. Възможност за прехвърляне Switch to или за затваряне End task на модул от PC Проектант. Контрол на наличния в момента ресурс на системата – Info.


Config

Общо:

Диалог за настройка на някои общи параметри контролирани от PC Проектант. При OK и включена опция ReStart, се рестартира системата с новите параметри. При OK и не включена опция ReStart, само ново стартираните модули ще работят с новите параметри.

Globals

– Win XP style – използува новият стил въведен с Windows XP при визуализацията на контроли. Действа при всички модули;

– Splash screen – показва начален стартов екран – лого на системата;

– Balloon popups – определя вида на popup help;

– Custom menu – алтернативна промяна стила на менютата (стандартен и с икони). При включена опция потребителят може да избира между следните възможности:

– преоразмеряване на иконите;

– помощни текстове (tooltips) и вида им;

– да се маркират ли сивите/забранени полета при движение по менюто;

– прозрачност (променя се алтернативно от системно меню или при ляв бутон на мишката и натиснат Ctrl върху Габър – променя се заедно с тази на диалога);

– преливане на цветове при меню (нормално и удължено);

– преливане на цветове при лентата за селектиране;

– опция Animation - Blink премигване - 0.16 sec на активният ред (само, ако той е активен и не е подменю);

– цветове (системни – динамично се променят при промяна настройките/цветовете на Windows, зададена комбинация или промяна на всеки от тях, чрез натискана на ляв за текст и десен за фон, бутони на мишката върху съответната позиция). Цвета на основата и прозрачността са общи за всички Tooltips.

– Sound splash screen – задава звуков сигнал при стартиране на системата;

– Sound salute – поздрав от автора;

– Sound password error – звуков ефект при неправилна парола на потребител.

Buttons

– Flat – задава гладки бутони, при изключено те са релефни;

– Modern contour – при минаване на мишката върху бутон той се повдига релефно;

– Sound move – при минаване на мишката върху бутон той кликва;

– Sound command – при натискане на левият бутон на мишката върху бутон се възпроизвежда звук;

– Light – при минаване на мишката върху бутон той просветва. При check, възможност за задаване цвета на светлината;

– Hand cursor – при минаване на мишката върху бутон курсора от default (обикновено стрелка) се сменя на ръка;

– Windows default colors – PC Проектант автоматично отчита промяната на системните цветове (примерно чрез Desktop Themes) и променя цветовете на своите бутони. При изключено са сиви;

– Popup help – задава появяването на пояснителен текст към бутона върху който е задържана мишката;

– Animation - Blink – задава анимиране (в случая премигване - 0.12 sec) при минаване на мишката върху бутона;

– Animation - Scale – задава анимиране (в случая намаляване размера на картинката - 0.15 sec) при минаване на мишката върху бутона;

– Animation - Star – задава анимиране (в случая преминаване през бутона на 4 лъча към върховете му - 0.12+0.07 sec) при минаване на мишката върху бутона.

Edit

– Text help – задава пояснителен текст върху вдлъбнато каре върху диалога;

– Popup help (alternate Alt) – задава горният пояснителен текст под контролата за въвеждане. Alt - алтернативно;

– SetFocus - mark all (alternate Ctrl) – при приемане на фокус маркира целият текст автоматично, алтернативно - при натиснат Ctrl и приемане на фокус не маркира текста. При изключено - обратно, при приемане на фокус не маркира текста, а при натиснат Ctrl и приемане на фокус - маркира целият текст. При натиснат Shift и приемане на фокус Windows маркира текста до позицията на маркера.

Възможност за пресмятане на израз или задаване на константа/функция след натискане на бутон за аритметично действие, малки скоби или процент (виж Калкулатор) в полетата за въвеждане на стойности.

– Tool Mark - default (Hot key Ctrl-J) – при работа/маркиране на възли или елементи подсказва кой възел/елемент ще бъде прехванат. Горещ клавиш Ctrl-J за алтернативна промяна на default в конкретен модул.

Limits

– Курсори при работа с възли и обекти – задава/спира визуализация, чрез курсор за текущото действие за всички модули;

– Курсор кръст – задава размера на алтернативния маркер – кръст в % от вертикалния размер на прозореца. При зададени 100 % – кръст през цялото работно поле на прозореца хоризонтално и вертикално;

– Undo/Redo – задава max брой стъпки при Undo и Redo, при отказ от действие се задават 0 или 1 – No undo. При стартирани едновременно няколко модула от един вид – Undo/Redo е активно само при първият;

– Auto synchronize local time on start, if difference > 10 sec – при стартиране на системата задава автоматично синхронизиране/сверяване на локалното време с това от мрежата (при наличие на I-net), ако разликата е > 10 секунди;

– Time.

Габър - определя алтернативно стила/видимостта на прозореца (topmost/normal), намира се върху Title bar горе-дясно. Ctrl-Габър - извежда диалог за определяне на степента на прозрачност (ако версията на Windows позволява). Габър - се явява за всички диалози с Caption, които не са MessageBox и Tool window, запомнят се позиция и размери. С тези параметри може да се работи и от системното меню (десен бутон на мишката върху Caption) на текущият прозорец.


User

Общо:

Модул за контрол при работа със системата. Паролата на Master е зададена към съответната инсталация. Само той може да създава (в този момент паролата съвпада с името на потребителя) или унищожава потребители на до 10 нива. Всеки потребител има достъп (промяна на парола и информация за потребителя) до себе си и до нивата по-долни от неговото. В раздел Информация може да се прегледа времето на работа (заетостта) на всеки от модулите по часове и дати за конкретния потребител при зададен интервал от време. При Copy информацията се копира в Clipboard за евентуална работа с нея (примерно графика в Exel).


Подготовка на език

Общо:

Възможности за настройка на работата с различни езици.

Set - задава текущ език за цялата система. Той може да е един от начално зададените при изготвянето на инсталацията на системата от авторите или такъв създаден в процеса на работа от потребител. Системата не работи, ако изчитате файлове на друг език създадени преди това от нея, би следвало те да се конвертират преди това.

New - създава нов език на основата на sors-оригинал и target-работен. Задават се име, коментар/автор и икона (ico). В последствие този език може да се редактира и да се и използува за работа със системата и за конвертиране на файлове.

Edit - редактиране на новосъздаден от потребителя език.

Видове записи/стрингове:

Sors - от текста на програмата (няма ограничение);
File - текст при работа с файлове (ограничение брой символи);
Res - текст от ресурс (ограничение брой пиксели).

Управление:

-/+- последователно движение по поредни записи. Възможност за скок на определен запис по неговото ID или пореден номер.
Ctrl-Z - връща след редактиране първоначалния вид на записа.
Ctrl-R - връща след търсене на стартовия запис.
Sort - сортира в зависимост от зададеното (Comment, Original, Work).
Find - търси текст от текущата позиция в зависимост от зададеното (Comment, Original, Work).
Go - ходи по зададените видове записи с/или условия (лимит или брой пиксели).

Del - изтриване на новосъздаден от потребителя език.


Промяна на стандарт

Общо:

Възможности за алтернативна работа с различни стандарти БДС и/или EuroCODE.


Help

Общо:

Стартира този файл - Home. При Alt - стартира Учител - модул за обучение.


Учител

Общо:

Модул за избор и управление на филми за обучение със системата.

При инсталиране филмите за обучение не се копират на диска поради значителният им обем. По целесъобразно е с тях да се работи от CD, за тази цел е необходимо да се пренасочи модула по подходящ начин към съответната директория на CD.

При липса на звук и наличие на технически възможности за това, инсталирай всичко от Add/Remove Programs - Windows Setup - Multimedia.

Работно поле:

Възможности:

Показва изчетения брой файлове и времетраенето им, а при избор на филм за преглед показва броя файлове участвуващи във филма и времетраенето му. Go - стартира избраният филм. Възможност за създаване на собствен филм (_Temp_). Разместването на реда на файловете става, като след кликване върху първа колона се определя мястото (посоката се обръща с Shift), където ще се вмъква файл посочен след кликване върху втора колона. Участитето на файла във филма се определя от бутона в последната колона, при Shift върху нея се стартира индивидуално файла от текущия ред. Ок - приема редактираното във филм (_Temp_). Alt при Ок - отказ от промените. Alt при филм и Close - прекъсва изпълнението на филма. Възможност за преглед (работи с асоциран) с асоцираният в момента към Windows Media Player или зададена (предпочитана) програма за преглед на филми (avi).

Файлове:

Формат на файловете за филми (avi).


Time

Общо:

Диалог за синхронизиране/сверяване на локалното време за компютъра с това от световната мрежа (при наличие на I-net).

Синхронизирането/сверяването става чрез ляв бутон на мишката върху долната икона или панела с времето. Чрез горната икона се промяна на локалното време за компютъра. Ляв бутон на мишката променя вида на двоичното време. Десен бутон на мишката - изход.


Files Find

Общо:

Диалог за търсене на файлове от системата PC Проектант или други. Стартира се от основно меню или от всеки диалог при четене или запис на файл чрез бутон File & Folders.

– Start from – избор на пътя за търсене;

– File type – задава се филтър на търсене – *.r__ ; ??c.* ; test*.txt. Всеки филтър се отделя от предходния чрез ; . Коментари на призволно място заградени със средни скоби – [ Коментар ];

– Search – започва търсене, същият бутон Cancel за прекъсване;

– Include sub-folders – опция дали да се търси в директориите на вътре от зададената;

– Right-click – извежда диалог с Properties за файла върху който е мишката;

– Double-click – извършва действието на избраната от четирите възможни опции; View/Open - показва файла, ако е асоциран от системата, при Shift и файл на PC Проектант - преглед на файла като текст, Explore - отваря папката с маркирания файл, Clipboard - копира път/файла в Clipboard, Get - взема файла като избран;

– Sort column – при кликване върху съответната колона сортира в текущата посока.


Информация

Общо:

Диалог с подробна информация за Computer System, Registered, Windows, Time, Host Address, Country, Language, Processor, Bios, Memory, Fixed disk, Screen. Възможност за преглед на System Information.


About

Общо:

Диалог за преглед на версията на PC Проектант и датата на която е направена инсталацията. Виждат се и датата на първото инсталиране, брой стратирания и изминали дни. При грешка на същият ред от дясно се изписва номера и (Error: ??,???) - при връзка с авторите би следвало да им се изпрати този номер ! Показват се лиценз и регистрационен номер на продукта. За връзка се дават интернет страница (Web Page) и електронна поща (E-mail) на авторите (диалога им се извиква като се натисне ляв бутон на мишката върху текущия диалог).


Windows съвместимост

[1] UAC - задължително UAC-off при Windows Vista до SP. Не е необходимо при Windows Vista SP2, 7, 8.

Изключване на 'User Account Control' (UAC)

Възможни са няколко подхода за това (тук е разгледан този, към който насочва 'PC Проектант' при опит да се работи с него).

1. Отворете Control Panel (преминете на Classic View), след което изберете User Accounts.

2. Изберете Turn User Account Control on or off (след съответното съобщение, този диалог се стартира автоматично при опит да се работи с 'PC Проектант').

3. Изключете опция Use User Account Control (UAC) to help protect your computer и натиснете бутон 'OK'.

4. За рестарт на Windows натиснете бутон 'Restart Now'.

Изключване на 'User Account Control' (UAC) при Windows 8.

[2] Aero scheme - препоръчително за по удобна работа с диалозите на системата.

Промяна на Color scheme 'Windows Aero' с друга

Това се налага за видимост и следователно възможност за работа с Габър (промяна характера и прозрачността на текущият диалог). С тези параметри може да се работи и от системното меню (десен бутон на мишката върху Caption) на текущият прозорец.

1. Отворете Control Panel (преминете на Classic View), след което изберете Personalization.

2. Изберете Window Color and Appearance.

3. Изберете Open classic appearance propertties for more color options (този диалог може да не се появи, ако не сте в съответната Color scheme).

4. Изберете Color scheme със стил различен от Aero.

[3] AntiVirus - задължително изключване на антивирусната програма при фалшив сигнал.

Изключване на антивирусната програма при фалшив сигнал за вирус

Някои антивирусни програми дават фалшив сигнал за вирус.

Възможни са няколко подхода за да се избегне фалшивия сигнал за вирус:

1. Изключи антивирусната програма. Инсталирай PC Проектант. Включи антивирусната програма и изключи папката на PC Проектант (обикновено c:\pcp) от анализ - препоръчва се;

2. При работа изключвай антивирусната програма;

3. Деинсталирай антивирусната програма;

4. Смени антивирусната програма - виж за подходяща таблицата горе.

[4] non-Unicode - задължително при работа на кирилица.

Промяна на non-Unicode шрифтове за работа на кирилица със системата.

Налага се при липса на четимост на менютата и диалозите на системата.

Промяна на non-Unicode шрифтовете за работа с менютата и диалозите на системата при Windows 8.


Възли

С левия бутон на мишката се прихваща най-близкия възел, с Shift + Zoom се прихващат всички възли в областта. С десния бутон отказ от маркиране на възли и престъпване към действие. BackSpace - връща назад маркирани възли. При Del и прехванат (с левия бутон на мишката) вече маркиран възел, той се демаркира.

Въвежда

Въвежда координати на възел. За да е възможно това трябва да сте в една от трите равнини с изключена опция за перспектива, тогава като трета координата се приема числото от Координати-ниво (което също може да се редактира), ако не (маркирано меню) автоматично изключва перспективата и склопява в равнина x0y. При прихванат възел и пуснати добавки работите като с относителни координати.

Редакт

Редактиране на координатите на прихванат възел.

Мести Shift

Мести прихванатите възли с указаните отмествания. Мести + Shift мести всички възли.

Дърпа

Мести прихванатите възли пропорционално от указания възел, като указания възел не се премества, най-отдалечения се премества на указаното отместване, средния на половината и т.н.

Върти Shift

Завърта прихванатите възли с указаните ъгли около указания възел. Върти + Shift завърта всички възли около указания възел.

Копира Shift

Копира прихванатите възли с указаните отмествания зададения брой пъти. Копира + Shift копира всички възли зададения брой пъти.

Размножава

от точка

Размножава от прихванатия възел с указаните отмествания зададения брой възли.

по отсечка

Размножава зададения брой възли като разделя отсечката на равни части при условие, че делта L = 0. В противен случай добавя зададения брой възли по отсечката (от първия) на указаното делта L.

по крива Shift

Размножава зададения брой възли по крива като разделя всяка отсечка на зададения брой части. За да е възможно действието трябва да сте в една от трите равнини с изключена опция за перспектива, ако не (маркирано меню) автоматично изключва перспективата и склопява в равнина x0y.

Shift съществува при модули свързани с чертане - генерира полигон.

отворена

Генерира гладка отворена крива.

затворена

Генерира гладка затворена крива.

по окръжност Shift

Зададеният брой възли се умножава по 4 (за всеки квадрант). За да е възможно действието трябва да сте в една от трите равнини с изключена опция за перспектива, ако не (маркирано меню) автоматично изключва перспективата и склопява в равнина x0y.

Shift съществува при модули свързани с чертане - генерира полигон.

R

Задават се два възела които формират радиуса - R (първият е център).

D

Задават се два възела които формират диаметъра - D.

3 точки

Задават се три възела които определят окръжност.

център (R)

Задават се един възел – център, стойност на радиуса - R.

център (D)

Задават се един възел – център, стойност на диаметъра - D.

по елипса Shift

Зададеният брой възли се умножава по 4 (за всеки квадрант). За да е възможно действието трябва да сте в една от трите равнини с изключена опция за перспектива, ако не (маркирано меню) автоматично изключва перспективата и склопява в равнина x0y.

Shift съществува при модули свързани с чертане - генерира полигон.

D1, R2

Задават се три възела. Разстоянието между първите два е единия диагонал, а разстоянието от третия до центъра на първите два е втория радиус.

R1, R2

Задават се три възела. Разстоянието между първите два е първият радиус, а разстоянието между първия и третия е втория радиус (първият е център).

център (R1, R2)

Задават се един възел – център, стойности на радиусите – R1, R2.

център (D1, D2)

Задават се един възел – център, стойности на диаметрите – D1, D2.

правоъгълник

За да е възможно действието трябва да сте в една от трите равнини с изключена опция за перспектива, ако не (маркирано меню) автоматично изключва перспективата и склопява в равнина x0y.

D'

Задават се два възела определящи един от двата диагонала. Генерират се останалите два възела на правоъгълника.

център (Lh, Lv)

Размножава 4 броя възли във върховете на правоъгълник с център прихванатия възел и зададените страни.

страна [2.3]

Размножава 2 броя възли, като върхове на правоъгълник със страна A (първите два възела) и страна B (разстоянието перпендикулярно от третият възел към страната A). При зададени само 2 възела (страна A ) се задава и d=B. Положителна посока обратно на часовниковата стрелка.

по площ

Задават се три възела образуващи някакъв ъгъл. Размножава зададения брой възли като разделя двете страни на ъгъла на зададения брой равни части.

център

Въвежда един възел като център на прихванатите възли.

пресечница [2.3.4]

Въвежда един възел като пресечница на две прави. При 4 възела - първия и втория определят първата права, а останалите втората. При 3 възела - първия и втория определят първата права, а останалия трети възел - втората, след запитване дали е хоризонтална, вертикална или перпендикулярна на първата права. При 2 възела - първия определя хоризонтална права, втория вертикална. За да е възможно действието трябва да сте в една от трите равнини с изключена опция за перспектива, ако не (маркирано меню) автоматично изключва перспективата и склопява в равнина x0y.

Трие Shift

съвпадащи

Търси за прихванатите възли общи координати (разлики по-малки от числото в Координати-кратни на) и ги обединява в един общ. съвпадащи + Shift за всички възли.

съвпадащи и свободни

Търси за прихванатите възли общи координати (разлики по-малки от числото в Координати-кратни на) и ги обединява в един общ. Свободните възли (възли към които няма прихванат елемент) ги изтрива. съвпадащи и свободни + Shift за всички възли.

Таблица

Преглед и редакт на въведените възли. Въвеждане (Ins) на нови възли.


Таблица

Общо:

Помощен модул за преглед, контрол, редактиране, въвеждане и триене на различни по тип данни.

Режим преглед:

Home начало вертикално база данни;
End край вертикално база данни;
^ред на горе;
v ред на долу;
PgUp страница на горе;
PgDn страница на долу;
Ctrl-Home начало хоризонтално база данни;
Ctrl-End край хоризонтално база данни;
<колона на ляво;
>колона на дясно;
Ctrl-PgUp страница на ляво;
Ctrl-PgDn страница на дясно;
F1 help;
Ctrl-F търси, сменя и заменя.

Празен помощен ред.

Режим редактиране:

В този режим (ако е разрешен) се влиза при кликване върху Edit Box или ако сте в режим преглед - редактиране чрез Enter.

Tab движение по колони (хоризонтално) на дясно;
Shift-Tab движение по колони (хоризонтално) на ляво;
Enter движение по редове (вертикално) на долу;
Shift-Enter движение по редове (вертикално) на горе;
Esc режим преглед - редактиране;
F1 help;
Ctrl-F търси, сменя и заменя.

На помощен ред информация за интервала и вида на данните.

Режим преглед - редактиране:

Home начало вертикално база данни;
End край вертикално база данни;
^ред на горе;
v ред на долу;
PgUp страница на горе;
PgDn страница на долу;
Ctrl-Home начало хоризонтално база данни;
Ctrl-End край хоризонтално база данни;
<колона на ляво;
>колона на дясно;
Ctrl-PgUp страница на ляво;
Ctrl-PgDn страница на дясно;
Ins вмъква ред под текущия;
Del трие текущия ред;
Enter режим редактиране;
Esc режим преглед;
F1 help;
Ctrl-F търси, сменя и заменя.

На помощен ред информация за ред / колона.

OK изход.

Режим блокова работа - Ctrl-F:

Find търси по зададената област (границите и текущото се дават на помощен ред), такова поле-цял стринг или част от стринг в зависимост от Field, който след промяната в зависимост от Case да съвпада с търсеното. Търси по Static text и Edit text;
Set сменя по зададената област (границите и текущото се дават на помощен ред) полетата със зададения стринг, като преди това той се променя в зависимост от Case. Търси по Edit text, като контролира интервала, ако е число;
Replace заменя по зададената област (границите и текущото се дават на помощен ред) полета или част от полета в зависимост от Field, като преди това те се променят в зависимост от Case. Търси по Edit text, като контролира интервала, ако е число;
Swap разменя едната стойност (намерената) с другата (и обртатно) по зададената област (границите и текущото се дават на помощен ред) полета или част от полета в зависимост от Field, като преди това те се променят в зависимост от Case. Търси по Edit text, като контролира интервала, ако е число;
Calc изчислява стойността на зададения израз по зададената област (границите и текущото се дават на помощен ред). Преди това те се променят в зависимост от Case (има смисъл при стригове). Търси по Edit text, като контролира интервала, ако е число. Възможни динамични променливи: %%F, %%f - поле, %%R, %%r - ред, %%C, %%c - колона, както и всички константи и функции дефинирани в калкулатор;
Limits извежда стойностите на сумата - sum, средното аритметично - mid и позициите и стойностите на min и max по зададената област. Търси по Static text и Edit text;
Paste сменя по зададената област (границите и текущото се дават на помощен ред) полетата с текста (ако има такъв), който се намира в Clipboard. За разделители при редове и колони се използват всеки от преди това зададените символи ('\r' - Return, '\t' - Tab, ... ) - виж ги с Ctrl-Paste. Контрол на наличният текст в Clipboard през 1 sec - Tooltip. Търси по Edit text, като контролира интервала, ако е число;
Copy копира по зададената област (границите и текущото се дават на помощен ред) полетата (като текст) в Clipboard. За разделители при редове и колони се използват първите символи от зададените стрингове ('\r' - Return, '\t' - Tab, ... ) - виж ги с Ctrl-Copy. Възможност за копиране на текст в Clipboard и като UniCode. Копира по Static text и Edit text;
Field дали да работи с цяло поле (пълно съвпадение на двата стринга) или с част от него (търсения стринг се среща в полето);
Case дали да конвертира преди сравнение стринговете;
All настройва цялата допустима област за търсене. При потъмнени (прихваната позиция на работа) Start, End, Row, Column - локализира съответния елемент.

При потъмнени (прихваната позиция на работа) за всеки от режимите на работа и кликване/промяна върху ред (на който са получени съответно - ред, колона) от ListBox, съществува възможност за синхронен преглед на съответната клетка от таблицата, без да се напуска текущия режим на работа.


Спецификация на армировка

Общо:

Модул за редактиране и сортировка на армировката по фигури с последваща генерация на таблица за това.

Редакт армировка:

Изход

Изход спецификация. Връща съответните/текущи актуализирани номера на позиции.

Сорт

Задава се реда на сортиране (подреждане) на фигурите армировка в тази таблицата. Опции за сортиране по Елемент, Тип фигура, Стомана, Диаметър и Дължина. Опция за възходящо или низходящо сортиране.

Таблица

Стартира алтернативната таблица - Таблица армировка.

Генерация на Редакт армировка за контрол и редактиране (възможност при близки фигури те да се редактират, щото да се получат по-малко фигури/позиции или ако конструктора има други съображения за това). Редактираната дължина на позиция от фигура се подчертава с цвят и звезда, като отдолу се дава оригиналният размер. Този размер от фигура се маркира в жълто при изчертаване и не се променя с последваща промяна на условията за този фигура. Този размер от фигура отпада при изтриване на обекта, задаване на нов тип фигура или редактиране до оригиналният размер в тази таблица. Не могат да се редактират фигури с дължини в стил от - до и детайли. При кликване върху колона Фигура връща оригиналният и размер, при кликване върху колона от къде приравнява размерите на посочената фигура с тази маркирана в колона ni. Око - видимост на фигура. При липса на видимост, тя не влиза в спецификацията - т.е. възможност да се замени с алтернативна или съседна модифицирана. Shift - извършва действието за всички редове за действието от текущата колона, ако е възможно. Прихваната армировка/елемент при наличие на "*" при номер и име.

Таблица армировка:

Изход

Изход спецификация. Връща съответните/текущи актуализирани номера на позиции.

Сорт

Задава се реда на сортиране (подреждане) на фигурите армировка в тази таблицата. Опции за сортиране по Елемент, Тип фигура, Стомана, Диаметър и Дължина. Опция за възходящо или низходящо сортиране.

Таблица

Стартира алтернативната таблица - Редакт армировка.

Генерация на Таблицата армировка за контрол (възможност при близки фигури, така да се коригира чертежа, щото да се получат по-малко фигури/позиции). Тук се задават от колко различни елемента армировката е обединена, кои са те, стомана, бройки за дадената фигура, диаметър, обща дължина, фигура, подробни размери.

Детайл се тълкува като армировка (в сила са опциите за надписване на армировка, спецификация-фигури) ако:

– има точно един полигон, без да се броят текстовете и останалите видиве елементи;

– има задължителен текст във формат брой Ф/N диаметър x дължина (5N20x400) и евентуално / разстояние (7N10x300/15);

– няма нито един елемент група.

За този детайл-армировка се тълкуват:

– характеристиките на полигона, определят фигурата (и цвета) на армировката при генерация на спецификацията му;

– като основен надпис на армировката текстове във формат брой Ф/N диаметър x дължина (5N20x400) и евентуално / разстояние (7N10x300/15), ако има такова при греди то се игнорира;

– в спецификацията за надписване на армировката - подробно се пренасят само текстове тип - текст2, които са прехванати към два съседни възли на основния елемент - полигона;

– всички останали елементи се изобразяват, но не се обработват при спецификацията.

Две армировки са една фигура, ако съвпадат: броя на отсечките на полигона, броя на текстовете при участъци - подробна армировка и наклоните (кратни на 180ё) за всяка отсечка подред (при завъртяна хоризонтално армировка за най-дългия участък). Това дава възможност на завъртени, несиметрични обърнати армировки в стил ляво/дясно или горе/долу да се тълкуват като една фигура).

Прихваната армировка/елемент при наличие на "*" при номер и име.


Файлове - разширения

Файловите разширения на програмата автоматично се асоцират към системата при инсталация.

– файлове, които се визуализират графично (основно в Ревю).

– файлове, които се извеждат като данни в съответния модул.

При кликване върху файл (примерно в Explorer) и задържан Shift - извежда асоцирания файл като текст.

Разширение | Модул подава | Модул приема | Ревю | Принт
b02 | Вход на обекти | Вход на обекти Геометрични характеристики Контрол запис обекти | - | -
k02 | Вход на обекти Контрол запис обекти | Вход на обекти Кофражен план (изчисление) | + | -
k01 | Кофражен план (изчисление) | Кофражен план (изчисление) | - | -
p__ | Кофражен план (изчисление) | Кофражен план (изчертаване) Поле Контрол запис обекти | + | +
g__ | Кофражен план (изчисление) | Кофражен план (изчертаване) Греди (изчертаване) Греда Контрол запис обекти | + | +
k__ | Кофражен план (изчисление) | Кофражен план (изчертаване) Контрол запис обекти | - | +
k03 | Кофражен план (изчертаване) | Кофражен план (изчертаване) | - | -
g03 | Греди (изчертаване) | Греди (изчертаване) | - | -
z01 | Сеизмично изследване Контрол запис обекти | Сеизмично изследване | + | -
z02 | Сеизмично изследване Контрол запис обекти | Сеизмично изследване | + | -
z__ | Сеизмично изследване | Рамки (изчисление) - комбиниране Общо оразмеряване Контрол запис обекти | + | +
r02 | Вход на обекти Контрол запис обекти | Вход на обекти Генерация на мрежа | + | -
r01 | Генерация на мрежа | Генерация на мрежа Плочи (изчисление) | + | -
r__ | Плочи (изчисление) | Плочи (изчертаване) Кофражен план (изчисление) | + | +
r03 | Плочи (изчертаване) | Плочи (изчертаване) | - | -
s02 | Вход на обекти Контрол запис обекти | Вход на обекти Генерация на мрежа | + | -
s01 | Генерация на мрежа | Генерация на мрежа Гредостени (изчисление) | + | -
s__ | Гредостени (изчисление) | Гредостени (изчертаване) | + | +
s03 | Гредостени (изчертаване) | Гредостени (изчертаване) | - | -
n02 | Вход на обекти | Вход на обекти Генерация на мрежа | + | -
n01 | Генерация на мрежа | Генерация на мрежа Оразмеряване на сечения | + | -
n__ | Оразмеряване на сечения | - | + | +
i02 | Вход на обекти | Вход на обекти Генерация на мрежа | + | -
i01 | Генерация на мрежа | Генерация на мрежа Изключване на опън | + | -
i__ | Изключване на опън | - | + | +
t02 | Вход на обекти | Вход на обекти Генерация на мрежа | + | -
t01 | Генерация на мрежа | Генерация на мрежа Температури | + | -
t__ | Температури |  | + | +
x02 | Вход на обекти Контрол запис обекти | Вход на обекти Рамки (изчисление) Сеизмично изследване | + | -
x__ | Рамки (изчисление) | Рамки (изчисление) - комбиниране | + | +
kor | Рамки (изчисление) - комбиниране | Рамки (изчисление) - комбиниране | - | -
d__ | 3DD Рамки (изчисление) | 3DD Рамки (изчисление) | + | +
o__ | Общо оразмеряване | Общо оразмеряване | - | +
det | Детайли | Детайли | - | -
clc | Калкулатор | Калкулатор | - | +
srt | Сорт | Сорт | - | -
pec | Принтер | Принтер | - | -
spc | Кофражен план (изчертаване) Греди (изчертаване) Плочи (изчертаване) Гредостени (изчертаване) | - | - | +
scr | Кофражен план (изчертаване) Греди (изчертаване) Плочи (изчертаване) Гредостени (изчертаване) | Export DXF-DWG PCPcad AutoCAD | - | -
dpf | Кофражен план (изчертаване) Греди (изчертаване) Плочи (изчертаване) Гредостени (изчертаване) | PCPcad | - | -
dxf | Export DXF-DWG | Вход на обекти PCPcad AutoCAD |  |
dwg | Export DXF-DWG | Вход на обекти PCPcad AutoCAD |  |
dxo | Export DXF-DWG | Export DXF-DWG | - | -
gif | 3DD Рамки (изчисление) | - | - | -
avi | 3DD Рамки (изчисление) | - | - | -
d01 | DOS версия - Кофражен план | - | + | -
d02 | DOS версия - Кофражен план | - | + | -
d03 | DOS версия - Кофражен план | - | + | -
d04 | DOS версия - Кофражен план | - | + | -

Поле, Греда, Фундамент, Оразмеряване, Провисване - при самостоятелна работа нямат запазени разширения!


Схема на връзките между модулите

Изчисление на единични бетонни и стоманобетонни (симетрични и не- симетрични) фундаменти, натоварени центрично и нецентрично. Слягане.Изчисление на температурно поле за ограждащи конструкции по МКР.Автоматична генерация на триъгълна мрежа за обект с възможности за контрол и редактиране.Графично въвеждане на конструкция или обекти от нея в 3D. Контрол между обекти. Геометрични и товарни характеристики на обекти.Модул за преглеждане на входна информация и резултати в 3D графичен вид.Изключва опъна на обект или група от обекти.Изчислява гредостени по МКЕ (триъгълни 3x2).Изчислява равнинни рамки по МКЕ, включващи безкрайно корави зони. Комбинации с обвивки за надлъжна и напречна армировки.Автоматично оразмеряване на еле- менти по нива (колони от кофражни планове, шайби и рамки от сеизмично изследване) в табличен вид.Изчисление на сгради на сеизмично въздействие (включително шайби с отвори т.е. рамки имащи безкрайно корави зони).Изчисление на стоманобетонни сечения на огъване, срязване, усукване, натиск, опън, кобилици и комбинации от тях.Изчисление на правоъгълни, плочо- гредови, обратно плочогредови, 2T стоманобетонни сечения на провисване.Изчертаване на кофражен и арми- ровачен план за безгредова плоча, с пълен контрол на въведените и изчислени данни.Изчертаване на греди (прости и непрекъснати), с пълен контрол на въведените и изчислени данни.Изчертаване на кофражен и арми- ровачен план, с пълен контрол на въведените и изчислени данни.Изчисление на непрекъснати греди (до 15 отвора + 2 конзоли) с край: конзола, става, запъване. До 15 товара на участък.Проверка на сечение или група от сечения на косо огъване, натиск или опън в общо положение.Изчислява фундаментни, етажни и смесени плочи по МКЕ (триъгълни 3x3 3x6).Изчисление на въведен кофражен план с автоматично предаване на товарите между констр. елементи (полета, греди, колони).Изчисление на конзолни, еднопосочно армирани, тристранно (с балкон) и четиристранно подпрени полета. Статика, оразмеряване, провисване.Модул за печат на входна информация и резултати в текстов и графичен вид.Библиотека от бетони с характеристики по I и II гранични състояния.Language Bulgarian - officialПомощ и описание при работата с модулите - Home.Обучаващи филми за работа със системата - учител.Възможност за конвертиране, стръскване по матрици и форми на текстов файл (резултати).Средство за: Старт на PCPcad. Експорт на DXF-DWG файл. Връзка между AutoCAD и SCRIPT файл.Модул за преглеждане на входна информация и резултати в текстов вид.Текстов редактор. Пълно функционална среда за редактиране и печат.Изчертаване на вложените мрежи при гредостена, с пълен контрол на въведените и изчислени данни.Създаване и подготовка на библиотека от параметрични детайли необходими при изчертаване.Изчислява аритметичен израз или процедура от изрази (разклонение, цикъл, debug, запис), конвертиране.Право на достъп за потребител.Конфигуриране на системата.Контрол и оценка якостта на бетона за доказване принадлежността му към определен клас (B).Определя състава на бетона по метода на последователните приближения (плътните обеми).Таблица за преглед и контрол на армировка за стремена.Таблица за преглед и контрол на армировка по бройки/диаметър.Каталог на профили с въведени характеристики по групи.Библиотека от стомани с характеристики по I и II гранични състояния.Управление на стартираните модули от 'PC Проектант'.AboutИзчислява стойността на вложените материалиPCPcad Пълно функционална CAD среда.Каталог на материали с въведени характеристики по групи.Standart BDS <-> EuroCODESynchronize time.Files Find.Информация.


Използувана литература

Някои от използуваните източници при разработката на системата.

НОРМИ ЗА ПРОЕКТИРАНЕ НА БЕТОННИ И СТОМАНОБЕТОННИ КОНСТРУКЦИИ София, 1988 г.

НОРМИ ЗА ПРОЕКТИРАНЕ НА СГРАДИ И СЪОРЪЖЕНИЯ В ЗЕМЕТРЪСНИ РАЙОНИ София, 1987 г.

СТОМАНОБЕТОН - проф. инж. Л. Маноилов ВИАС София, 1983 г.

РЪКОВОДСТВО ПО СТОМАНОБЕТОН - колектив ВИАС София, 1988 г.

РЪКОВОДСТВО ПО ЗЕМНА МЕХАНИКА И ФУНДИРАНЕ - колектив ВИАС София, 1986 г.

РЪКОВОДСТВО за проектиране на бетонни и стоманобетонни конструкции от обикновен бетон - колектив НИСИ София, 1983 г.

СТОМАНОБЕТОННИ КОНСТРУКЦИИ изчисляване на деформации и пукнатини - доц. к.т.н. инж. К. Трънка, к.т.н. инж. Л. Оксанович, к.т.н. инж. И. Данчев София, 1985 г.

НАРЪЧНИК ЗА ПРОЕКТИРАНЕ И ИЗЧИСЛЯВАНЕ НА СТОМАНОБЕТОННИ КОНСТРУКЦИИ - проф. инж. Х. Нисимов София, 1987 г.

СТОМАНОБЕТОННИ СКЕЛЕТНИ КОНСТРУКЦИИ ЗА МНОГОЕТАЖНИ СГРАДИ - проф. инж. Х. Нисимов София, 1984 г.

НОСЕЩИ СТЕНИ И СМЕСЕНИ КОНСТРУКЦИИ НА СГРАДИ - проф. инж. Х. Нисимов София, 1984 г.

НАРЪЧНИК за проектиране и изчисляване на стоманобетонни конструкции - проф. инж. Х. Нисимов София, 1973 г.

МЕТОДИЧЕСКИ УКАЗАНИЯ за курсово проектиране на дисциплината "Стоманобетон" за специалността ПГС - колектив УАСГ София, 1992 г.

ИЗЧИСЛЯВАНЕ НА СТРОИТЕЛНИ КОНСТРУКЦИИ ПО МЕТОДА НА КРАЙНИТЕ ЕЛЕМЕНТИ - доц. инж. Ю. Павлова / доц. инж. Б. Банков София, 1989 г.

ЧИСЛЕНИ МЕТОДИ В СТРОИТЕЛНАТА МЕХАНИКА - доц. инж. Т. Карамански София, 1976 г.

НАРЪЧНИК по изчислителни методи за инженери - Тери Шоуп София, 1983 г.

ПРОЕКТИРАНЕ на стоманобетонни конструкции за сгради по ЕВРОКОД2 и НБПСК'88 - колектив София, 1996 г.

ПРОЕКТИРАНЕ на стоманобетонни конструкции според европейските норми (ЕВРОКОД2) - колектив УАСГ София, 1997 г.

НАРЕДБА ЗА ПРОЕКТИРАНЕ НА СГРАДИ И СЪОРЪЖЕНИЯ В ЗЕМЕТРЪСНИ РАЙОНИ София, 2007 г.

СТОМАНОБЕТОН НБПСК И EC - инж. Константин Русев София, 2008 г.

НАРЕДБА ЗА ПРОЕКТИРАНЕ НА СГРАДИ И СЪОРЪЖЕНИЯ В ЗЕМЕТРЪСНИ РАЙОНИ София, 2010 г.


What's new ?

∑ Нови възможности и промени към:

28 [image] 22.02.2015 г. версия 13 3DD EC8

3DD Рамки – 3D рамки – статика и динамика;

3DD Рамки – Земетръс 3D – добавен OpenGL (Video - gif, avi, Image - bmp, jpg, gif, png, tif) );

3DD Рамки – Земетръс 3D – възможност за задаване на image - мащаб, позиция, stretch;

CAD – подобрена работа при спецификации на армировка;

EC – проблем при получена армировка по-малка от конструктивната;

EC – проблем с дуктилна стомана;

Вход – "Характеристики" – добавен полярен инерционен момент Jo;

Вход – "Характеристики" – добавен запис на характеристики (G, Xcm, Ycm, Jmc) и контури;

Детайли – таблица колони – добавено покрите на армировката;

Материали – оптимизирано и добавени ~150 нови материали – ISO 10456;

Печат – добавена възможност за вътрешна генерация на PDF документи;

Преглед текст – оптимизирана работа с Enter при редактиране;

Преглед текст – оптимизирана работа с Headers;

Профили – добавени профили – над 15000;

Профили – добавен избор на профил при 3D рамки;

Профили – оптимизиран преглед при последна колона;

Рамки – комбинации – добавено изчитане и работа с шайби файлове формат (z__);

Рамки – комбинации – добавено изчитане и работа с 3D рамки файлове формат (d__);

Ревю – оптимизиран контрол за op2, op3;

Ревю – добавени опции за движение при диалог "Групи";

Ревю – добавена възможност за преглед по елементи при файлове формат (d__);

Земетръс – при импорт на файл с формат x02 – автоматично определяне на възли по нива;

Земетръс – добавен EuroCode 8;

Земетръс – добавено изчитане на характеристики (G, Xcm, Ycm, Jmc) и контури;

Земетръс 3D – добавен 3D земетръс по Норми – НПССЗР и EuroCode 8;

Таблично оразмеряване – генерация на файлове формат (x__) за шайби;

Чертане греди – добавени опции за вид на куки при стреме;

Чертане греди – добавени покрития на армировките и разстояние.

71 [image] 20.10.2012 г. версия 13 EC

EC – материали: бетони и стомани;

EC – оразмеряване на огъване, срязване, усукване, натиск, опън, кобилици и комбинации от тях;

EC – продънване;

EC – провисване;

CAD – подобрена работа с Multiline texts;

PCP – добавена възможност за паралелни инсталации;

PCP – добавена опция при търсене за отваряне на избраната папка;

PCP – добавени вътешни UniCode шрифтове 'PC Proektant Uni' и 'PC Proektant Uni 80%';

PCP – добавени опции при работа с Multiline Edit;

PCP – добавени нови MsgBox;

PCP – оптимизирана работа с UniCode – ClipBoard;

PCP – оптимизиран Tool Bars – SetFocus;

PCP – информация - UAC, IP, Aero;

PCP – нова контрола MsgBoxPCP;

PCP – оптимизиран MsgBoxPCP;

Земетръс – добавени НПССЗР '07;

Земетръс – добавени НПССЗР '10;

Земетръс – добавени резултати Vx, Vy, Zz при рамки;

Земетръс – добавен контрол при отместване за произволна стойност;

Изчисление на кофраж – оптимизиран контрол при единични опори МКЕ и опори греди;

Калкулатор – блоково преместване (Tab) на маркирани редове;

Калкулатор – изчитане на файлове с формат c__;

Калкулатор – при Conversions добавени примерни щаблони (Form);

Калкулатор – оптимизирана работа при Tab;

Калкулатор – оптимизирана работа при обикновен режим;

Контрол на бетона – първа публична версия;

Косо оразмеряване – подобрена работа при малък ексцентритет;

Косо оразмеряване – добавени коефициенти за условия на работа на материалите;

Оразмеряване – добавена работа с рамки при EC;

Оразмеряване – оптимизирано конструктивно разстояние;

Оразмеряване – оптимизирано max разстояние;

Печат – добавен възможност за работа с Enhanced metafile - emf;

Печат – добавена нова мощна компонента за преглед и печат;

Печат – добавена възможност за инсталиране на 'PDF Printer' - генерация на PDF документи;

Печат – добавено автоматично конвертиране до DOS/Windows текст;

Печат – оптимизирана работа при Четка;

Печат – четене на текст в UniCode формат;

Преглед текст – вмъква текстов файл след предварителен анализ;

Преглед текст – възможност за позиция на текст (ляво, център, дясно);

Преглед текст – възможност за форматиране (bullets) - няколко типа;

Преглед текст – блоково преместване (Tab) на маркирани редове;

Преглед текст – запис на текст в UniCode формат;

Преглед текст – възможности за форматиране Superscript и Subscript;

Преглед текст – възможност за подчертаване на текст с точки;

Преглед текст – възможност за автоматично поставяне на кадри в текста;

Преглед текст – добавени маркери при работа четене/запис с rtf файлове;

Преглед текст – добавен 'Текущ запис';

Преглед текст – добавен филтър при триене на блокове;

Преглед текст – добавена работа с Redo;

Преглед текст – оптимизирана работа с ANSI;

Преглед текст – оптимизирана работа с Undo;

Преглед текст – оптимизирана работа с маркери по линии;

Преглед текст – оптимизирана скорост на обработка при четене;

Преглед текст – оптимизирана работа с линкове;

Преглед текст – оптимизирана работа с ефекти;

Преглед текст – оптимизирана работа с клавиши;

Профили – оптимизиран преглед;

Рамки – комбинации – добавена генерация на бройки, разстояния и диаметри;

Рамки – комбинации – добавена работа и със симетрична армировка;

Ревю – оптимизирани разрези при къси конзоли;

Сорт – добавено конвертиране в Unicode;

Таблично оразмеряване – подобрено изчитане при новата версия;

Чертане греди – подобрена работа с имена на оси;

Чертане греди – подобрена работа при завъртане на коти;

Чертане гредостени – подобрена работа с имена на оси;

Чертане гредостени – подобрена работа при завъртане на коти;

Чертане кофраж – подобрена работа с имена на оси;

Чертане кофраж – подобрена работа при завъртане на коти

Чертане на плоча по МКЕ – подобрена работа с имена на оси;

Чертане на плоча по МКЕ – подобрена работа при завъртане на коти;

Чертане на плоча по МКЕ – за EC отчита влиянието на надлъжните армировки при проверка на продънване.

63 [image] 01.10.2009 г. версия 13 CAD

PCP – Config – Limits – добавена опция Курсори при работа с възли и обекти;

PCP – Config – Limits – добавена опция Курсор кръст;

PCP – Config – Limits – Time – добавено Change local time;

PCP – Report - оптимизиран;

PCP – Report - добавени: инсталиран, модули и режим;

PCP – добавени в системното меню на текущият прозорец функциите на Габър;

PCP – добавено в меню "x" при недостъпни модули;

CAD – добавен Alt-C;

CAD – добавена възможност за задаване на типизирани стилове – MLSPCP, MLSPCP_;

CAD – добавена възможност към команда DIMCON за автоматично определяне на посоката на работа;

CAD – добавена възможност към команда DIMCON за управление дължината на помощните линии;

CAD – добавена работа с относителни координати при допълнителни команди;

CAD – оптимизирано появяване на диалози при старт и/или обратна връзка;

Plugin KA – добавена възможност за промяна на всички текущи цени;

Plugin KA – добавена възможност за задаване на отвори;

Plugin KA – добавена опция за пълен разрез на стълбищно рамо;

Plugin KA – добавена опция тип колона без щрих;

Plugin KA – добавена опция 'Библиотека' за промяна на типа с друг от наличните греди, колони и армировки;

Plugin KA – добавена възможност за промяна действието на маркерите при армировка;

Plugin KA – добавена нови входни точки при въвеждане на стълбищно рамо;

Plugin KA – добавен диалог за управление на групите елементи от диалог 'Properties';

Plugin KA – добавена работа с относителни координати за всички обекти;

Plugin KA – контрол при кофраж и отворени сечения;

Plugin KA – оптимизирани сечения при полета;

Plugin KA – оптимизирани сечения при греди;

Plugin KA – оптимизирано завъртане;

Plugin KA – оптимизирани количества за всички обекти;

Plugin KA – оптимизирани коти стълбища;

Plugin KA – Кофражен/Армировъчен план в CAD - версия 1.7 (скорост, оптимизация, съвместимост);

Вход – курсори при работа с възли;

Вход – курсори при работа с обекти;

Детайли – курсори при работа с възли;

Детайли – курсори при работа с обекти;

Детайли – оптимизирано действие 'последно';

Детайли – оптимизирана генерация на таблица колони за шайби при имена с и над 10;

Калкулатор – оптимизиран toolbar;

Материали – добавени нови материали;

Материали – добавено число на дифузно съпротивление на водната пара към характеристиките;

Мрежа – курсори при работа с възли;

Мрежа – курсори при работа с обекти;

Мрежа – оптимизирана точност при генерация на мрежа (вертикални линии с отклонение 1 mm);

Поле – добавена възможност за преглед на редуциран площен товар за всички типове полета;

Поле – добавена възможност за задаване на нормативен площен товар;

Поле – оптимизирано прехвърляне на товари при тристранно подпрени полета;

Провисване – автоматично определяне на ks за всеки участък;

Провисване – автоматично определяне на допълнително провисване Wкор от завъртане при козоли;

Провисване – отчита влиянието на гладката армировка;

Провисване – опция за контрол на допустимото провисване при козоли;

Провисване – опция за задаване на допълнително провисване Wкор (козоли);

Провисване – оптимизиран контрол(алгоритъм) на провисването;

Чертане греди – курсори при работа с възли;

Чертане греди – курсори при работа с обекти;

Чертане греди – оптимизиране – сума kg при спецификация на армировка;

Чертане гредостени – курсори при работа с възли;

Чертане гредостени – курсори при работа с обекти;

Чертане гредостени – оптимизиране – сума kg при спецификация на армировка;

Чертане кофраж – курсори при работа с възли;

Чертане кофраж – курсори при работа с обекти

Чертане кофраж – оптимизиране – сума kg при спецификация на армировка;;

Чертане на плоча по МКЕ – добавен контрол на провисването при текущото състояние на конструирането;

Чертане на плоча по МКЕ – курсори при работа с възли;

Чертане на плоча по МКЕ – курсори при работа с обекти;

Чертане на плоча по МКЕ – оптимизиране – сума kg при спецификация на армировка.

119 [image] 16.09.2008 г. версия 13 +

CAD – добавено подържане на версии за DWG и DXF файлови формати за AutoCAD 2oo7/2oo8/2oo9;

CAD – добавени възможности за промяна реда на чертане;

CAD – добавена възможност за групово прехвърляне/копиране на обекти при Link 3;

CAD – добавена възможност за задаване на типизирани стилове – DIMPCP, DIMPCP_;

CAD – добавена възможност за селектиране по групи обекти;

CAD – добавена възможност за синхронизиране на времето през I-net;

CAD – добавена команда Array/Размножава;

CAD – добавена команда Break/Прекъсва;

CAD – добавена команда за продължаване дименсията (орто, наклонена);

CAD – добавена команда Stretch/Разтяга;

CAD – оптимизирано вмъкване на външни чертежи;

CAD – оптимизирана работа с ARM_;

Help – CAD;

Help – Генерация на таблици в CAD;

PCP – Config – Buttons – добавена опция Animation-Blink;

PCP – Config – Buttons – добавена опция Animation-Scale;

PCP – Config – Buttons – добавена опция Animation-Star;

PCP – автоматично синхронизиране/сверяване на локалното време с това от мрежата;

PCP – добавен контрол за вида на грешката при Sentinel;

PCP – добавен контрол за Sentinel drivers – Rescan - soft;

PCP – добавен контрол за Sentinel drivers – Reinstall - hard;

PCP – помощна опция за търсене на добавени нови устройства;

PCP – нов ефект 'магнит' за прозорци/диалози;

PCP – ново custom menu;

PCP – custom menu – добавена опция Animation-Blink;

PCP – нови икони;

PCP – оптимизиран ListView control;

PCP – оптимизиран преглед на диалога при четене и запис на файлове;

PCP – оптимизиран по подразбиране (default) преглед (view) на диалога при четене и запис на файлове;

PCP – оптимизирана работа със служебни символи при наличието им в имената на файловете;

Plugin TAB – Генерация на таблици в CAD;

Plugin TAB – Генерация на таблици в CAD - версия 1.2;

Plugin TAB – Генерация на таблици в CAD - версия 1.3;

Plugin KA – Кофражен/Армировъчен план в CAD - версия 1.5;

Армировка – оптимизирана работа при равни (изчислена - вложена) армировки;

Армировка – оптимизирано предлагани армировки;

Вход – auto convert при четене (b02) на 13.1X версия;

Вход – оптимизарана видимост при подчинени обекти;

Вход – оптимизаран контрол при насадени колони;

Вход – оптимизаран контрол центрове елементи (печати, ...);

Вход – оптимизаран запис при кофражни планове с плочи по МКЕ;

Вход – оптимизаран Undo/Redo - дава вида на стъпката;

Вход – "Характеристики" – добавени опции за площни, линейни и точкови подобекти;

Греди – добавена възможност за преместване на участъците при работа/промяна на греди с лява конзола;

Греди – добавена опция ">" при концентрирани сили, за които не се оразмяряват и чертаят кобилици;

Детайли – auto convert при четене (det) на 13.1X версия;

Детайли – въвеждане/полагане на празен цвят - 248;

Детайли – добавена възможност за промяна реда на чертане;

Детайли – нови детайли за разрези при покрив;

Детайли – оптимизиран текст2 (автоматична промяна ориентацията на текста);

Детайли – оптимизаран Undo/Redo - дава вида на стъпката;

Калкулатор – маркира текущият Unit при Conversions;

Изчисление на кофраж – добавена опция за редукция на всички товари до концентрирани сили;

Изчисление на кофраж – добавена опция за редукция на всички товари до концентрирани сили без действителните такива;

Изчисление на кофраж – оптимизиран контрол и управление за max брой товари при греди;

Изчисление на кофраж – оптимизиран контрол на геометрия при подаваеми опори/греди;

Изчисление на кофраж – оптимизиран контрол на товари при подаваеми опори/греди;

Изчисление на кофраж – оптимизирано управление за max брой товари при греди - автоматично прехвърляне към подходящо решение за да не се губят товари;

Мрежа – добавена опция force chain;

Мрежа – оптимизаран Undo/Redo - дава вида на стъпката;

Печат – добавена втора възможност при работа с Четка - пикселизация;

Печат – добавен контрол върху bitmaps - dpi;

Преглед текст – възможност за четене rtf файл;

Преглед текст – възможност за запис rtf файл;

Преглед текст – възможност за запис html файл;

Преглед текст – възможност за пряк печат;

Преглед текст – възможност за import на windows обекти;

Преглед текст – възможности за ефекти: bold и italic за обща работа с файлове.

Преглед текст – силно разширени възможности за редактиране;

Преглед текст – оптимизирана работа с модула;

Стремена – оптимизирана работа при равни (изчислена - вложена) армировки;

Таблица – добавено синхрон при кликване върху ListBox към съответната клетка от таблицата;

Таблица – добавено Paste from Clipboard;

Таблица – добавено Copy to Clipboard;

Таблица – оптимизирани хоризонтален и вертикален скрол;

Чертане – стартира PCPcad;

Чертане греди – auto convert при четене (g03) на 13.1X версия;

Чертане греди – възможност за маркиране (копиране) при Количества;

Чертане греди – добавена визуализация (червено) при недостиг на армировка;

Чертане греди – добавено пълно комбиниране при надписване на оси;

Чертане греди – оптимизирана логика при автоматична генерация на коти;

Чертане греди – оптимизирана логика при изчитане на сечения (оразмеряване, провисване);

Чертане греди – оптимизирана работа със стремена;

Чертане греди – оптимизиран работа с горна армировка (добавена изчетена армировка);

Чертане греди – оптимизаран Undo/Redo - дава вида на стъпката;

Чертане греди – изчитане на двойна армировка (оразмеряване, провисване);

Чертане греди – изчертаване на допълнителни/втори крайни вертикални линии при запънат край на греда;

Чертане греди – котиране при долна права армировка;

Чертане гредостени – auto convert при четене (s03) на 13.1X версия;

Чертане гредостени – възможност за маркиране (копиране) при Количества;

Чертане гредостени – изведени параметри за изчертаване на S-ове;

Чертане гредостени – добавен min % за армировка при оразмеряване;

Чертане гредостени – добавено пълно комбиниране при надписване на оси;

Чертане гредостени – оптимизаран Undo/Redo - дава вида на стъпката;

Чертане кофраж – auto convert при четене (k03) на 13.1X версия;

Чертане кофраж – възможност за маркиране (копиране) при Количества;

Чертане кофраж – добавен алтернативен ъгъл при генерация/въвеждане на разрези;

Чертане кофраж – добавена визуализация (червено) при недостиг на армировка – полета и опори;

Чертане кофраж – добавено пълно комбиниране при надписване на оси;

Чертане кофраж – оптимизирано въвеждане/редактиране на армировка;

Чертане кофраж – оптимизирано изчертаване рамо на стълбище;

Чертане кофраж – оптимизаран Undo/Redo - дава вида на стъпката;

Чертане кофраж – изведени базови параметри за изчертаване на армировката;

Чертане кофраж – изведен параметър за изчертаване на горна армировка;

Чертане кофраж – изведени параметри за изчертаване на столчета;

Чертане кофраж – наклон за МА и РА в зависимост от ъгъла на снопа армировка;

Чертане на плоча по МКЕ – auto convert при четене (r03) на 13.1X версия;

Чертане на плоча по МКЕ – възможност за маркиране (копиране) при Количества;

Чертане на плоча по МКЕ – добавен min % за армировка при оразмеряване;

Чертане на плоча по МКЕ – добавен алтернативен ъгъл при генерация/въвеждане на разрези;

Чертане на плоча по МКЕ – добавено пълно комбиниране при надписване на оси;

Чертане на плоча по МКЕ – добавен индивидуален процент за завишаване на Qakt при кобилици;

Чертане на плоча по МКЕ – добавен запис за индивидуално задавани характеристики при кобилици;

Чертане на плоча по МКЕ – изведен параметър за изчертаване на горна армировка;

Чертане на плоча по МКЕ – изведен параметър за изчертаване на кобилици;

Чертане на плоча по МКЕ – изведени параметри за изчертаване на столчета;

Чертане на плоча по МКЕ – оптимизирано изчертаване рамо на стълбище;

Чертане на плоча по МКЕ – оптимизирано изчисление на продънване;

Чертане на плоча по МКЕ – оптимизаран Undo/Redo - дава вида на стъпката.

619 [image] 21.11.2005 г. версия 13

DXF export – нова опция за заместване на текст при export;

DXF export – нова опция за конвертиране на коти към AutoCAD dimension;

DXF export – нова опция при конвертиране на коти – text override;

DXF import – вмъква текст;

DXF import – контрол върху стойността на координати (x,y,z);

DXF import – нова опция за заместване на текст при import;

DXF import – добавен контрол за Limits при работа с възли;

DXF import – добавени опции за задаване на абсолютни координати (x,y,z);

DXF import – оптимизирани параметри при текущ запис;

HELP – основно преработен;

PCP – добавени системни числови константи;

PCP – Config – Edit – Popup, възможност за алтернативно;

PCP – Report;

PCP – Дemo – печат оптимизиран;

PCP – в текущият Config е изключен Popup при редактиране;

PCP – добавена функция за работни размери на екрана;

PCP – добавена функция Gaber за запомняне на позиция, размери, стил на всички диалози;

PCP – добавени системни стрингови константи;

PCP – добавена опция Tool Mark;

PCP – добавено Config – Globals – Balloon popups;

PCP – добавено при User – графика;

PCP – добавено при User – редактиране;

PCP – изнесени и ускорени (450%) функции при калкулатор;

PCP – клавиш Shift+Tab;

PCP – клавиш, възможност за аритметични действия/константи/функции при редкат;

PCP – нови изглед на бутони;

PCP – нова възможност за независимо изготвяне и работа с допълнителен език;

PCP – нова функция за предна позиция на прозореца;

PCP – нова функция за центриране на MessageBox;

PCP – оптимизирана работа с User;

PCP – оптимизирана работа с OpenFileDialog (File not found. File already exist.);

PCP – оптимизирана статистика при User – ClipBoard диалог;

PCP – оптимизирана функция Convert;

PCP – оптимизирана функция UCaseCyr;

PCP – оптимизирана функция LCaseCyr;

PCP – подобрен контрол при 3D текст;

PCP – подобрен контрол при MultiRead;

PCP – подобрена обработка на израз при калкулатор (+-, --);

PCP – подобрени ToolTip – Left, Right, Center, Icons;

PCP – при User – име оптимизирано от 22 на 100 символа;

PCP – помни фокус при работа с товари и възли

PCP – увеличен интервал при работа с възли;

Армировка – Get – при двойно кликване с мишката;

Армировка – оптимизирана работа с армировка за m';

Армировка – опция за нулиране при избор на армировка;

Бетони – оптимизиран преглед;

Бетони – оптимизиран избор;

Вход – добавен бутон за диалог видимост;

Вход – добавен бутон за преден изглед;

Вход – Ctrl+G – извиква диалог групи;

Вход – Scroll Lock – обръща посоките на движение;

Вход – auto convert при четене (b02) на 12.XX версия;

Вход – auto връща диалог обекти;

Вход – auto връща последната позиция;

Вход – визуализация на размери/положение колони;

Вход – вмъкнати характеристики за обект;

Вход – възможност за не мащабно изчертаване на силите;

Вход – диалог групи, чрез Shift работа по колони;

Вход – добавен среден клавиш мишка, пан - преместване;

Вход – добавен среден клавиш мишка, скрол - мащабиране;

Вход – добавен среден клавиш мишка - при двойно кликване централна позиция;

Вход – добавен диалог за задаване характеристики на колони;

Вход – добавена възможност за auto генерация на колона по един възел;

Вход – добавена възможност за генерация на собствено тегло при концентиран товар;

Вход – добавена възможност за генерация на собствено тегло при линеен товар;

Вход – добавена възможност за генерация на собствено тегло при площен товар;

Вход – добавена възможност за вмъкване на маркирани L, a, dX, dY, dZ;

Вход – добавена възможност за вмъкване на колоните при четене на обект кофражен план;

Вход – добавена възможност за ефект – светлина при работа с греди и колони;

Вход – добавена възможност при рамки за swap b/h;

Вход – добавена позиция при диалози (tools);

Вход – добавена опция за положителна посока на вертикалните сили;

Вход – добавена опция при пореден номер – auto + 1;

Вход – добавена опция – Zoom X ?, кадър;

Вход – добавена опция Tool Mark за възли;

Вход – добавена опция Tool Mark за елементи;

Вход – добавена таблица възли;

Вход – добавена таблица печати;

Вход – добавена таблица концентрирани товари;

Вход – добавена таблица линейни товари;

Вход – добавена таблица площни товари;

Вход – добавена контрола за Limits при работа с възли;

Вход – добавен клавиш Ctrl+J към Tool Mark;

Вход – добавени геометрични характеристики (L,P,A) за обект;

Вход – добавено графично/auto–zoom определяне на видимост;

Вход – добавено задаване на площен товар, чрез концентрирана сила;

Вход – добавено задаване на разпределен товар, чрез концентрирана сила;

Вход – добавено меню 'Редукции' за работа с обекти;

Вход – добавено ново средство изгледи;

Вход – добавено при копиране на възли да генерира колони;

Вход – добавено размножаване на възли по два възела + трети за разстояние;

Вход – добавено размножаване на възли по два възела и разстояние;

Вход – колона–рамка, взема действителни размери колона;

Вход – към диалог обекти показва брой елементи към обект;

Вход – надписване номера на всички елементи;

Вход – нов диалог за работа с възли;

Вход – оптимизиран диалог координати;

Вход – оптимизирана работа при вмъкване (Ins) на възли, при редактиране на контур;

Вход – оптимизирана работа при задаване линейни опори за греди;

Вход – оптимизирана работа при насадена колона под която има плоча МКЕ;

Вход – оптимизирана работа при обща колона при шайби;

Вход – оптимизирана работа при сума моменти при шайба;

Вход – оптимизирана работа при шайба под ъгъл;

Вход – оптимизирана работа с видимост;

Вход – оптимизирана работа с колони;

Вход – оптимизирана работа с коментари при обекти;

Вход – оптимизирана работа с опори при колони;

Вход – оптимизирана работа с текстове при вертикални товари;

Вход – оптимизирана работа с площни товари;

Вход – оптимизирана работа с линейни товари;

Вход – оптимизирана работа с мрежа/grid;

Вход – оптимизирана работа с концентрирани товари;

Вход – оптимизирана работа с ъгли;

Вход – оптимизирано меню;

Вход – опция Auto, за автоматична работа с площни товари;

Вход – опция Auto, за автоматична работа с колони;

Вход – опция Auto All, за автоматична работа с всички колони;

Вход – опция за работа с действителни размери колони;

Вход – променено викане на диалог "Параметри";

Вход – работа с възли при алтернативен режим;

Вход – силно оптимизирана работа с групи;

Вход – сменен принцип при работа с вложени възли;

Вход – стойностите на моментите се ориентират с auto;

Вход – чертае основата DXF, след обектите;

Вход – чертае с цвят магента товари с посока на горе;

Греди – добавен Esc при пренос на опори и сечения;

Греди – добавен текст (32 символа) при опори греди;

Греди – добавена възможност за auto d = D/2;

Греди – добавена възможност за auto оразмеряване на текущата греда;

Греди – добавена възможност за auto проверка на провисване на текущата греда;

Греди – добавена възможност за генерация на собствено тегло при линеен товар;

Греди – добавена възможност за контрол на max моменти за единична и двойна армировка;

Греди – добавена възможност за приемане на max момент за единична армировка;

Греди – добавени горещи клавиши при оразмеряване и провисване;

Греди – добавени номера на колони от кофражен план;

Греди – добавени сума реакции;

Греди – добавено задаване на разпределен товар, чрез концентрирана сила;

Греди – добавено изчисление на Q ръбово;

Греди – добавено изчисление на Mmax;

Греди – добавено изчисление на M, Q при зададено L;

Греди – добавено представяне на еластичното провисване;

Греди – допълнителна опция за генерация на Befec при необходимост;

Греди – завишени допустими стойности за товари;

Греди – оптимизиран запис на текстов файл Mmax и др.;

Греди – оптимизиран запис след оразмеряване и проверка на провисване;

Греди – оптимизирана визуализация на товари, сечения и опори;

Греди – оптимизиран пренос на товари;

Греди – оптимизиран пренос на дължина сечение, редукция товари;

Греди – оптимизирана работа при Auto за греди - статика;

Греди – оптимизирана работа при задаване на сечения на греди;

Греди – оптимизирана работа при товар 'Собствено тегло';

Греди – оптимизирана работа с d, D;

Греди – оптимизирана работа с интервала за D;

Греди – оптимизирано изчисление на M ръбово;

Греди – обединява в една кобилица, сили при dL< B;

Греди – подава едностранни кобилици при < H до ръба;

Греди – подобрен контрол на моменти в полета и над опори;

Греди – показва светло разстояние;

Греди – пояс, довавени q1, q2;

Греди – пояс, оптимизиран диалог;

Греди – пояс, оптимизиран запис на текстов файл;

Греди – при разпределен триъгълников товар, редактирането се фокусира към значещата стойност;

Греди – при Demo, работа с опорни крайни моменти – запъване;

Греди – чертае с цвят магента товари с посока на горе;

Детайли – auto convert при четене (det) на 12.XX версия;

Детайли – Ctrl+G – извиква диалог групи;

Детайли – Scroll Lock – обръща посоките на движение;

Детайли – диалог групи, чрез Shift работа по колони;

Детайли – добавен среден клавиш мишка, пан - преместване;

Детайли – добавен среден клавиш мишка, скрол - мащабиране;

Детайли – добавен среден клавиш мишка - при двойно кликване централна позиция;

Детайли – добавена възможност за вмъкване на маркирани L, a, dX, dY;

Детайли – добавена възможност за обединяване на еднаквите колони в таблица колони;

Детайли – добавена възможност при местене за фиксирана стъпка на ъгъла (Align);

Детайли – добавена позиция при диалози (tools);

Детайли – добавени два нови детайла;

Детайли – добавено размножаване на възли по два възела + трети за разстояние;

Детайли – добавено размножаване на възли по два възела и разстояние;

Детайли – добавена опция – Zoom X ?, кадър;

Детайли – добавена опция Tool Mark за възли;

Детайли – добавена опция Tool Mark за елементи;

Детайли – добавена контрола за Limits при работа с възли;

Детайли – добавен клавиш Ctrl+J към Tool Mark;

Детайли – изключени групи възли не се прихващат;

Детайли – импорт DXF/DWG + текст;

Детайли – нов детайл печат;

Детайли – нов диалог за работа с възли;

Детайли – оптимизиран диалог координати;

Детайли – оптимизирана работа с изрази;

Детайли – оптимизирана работа с мрежа/grid;

Детайли – оптимизирана работа с таблица колони;

Детайли – оптимизирана работа при таблица колони с рамки;

Детайли – оптимизирана работа с ъгли;

Детайли – оптимизирано меню;

Детайли – променено викане на диалог "Параметри";

Детайли – работа с възли при алтернативен режим;

Детайли – стрингови константи;

Земетръс – auto вмъква гредостени;

Земетръс – при Ctrl файл чете = файл запис;

Изчисление на гредостени – печат на опори q1 и q2;

Изчисление на гредостени – оптимизирано изчисление дължината на някои линейни опори;

Изчисление на кофраж – auto стартиране на Мрежа при липса на обект (r02);

Изчисление на кофраж – добавен автоматичен преглед за безгредови плочи;

Изчисление на кофраж – добавена възможност за auto изчисление на всички греди;

Изчисление на кофраж – добавена възможност за auto изчисление на всички полета;

Изчисление на кофраж – добавена възможност за auto оразмеряване на всички изчислени греди;

Изчисление на кофраж – добавена възможност за auto оразмеряване на текущата греда;

Изчисление на кофраж – добавена възможност за auto проверка на провисване на всички изчислени греди;

Изчисление на кофраж – добавена възможност за auto проверка на провисване на текущата греда;

Изчисление на кофраж – добавена възможност за равномерно разпределен товар с q1 - q2 при МКЕ (линейни опори);

Изчисление на кофраж – добавена възможност за работа без полета;

Изчисление на кофраж – добавени горещи клавиши при полета, греди, оразмеряване и провисване;

Изчисление на кофраж – оптимизиран преглед при товари за греди;

Изчисление на кофраж – оптимизирана работа при концентрирани сили за греди;

Изчисление на кофраж – оптимизирано четене на Mmax;

Изчисление на кофраж – обединява в една кобилица, сили при dL< B;

Изчисление на кофраж – подава едностранни кобилици при < H до ръба;

Изчисление на кофраж – подобрено управление на кофраж;

Изчисление на кофраж – предава auto номера на колони към греди;

Изчисление на кофраж – чете и подава действителни размери/положение колони, като опори греди;

Калкулатор – добавени Functions f00–f99;

Калкулатор – достъп до всички модули;

Калкулатор – нов пример;

Калкулатор – нов шрифт (ttf);

Калкулатор – нова възможност за бърза работа с външни функции Fun();

Калкулатор – оптимизиран преглед при Conversions;

Калкулатор – оптимизирана работа при оператор STEP;

Калкулатор – оптимизирани цветове;

Калкулатор – промяна размера на шрифта;

Калкулатор – работа с Functions;

Калкулатор – стрингови константи $c0–99;

Калкулатор – числови константи %c0–99;

Материали – нов модул с характеристики на материалите;

Мрежа – Ctrl+G – извиква диалог групи;

Мрежа – Scroll Lock – обръща посоките на движение;

Мрежа – auto връща последната позиция;

Мрежа – връща позиция след работа с възли;

Мрежа – възможност за не мащабно изчертаване на силите;

Мрежа – диалог групи, чрез Shift работа по колони;

Мрежа – добавен бутон за диалог таблици;

Мрежа – добавен бутон за преден изглед;

Мрежа – добавен среден клавиш мишка, пан - преместване;

Мрежа – добавен среден клавиш мишка, скрол - мащабиране;

Мрежа – добавен среден клавиш мишка - при двойно кликване централна позиция;

Мрежа – добавена възможност за вмъкване на маркирани L, a, dX, dY, dZ;

Мрежа – добавена възможност за генерация на собствено тегло при концентиран товар;

Мрежа – добавена опция за положителна посока на вертикалните сили;

Мрежа – добавена опция – Zoom X ?, кадър;

Мрежа – добавена опция Tool Mark за възли;

Мрежа – добавена опция Tool Mark за елементи;

Мрежа – добавена контрола за Limits при работа с възли;

Мрежа – добавен клавиш Ctrl+J към Tool Mark;

Мрежа – добавена позиция при диалози (tools);

Мрежа – добавено размножаване на възли по два възела + трети за разстояние;

Мрежа – добавено размножаване на възли по два възела и разстояние;

Мрежа – нов диалог за работа с възли;

Мрежа – оптимизирана дебелина печати;

Мрежа – оптимизиран диалог координати;

Мрежа – оптимизирана работа с мрежа/grid;

Мрежа – оптимизирана работа с ъгли;

Мрежа – оптимизирана разбивка при частен случай;

Мрежа – оптимизирано меню;

Мрежа – променено викане на диалог "Параметри";

Мрежа – работа с възли при алтернативен режим;

Мрежа – стойностите на моментите се ориентират с auto;

Мрежа – чертае с цвят магента товари с посока на горе;

Оразмеряване – допълнителна опция за генерация на Befec при необходимост;

Оразмеряване – оптимизиране при закръгляне на конструктивна армировка;

Оразмеряване – оптимизирано при празен запис към греда;

Оразмеряване – променено съобщение за проверка при обърнато сечение;

Оразмеряване – работа с едностранни кобилици;

Печат – генерация на header и footer за страница;

Печат – добавен среден клавиш мишка, пан - преместване;

Печат – добавен среден клавиш мишка, скрол - мащабиране;

Печат – добавен среден клавиш мишка - при двойно кликване централна позиция;

Печат – възможност за стрингови константи при header и footer;

Печат – възможност за convert на header и footer;

Печат – наредба на изчетените текстови файлове – drag and drop;

Печат – нова възможност за местене/копиране на страници;

Поле – добавена възможност за генерация на собствено тегло при площен товар;

Поле – оптимизиран преглед товари;

Преглед текст – възможност за печат при редактиран/променен файл;

Преглед текст – добавен среден клавиш мишка, скрол текст;

Преглед текст – добавен текстов контрол при маркери;

Преглед текст – записва размера на текущият шрифт;

Преглед текст – контрол при промяна на файла от друга програма;

Провисване – добавено представяне на еластичното провисване + отношението с пластичното;

Провисване – допълнителна опция за генерация на Befec при необходимост;

Провисване – оптимизирано при празен запис към греда;

Профили – оптимизирани add, edit при сортирано;

Плоча по МКЕ – опция Rz за извършване на итерации при обратен знак на земната реакция;

Плоча по МКЕ – печат на опори q1 и q2;

Плоча по МКЕ – оптимизирано изчисление дължината на някои линейни опори;

Рамки – комбинации – елементи под ъгъл;

Ревю – Ctrl+G – извиква диалог групи;

Ревю – Scroll Lock – обръща посоките на движение;

Ревю – auto връща последната позиция;

Ревю – връща позиция след работа с разрези;

Ревю – въвеждане на текст става, като auto склопява в равнина;

Ревю – възможност за не мащабно изчертаване на силите;

Ревю – генерация на нови скали 2D при плочи, гредостени и температури;

Ревю – горещи клавиши за групи;

Ревю – диалог групи – изцяло променен в стил tree;

Ревю – диалог групи – автоматично опреснява екрана;

Ревю – добавен контрол при текст на разрези;

Ревю – добавен среден клавиш мишка, пан - преместване;

Ревю – добавен среден клавиш мишка, скрол - мащабиране;

Ревю – добавен среден клавиш мишка - при двойно кликване централна позиция;

Ревю – добавен пласт 'Направление Q' при температурни полета;

Ревю – добавена възможност при разрези за фиксирана стъпка на ъгъла (Align);

Ревю – добавена позиция при диалози (tools);

Ревю – добавена опция – Zoom X ?, кадър;

Ревю – добавени разрези M, Q - диаграми - греди;

Ревю – добавени разрези M, Q, N - диаграми - рамки;

Ревю – добавени разрези M, Q, N - диаграми - сеизмично изследване (шайби и рамки);

Ревю – добавени разрези M, Q, N - комбинации;

Ревю – добавени разрези армировка (надлъжна и напречна) - комбинации;

Ревю – елементи под ъгъл;

Ревю – маркиране в менюто на използуваните/пуснатите групи;

Ревю – обръща повърхнината при отрицателен параметър (Lmax/–8);

Ревю – оптимизиран прозорец за време;

Ревю – опция All при текст;

Ревю – подобрен преден изглед;

Ревю – подобрен филтър при гредостена - опори;

Ревю – подобрен филтър при плоча по МКЕ - опори;

Ревю – подобрен филтър при земетръс;

Ревю – променено викане на диалог "Параметри";

Ревю – стойностите на моментите се ориентират с auto;

Ревю – стрингови константи;

Ревю – филтър греди, добавен слой M-ръбово;

Ревю – филтър греди, добавен слой Q-ръбово;

Ревю – филтър греди, преименуван и оптимизиран слой Реакции в Опори;

Ревю – филтър греди, оптимизиран слой Коти;

Ревю – чертае с цвят магента товари с посока на горе;

Сорт – оптимизирана работа при въпрос;

Спецификация на армировка – добавени железа с дължини от – до;

Спецификация на армировка – добавено произволно желязо/детайл като пълноценна армировка;

Спецификация на армировка – оптимизирана работа;

Спецификация на армировка – оптимизирана работа при MA;

Спецификация на армировка – оптимизирана работа при генерация на DXF/DWG;

Спецификация на армировка – оптимизирани цветове, таблица;

Стойност – нов модул;

Стомани – оптимизиран преглед;

Стомани – оптимизиран избор;

Стомани – подобрена работа със знак армировка;

Стремена – Get – при двойно кликване с мишката;

Таблица – Shift+Enter – назад по колони;

Таблица – Shift+Tab – назад по редове;

Таблица – добавен Control;

Таблица – добавен Swap;

Таблица – добавен Calc;

Таблица – добавено локализиране на работната точка;

Таблица – добавен среден клавиш мишка, скрол текст;

Таблично оразмеряване – възможност за hide/unhide на всички елементи – таблично;

Таблично оразмеряване – възможност за hide/unhide на всички етажи от елемент;

Таблично оразмеряване – добавена възможност за auto swap B/H;

Таблично оразмеряване – добавена възможност/опция за генерация на товар от собствено тегло;

Таблично оразмеряване – елементи под ъгъл;

Таблично оразмеряване – оптимизирана работа при задаване на допълнителни колони;

Таблично оразмеряване – оптимизирана работа при работа с рамки;

Таблично оразмеряване – чете действителни размери колони;

Температурно поле – оптимизирано изчисление дължината на някои гранични условия;

Фундамент – добавена възможност за генерация на собствено тегло при концентриран товар;

Фундамент – добавена възможност за задаване на имена на пластовете при слягане;

Фундамент – добавена възможност за преизчисляване на R, след задаване на a,b и h;

Фундамент – добавена възможност за отчет на напрежение и слягане за произволна дълбочина;

Фундамент – оптимизирано изчисление на слягане през 1 cm;

Фундамент – оптимизирано определяне на приведено R;

Фундамент – оптимизирано актуализиране за вложена армировка;

Фундамент – оптимизирани интервали за характерисиките на пластовете при слягане;

Чертане греди – auto convert при четене (g03) на 12.XX версия;

Чертане греди – Ctrl+G – извиква диалог групи;

Чертане греди – S–ове добавени стомана, диаметър и разстояние;

Чертане греди – Scroll Lock – обръща посоките на движение;

Чертане греди – вмъква детайли от друг обект;

Чертане греди – диалог групи, чрез Shift работа по колони;

Чертане греди – диалог печат;

Чертане греди – добавен % за горната армировка от долната армировка;

Чертане греди – добавен % за средната армировка от площта на сечението;

Чертане греди – добавен среден клавиш мишка, пан - преместване;

Чертане греди – добавен среден клавиш мишка, скрол - мащабиране;

Чертане греди – добавен среден клавиш мишка - при двойно кликване централна позиция;

Чертане греди – добавен текст (32 символа) при опори греди;

Чертане греди – добавена възможност за вмъкване на маркирани L, a, dX, dY;

Чертане греди – добавена възможност за въвеждане на наклонени коти – Alt;

Чертане греди – добавена възможност за връщане назад при въвеждане на коти – BackSpace;

Чертане греди – добавена възможност при въвеждане на коти за прихващане на оси;

Чертане греди – добавена възможност при въвеждане на коти за автоматична перпендикулярност на котата към първия прихванат елемент – Alt;

Чертане греди – добавена възможност за параметрично изчертаване рамката на чертежа;

Чертане греди – добавена възможност при местене за фиксирана стъпка на ъгъла (Align);

Чертане греди – добавена логика за над един ред долна армировка;

Чертане греди – добавена опция за пренареждане на гредите в рамките на листа;

Чертане греди – добавена опция – Ctrl+A, за прехващане и редактиране на армировка;

Чертане греди – добавена опция Tool Mark за възли;

Чертане греди – добавена опция Tool Mark за елементи;

Чертане греди – добавена контрола за Limits при работа с възли;

Чертане греди – добавен клавиш Ctrl+J към Tool Mark;

Чертане греди – добавена позиция при диалози (tools);

Чертане греди – добавена опция – Zoom X ?, кадър;

Чертане греди – добавени 1–9 срезни стремена;

Чертане греди – добавени количества на материалите;

Чертане греди – добавени номера на колони от кофражен план;

Чертане греди – добавено произволно желязо/детайл като пълноценна армировка в спецификацията по фигури;

Чертане греди – добавено размножаване на възли по два възела + трети за разстояние;

Чертане греди – добавено размножаване на възли по два възела и разстояние;

Чертане греди – изключени групи възли не се прихващат;

Чертане греди – кобилици, опции за auto b и h;

Чертане греди – надписване размери и полета до mm;

Чертане греди – надписване сечения до mm;

Чертане греди – нов диалог за работа с възли;

Чертане греди – оптимизиран диалог координати;

Чертане греди – оптимизирана логика за средна армировка;

Чертане греди – оптимизирана настройка – чертане;

Чертане греди – оптимизирана работа с мрежа/grid;

Чертане греди – оптимизирана работа с ъгли;

Чертане греди – оптимизирани размери при крайни опори и запъване;

Чертане греди – оптимизирани количества на кофраж и бетон при детайли;

Чертане греди – оптимизирани количества на кофраж, бетон и армировка при скрити детайли;

Чертане греди – оптимизирано добавяне на греди при режим редактиране;

Чертане греди – оптимизирано меню;

Чертане греди – оптимизирано пренареждане на усилители и средна армировка;

Чертане греди – оптимизирано четене на Mmax;

Чертане греди – оптимизирано четене размери на опори;

Чертане греди – оптимизирано четене на усилители;

Чертане греди – оптимизирано четене на кoнзoли;

Чертане греди – оптимизирано представяне на Lmin при армировка над опори;

Чертане греди – опция All при текст;

Чертане греди – обединява в една кобилица, сили при dL< B;

Чертане греди – при едностранни кобилици, автоматично разпознаване на вида им;

Чертане греди – при четене и различен диаметър, тълкува прави + огънати;

Чертане греди – променено викане на диалог "Параметри";

Чертане греди – работа с възли при алтернативен режим;

Чертане греди – стрингови константи;

Чертане гредостени – auto convert при четене (s03) на 12.XX версия;

Чертане гредостени – Ctrl+G – извиква диалог групи;

Чертане гредостени – Scroll Lock – обръща посоките на движение;

Чертане гредостени – вмъква детайли от друг обект;

Чертане гредостени – вмъква зони от друг обект;

Чертане гредостени – диалог групи, чрез Shift работа по колони;

Чертане гредостени – диалог печат;

Чертане гредостени – добавен среден клавиш мишка, пан - преместване;

Чертане гредостени – добавен среден клавиш мишка, скрол - мащабиране;

Чертане гредостени – добавен среден клавиш мишка - при двойно кликване централна позиция;

Чертане гредостени – добавена възможност за вмъкване на маркирани L, a, dX, dY;

Чертане гредостени – добавена възможност за въвеждане на наклонени коти – Alt;

Чертане гредостени– добавена възможност за връщане назад при въвеждане на коти – BackSpace;

Чертане гредостени – добавена възможност при въвеждане на коти за прихващане на оси;

Чертане гредостени – добавена възможност при въвеждане на коти за автоматична перпендикулярност на котата към първия прихванат елемент – Alt;

Чертане гредостени – добавена възможност за параметрично изчертаване рамката на чертежа;

Чертане гредостени – добавена възможност при местене за фиксирана стъпка на ъгъла (Align);

Чертане гредостени – добавена позиция при диалози (tools);

Чертане гредостени – добавено задаване на точен брой железа в зона;

Чертане гредостени – добавено произволно желязо/детайл като пълноценна армировка в спецификацията по фигури;

Чертане гредостени – добавена опция – Ctrl+A, за прехващане и редактиране на армировка;

Чертане гредостени – добавена опция – Zoom X ?, кадър;

Чертане гредостени – добавена опция Tool Mark за възли;

Чертане гредостени – добавена опция Tool Mark за елементи;

Чертане гредостени – добавена контрола за Limits при работа с възли;

Чертане гредостени – добавен клавиш Ctrl+J към Tool Mark;

Чертане гредостени – добавени количества на материалите;

Чертане гредостени – добавено размножаване на възли по два възела + трети за разстояние;

Чертане гредостени – добавено размножаване на възли по два възела и разстояние;

Чертане гредостени – изключени групи възли не се прихващат;

Чертане гредостени – нов диалог за работа с възли;

Чертане гредостени – нова възможност за задаване конкретни или параметрични стойности на изолиниите – auto, групи и др.;

Чертане гредостени – нова възможност за задаване на брой железа на m' и строеж на изолинии за диаметър;

Чертане гредостени – нова възможност за задаване на диаметър и строеж на изолинии за брой железа на m';

Чертане гредостени – нова опция за базова армировка при стойности на изолинии;

Чертане гредостени – оптимизация при работа с брой мрежи;

Чертане гредостени – оптимизиран диалог координати;

Чертане гредостени – оптимизирана визуализация при изолинии;

Чертане гредостени – оптимизирана работа – спецификация при една MA/РА;

Чертане гредостени – оптимизирана работа при вход мрежи;

Чертане гредостени – оптимизирана работа при вход мрежи - армировка;

Чертане гредостени – оптимизирана работа при изчисление на окончателен брой железа в зона;

Чертане гредостени – оптимизирана работа с армировка;

Чертане гредостени – оптимизирана работа с индивидуална армировка при базова;

Чертане гредостени – оптимизирана работа с индивидуална армировка при зони;

Чертане гредостени – оптимизирана работа с диалог изолинии при армировка;

Чертане гредостени – оптимизирана работа с мрежа/grid;

Чертане гредостени – оптимизирана работа с ъгли;

Чертане гредостени – оптимизирани количества на кофраж, бетон и армировка при скрити детайли;

Чертане гредостени – оптимизирано меню;

Чертане гредостени – опция All при текст;

Чертане гредостени – променено викане на диалог "Параметри";

Чертане гредостени – работа с възли при алтернативен режим;

Чертане гредостени – стрингови константи;

Чертане гредостени – силно оптимизирана работа с армировка/изолинии;

Чертане гредостени – чертае армировка в зони – две опции;

Чертане кофраж – auto convert при четене (k03) на 12.XX версия;

Чертане кофраж – Ctrl+G – извиква диалог групи;

Чертане кофраж – Scroll Lock – обръща посоките на движение;

Чертане кофраж – вмъква греди от друг обект;

Чертане кофраж – вмъква детайли от друг обект;

Чертане кофраж – вмъква колони от друг обект;

Чертане кофраж – диалог групи, чрез Shift работа по колони;

Чертане кофраж – диалог печат;

Чертане кофраж – добавен среден клавиш мишка, пан - преместване;

Чертане кофраж – добавен среден клавиш мишка, скрол - мащабиране;

Чертане кофраж – добавен среден клавиш мишка - при двойно кликване централна позиция;

Чертане кофраж – добавена възможност за вмъкване на маркирани L, a, dX, dY;

Чертане кофраж – добавена възможност за параметрично изчертаване рамката на чертежа;

Чертане кофраж – добавена възможност при местене за фиксирана стъпка на ъгъла (Align);

Чертане кофраж – добавена възможност при колони за swap Lx/Ly;

Чертане кофраж – добавена възможност за наклонени секущи при разрез – Alt;

Чертане кофраж – добавена възможност за въвеждане на наклонени коти – Alt;

Чертане кофраж – добавена възможност за връщане назад при въвеждане на коти – BackSpace;

Чертане кофраж – добавена възможност при въвеждане на коти за прихващане на колони и оси;

Чертане кофраж – добавена възможност при въвеждане на коти за избор на прихванат елемент (греда, колона, ос);

Чертане кофраж – добавена възможност при въвеждане на коти за автоматична перпендикулярност на котата към първия прихванат елемент – Alt;

Чертане кофраж – добавена позиция при диалози (tools);

Чертане кофраж – добавена опция – Ctrl+A, за прехващане и редактиране на армировка;

Чертане кофраж – добавена опция – Zoom X ?, кадър;

Чертане кофраж – добавена опция Tool Mark за възли;

Чертане кофраж – добавена опция Tool Mark за елементи;

Чертане кофраж – добавена контрола за Limits при работа с възли;

Чертане кофраж – добавен клавиш Ctrl+J към Tool Mark;

Чертане кофраж – добавени количества за бетон;

Чертане кофраж – добавени количества на материалите;

Чертане кофраж – добавено произволно желязо/детайл като пълноценна армировка в спецификацията по фигури;

Чертане кофраж – добавено размножаване на възли по два възела + трети за разстояние;

Чертане кофраж – добавено размножаване на възли по два възела и разстояние;

Чертане кофраж – изключени групи възли не се прихващат;

Чертане кофраж – нов диалог за работа с възли;

Чертане кофраж – оптимизиран диалог координати;

Чертане кофраж – оптимизиран диалог при четене размери на клони;

Чертане кофраж – оптимизирана работа с армировка;

Чертане кофраж – оптимизирана работа с мрежа/grid;

Чертане кофраж – оптимизирана работа с ъгли;

Чертане кофраж – оптимизирани количества на кофраж, бетон и армировка при скрити детайли;

Чертане кофраж – оптимизирано меню;

Чертане кофраж – оптимизирано надписване размери колони;

Чертане кофраж – оптимизирано надписване коти разрези;

Чертане кофраж – оптимизирано при изчертаване на обратни греди;

Чертане кофраж – опция All при текст;

Чертане кофраж – променено викане на диалог "Параметри";

Чертане кофраж – работа с възли при алтернативен режим;

Чертане кофраж – стрингови константи;

Чертане кофраж – чете и чертае действителни размери/положение колони;

Чертане на плоча по МКЕ – auto convert при четене (r03) на 12.XX версия;

Чертане на плоча по МКЕ – Ctrl+G – извиква диалог групи;

Чертане на плоча по МКЕ – Ctrl+K – извиква диалог продънване;

Чертане на плоча по МКЕ – Scroll Lock – обръща посоките на движение;

Чертане на плоча по МКЕ – вмъква греди от друг обект;

Чертане на плоча по МКЕ – вмъква детайли от друг обект;

Чертане на плоча по МКЕ – вмъква зони от друг обект;

Чертане на плоча по МКЕ – вмъква колони от друг обект;

Чертане на плоча по МКЕ – генерация на списък (txt) при оразмеряване на продънване;

Чертане на плоча по МКЕ – диалог групи, чрез Shift работа по колони;

Чертане на плоча по МКЕ – диалог печат;

Чертане на плоча по МКЕ – добавен отчет на момент при продънване;

Чертане на плоча по МКЕ – добавен контрол на товари;

Чертане на плоча по МКЕ – добавен контрол на оопори;

Чертане на плоча по МКЕ – добавен среден клавиш мишка, пан - преместване;

Чертане на плоча по МКЕ – добавен среден клавиш мишка, скрол - мащабиране;

Чертане на плоча по МКЕ – добавен среден клавиш мишка - при двойно кликване централна позиция;

Чертане на плоча по МКЕ – добавена възможност за вмъкване на маркирани L, a, dX, dY;

Чертане на плоча по МКЕ – добавена възможност за параметрично изчертаване рамката на чертежа;

Чертане на плоча по МКЕ – добавена възможност при колони за swap Lx/Ly;

Чертане на плоча по МКЕ – добавена възможност за наклонени секущи при разрез – Alt;

Чертане на плоча по МКЕ – добавена възможност за въвеждане на наклонени коти – Alt;

Чертане на плоча по МКЕ – добавена възможност за връщане назад при въвеждане на коти – BackSpace;

Чертане на плоча по МКЕ – добавена възможност при въвеждане на коти за прихващане на колони и оси;

Чертане на плоча по МКЕ – добавена възможност при въвеждане на коти за избор на прихванат елемент (греда, колона, ос);

Чертане на плоча по МКЕ – добавена възможност при въвеждане на коти за автоматична перпендикулярност на котата към първия прихванат елемент – Alt;

Чертане на плоча по МКЕ – добавена възможност при местене за фиксирана стъпка на ъгъла (Align);

Чертане на плоча по МКЕ – добавена позиция при диалози (tools);

Чертане на плоча по МКЕ – добавена сеизмична комбинация за почвена реакция;

Чертане на плоча по МКЕ – добавена опция – Ctrl+A, за прехващане и редактиране на армировка;

Чертане на плоча по МКЕ – добавена опция – Zoom X ?, кадър;

Чертане на плоча по МКЕ – добавена опция Tool Mark за възли;

Чертане на плоча по МКЕ – добавена опция Tool Mark за елементи;

Чертане на плоча по МКЕ – добавена контрола за Limits при работа с възли;

Чертане на плоча по МКЕ – добавени количества на материалите;

Чертане на плоча по МКЕ – добавен клавиш Ctrl+J към Tool Mark;

Чертане на плоча по МКЕ – добавени изолинии за почвена реакция – комбинация;

Чертане на плоча по МКЕ – добавени при комбиниране реакции и сили;

Чертане на плоча по МКЕ – добавено задаване на точен брой железа в зона;

Чертане на плоча по МКЕ – добавено произволно желязо/детайл като пълноценна армировка в спецификацията по фигури;

Чертане на плоча по МКЕ – добавено размножаване на възли по два възела + трети за разстояние;

Чертане на плоча по МКЕ – добавено размножаване на възли по два възела и разстояние;

Чертане на плоча по МКЕ – изключени групи възли не се прихващат;

Чертане на плоча по МКЕ – нов диалог за работа с възли;

Чертане на плоча по МКЕ – нова възможност за задаване конкретни или параметрични стойности на изолиниите – auto, групи и др.;

Чертане на плоча по МКЕ – нова възможност за задаване на брой железа на m' и строеж на изолинии за диаметър;

Чертане на плоча по МКЕ – нова възможност за задаване на диаметър и строеж на изолинии за брой железа на m';

Чертане на плоча по МКЕ – нова възможност за задаване стомана при кобилици;

Чертане на плоча по МКЕ – нова възможност за задаване на закотвяне в cm при кобилици;

Чертане на плоча по МКЕ – нова възможност за ъгъл на огъване при кобилици;

Чертане на плоча по МКЕ – нова опция за базова армировка при стойности на изолинии;

Чертане на плоча по МКЕ – нова опция, оразмеряване/комбиниране само за Mx и My;

Чертане на плоча по МКЕ – оптимизиран диалог координати;

Чертане на плоча по МКЕ – оптимизирана визуализация при изолинии;

Чертане на плоча по МКЕ – оптимизирано оразмеряване при зададен радиус на обработка;

Чертане на плоча по МКЕ – оптимизирана работа – спецификация при една MA/РА;

Чертане на плоча по МКЕ – оптимизирана работа при вход мрежи;

Чертане на плоча по МКЕ – оптимизирана работа при вход мрежи - армировка;

Чертане на плоча по МКЕ – оптимизирана работа при изчисление на окончателен брой железа в зона;

Чертане на плоча по МКЕ – оптимизирана работа с армировка;

Чертане на плоча по МКЕ – оптимизирана работа с мрежа/grid;

Чертане на плоча по МКЕ – оптимизирана работа с ъгли;

Чертане на плоча по МКЕ – оптимизирана работа с възли за обработка/закръгляне при опори;

Чертане на плоча по МКЕ – оптимизирана възможност при опция възли – показва възлите за обработка/закръгляне + R на обработка;

Чертане на плоча по МКЕ – оптимизирана работа с индивидуална армировка при базова;

Чертане на плоча по МКЕ – оптимизирана работа с индивидуална армировка при зони;

Чертане на плоча по МКЕ – оптимизирана работа с диалог изолинии при армировка;

Чертане на плоча по МКЕ – оптимизирани количества на кофраж, бетон и армировка при скрити детайли;

Чертане на плоча по МКЕ – оптимизирано меню;

Чертане на плоча по МКЕ – оптимизирано надписване размери колони;

Чертане на плоча по МКЕ – оптимизирано надписване коти разрези;

Чертане на плоча по МКЕ – оптимизирано при изчертаване на обратни греди;

Чертане на плоча по МКЕ – опция All при текст;

Чертане на плоча по МКЕ – променено викане на диалог "Параметри";

Чертане на плоча по МКЕ – пусната от – до промяна за столчетата на зоните;

Чертане на плоча по МКЕ – работа с възли при алтернативен режим;

Чертане на плоча по МКЕ – стрингови константи;

Чертане на плоча по МКЕ – силно оптимизирана работа с армировка/изолинии;

Чертане на плоча по МКЕ – чертае армировка в зони – две опции;

Чертане на плоча по МКЕ – чете и чертае действителни размери/положение колони.

62 [image] 10.09.2003 г. версия 13

All – при бутони със стомана бройки/диаметър добавен tooltip с cm2;

All – при критичните процеси са добавени допълнителни Thread за по-добро управление и контрол;

All – силно подобрена работа при разпознаване на материали по име;

DXF export – export DWG файлове;

DXF export – нова опция за генерация или не на текстов файл с количества;

DXF import – import DWG файлове;

DXF import – добавена опция за max segment length;

DXF import – оптимизиран import;

HELP – оптимизиран и актуализиран;

PCP – актуализирана функция multi selection при избор на файлове;

PCP – актуализирана функция за запаметени файлове/директории при работа с дискети;

PCP – актуализирана функция за моментна наличност за запаметени файлове/директории;

PCP – оптимизиран tooltip;

PCP – оптимизиран пренос на данни между модулите;

TASK – в Info добавен език;

TASK – в Info добавена държава;

TASK – оптимизиран Info;

Бетони – добавен табличен преглед, сортиране;

Бетони – добавени нови;

Бетони – подобрена работа при поле без материал;

Бетони – увеличение на до 50;

Вход – нова възможност за задаване на нулеви линейни опори, върху които впоследствие могат да се зададат стени, бордове;

Вход – площните товари могат да се задават автоматично върху контури и типове;

Вход – подобрена работа с греди генерирани от рамки;

Вход – подобрена работа с греди генерирани от шайби;

Вход – при кофражен план нов обект 'принадлежащи възли' за по-добра работа с греди генерирани от рамки и шайби;

Греда – добавен диалог за групова промяна на опорни моменти с коефициент;

Детайли – нови характеристики при редакт елемент: дължина, периметър, площ;

Изчисление на плоча по МКЕ – нова възможност при етажна/фундамента с 3/6 за изчисление на стени, бордове (допълнителна коравина);

Косо оразмеряване – армировки над 255;

Кофражен план – при задаване на подаваеми греди – връзка с профили/сечения;

Мрежа – възможност за прекъсване на процеса на разбиване на мрежата за да се локализират критичните зони;

Мрежа – горещ клавиш за таблици Ctrl–T;

Мрежа – нова възможност за задаване на сечения при стени, бордове;

Мрежа – нова възможност за задаване на сечения – опция стени, бордове;

Мрежа – оптимизиран New;

Мрежа – оптимизиран текущ запис;

Мрежа – при задаване на стени, бордове – връзка с профили;

Мрежа – типове разширени над 255;

Печат – оптимизирана мрежа 5/5 mm;

Печат – оптимизирана четка;

Печат – подобрен избор на начина на генерация на печата;

Печат – подобрена визуализация;

Плоча по МКЕ – типове разширени над 255;

Провисване – оптимизирана работа със стомана;

Профили – нов модул. Каталози на EuroCOD, ГОСТ, ASTM, BS, DIN, добавяне на свои, сортиране и др.;

Рамки – връзка с профили/сечения;

Ревю – нова възможност за генерация на цветове по дъга;

Стомани – добавен табличен преглед, сортиране;

Стомани – добавена опция за изчертаване на куки при стомани;

Стомани – добавени нови;

Стомани – подобрена работа при поле без материал;

Стомани – увеличение на до 50;

Температурно поле – типове разширени над 255;

Чертане кофраж – оптимизирано изчертаване на знака за всеки вид армировка;

Чертане кофраж – при редакт на армировка, добавена опция move

Чертане кофраж – при редакт на армировка, добавени отделни/различни стомани за всяко желязо;

Чертане кофраж – при редакт на армировка, подобрена актуализация на чертежа;

Чертане кофраж – при редакт на армировка, силно подобрена работа с контрол на армировката;

Чертане плоча по МКЕ – подобрен алгоритъм за продънване – spline;

Чертане плоча по МКЕ – подобрен алгоритъм за продънване – външен периметър;

Шайба – типове разширени над 255.

169 [image] 07.05.2003 г. версия 13

DXF export – вмъква използваните типове линии при съответния мащаб;

DXF export – изцяло оптимизиран – препоръчва се (в диалога това вече с приоритет/отпред);

DXF export – подобрена генерация на тип линия;

DXF export – подобрена оптимизация при търсене на max координата;

DXF export – подобрена работа с blocks;

DXF export – подобрена работа с layer за 3Dface;

DXF export – подобрена работа с layers;

PCP – актуализиран адрес за връзка;

PCP – в config възможност за избор на WinXP style;

PCP – добавени два нови файла при примерите \exm.avi;

PCP – актуализиран Task;

PCP – актуализиран контрол време;

PCP – tab control възможност за disable;

PCP – tab control оптимизиран;

PCP – актуализиран импорт към ClipBoard при статистика;

PCP – нови бутони в диалог;

PCP – ново таблицата при едит с позиция;

PCP – оптимизирано меню;

PCP – подобрена визуализация на линейни опори – направление и текст;

PCP – подобрена работа на Files/Folders;

PCP – силно оптимизирана работа при запис на обекти с контрол;

PCP – тъмните цветове леко по светли (по добра видимост);

PCP – филтри – надписва център печати;

PCP – филтри – надписва център товари;

SCRIPT – генерира се вече за Windows базиран AutoCAD;

SCRIPT – не се инсталира вече DOS AutoCAD;

Армировка – подобрена работа с brush;

Вход – в плоча по МКЕ конвертиране от печати в концентрирани сили и обратно;

Вход – добавени възможности за генерация на окръжности по R, D, 3T, c–R, c–D;

Вход – добавени възможности за генерация на правоъгълник по D1_D2, c Lx,Ly;

Вход – добавени възможността за генерация на елипси по D1_R1, R1_R2, c–R1_R2, c–D1_D2;

Вход – конвертиране на плоча по МКЕ към обект изключване на опън и обратно;

Вход – надписва център печати;

Вход – надписва център товари;

Вход – нова възможност за надписване координати на възли;

Вход – по маркирани възли генерира spline – отворен/затворен;

Вход – подобрен вход и редактиране на възли;

Вход – подобрено име при подчинен обект на кофраж – плоча по МКЕ;

Вход – редактиране на обект по номер;

Детайли – автоматично преконфигуриране при размер на лист, мащаб и коефициент за текст;

Детайли – добавени възможности за генерация на елипси по D1_R1, R1_R2, c–R1_R2, c–D1_D2;

Детайли – добавени възможности за генерация на правоъгълник по D1_D2, c_Lx,Ly;

Детайли – добавени възможността за генерация на окръжности по R, D, 3T, c–R, c–D;

Детайли – задаване на окръжност по радиус/диаметър;

Детайли – нова възможност за работа/структуриране по групи;

Детайли – по маркирани възли генерира spline – отворен/затворен;

Детайли – поддръжка на AutоCAD цветове – ACI, 255 цвята;

Детайли – поддръжка на нови 25 типа линии;

Детайли – подобрен вход и редактиране на възли;

Детайли – подобрена работа при избор на лист;

Детайли – подобрена таблица колони;

Детайли – подобрено изчертаване на pline с дебелина 0;

Детайли – при задаване на контур, нова опция spline;

Детайли – при задаване на полигон, нова опция spline;

Детайли – променен клавиш за видимост на статус;

Детайли – увеличение и намаление на текст (като в модулите за чертане);

Език – подобрено избиране по ID;

Земетръс – нова възможност за произволно подпиране на рамки при сеизмично изследване;

Земетръс – подобрен печат на рамки;

Изчисление на гредостени – нова възможност за задаване на премествания;

Изчисление на гредостени – нова възможност за задаване на пружини;

Изчисление на гредостени – поддръжка на "стар" формат файлове;

Изчисление на гредостени – подобрен контрол при тълкуване на линейни опори;

Изчисление на гредостени – подобрен контрол/печат на реакции;

Изчисление на гредостени – подобрена таблица за единични опори;

Изчисление на гредостени – подобрена таблица за линейни опори;

Изчисление на кофраж – поддръжка на "стар" формат файлове;

Изчисление на кофраж – подобрен контрол на сума колони и тежестен център;

Изчисление на кофраж – при изчисление на плоча по МКЕ, нова възможност за задаване на сечение/характеристики, материал за отчитане подаването на гредите при съвместната работа с плочата;

Изчисление на плоча по МКЕ – нова възможност за задаване на премествания/завъртания;

Изчисление на плоча по МКЕ – нова възможност за задаване на пружини;

Изчисление на плоча по МКЕ – поддръжка на "стар" формат файлове;

Изчисление на плоча по МКЕ – подобрен контрол при тълкуване на линейни опори;

Изчисление на плоча по МКЕ – подобрен контрол/печат на реакции;

Изчисление на плоча по МКЕ – подобрена таблица за единични опори;

Изчисление на плоча по МКЕ – подобрена таблица за линейни опори;

Изчисление на рамка – поддръжка на "стар" формат файлове;

Изчисление на рамки – нова възможност за задаване на премествания/завъртания;

Изчисление на рамки – нова възможност за задаване на пружини;

Мрежа – надписва център печати;

Мрежа – добавени възможности за генерация на окръжности по R, D, 3T, c–R, c–D;

Мрежа – добавени възможности за генерация на правоъгълник по D1_D2, c_Lx,Ly;

Мрежа – добавени възможността за генерация на елипси по D1_R1, R1_R2, c–R1_R2, c–D1_D2;

Мрежа – по маркирани възли генерира spline – отворен/затворен;

Мрежа – поддръжка на "стар" формат файлове;

Мрежа – подобрен вход и редактиране на възли;

Печат – подобрен init на размер на шрифт при първо стартиране;

Ревю – зададените коментари в функция от режима в модула;

Ревю – нова възможност за генерация между два цвята;

Таблично оразмеряване – подобрен запис и преглед;

Температурно поле – увеличена възможност за задаване на lambda;

Чертане греди – автоматично преконфигуриране при размер на лист, мащаб и коефициент за текст;

Чертане греди – добавена възможност за генерация на полигон при размножаване на възли;

Чертане греди – добавени възможности за генерация на окръжности по R, D, 3T, c–R, c–D;

Чертане греди – добавени възможности за генерация на правоъгълник по D1_D2, c_Lx,Ly;

Чертане греди – добавени възможността за генерация на елипси по D1_R1, R1_R2, c–R1_R2, c–D1_D2;

Чертане греди – нова "истинска" визуализация на дебелини и типове линии при детайли и чертеж;

Чертане греди – нова възможност за работа/структуриране по групи;

Чертане греди – нови типове линии;

Чертане греди – по маркирани възли генерира spline – отворен/затворен;

Чертане греди – поддръжка на AutоCAD цветове – ACI, 255 цвята;

Чертане греди – поддръжка на нови 25 типа линии;

Чертане греди – подобрен вход и редактиране на възли;

Чертане греди – подобрена работа при избор на лист;

Чертане греди – подобрена работа с "кадри";

Чертане греди – подобрена работа с позиция на текст;

Чертане греди – подобрена работа с размер на текст;

Чертане греди – подобрена таблица с коментари – позиция;

Чертане греди – подобрено изчитане на оразмерени греди с двойна армировка;

Чертане гредостени – автоматично преконфигуриране при размер на лист, мащаб и коефициент за текст;

Чертане гредостени – добавена възможност за генерация на полигон при размножаване на възли;

Чертане гредостени – добавени възможности за генерация на елипси по D1_R1, R1_R2, c–R1_R2, c–D1_D2;

Чертане гредостени – добавени възможности за генерация на окръжности по R, D, 3T, c–R, c–D;

Чертане гредостени – добавени възможности за генерация на правоъгълник по D1_D2, c_Lx,Ly;

Чертане гредостени – нов цвят зони;

Чертане гредостени – нова "истинска" визуализация на дебелини и типове линии при детайли и чертеж;

Чертане гредостени – нова възможност за работа/структуриране по групи;

Чертане гредостени – нови типове линии;

Чертане гредостени – по маркирани възли генерира spline – отворен/затворен;

Чертане гредостени – поддръжка на AutоCAD цветове – ACI, 255 цвята;

Чертане гредостени – поддръжка на нови 25 типа линии;

Чертане гредостени – подобрен вход и редактиране на възли;

Чертане гредостени – подобрена работа при избор на лист;

Чертане гредостени – подобрена работа с "кадри";

Чертане гредостени – подобрена работа с базова точка;

Чертане гредостени – подобрена работа с позиция на текст;

Чертане гредостени – подобрена работа с размер на текст;

Чертане гредостени – подобрена таблица с коментари – позиция;

Чертане гредостени – подобрено изчертаване на скала;

Чертане кофраж – автоматично преконфигуриране при размер на лист, мащаб и коефициент за текст;

Чертане кофраж – добавена възможност за генерация на полигон при размножаване на възли;

Чертане кофраж – добавени възможности за генерация на окръжности по R, D, 3T, c–R, c–D;

Чертане кофраж – добавени възможности за генерация на правоъгълник по D1_D2, c_Lx,Ly;

Чертане кофраж – добавени възможността за генерация на елипси по D1_R1, R1_R2, c–R1_R2, c–D1_D2;

Чертане кофраж – нова "истинска" визуализация на дебелини и типове линии при детайли и чертеж;

Чертане кофраж – нова възможност за работа/структуриране по групи;

Чертане кофраж – нови типове линии;

Чертане кофраж – по маркирани възли генерира spline – отворен/затворен;

Чертане кофраж – поддръжка на AutоCAD цветове – ACI, 255 цвята;

Чертане кофраж – поддръжка на нови 25 типа линии;

Чертане кофраж – подобрен вход и редактиране на възли;

Чертане кофраж – подобрена работа при избор на лист;

Чертане кофраж – подобрена работа с "кадри";

Чертане кофраж – подобрена работа с позиция на текст;

Чертане кофраж – подобрена работа с размер на текст;

Чертане кофраж – подобрена таблица с коментари – позиция;

Чертане кофраж – подобрено изчертаване на разрези, стълбища;

Чертане плоча по МКЕ – автоматично преконфигуриране при размер на лист, мащаб и коефициент за текст;

Чертане плоча по МКЕ – добавена възможност за генерация на полигон при размножаване на възли;

Чертане плоча по МКЕ – добавени възможности за генерация на окръжности по R, D, 3T, c–R, c–D;

Чертане плоча по МКЕ – добавени възможности за генерация на правоъгълник по D1_D2, c_Lx,Ly;

Чертане плоча по МКЕ – добавени възможността за генерация на елипси по D1_R1, R1_R2, c–R1_R2, c–D1_D2;

Чертане плоча по МКЕ – нов цвят зони;

Чертане плоча по МКЕ – нова "истинска" визуализация на дебелини и типове линии при детайли и чертеж;

Чертане плоча по МКЕ – нова възможност за работа/структуриране по групи;

Чертане плоча по МКЕ – нови типове линии;

Чертане плоча по МКЕ – по маркирани възли генерира spline – отворен/затворен;

Чертане плоча по МКЕ – поддръжка на AutоCAD цветове – ACI, 255 цвята;

Чертане плоча по МКЕ – поддръжка на нови 25 типа линии;

Чертане плоча по МКЕ – подобрен вход и редактиране на възли;

Чертане плоча по МКЕ – подобрен контрол при продънване;

Чертане плоча по МКЕ – подобрена работа при избор на лист;

Чертане плоча по МКЕ – подобрена работа с "кадри";

Чертане плоча по МКЕ – подобрена работа с базова точка;

Чертане плоча по МКЕ – подобрена работа с позиция на текст;

Чертане плоча по МКЕ – подобрена работа с размер на текст;

Чертане плоча по МКЕ – подобрена таблица с коментари – позиция;

Чертане плоча по МКЕ – подобрено изчертаване на разрези, стълбища;

Чертане плоча по МКЕ – подобрено изчертаване на разрези, стълбища.

22 [image] 22.12.2002 г. версия 12 +

Греди (изчертаване) – достъпни при демо–инсталация за преглед и обучение;

Гредостени (изчертаване) – задаване отместване изчертаване на армировката;

Гредостени (изчертаване) – подобрена работа при армировка с куки;

Гредостени (изчертаване) – подобрена работа при редактиране на зони;

Нов демо–диалог;

Оразмеряване – нови менюта: Ново, Текущо чете, Текущо запис;

Печат текст/картинки – подобрена работа с ориентацията на хартията;

Плочи по МКЕ (изчертаване) – подобрена работа при армировка с куки;

Плочи по МКЕ (изчертаване) – подобрена работа при редактиране на зони;

Подобрен демо–контрол;

Подобрена работа на библиотека с бутони;

Провисване – изчистен контрол за допустими провисвания;

Провисване – нови менюта: Ново, Текущо чете, Текущо запис;

Ревю – задаване интервал на конвертиране за цветовете;

Ревю – конвертиране на всеки цвят от RGB към HLS;

Филтър греди – текст без лимит;

Филтър полета – текст без лимит;

Филтър фундамент – текст без лимит;

Фундамент – разширен интервал при изчисляване на слягане;

Фундамент – подобрен контрол и увеличен брой слоеве;

Фундамент – подобрен контрол проверки;

Фундамент – подобрен контрол размери.

7 [image] 26.11.2002 г. версия 12

Изчертаване на плочи по МКЕ – премества/задава позиция от армировка от зони;

Изчертаване на гредостени – премества/задава позиция от армировка от зони;

Изчертаване на плочи по МКЕ – подобрена работа с трапецовидни зони с армировка;

Изчертаване на гредостени – подобрена работа с трапецовидни зони с армировка;

Изчертаване на плочи по МКЕ – подобрено изчертаване на наклонени зони с армировка;

Изчертаване на гредостени – подобрено изчертаване на наклонени зони с армировка;

Подобрена работа на библиотека с бутони за PC Проектант.

64 [image] 22.11.2002 г. версия 12

Генериране на таблица на колони – подобрение;

Графичен преглед – инжертиране на цветове;

Графичен преглед – отместване на цветове;

Графичен преглед – цветове по подразбиране 13;

Диалози всички – подобрения;

Добавени Gaber при избор на армировка, стремена, преглед текст, графика;

Добавени към асоцирани – kor;

Добавени към асоциирани, като текст – o__, clc;

Изчертаване на греди – подобрен контрол върху редактирана в спецификация армировка;

Изчертаване на греди – подобрена спецификация;

Изчертаване на греди – подобрено редактиране;

Изчертаване на гредостени – добавена работа с наклонени зони;

Изчертаване на гредостени – добавена работа с трапецовидни зони на армиране;

Изчертаване на гредостени – над 14 изолинии – моно и надписва чрез параметър;

Изчертаване на гредостени – подобрен контрол върху редактирана в спецификация армировка;

Изчертаване на гредостени – подобрен контрол при Undo;

Изчертаване на плочи по МКЕ – над 14 изолинии – моно и надписва чрез параметър;

Изчертаване на плочи по МКЕ – подобрен контрол върху редактирана в спецификация армировка;

Изчертаване на плочи по МКЕ – подобрен контрол при Undo;

Изчертаване на плочи по МКЕ – подобрен контрол при работа с наклонени зони;

Изчисление на кофраж – подобрен контрол върху редактирана в спецификация армировка;

Изчисление на кофраж – подобрена работа с пакет;

Импорт DXF – добавена работа с BLOCKS – scale, rotate;

Калкулатор – добавени стрелки F2;

Калкулатор – оптимизиран файл;

Калкулатор – подобрен контрол на меню;

Калкулатор – подобрен редактор, добавено Popup меню;

Комбинации рамки – запис;

Комбинации рамки – подобрен контрол на данни;

Контрол на обекти – подобрена работа;

Оразмеряване – подобрено предлагане на стремена и/или усукване;

Печат – подобрено приемане на файл;

Поддръжка на новия Windows XP стил на контролите;

Подобрена работа с таблица под Windows XP – запис;

Подобрена работа с таблица под Windows XP – подаване на данни;

Подобрено меню при кадри;

Преглед текст – подобрен контрол на меню;

Преглед текст – подобрен редактор, добавено Popup меню;

Спецификация на армировка – нов критерии за сортиране елемент;

Спецификация на армировка – нова таблица за редактиране на участъци на фигури армировка;

Спецификация на армировка – поддръжка на имена от чертане при кофраж и греди;

Фундамент – добавен алгоритъм за изчисление на Винклерова константа;

Фундамент – добавен алгоритъм за изчисление на сеизмична Винклерова константа;

Фундамент – добавен алгоритъм за слягане на фундаменти плочи;

Фундамент – нови параметри, контрол на итерациите;

При таблица възможности за автоматично търсене, смяна, статистика и др.

17 [image] 15.09.2002 г. версия 12

Нова възможност за редактиране на периметъра при продънване за плочи по МКE;

Подобрена работа при редактиране размери на единичен фундамент;

Чертане на греди – подобрена работа при срезност на кобилици;

Чертане на греди – подобрена работа при четене на армировка, втория диаметър се приема за огъната армировка;

Чертане на греди – подобрени разрези на греди;

Подобрена библиотека при работа с ToolTips;

Чертане – опция за вид на сечение отворено или не;

Чертане – опция за размери на колони, избор при какви условия да се чертаят;

Избор на файл – към меню добавка за търсене на файлове;

Армировка – предлага армировка по избор по три критерия;

Export DXF – добавен viewport;

Подобрена скорост при CRC32 над три пъти;

Повишена точност при някои функции на калкулатора;

Чертане – подобрени и добавени нови формати при чертане;

Преглед на текст – добавени Upper Case и Lower Case и разширен преглед на файлове;

Чертане – добавени сеизмични коефициенти при плочи и гредостени;

Рамки комбинации – добавен сеизмичен коефициент по избор за произволна комбинация.

48 [image] 01.06.2002 г. версия 12

Поддръжка на NT технология т.е. вече работи и на Windows XP и Windows 2000;

Усъвършенствана библиотека с бутони (flat, светлина, звук и т.н.);

Усъвършенствана поддръжка на избраната тема при Windows (BMP и т.н.);

Усъвършенствана библиотека за въвеждане на стойности в определен интервал (popup help и т.н.);

Undo/Redo – Силно подобрена работа;

Undo/Redo – Създаване на потребителски лимит;

3D Zoom при всички модули;

Увеличен интервал при въвеждане на възли;

Нови методи при размножаване на възли;

Text/коментар на няколко реда при всички модули;

Еxport на чертежи в DXF формат (избор на trim, fillet, цветове, език, кирилица, шрифт и т.н.) ново;

Import на DXF (филтър по слоеве, елементи и цветове) – ново;

Контрол на използваните възли в DXF;

Проверка коректността на току що въведен обект;

Задаване автоматично площни товари върху контур;

Усъвършенствано редактиране на контури (Ins – вмъкване, Del – триене на възли);

Задаване на зони за изчертаване на оси;

Наклонени оси;

Наклонени коти;

Наклонени нива пo разрези – два вида;

Кръгли и елипсовидни колони;

Продънване колони – контрол и на детайли/колони;

Продънване колони – автоматично добавяне на зони с кобилици;

Плоча по МКЕ – наклонени зони с кобилици;

Плоча по МКЕ – горни огънати зони;

Плоча по МКЕ – трапецовидни зони;

Плоча по МКЕ – зони за армиране под ъгъл;

За всички модули вече армировката от стомана A I е с куки;

Стойности изолинии с цвят по зони;

Нови възможности за избор при надписване на оси – типово и индивидуално;

Нови възможности за избор при надписване/щриховане на греди – типово и индивидуално;

Нови възможности за избор при надписване/щриховане на колони – типово и индивидуално;

Нови възможности за избор при надписване/изчертаване на полета;

Нови възможности за избор при надписване/изчертаване на зони;

Нови възможности за избор при надписване на армировка;

Втора стомана при класически армировъчен план – с греди;

Подобрен контрол при кофражен план;

Нов модул за преглед, редакт, конверт на текстови файлове;

Силно оптимизиран модул за печат на текстови файлове и кадри по страници, коментари, настройки и т.н.;

Нов формат файл (рес) за текуща подготовка при печат;

Подобрена работа на модула за конвертиране на мерните единици;

Настройка на всички параметри при различни графични филтри;

Запомняне на текущо състояние при избран филтър – памет;

Изготвяне на произволен брой разрези по направление и дължина през обект, анимация;

Гладки еластични линии при различните графични филтри;

Подобрен алгоритъм при оразмеряване в общо положение;

При комбиниране на рамки възможности за задаване на отделни характеристики за всеки елемент;

При таблица възможности за автоматично търсене, смяна, статистика и др.


Home

Екрани


Вход на обекти


Вход на обекти - Геометрични характеристики


Генерация на мрежа


Кофражен план (изчисление)


Плочи (изчисление)


Изключване на опън


Оразмеряване на сечения


Сеизмично изследване


Гредостени (изчисление)


Рамки (изчисление)


Рамки (изчисление) - Комбинации


3DD Рамки (изчисление)


Общо оразмеряване


Поле


Греда


Фундамент


Оразмеряване


Провисване


Надлъжна армировка


Напречна армировка - стремена


Кофражен план (изчертаване)


Греди (изчертаване)


Плочи (изчертаване)


Гредостени (изчертаване)


Детайли


Детайли - Таблица на колони


Старт DPF-DXF-DWG


PCPcad


PCPcad - CAD Таблица

PCPcad - Plugins - CAD Таблица


PCPcad - Кофражен/Армировъчен план

PCPcad - Plugins - Кофражен/Армировъчен план


Контрол на бетона


Бетони - характеристики


Стомани - характеристики


Профили


Характеристики


Температури


Преглед графика - ревю


Преглед текст


Преглед текст под Windows


Принтер


Калкулатор


Сорт


Стойност


Импорт DXF-DWG


Експорт DXF-DWG


Task


Config


User


Подготовка на език


Учител


sTime

Time


Files Find


Информация


About


Възли


Таблица


Спецификация на армировка


За контакт:

Бихме били благодарни за всяко предложение и идея, които споделите или предложите във връзка със системата. При проблеми възникнали в процеса на работа с подходящ пример се обръщайте на долните адреси.

Възможности за връзка с авторите:

УАСГ – София 1046

бул. "Хр. Смирненски" №1

корпус "Б", кабинет 745

тел.: (359 2) 9635245–56 / 651

доц. д-р инж. Пламен Чобанов

E-mail: | mail@PCProektant.com, Chobanov_FCE@uacg.bg
Web page: | www.PCProektant.com
 | Благодарим Ви, че избрахте българското !


Файлове - разширения

Разширение | Модул подава | Модул приема | Ревю | Принт
b02 | Вход на обекти | Вход на обекти Геометрични характеристики Контрол запис обекти | - | -
k02 | Вход на обекти Контрол запис обекти | Вход на обекти Кофражен план (изчисление) | + | -
k01 | Кофражен план (изчисление) | Кофражен план (изчисление) | - | -
p__ | Кофражен план (изчисление) | Кофражен план (изчертаване) Поле Контрол запис обекти | + | +
g__ | Кофражен план (изчисление) | Кофражен план (изчертаване) Греди (изчертаване) Греда Контрол запис обекти | + | +
k__ | Кофражен план (изчисление) | Кофражен план (изчертаване) Контрол запис обекти | - | +
k03 | Кофражен план (изчертаване) | Кофражен план (изчертаване) | - | -
g03 | Греди (изчертаване) | Греди (изчертаване) | - | -
z01 | Сеизмично изследване Контрол запис обекти | Сеизмично изследване | + | -
z02 | Сеизмично изследване Контрол запис обекти | Сеизмично изследване | + | -
z__ | Сеизмично изследване | Рамки (изчисление) - комбиниране Общо оразмеряване Контрол запис обекти | + | +
r02 | Вход на обекти Контрол запис обекти | Вход на обекти Генерация на мрежа | + | -
r01 | Генерация на мрежа | Генерация на мрежа Плочи (изчисление) | + | -
r__ | Плочи (изчисление) | Плочи (изчертаване) Кофражен план (изчисление) | + | +
r03 | Плочи (изчертаване) | Плочи (изчертаване) | - | -
s02 | Вход на обекти Контрол запис обекти | Вход на обекти Генерация на мрежа | + | -
s01 | Генерация на мрежа | Генерация на мрежа Гредостени (изчисление) | + | -
s__ | Гредостени (изчисление) | Гредостени (изчертаване) | + | +
s03 | Гредостени (изчертаване) | Гредостени (изчертаване) | - | -
n02 | Вход на обекти | Вход на обекти Генерация на мрежа | + | -
n01 | Генерация на мрежа | Генерация на мрежа Оразмеряване на сечения | + | -
n__ | Оразмеряване на сечения | - | + | +
i02 | Вход на обекти | Вход на обекти Генерация на мрежа | + | -
i01 | Генерация на мрежа | Генерация на мрежа Изключване на опън | + | -
i__ | Изключване на опън | - | + | +
t02 | Вход на обекти | Вход на обекти Генерация на мрежа | + | -
t01 | Генерация на мрежа | Генерация на мрежа Температури | + | -
t__ | Температури |  | + | +
x02 | Вход на обекти Контрол запис обекти | Вход на обекти Рамки (изчисление) Сеизмично изследване | + | -
x__ | Рамки (изчисление) | Рамки (изчисление) - комбиниране | + | +
kor | Рамки (изчисление) - комбиниране | Рамки (изчисление) - комбиниране | - | -
det | Детайли | Детайли | - | -
o__ | Общо оразмеряване | Общо оразмеряване Таблица колони | - | +
clc | Калкулатор | Калкулатор | - | +
pec | Принтер | Принтер | - | -
spc | Кофражен план (изчертаване) Греди (изчертаване) Плочи (изчертаване) Гредостени (изчертаване) | - | - | +
scr | Кофражен план (изчертаване) Греди (изчертаване) Плочи (изчертаване) Гредостени (изчертаване) | AutoCAD R10 | - | -
dxf | Export DXF | Вход на обекти AutoCAD | - | -
dxo | Export DXF | Export DXF | - | -
d01 | DOS версия - Кофражен план | - | + | -
d02 | DOS версия - Кофражен план | - | + | -
d03 | DOS версия - Кофражен план | - | + | -
d04 | DOS версия - Кофражен план | - | + | -

Поле, Греда, Фундамент, Оразмеряване, Провисване - при самостоятелна работа нямат запазени разширения!